Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 3406 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Θέμα Δ
« στις: 23 Ιούν 2020, 09:24:06 μμ »
Εδώ συζητάμε για το θέμα Δ των εξετάσεων 2019-2020
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #1 στις: 24 Ιούν 2020, 10:30:32 πμ »
Πολύ καλό το Δ2. Θα ξεχωρίσει αυτούς που σκέφτονται από αυτούς που έχουν μάθει απέξω 2-3 μεθοδολογίες.
Μπράβο στην επιτροπή!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

ApoAntonis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 133
Απ: Θέμα Δ
« Απάντηση #2 στις: 24 Ιούν 2020, 10:39:48 πμ »
Ερώτηση (που δεν την έχω καλοσκεφτεί)
με αυτή την διατύπωση του Δ2
αν κάποιος ξεκινήσει με 'Χ' σε όλον τον πίνακα και μετά κάνει εισαγωγή δεδομένων,
να τις πάρει όλες τις μονάδες ή όχι;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #3 στις: 24 Ιούν 2020, 10:46:00 πμ »
Πολύ καλή παρατήρηση!
όχι δεν πρέπει να τις πάρει όλες, γιατί ξεγλιστράει από τη δυσκολία της συμπλήρωσης του υπόλοιπου πίνακα ενώ η εκφώνηση είναι πολύ συγκεκριμένη! Aυτός/η που θα βάλει από την αρχή Χ κατά κάποιον τρόπο "κλέβει".
Κάποιοι θα κόψουν ακόμα και 2 μονάδες για αυτό (γιατί πιάνει 5) αλλά κάποιοι άλλοι βαθμολογητές θα πουν ότι αφού έχει το ίδιο αποτέλεσμα και "δουλεύει" δεν του κόβω.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #4 στις: 24 Ιούν 2020, 10:47:49 πμ »
Αν βάλει Χ παντου και στη συνέχεια διαβάσει με "τέλος" τον πίνακα κατά γραμμές θα χάσει μονάδες;

Δηλαδή αν π.χ. διαβάσει πρώτα τον πίνακα μετρήσεων και μετά τα ονόματα ΚΟΜΥ, θα χάσει μονάδες;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #5 στις: 24 Ιούν 2020, 10:48:46 πμ »
Δεν είναι το ίδιο. Άλλο να αλλάζει τη σειρά των ερωτημάτων και άλλο να κάνει τις ενέργειες που ζητούνται στο ίδιο ερώτημα με άλλη σειρά. Σίγουρα κάποιοι θα κόψουν πάντως και κάποιοι όχι.
Θα συζητηθεί στο βαθμολογικό, το μόνο σίγουρο.

Αν βάλει Χ παντου και στη συνέχεια διαβάσει με "τέλος" τον πίνακα κατά γραμμές θα χάσει μονάδες;

Δηλαδή αν π.χ. διαβάσει πρώτα τον πίνακα μετρήσεων και μετά τα ονόματα ΚΟΜΥ, θα χάσει μονάδες;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #6 στις: 24 Ιούν 2020, 10:53:59 πμ »
Προφανώς δεν είναι η ίδια σειρά ενεργειών.
Ωστόσο οι εισαγόμενες τιμές είναι οι ίδιες και με την ίδια σειρά.

Προσωπικά δεν βλέπω λόγο μείωσης μονάδων, μάλιστα θεωρώ σημαντικότερη σκέψη όποιου μαθητή έχει προετοιμάσει τον πίνακα από πριν για την επικείμενη είσοδο δεδομένων, δείχνει ότι επίσης κατανόησε το τι συμβαίνει με αυτόν τον πίνακα

SuperTz

  • Βετεράνος
  • ****
  • Μηνύματα: 56
Απ: Θέμα Δ
« Απάντηση #7 στις: 24 Ιούν 2020, 11:03:18 πμ »
Έχω την αίσθηση πως δεν είναι σαφές το τι θα κάνει η Διαδικασία και τι το Πρόγραμμα στην περίπτωση του ίδιου αριθμού θετικών δειγμάτων. Διαβάζοντας το Δ4 περίμενα να δω κάτι στο Δ5, αλλά δεν...
Θεωρείτε πως η Διαδικασία ή το Πρόγραμμα θα αναλάβει την περίπτωση αυτή; Με μια πρώτη ανάγνωση φαίνεται το Πρόγραμμα, αλλά νομίζω πως στερείται σαφήνειας

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #8 στις: 24 Ιούν 2020, 11:04:13 πμ »
Έχω την αίσθηση πως δεν είναι σαφές το τι θα κάνει η Διαδικασία και τι το Πρόγραμμα στην περίπτωση του ίδιου αριθμού θετικών δειγμάτων. Διαβάζοντας το Δ4 περίμενα να δω κάτι στο Δ5, αλλά δεν...
Θεωρείτε πως η Διαδικασία ή το Πρόγραμμα θα αναλάβει την περίπτωση αυτή; Με μια πρώτη ανάγνωση φαίνεται το Πρόγραμμα, αλλά νομίζω πως στερείται σαφήνειας

το δεύτερο κριτηριο ταξινομησης, δεν ειναι υποθεση της ταξινομησης (δηλαδη της Διαδικασίας);

SuperTz

  • Βετεράνος
  • ****
  • Μηνύματα: 56
Απ: Θέμα Δ
« Απάντηση #9 στις: 24 Ιούν 2020, 11:05:47 πμ »
γράφει "να εμφανίζονται με αλφαβητική σειρά" και όχι να ταξινομούνται

gkappa

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα Δ
« Απάντηση #10 στις: 24 Ιούν 2020, 11:06:56 πμ »
Προφανώς δεν είναι η ίδια σειρά ενεργειών.
Ωστόσο οι εισαγόμενες τιμές είναι οι ίδιες και με την ίδια σειρά.

Προσωπικά δεν βλέπω λόγο μείωσης μονάδων, μάλιστα θεωρώ σημαντικότερη σκέψη όποιου μαθητή έχει προετοιμάσει τον πίνακα από πριν για την επικείμενη είσοδο δεδομένων, δείχνει ότι επίσης κατανόησε το τι συμβαίνει με αυτόν τον πίνακα
Συμφωνώ απόλυτα με τον Παναγιώτη!
Με ποια λογική θα κόψει κάποιος μια τέτοια λύση-αντιμετώπιση του θέματος;
Στην λογική του "κλέβει" που λέει ο Ευριπίδης, η απάντηση είναι ΝΑΙ, και πολύ καλά κάνει αφού μπορεί!
Που πάει τότε το "Κάθε λύση επιστημονικά τεκμηριωμένη είναι αποδεκτή";

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 39
Απ: Θέμα Δ
« Απάντηση #11 στις: 24 Ιούν 2020, 11:08:08 πμ »
Δέν νομίζω να υπάρχει κάποια ασάφεια ως προς το τι κάνει το πρόγραμμα και τι η διαδικασία.. Στο πρόγραμμα απλά καλούμε και εν συνεχεία εμφανίζουμε μόνο τον πίνακα Π.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #12 στις: 24 Ιούν 2020, 11:08:27 πμ »
Τώρα που το διαβάζω καλύτερα πράγματι η σειρά εισαγωγής δεν αλλάζει, άρα η συμπεριφορά του προγράμματος παραμένει η ίδια.
Ωστόσο η αλλαγή της σειράς των ενεργειών έχει αντίκτυπο στον τελικό αλγόριθμο και στη δυσκολία του.
Και επειδή πάντα σκεφτόμαστε τον μαθητή από τον οποίο κόβουμε να αντιστρέψω λίγο το ερώτημα:
 Ο μαθητής που θα το κάνει ακριβώς όπως το λέει η εκφώνηση είναι σωστό να πάρει τις ίδιες μονάδες με αυτόν/η που θα βάλει από την αρχή Χ?

ΥΓ. Το 2 μονάδες που είπα είναι υπερβολικό.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #13 στις: 24 Ιούν 2020, 11:09:49 πμ »
γράφει "να εμφανίζονται με αλφαβητική σειρά" και όχι να ταξινομούνται

Νομίζω ότι το ερώτημα Δ4 είναι ίδιο με αυτό του 2004 (2ο κριτήριο ταξινόμησης) απλά είναι με διαδικασία. Αλφαβητική σειρά δεν σημαίνει κάτι άλλο παρά ταξινόμηση.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #14 στις: 24 Ιούν 2020, 11:10:38 πμ »
Που πάει τότε το "Κάθε λύση επιστημονικά τεκμηριωμένη είναι αποδεκτή";
Υπενθυμίζω ότι στο μάθημά οι λύσεις που δίνονται στα Γ και Δ δεν είναι επιστημονικά τεκμηριωμένες. Μόνο αυτές που έχουν αιτιολόγηση μπορούν να θεωρηθούν τέτοιες!

Εκτός αν ορίσουμε τι σημαίνει επιστημονικά τεκμηριωμένη λύση στο μάθημά μας.

Π.χ. το θέμα Α3 είναι επιστημονικά τεκμηριωμένο?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #15 στις: 24 Ιούν 2020, 11:14:14 πμ »
Είναι σίγουρα λάθος οι μονάδες στο Δ4,Δ5...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #16 στις: 24 Ιούν 2020, 11:14:25 πμ »
Τώρα που το διαβάζω καλύτερα πράγματι η σειρά εισαγωγής δεν αλλάζει, άρα η συμπεριφορά του προγράμματος παραμένει η ίδια.
Ωστόσο η αλλαγή της σειράς των ενεργειών έχει αντίκτυπο στον τελικό αλγόριθμο και στη δυσκολία του.
Και επειδή πάντα σκεφτόμαστε τον μαθητή από τον οποίο κόβουμε να αντιστρέψω λίγο το ερώτημα:
 Ο μαθητής που θα το κάνει ακριβώς όπως το λέει η εκφώνηση είναι σωστό να πάρει τις ίδιες μονάδες με αυτόν/η που θα βάλει από την αρχή Χ?

ΥΓ. Το 2 μονάδες που είπα είναι υπερβολικό.


Έχεις δίκιο στο ότι το να βάλεις μετά τα Χ είναι (ελάχιστα) πιο απαιτητικό.  Από την εκτεταμένη εμπειρία σου στη βαθμολόγηση αυτό δικαιολογεί απώλεια μονάδων ενώ  γίνεται η δουλειά;
Εν τω μεταξύ οι 6 μονάδες δεν είναι: 0.5 - 1 στο ΓΙΑ i, 3-3.5 στο ΟΣΟ και 1.5-2 στο επικείμενο  ΓΙΑ των 'Χ';

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 608
    • Ανάπτυξη Εφαρμογών
Απ: Θέμα Δ
« Απάντηση #17 στις: 24 Ιούν 2020, 11:19:41 πμ »
Καλημέρα παιδιά.

Ευριπίδη από τη μία έχεις δίκιο αλλά από την άλλη και η άλλη απάντηση δεν στέκει να την κόψουμε. Εγώ πάντως όταν την έλυσα την έλυσα γεμίζοντας πρώτα τον πίνακα με Χ.

Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #18 στις: 24 Ιούν 2020, 11:20:16 πμ »
Είναι σίγουρα λάθος οι μονάδες στο Δ4,Δ5...

Λιγότερη αμοιβή (μονάδες) για περισσότερη δουλειά,
ακούγεται σαν σύγχρονο εργασιακό περιβάλλον

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #19 στις: 24 Ιούν 2020, 11:21:23 πμ »
Έχεις δίκιο στο ότι το να βάλεις μετά τα Χ είναι (ελάχιστα) πιο απαιτητικό.  Από την εκτεταμένη εμπειρία σου στη βαθμολόγηση αυτό δικαιολογεί απώλεια μονάδων ενώ  γίνεται η δουλειά;
Εν τω μεταξύ οι 6 μονάδες δεν είναι: 0.5 - 1 στο ΓΙΑ i, 3-3.5 στο ΟΣΟ και 1.5-2 στο επικείμενο  ΓΙΑ των 'Χ';
Λογικά οι περισσότεροι υποθέτω ότι δεν θα κόψουν αλλά κάποιοι πιθανόν να κόψουν μια μονάδα για τους λόγους που είπα, εκτός αν συμφωνήσουν και αυτοί για να μην υπάρξει πρόβλημα. Ωστόσο επειδή αυτός που το έχει κάνει όπως το ζητάνε (και νομίζω ότι δεν είναι ελάχιστα πιο απαιτητικό αλλά αρκετά απαιτητικό), θα έλεγα ότι πρέπει να πάρει κάτι παραπάνω.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #20 στις: 24 Ιούν 2020, 11:22:09 πμ »
Εσένα θα σου έκοβα σίγουρα για τα ονόματα που θα είχες βάλει στους μετρητές των επαναλήψεων  :D

Καλημέρα παιδιά.

Ευριπίδη από τη μία έχεις δίκιο αλλά από την άλλη και η άλλη απάντηση δεν στέκει να την κόψουμε. Εγώ πάντως όταν την έλυσα την έλυσα γεμίζοντας πρώτα τον πίνακα με Χ.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 608
    • Ανάπτυξη Εφαρμογών
Απ: Θέμα Δ
« Απάντηση #21 στις: 24 Ιούν 2020, 11:22:32 πμ »
Το ερώτημά μου είναι αν το Δ3 το λύση με τη βοήθεια του Δ4 θα πιαστεί σωστό?
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #22 στις: 24 Ιούν 2020, 11:24:59 πμ »
Το ερώτημά μου είναι αν το Δ3 το λύση με τη βοήθεια του Δ4 θα πιαστεί σωστό?

ωραίος..
Αν καλέσεις πρώτα την (κακοπληρωμένη) κα ΔΙΑΔΙΚΑΣΙΑ να σε βοηθήσει και μετά εμφανίσεις τα ζητούμενα, είσαι ατσαλάκωτος    8)
(μπορεί να είναι και πιο απαιτητική λύση αν δε γίνει με ΓΙΑ)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #23 στις: 24 Ιούν 2020, 11:25:44 πμ »
Πέτρο έχεις δίκιο!
Τους ξέφυγε!
Είναι σοβαρό! Έτσι όπως το έχουν όποιος γράψει μόνο με την κλήση παίρνει 3 μονάδες, τις ίδιες με το υποπρόγραμμα.
Πρέπει να στείλουν άμεσα οδηγία στα βαθμολογικά!
Ας ελπίσουμε οι βαθμολογητές των ΦΑ να το καταλάβουν και να δράσουν σωστά και με ψυχραιμία.

Είναι σίγουρα λάθος οι μονάδες στο Δ4,Δ5...
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #24 στις: 24 Ιούν 2020, 11:27:09 πμ »
Πέτρο έχεις δίκιο!
Τους ξέφυγε!
Είναι σοβαρό! Έτσι όπως το έχουν όποιος γράψει μόνο με την κλήση παίρνει 3 μονάδες, τις ίδιες με το υποπρόγραμμα.
Πρέπει να στείλουν άμεσα οδηγία στα βαθμολογικά!
Ας ελπίσουμε οι βαθμολογητές των ΦΑ να το καταλάβουν και να δράσουν σωστά και με ψυχραιμία.


είναι και η εμφάνιση παίδες. Μην πετροβολήσετε παρακαλώ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #25 στις: 24 Ιούν 2020, 11:28:17 πμ »
Συμφωνώ με τον Παναγιώτη. Αυτός που θα έχει το θράσος να το κάνει πρέπει να πάρει και παραπάνω

Το ερώτημά μου είναι αν το Δ3 το λύση με τη βοήθεια του Δ4 θα πιαστεί σωστό?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #26 στις: 24 Ιούν 2020, 11:29:57 πμ »
Πάντως το θέμα Δ και όσον αφορά την κατανομή των μονάδων και όσον αφορά ότι ζητάνε ταξινόμηση αφού πριν έχουν ζητήσει το μέγιστο δείχνει απειρία από την πλευρά των θεματοδοτών
ή κάτι συνέβη και δεν προλάβαιναν οπότε τελευταία στιγμή πέταξαν και μια ταξινόμηση. Κάτι δεν πήγε καλά εκεί πάντως.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #27 στις: 24 Ιούν 2020, 11:36:08 πμ »
Πάντως το θέμα Δ και όσον αφορά την κατανομή των μονάδων και όσον αφορά ότι ζητάνε ταξινόμηση αφού πριν έχουν ζητήσει το μέγιστο δείχνει απειρία από την πλευρά των θεματοδοτών
ή κάτι συνέβη και δεν προλάβαιναν οπότε τελευταία στιγμή πέταξαν και μια ταξινόμηση. Κάτι δεν πήγε καλά εκεί πάντως.

Η επιτροπή έβγαλε 3 σετ θεμάτων

(ή/και απλά ήθελαν να κυλήσει μία ήρεμη μέρα χωρίς lock down μετά την Βιολογία κλπ με εξέταση βασικών επεξεργασιών και κάποια πονηρά διασκορπισμένα όπως παλιά,
ναι θα μπορούσε με καθαρότερο μυαλό να βγει ένα ωραιότερο θέμα)

mikezante

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Δ
« Απάντηση #28 στις: 24 Ιούν 2020, 11:44:14 πμ »
Δ3 θελει αλλαγη

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ζ, μαξ, πλ, θεση, Σ[20], κ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], δειγμα, ΑΠ[20, 100]
ΑΡΧΗ
!Δ2
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ζ <- 1
    ΔΙΑΒΑΣΕ δειγμα
    ΟΣΟ δειγμα <> 'ΤΕΛΟΣ' ΚΑΙ ζ <= 100 ΕΠΑΝΑΛΑΒΕ
     
      ΑΠ[ι, ζ] <- δειγμα
       ζ <- ζ + 1
      ΔΙΑΒΑΣΕ δειγμα
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ κ ΑΠΟ ζ ΜΕΧΡΙ 100
      ΑΠ[ι, ζ] <- 'Χ'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ3
  μαξ <- -1
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    πλ <- 0
    ΓΙΑ ζ ΑΠΟ 1 ΜΕΧΡΙ 100
      ΑΝ ΑΠ[ι, ζ] = 'Θ' ΤΟΤΕ
        πλ <- πλ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Σ[ι] <- πλ
    ΑΝ πλ > μαξ ΤΟΤΕ
      μαξ <- πλ
      θεση <- ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Περισότερα κρούσματα στην περιοχή:', Π[θεση]
!Δ4
  ΚΑΛΕΣΕ ταξινομηση(Σ, Π)
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


!Δ5
ΔΙΑΔΙΚΑΣΙΑ ταξινομηση(Σ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ[20], ι, ζ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τομπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ ζ ΑΠΟ 20 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Σ[ζ - 1] < Σ[ζ] ΤΟΤΕ
        τεμπ <- Σ[ζ]
        Σ[ζ] <- Σ[ζ - 1]
        Σ[ζ - 1] <- τεμπ
        τομπ <- Π[ζ]
        Π[ζ] <- Π[ζ - 1]
        Π[ζ - 1] <- τομπ
      ΑΛΛΙΩΣ_ΑΝ Σ[ζ - 1] = Σ[ζ] ΤΟΤΕ
        ΑΝ Π[ζ - 1] > Π[ζ] ΤΟΤΕ
          τομπ <- Π[ζ]
          Π[ζ] <- Π[ζ - 1]
          Π[ζ - 1] <- τομπ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
« Τελευταία τροποποίηση: 24 Ιούν 2020, 12:02:49 μμ από mikezante »
Γ. Β.

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Θέμα Δ
« Απάντηση #29 στις: 24 Ιούν 2020, 11:52:52 πμ »
Λέει ποιες περιοχές είχαν περισσότερα θετικά κρούσματα, πρέπει να ελέγξεις όλο τον  πίνακα γιατί το μαχ μπορεί να εμφανίζεται παραπάνω από μιά φορά!

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #30 στις: 24 Ιούν 2020, 11:53:37 πμ »
mikezante
Στο Δ3. (;)
Άλλο ζητάει !
 ... το όνομα ή τα ονόματα ...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #31 στις: 24 Ιούν 2020, 11:56:53 πμ »
Πράγματι αλλά τα σετ αυτά είναι σχεδόν ίδια!
Η επιτροπή έβγαλε 3 σετ θεμάτων
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #32 στις: 24 Ιούν 2020, 12:04:20 μμ »
Το διάβασμα του πίνακα δεν είναι τόσο απλή υπόθεση
Αν το j είναι 100, δεν έχει νόημα να διαβαστεί τιμή πριν το τέλος επανάληψης
Θέλει πολύ πρόσθετο κώδικα για να είναι σωστό σε όλα του
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #33 στις: 24 Ιούν 2020, 12:46:22 μμ »
Σωστό Πέτρο, θέλει διπλή συνθήκη!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #34 στις: 24 Ιούν 2020, 12:57:08 μμ »
Θεωρώ ότι οι περισσότερες λύσεις που θα ανέβουν στο διαδίκτυο για αυτό το ερώτημα θα είναι ελαττωματικές σε κάτι
Θέλει πολύ προγραμματιστική φροντίδα το συγκεκριμένο ερώτημα ώστε να μη διαβάζει περιττά δεδομένα, να μην βγαίνει εκτός ορίων και φυσικά να μην κάνει λάθος υλοποίηση του ζητούμενου
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 41
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #35 στις: 24 Ιούν 2020, 01:06:42 μμ »
.....
Θέλει πολύ προγραμματιστική φροντίδα το συγκεκριμένο ερώτημα ώστε να μη διαβάζει περιττά δεδομένα, να μην βγαίνει εκτός ορίων και φυσικά να μην κάνει λάθος υλοποίηση του ζητούμενου

Καλημέρα !
Συμφωνώ !!
Panos

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #36 στις: 24 Ιούν 2020, 01:08:24 μμ »
Και παρατηρώ ότι πολλά παιδιά δεν του έχουν δώσει σημασία και θεωρούν ότι το έχουν υλοποιήσει σωστά
Πολύ δύσκολα κάποιος θα πάρει 6/6
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #37 στις: 24 Ιούν 2020, 01:14:16 μμ »
Και επιπλέον οι υπόλοιπες θέσεις να γεμίσουν με 'Χ' !!!
Εκτός κι αν προβλέψει να αρχικοποιήσει τον ΑΠ[20,100] με 'Χ' ...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #38 στις: 24 Ιούν 2020, 01:26:40 μμ »
Τελικά η αρχικοποίηση του πίνακα με Χ μάλλον θα είναι το τελευταίο πρόβλημα που θα έχουν να σκεφτούν οι βαθμολογητές.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

mikezante

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Δ
« Απάντηση #39 στις: 24 Ιούν 2020, 01:29:38 μμ »
mikezante
Στο Δ3. (;)
Άλλο ζητάει !
 ... το όνομα ή τα ονόματα ...

Ναι ναι, το γράφω σαν σχόλιο πάνω από τον κώδικα ότι το Δ3 μου δεν είναι σωστό!
Γ. Β.

vlachakis

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Δ
« Απάντηση #40 στις: 24 Ιούν 2020, 02:03:26 μμ »
Δ3 θελει αλλαγη


!Δ5
ΔΙΑΔΙΚΑΣΙΑ ταξινομηση(Σ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ[20], ι, ζ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τομπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ ζ ΑΠΟ 20 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Σ[ζ - 1] < Σ[ζ] ΤΟΤΕ
        τεμπ <- Σ[ζ]
        Σ[ζ] <- Σ[ζ - 1]
        Σ[ζ - 1] <- τεμπ
        τομπ <- Π[ζ]
        Π[ζ] <- Π[ζ - 1]
        Π[ζ - 1] <- τομπ
      ΑΛΛΙΩΣ_ΑΝ Σ[ζ - 1] = Σ[ζ] ΤΟΤΕ
        ΑΝ Π[ζ - 1] > Π[ζ] ΤΟΤΕ
          τομπ <- Π[ζ]
          Π[ζ] <- Π[ζ - 1]
          Π[ζ - 1] <- τομπ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
εμένα έκαναν αυτή τη λύση

ΔΙΑΔΙΚΑΣΙΑ ταξινομηση(Σ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ[20], ι, ζ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τομπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ ζ ΑΠΟ 20 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Σ[ζ - 1] < Σ[ζ] ή Σ[ζ - 1] = Σ[ζ] και Π[ζ - 1] > Π[ζ] ΤΟΤΕ
        τεμπ <- Σ[ζ]
        Σ[ζ] <- Σ[ζ - 1]
        Σ[ζ - 1] <- τεμπ
        τομπ <- Π[ζ]
        Π[ζ] <- Π[ζ - 1]
        Π[ζ - 1] <- τομπ
   
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

η ερώτηση μου είναι. θα την καταλάβουν οι διορθωτές;

tsak

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 183
Απ: Θέμα Δ
« Απάντηση #41 στις: 24 Ιούν 2020, 02:28:52 μμ »
Να σας βάλω ένα πιο δύσκολο? Μαθητής μου στο Δ2 έκανε:

Για i από 1 μέχρι 20
  Για j από 1 μέχρι 100
   Διάβασε απ[ι,j]
   Αν απ[ι.j]='τέλος' τότε
      Για κ από j μέχρι 100
        Απ[ι,κ]<-'χ'
      Τέλος_επανάληψης
     J<-100
   Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

Του το δίνεις ολόσωστο?

vlachakis

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Δ
« Απάντηση #42 στις: 24 Ιούν 2020, 02:32:16 μμ »
μη δομημένος προγραμματισμός το να εκχωρούμε στον μετρητή της Για

tsak

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 183
Απ: Θέμα Δ
« Απάντηση #43 στις: 24 Ιούν 2020, 02:47:54 μμ »
μη δομημένος προγραμματισμός το να εκχωρούμε στον μετρητή της Για
Σύμφωνοι...υπάρχει σχετική οδηγία ότι απαγορεύεται και κόβουμε βαθμούς όμως ή είναι και αυτό στις ασάφειες?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #44 στις: 24 Ιούν 2020, 02:50:03 μμ »
Σύμφωνοι...υπάρχει σχετική οδηγία ότι απαγορεύεται και κόβουμε βαθμούς όμως ή είναι και αυτό στις ασάφειες?
Δεν είναι ασάφεια και πρέπει να κοπούν μονάδες γιατί έτσι ξεγλιστράει από τη δυσκολία του θέματος. Ουσιαστικά είναι σαν να χρησιμοποιεί break.
Είμαι από τους λίγους που πιστεύω ότι η αλλαγή του μετρητή μέσα στη Για δεν πρέπει να θεωρείται λάθος, σε κάποιες περιπτώσεις πρέπει να είμαστε ελαστικοί αλλά αυτή δεν είναι μια από αυτές τις περιπτώσεις.

Το θέμα δεν είναι αν θα κοπούν μονάδες αλλά πόσες, γιατί το σκεπτικό του είναι αλγοριθμικά σωστό.

ΥΓ. Υπάρχει σχετική οδηγία, είναι στις τελευταίες οδηγίες που είχαν στείλει που είχε μέσα και άλλες για τα υποπρογράμματα.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tsak

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 183
Απ: Θέμα Δ
« Απάντηση #45 στις: 24 Ιούν 2020, 03:08:30 μμ »
Ευχαριστώ για τις επισημάνσεις. Κι εγώ πιστεύω ότι πρέπει να κοπούν, αλλά όχι πάνω από 2-3... Είναι και αυτό που επικαλούνται πολλές φορές οι μαθητές: "αφού παίζει καλά το πρόγραμμα..." και ανοίγει η κουβέντα...

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Θέμα Δ
« Απάντηση #46 στις: 24 Ιούν 2020, 03:24:06 μμ »
Το Δ2 εμένα μου άρεσε γενικά σαν ιδέα, για κάτι πιο δύσκολο , αν και όντως και οι δικοί μου μαθητές είχαν πολλές διαφορετικές λύσεις .. εγώ πάντως έχω βαρεθεί να μπαίνει ταξινόμηση με δευτερο κριτήριο αλφαβητικά τα ονόματα...εντάξει το καταλάβαμε πως γίνεται, έχει μπει σερί χρονιές, ας μπει του χρόνου και κάτι άλλο  >:D :angel: :D

taxata

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 102
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Θέμα Δ
« Απάντηση #47 στις: 24 Ιούν 2020, 03:28:37 μμ »
Ερώτηση περιέργειας εάν κάποιος λύσει πρώτα το Δ4 δηλαδή ταξινομήσει τους πίνακες και μετά το Δ3 δηλαδή εμφανίσει τα πάνω πάνω στοιχεία θα πάρει 6 + 3 ναι όχι και γιατί ?
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/

taseas

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Δ
« Απάντηση #48 στις: 24 Ιούν 2020, 03:29:20 μμ »
Δεν είναι ασάφεια και πρέπει να κοπούν μονάδες γιατί έτσι ξεγλιστράει από τη δυσκολία του θέματος. Ουσιαστικά είναι σαν να χρησιμοποιεί break.
Είμαι από τους λίγους που πιστεύω ότι η αλλαγή του μετρητή μέσα στη Για δεν πρέπει να θεωρείται λάθος, σε κάποιες περιπτώσεις πρέπει να είμαστε ελαστικοί αλλά αυτή δεν είναι μια από αυτές τις περιπτώσεις.

Το θέμα δεν είναι αν θα κοπούν μονάδες αλλά πόσες, γιατί το σκεπτικό του είναι αλγοριθμικά σωστό.

ΥΓ. Υπάρχει σχετική οδηγία, είναι στις τελευταίες οδηγίες που είχαν στείλει που είχε μέσα και άλλες για τα υποπρογράμματα.

Και γιατί να μη χρησιμοποιήσει την Όσο... επανάλαβε ; Εγώ εξηγώ στα παιδιά ότι η Για... είναι τρένο και δεν τη σταματάμε για κανένα λόγο. Αν θέλουν να κάνει "break" να βάζουν την Όσο... με flag.

Θα επανέλθω με μια δικιά μου λύση για το Θέμα Δ προσεχώς.

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #49 στις: 24 Ιούν 2020, 03:48:30 μμ »
Και το  break ... χάνει.
Η συνθήκη που ελέγχει η "Για  j " ...  είναι  j <= 100
Άρα ... j <- 101   και  όχι  j <- 100

Επίσης :  Β4  σελ. 73  8.3  τελευταία παράγραφος.

SuperTz

  • Βετεράνος
  • ****
  • Μηνύματα: 56
Απ: Θέμα Δ
« Απάντηση #50 στις: 24 Ιούν 2020, 03:52:46 μμ »
Νομίζω ότι το ερώτημα Δ4 είναι ίδιο με αυτό του 2004 (2ο κριτήριο ταξινόμησης) απλά είναι με διαδικασία. Αλφαβητική σειρά δεν σημαίνει κάτι άλλο παρά ταξινόμηση.

Επειδή ο μεγαλύτερος κριτής είναι οι μαθητές, δεν είδα να τους προβλημάτισε η διατύπωση.

Η αλφαβητική σειρά είναι ταξινόμηση αλλά εδώ είναι ένα δεύτερο κριτήριο το οποίο το αναφέρει στην Εμφάνιση και όχι στην Ταξινόμηση. Θα μπορούσε η διατύπωση να ήταν: "Να  εμφανίζει  τα  ονόματα  των  περιοχών,  ταξινομημένα  σε  φθίνουσα
σειρά ως προς το πλήθος των  θετικών δειγμάτων που εντοπίστηκαν. Σε περίπτωση  που  δύο  ή  περισσότερες  περιοχές  έχουν  το  ίδιο  πλήθος θετικών  δειγμάτων,  η ταξινόμηση να γίνεται κατά  αλφαβητική σειρά των ονομάτων των περιοχών. "

Υ.Γ. ωραίο το σχόλιο για την αμοιβή!:-)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #51 στις: 24 Ιούν 2020, 04:17:04 μμ »
Ανδρέα δεν ξέρω αν χάνει με το j <- 100 γιατί αμέσως μετά η Για κάνει την αύξηση, η αύξηση γίνεται μετά το τέλος επανάληψης και πριν ελεγχθεί η συνθήκη της Όσο (Για) άρα δουλεύει αν δεχθούμε ότι επιτρέπεται η αλλαγή του μετρητή της Για. Έτσι στην επιστροφή θα έχει ήδη γίνει 101 πριν τον έλεγχο.
Και το  break ... χάνει.
Η συνθήκη που ελέγχει η "Για  j " ...  είναι  j <= 100
Άρα ... j <- 101   και  όχι  j <- 100

Επίσης :  Β4  σελ. 73  8.3  τελευταία παράγραφος.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #52 στις: 24 Ιούν 2020, 04:32:08 μμ »
Ευριπίδη  , ΝΑΙ έτσι είναι !
Δεν το πρόσεξα  ... Βρίσκεται μέσα στην ΑΝ και πριν το Τέλος_επανάληψης  !
Αλλά ... Να γυρίσουμε στο συνέδριο  του Ισραήλ  1964 ; Ν ' ανακαλύψουμε ξανά τον ... 'τροχό ' ;

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 334
Απ: Θέμα Δ
« Απάντηση #53 στις: 24 Ιούν 2020, 06:27:20 μμ »
Το θέμα Δ ήταν τσιμπημένο. Και πολύ καλά έκαναν. Διαχωρίζει παπαγάλους από καλούς γνώστες του αντικειμένου, είναι εξαιρετικό θέμα βασικά.
Κλασικά στοιχεία θέματος Δ, δεμένα με πολύ ωραίο τρόπο όμως. Ταξινόμηση, παράλληλοι πίνακες, υποπρόγραμμα, δομές επιλογής κι επανάληψης, τι άλλο να θέλουμε, μια χαρά θέμα!


taseas

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Δ
« Απάντηση #54 στις: 24 Ιούν 2020, 07:02:35 μμ »
Τώρα βρήκα λίγο χρόνο και το έλυσα και εγώ. Ο τρόπος που έκανα τη διαδικασία είναι ίσως λίγο "χαζός" αλλά θα έλεγα ότι είναι περισσότερο quick-n-dirty και βγάζει σωστό αποτέλεσμα στην ταξινόμηση όπως και να 'χει.

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ θεμα_δ_by_taseas
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, k, max, sum_θετ[20]
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], αποτελ, ΑΠ[20, 100]

ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    j <- 1
    ΔΙΑΒΑΣΕ αποτελ
    ΟΣΟ αποτελ <> "ΤΕΛΟΣ" ΚΑΙ j <= 100 ΕΠΑΝΑΛΑΒΕ
      ΑΠ[i, j] <- αποτελ                                      !σίγουρα "Α" ή "Θ"
      j <- j + 1
      ΔΙΑΒΑΣΕ αποτελ                                        !"Α" ή "Θ" ή "ΤΕΛΟΣ"
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ k ΑΠΟ j ΜΕΧΡΙ 100!k=101 εάν έχουν ληφθεί όλα τα αποτελέσματα, οπότε δεν μπαίνει να βάλει "Χ"
      ΑΠ[i, k] <- "Χ"
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  max <- -1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    sum_θετ[i] <- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100
      ΑΝ ΑΠ[i, j] = "Θ" ΤΟΤΕ
        sum_θετ[i] <- sum_θετ[i] + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ max < sum_θετ[i] ΤΟΤΕ
      max <- sum_θετ[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ sum_θετ[i] = max ΤΟΤΕ
      ΓΡΑΨΕ Π[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(sum_θετ, Π)

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(sum_θετ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, temp1, sum_θετ[20]
  ΧΑΡΑΚΤΗΡΕΣ: temp2, Π[20]

ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1
      ΑΝ Π[j] < Π[j - 1] ΤΟΤΕ

        temp2 <- Π[j - 1]
        Π[j - 1] <- Π[j]
        Π[j] <- temp2

        temp1 <- sum_θετ[j - 1]
        sum_θετ[j - 1] <- sum_θετ[j]
        sum_θετ[j] <- temp1


      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1
      ΑΝ sum_θετ[j] > sum_θετ[j - 1] ΤΟΤΕ

        temp1 <- sum_θετ[j - 1]
        sum_θετ[j - 1] <- sum_θετ[j]
        sum_θετ[j] <- temp1

        temp2 <- Π[j - 1]
        Π[j - 1] <- Π[j]
        Π[j] <- temp2

      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #55 στις: 24 Ιούν 2020, 07:05:10 μμ »
Η διόρθωση/προσθήκη με έντονα γράμματα


ΠΡΟΓΡΑΜΜΑ θεμα_δ_by_taseas

    j <- 1
    ΔΙΑΒΑΣΕ αποτελ
    ΟΣΟ αποτελ <> "ΤΕΛΟΣ" ΚΑΙ j <= 100 ΕΠΑΝΑΛΑΒΕ
      ΑΠ[i, j] <- αποτελ                                      !σίγουρα "Α" ή "Θ"
      j <- j + 1
      ΑΝ j <= 100 ΤΕΛΟΣ
          ΔΙΑΒΑΣΕ αποτελ                                        !"Α" ή "Θ" ή "ΤΕΛΟΣ"
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   

taseas

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Δ
« Απάντηση #56 στις: 24 Ιούν 2020, 07:21:34 μμ »
Η διόρθωση/προσθήκη με έντονα γράμματα


Σωστός! Δεν θα εισαχθεί τίποτα λάθος, αλλά δεν υπάρχει λόγος να διαβαστεί κάτι εάν το j έχει γίνει 101, έχουν ήδη δοθεί 100 δεδομένα ("Θ" ή "Α")!


andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #57 στις: 24 Ιούν 2020, 07:29:03 μμ »
taseas

Διαδικασία ΤΑΞΙΝΟΜΗΣΗ

Παίζει ;

taseas

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Δ
« Απάντηση #58 στις: 24 Ιούν 2020, 07:33:04 μμ »
taseas

Διαδικασία ΤΑΞΙΝΟΜΗΣΗ

Παίζει ;

Ναι, σε ό,τι δοκιμές έκανα μέχρι τώρα παίζει κομπλέ. Αυτό που έκανα και λέω ότι είναι χαζό, είναι ότι κάνω 2 ταξινομήσεις: μία για να βάλω τις περιοχές σε αύξουσα (αλφαβητική) σειρά και έπειτα άλλη μία για να βάλω σε φθίνουσα σειρά με βάση το πλήθος των θετικών κρουσμάτων.

Σίγουρα inefficient (από άποψη reads στη μνήμη) αλλά σίγουρα και πιο απλό. Φαντάζομαι θα το έχουν κάνει αρκετά παιδιά έτσι.

juandojas

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #59 στις: 24 Ιούν 2020, 09:30:45 μμ »
Μαθητής μου στη διαδικασία, έκανε 2 παράλληλες ταξινομήσεις. Την πρώτη με κριτήριο τα ονόματα σε αύξουσα σειρα και τη δεύτερη με κριτήριο τον κατασκευασμενο πίνακα με τα πλήθη των Θ κάθε περιφέρειας σε φθίνουσα. Πόσο πιθανόν είναι ο διορθωτής να μην καταλάβει ότι η λύση δουλεύει μια χαρά κ να του αφαιρέσει;

ApoAntonis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 133
Απ: Θέμα Δ
« Απάντηση #60 στις: 24 Ιούν 2020, 10:46:46 μμ »
το δεύτερο κριτηριο ταξινομησης, δεν ειναι υποθεση της ταξινομησης (δηλαδη της Διαδικασίας);

Μα τότε δεν θα έπρεπε να λέει να ταξινομούνται με αλφαβητική σειρά, αντί να χρησιμοποιήσει το εμφανίζονται;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #61 στις: 24 Ιούν 2020, 11:04:31 μμ »
juandojas

Μηδενική.

Δουλεύει και ... θα το καταλάβει !

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #62 στις: 24 Ιούν 2020, 11:07:21 μμ »
Λύση που σκέφτηκα για το Δ2 στην αγρυπνία, πιστεύω ότι παραλλαγή της θα έχει προσεγγιστεί από αρκετούς μαθητές

Κώδικας: [Επιλογή]
Για i από 1 μέχρι 20
    γεμίζω <- αληθής
    Για j από 1 μέχρι 100
Αν γεμίζω = αληθής τότε
Διάβασε τιμή
Αν τιμή = 'τέλος' τότε
ΑΠ[i, j] <- 'X'
γεμίζω <- ψευδής
Αλλιώς
ΑΠ[i, j] <- τιμή
Τέλος_αν
Αλλιώς
ΑΠ[i, j] <- 'X'
Τέλος_αν
    Τέλος_επανάληψης
Τέλος_επανάληψης

pfan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
  • ...
Απ: Θέμα Δ
« Απάντηση #63 στις: 24 Ιούν 2020, 11:28:19 μμ »
Μόνο σε εμένα μου χτύπησε άσχημα που έβαλαν θέμα που σχετιζόταν με τον COVID19?
Δηλαδή αν υπάρχει παιδί που είχε δικό του άνθρωπο που νόσησε σοβαρά από covid19 θα του άρεσε να διαπραγματεύεται με αυτό το θέμα;;;

Τα θέματα πρέπει να έχουν και κοινωνική ευαισθησία η πανδημία και η καραντίνα δεν από αυτά που θα έπρεπε η επιτροπή να επιλέξει.

Για την περίπτωση που κάποιος θα έκανε πρώτα την ταξινόμηση και μετά θα εμφάνιζε τα μέγιστα μας έτυχε στο βαθμολογικό σήμερα και του δώσαμε όλα τα μόρια εφόσον το είχε σωστό.

Επίσης στο Δ θέμα αν και είναι καλό θα μπορούσε να είχε ουρά ή στοίβα ...

Τέλος για να κατανέμονται σωστά οι μονάδες της βαθμολόγησης στο Γ και Δ θέμα θα πρέπει να ζητήσουμε το κάθε θέμα να βαθμολογείται με 25 μονάδες και όχι το Α να έχει 40.
Η κατανομή βαθμολογίας στα Γ και Δ θέματα είναι προβληματική στα βαθμολογικά δεν μπορεί μια σελίδα κώδικα να πρέπει να της δώσεις 3 μονάδες μόνο ...

Πύρζα Φανή
Καθηγήτρια Πληροφορικής

dpa2006

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 722
Απ: Θέμα Δ
« Απάντηση #64 στις: 24 Ιούν 2020, 11:33:01 μμ »
Μόνο σε εμένα μου χτύπησε άσχημα που έβαλαν θέμα που σχετιζόταν με τον COVID19?
Δηλαδή αν υπάρχει παιδί που είχε δικό του άνθρωπο που νόσησε σοβαρά από covid19 θα του άρεσε να διαπραγματεύεται με αυτό το θέμα;;;

Τα θέματα πρέπει να έχουν και κοινωνική ευαισθησία η πανδημία και η καραντίνα δεν από αυτά που θα έπρεπε η επιτροπή να επιλέξει.

Για την περίπτωση που κάποιος θα έκανε πρώτα την ταξινόμηση και μετά θα εμφάνιζε τα μέγιστα μας έτυχε στο βαθμολογικό σήμερα και του δώσαμε όλα τα μόρια εφόσον το είχε σωστό.

Επίσης στο Δ θέμα αν και είναι καλό θα μπορούσε να είχε ουρά ή στοίβα ...

Τέλος για να κατανέμονται σωστά οι μονάδες της βαθμολόγησης στο Γ και Δ θέμα θα πρέπει να ζητήσουμε το κάθε θέμα να βαθμολογείται με 25 μονάδες και όχι το Α να έχει 40.
Η κατανομή βαθμολογίας στα Γ και Δ θέματα είναι προβληματική στα βαθμολογικά δεν μπορεί μια σελίδα κώδικα να πρέπει να της δώσεις 3 μονάδες μόνο ...



Έχεις δίκιο...
Computer science (abbreviated CS or CompSci) is the scientific and practical approach to computation and its applications. It is the systematic study of the feasibility, structure, expression, and mechanization of the methodical processes (or algorithms) that underlie the acquisition, representation, processing, storage, communication of, and access to information, whether such information is encoded in bits and bytes in a computer memory or transcribed engines and protein structures in a human cell.source:http://en.wikipedia.org/wiki/Computer_science

taseas

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Δ
« Απάντηση #65 στις: 25 Ιούν 2020, 01:33:45 πμ »
Μαθητής μου στη διαδικασία, έκανε 2 παράλληλες ταξινομήσεις. Την πρώτη με κριτήριο τα ονόματα σε αύξουσα σειρα και τη δεύτερη με κριτήριο τον κατασκευασμενο πίνακα με τα πλήθη των Θ κάθε περιφέρειας σε φθίνουσα. Πόσο πιθανόν είναι ο διορθωτής να μην καταλάβει ότι η λύση δουλεύει μια χαρά κ να του αφαιρέσει;

Παντελώς απίθανο. Το καλό γραπτό φαίνεται, αν δεν του έχει ξεφύγει κάτι κάπου αλλού δεν θα έχει κανένα θέμα.

Γιαννούλης Γιώργος

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Θέμα Δ
« Απάντηση #66 στις: 25 Ιούν 2020, 10:54:55 πμ »
Μαθητής μου στη διαδικασία, έκανε 2 παράλληλες ταξινομήσεις. Την πρώτη με κριτήριο τα ονόματα σε αύξουσα σειρα και τη δεύτερη με κριτήριο τον κατασκευασμενο πίνακα με τα πλήθη των Θ κάθε περιφέρειας σε φθίνουσα. Πόσο πιθανόν είναι ο διορθωτής να μην καταλάβει ότι η λύση δουλεύει μια χαρά κ να του αφαιρέσει;

Καλή απορία, προσωπικά ούτε που θα σκεφτόμουν να κόψω γιατί βγάζει πάντα σωστό αποτέλεσμα. Δεν είναι μέσα στην ύλη όμως ότι ο bubblesort και η ταξινόμηση επιλογής είναι stable, οπότε η μια ταξινόμηση δεν χαλάει την άλλη. Οπότε δεν είναι απίθανο να χάσει κάτι.

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Θέμα Δ
« Απάντηση #67 στις: 25 Ιούν 2020, 02:28:07 μμ »
Εντάξει, ο μαθητής που καταλαβαίνει σε βάθος πώς δουλεύει η φυσαλίδα,
προφανώς και καταλαβαίνει ότι τα κελιά με ίσες τιμές τα αφήνει με τη σειρά που βρίσκονταν από πριν!
Θα έπρεπε να το λέει η θεωρία δηλαδή;;;
Δε μπορώ να καταλάβω πώς μπορεί να συζητάμε καν το ενδεχόμενο χάσει μονάδες μια τέτοια λύση!   :o
Να κόβουμε μονάδες από τους μαθητές που το μυαλό τους παράγει περισσότερα από αυτά που τους δίνει το βιβλίο δηλαδή, αυτό λέμε ;
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Θέμα Δ
« Απάντηση #68 στις: 25 Ιούν 2020, 02:55:00 μμ »
Μόνο σε εμένα μου χτύπησε άσχημα που έβαλαν θέμα που σχετιζόταν με τον COVID19?
Δηλαδή αν υπάρχει παιδί που είχε δικό του άνθρωπο που νόσησε σοβαρά από covid19 θα του άρεσε να διαπραγματεύεται με αυτό το θέμα;;;
Τα θέματα πρέπει να έχουν και κοινωνική ευαισθησία η πανδημία και η καραντίνα δεν από αυτά που θα έπρεπε η επιτροπή να επιλέξει.
έχεις κάποιο δίκιο εδώ...

Επίσης στο Δ θέμα αν και είναι καλό θα μπορούσε να είχε ουρά ή στοίβα ...
Σ' αυτό δε συμφωνώ. Η μικρή πείρα με τις ασκήσεις ουράς και στοίβας έδειξε ότι
1) καμία εκφώνηση δεν κατάφερε να είναι αρκετά καλή, με πρώτες του σχολικού βιβλίου. Αλλά και απόπειρες δικές μου και συναδέλφων, όσο λεπτομερείς και να ήταν, δε θυμάμαι καμιά που δεν δημιούργησε προβλήματα ή ερωτηματικά και ασάφειες στο λύτη. Οι εκφωνήσεις ήταν πάντα πολύ μεγάλες και όχι κατανοητές από τα παιδιά. Πολλές δε, παρουσίαζαν πρόβλημα τελικά στην υλοποίηση.
2) πέρα από το μονότονο σενάριο ενός μενού επιλογής, όπου αποφασίζεται αν θα γίνει ώθηση/εισαγωγή ή απώθηση/εξαγωγή (για να κοπιάρουν τον αντίστοιχο παπαγαλισμένο κώδικα), σχεδόν καμία δεν μπόρεσε να προσφέρει μια αξιόλογη πρόκληση (σε σχέση με τα όλο και βελτιούμενα Θέματα Γ και Δ που είχαμε συνηθίσει, εννοώ)
3) έπειτα από 1-2 άντε 3 λύσεις, το πράγμα κατάντησε μονότονο και βαρετό και ένιωθα ότι χάνω πολύτιμο χρόνο (ειδικά στο χρόνο των επαναλήψεων, να λύνω τόσο μεγάλες ασκήσεις - τυφλοσούρτες)
Χαίρομαι που δεν επιλέχθηκε τέτοιο Θέμα Γ ή Δ και σχεδόν το περίμενα, γιατί θα σπαταλιόταν μια ευκαιρία να ζητηθεί κάτι πιο προκλητικό (τώρα, αν ζητήθηκε κάτι πιο προκλητικό, είναι ένα άλλο ζήτημα... :) )

Τέλος για να κατανέμονται σωστά οι μονάδες της βαθμολόγησης στο Γ και Δ θέμα θα πρέπει να ζητήσουμε το κάθε θέμα να βαθμολογείται με 25 μονάδες και όχι το Α να έχει 40.
Η κατανομή βαθμολογίας στα Γ και Δ θέματα είναι προβληματική στα βαθμολογικά δεν μπορεί μια σελίδα κώδικα να πρέπει να της δώσεις 3 μονάδες μόνο ...
Αν και έχω συνηθίσει και αγαπώ την παραδοσιακή βαθμοδότηση, ομολογώ ότι εδώ ίσως έχεις δίκιο και είναι μια ιδέα που μάλλον θα την ψήφιζα. +1
Φιλικά,
Γιώργος Θαλασσινός

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 795
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Θέμα Δ
« Απάντηση #69 στις: 25 Ιούν 2020, 08:03:21 μμ »
Η αρχικοποίηση του πίνακα ΑΠ με Χ οδηγεί στο σωστό αποτέλεσμα αλλά η λύση δεν ακολουθεί τις οδηγίες του θέματος άρα πρέπει ο μαθητής να χάσει κάποια μόρια. Αν ο μαθητής έλυνε σωστά το πρόβλημα με C++ ενώ η εκφώνηση έλεγε ότι πρέπει αν χρησιμοποιηθεί η ΓΛΩΣΣΑ θα έπρεπε να πάρει άριστα?

Ο κορωνοιος και η αντιμετωπισή του  είναι μια  σημαντική σημερινή πραγματικότητα στην Ελλάδα, στο μάθημα μας υποστηρίζουμε ότι τα θέματά μας είναι άμεσα συνδεμένα με τον πραγματικό κόσμο (διαβάστε τα αντίστοιχα θέματα φυσικής να δείτε τι σχέση έχουν με την πραγματικότητα).  Θεωρώ σωστό που οι θεματοδότες έβαλαν κάποιο σχετικό θέμα.

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Θέμα Δ
« Απάντηση #70 στις: 25 Ιούν 2020, 08:29:39 μμ »
Καλησπέρα σε όλους
τώρα να θέσω και εγώ ένα προβληματισμό ???  λες και δεν μας έφταναν οι υπόλοιποι που είχαμε ...  >:D :angel: :D  στα ερωτήματα Δ3, Δ4 και Δ5, μήπως πρέπει να ελέγξουμε και αν ολόκληρος ο δισδιάστατος πίνακας  έχει τιμή 'Χ' ??? θεωρητικά μπορεί να μην υπάρχει κανένα δείγμα και να εμφανιστούν λάθος αποτελέσματα σε περίπτωση που δεν το ελέγξει κάποιος ... προκύπτει από κάπου πως υπάρχουν τουλάχιστον κάποια δείγματα ??

UPDATE: η να μην υπήρχε κανένα θετικό δείγμα

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 565
Απ: Θέμα Δ
« Απάντηση #71 στις: 25 Ιούν 2020, 08:54:17 μμ »
Δεν έχει σημασία και με 0 στο πίνακα πλήθους τρέχουν τα ερωτήματα.... Δεν χτυπάει κάτι...


Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Θέμα Δ
« Απάντηση #72 στις: 25 Ιούν 2020, 08:57:22 μμ »
Καλά ναι δεν τίθεται θέμα "καθοριστικότητας" για παράδειγμα, αλλά αν όλα τα πλήθη είναι 0 πχ θα μπορούσε να εμφανιστεί μήνυμα "δεν υπήρχαν θετικα" πχ η κάτι τέτοιο .. μπορεί το 0 να θεωρηθεί ως "περισσότερα δείγματα" ?? ίσως μία διευκρίνιση ακόμη θα ήταν καλό να γίνει ... τέσπα μην το κουράζουμε πολύ, δεν υπάρχει θέμα, αλλά κάποιοι μαθητές μου το έκαναν

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Δ
« Απάντηση #73 στις: 26 Ιούν 2020, 01:54:52 μμ »
Σ' αυτό δε συμφωνώ. Η μικρή πείρα με τις ασκήσεις ουράς και στοίβας έδειξε ότι
1) καμία εκφώνηση δεν κατάφερε να είναι αρκετά καλή, με πρώτες του σχολικού βιβλίου. Αλλά και απόπειρες δικές μου και συναδέλφων, όσο λεπτομερείς και να ήταν, δε θυμάμαι καμιά που δεν δημιούργησε προβλήματα ή ερωτηματικά και ασάφειες στο λύτη. Οι εκφωνήσεις ήταν πάντα πολύ μεγάλες και όχι κατανοητές από τα παιδιά. Πολλές δε, παρουσίαζαν πρόβλημα τελικά στην υλοποίηση.
2) πέρα από το μονότονο σενάριο ενός μενού επιλογής, όπου αποφασίζεται αν θα γίνει ώθηση/εισαγωγή ή απώθηση/εξαγωγή (για να κοπιάρουν τον αντίστοιχο παπαγαλισμένο κώδικα), σχεδόν καμία δεν μπόρεσε να προσφέρει μια αξιόλογη πρόκληση (σε σχέση με τα όλο και βελτιούμενα Θέματα Γ και Δ που είχαμε συνηθίσει, εννοώ)
3) έπειτα από 1-2 άντε 3 λύσεις, το πράγμα κατάντησε μονότονο και βαρετό και ένιωθα ότι χάνω πολύτιμο χρόνο (ειδικά στο χρόνο των επαναλήψεων, να λύνω τόσο μεγάλες ασκήσεις - τυφλοσούρτες)
Χαίρομαι που δεν επιλέχθηκε τέτοιο Θέμα Γ ή Δ και σχεδόν το περίμενα, γιατί θα σπαταλιόταν μια ευκαιρία να ζητηθεί κάτι πιο προκλητικό (τώρα, αν ζητήθηκε κάτι πιο προκλητικό, είναι ένα άλλο ζήτημα... :) )
Συμφωνώ ως προς το αποτέλεσμα της σκέψης, δηλαδή καλύτερα που δεν μπήκε στοίβα και ουρά σε κώδικα. Ωστόσο δε νομίζω ότι είναι τόσο χάλια η κατάσταση, όσο περιγράφεις. Υπάρχουν θέματα που δεν είναι μεγάλα ούτε υπερβολικά πολύπλοκα και πετυχαίνουν τον σκοπό τους, θεωρώ. Ωστόσο συμφωνώ και στο ότι δύσκολα πετυχαίνεις να μην είναι μονότονη η χρήση των λειτουργιών, και γενικά δεν εμπιστεύομαι ότι θα έμπαινε ένα αρκετά σαφές και καθαρό θέμα για επίπεδο Πανελληνίων.
Πιστεύω ότι σε βάθος χρόνου θα φτιαχτούν καλές εκφωνήσεις, φέτος δε νομίζω ότι κανείς ασχολήθηκε σοβαρά με αυτό.

Τέλος για να κατανέμονται σωστά οι μονάδες της βαθμολόγησης στο Γ και Δ θέμα θα πρέπει να ζητήσουμε το κάθε θέμα να βαθμολογείται με 25 μονάδες και όχι το Α να έχει 40.
Η κατανομή βαθμολογίας στα Γ και Δ θέματα είναι προβληματική στα βαθμολογικά δεν μπορεί μια σελίδα κώδικα να πρέπει να της δώσεις 3 μονάδες μόνο ...
Το θεωρώ από εκείνα τα αυτονόητα που τελικά δεν γίνονται ποτέ. Συνέχεια αναγκάζομαι να λέω στους μαθητές "μην υποτιμάτε το 1ο θέμα, μπορεί να χάσετε περισσότερες μονάδες από ότι θα πάρετε με τη λύση ενός δύσκολου ερωτήματος στο Δ". Θα έπρεπε να μας προβληματίσει, όντας.. αλγοριθμιστές, αν μας ικανοποιεί αυτή η πραγματικότητα.
Είναι διδακτικά θεμιτό, να προσπαθούμε να δώσουμε βαθμολογική βοήθεια στους αδύναμους μαθητές, όταν αυτό μπορεί να αποβεί εις βάρος μαθητών που έχουν καταλάβει καλύτερα το μάθημα;
Νομίζω αυτό το θέμα έχει συζητηθεί στο παρελθόν εκτεταμένα εδώ μέσα.


Για το θέμα της διαφορετικής σειράς εκτέλεσης των ζητούμενων, εντός ενός ερωτήματος, είναι πολύ ενδιαφέρον να μπορούσαμε να ορίσουμε τι είναι το "επιστημονικά τεκμηριωμένο" στο μάθημά μας, αν μπορεί να γίνει, όπως σωστά είπε ο Ευριπίδης. Από την άλλη πάντως, θεωρώ πολύ άστοχο να κοπούν μονάδες για τη λύση που είπε ο Παναγιώτης. Αν κάτι δεν πρέπει να γίνει, ας το αποτρέπει η άσκηση, είτε έμμεσα είτε ρητά. Μήπως αυτός δεν είναι και ο λόγος που έχουμε χωριστή, ρητή απαίτηση για υποπρόγραμμα;
Και παρεμπιπτόντως, εδώ είναι ένα άλλο πρόβλημα: πάντα ζητάμε υποπρογράμματα ρητά, γιατί ποτέ δεν χρειάζονται πραγματικά στις ασκήσεις.. πολύ αποτυχία το ζήτημα του τμηματικού προγραμματισμού. Αυτό είναι μια πρόκληση, αντίστοιχη της στοίβας και ουράς που λέγαμε πριν: το θέμα δεν είναι να φτάσουμε να μην εξετάζουμε τέτοια θέματα, αλλά να μπορέσουμε με περισσότερη επιτυχία να συμπεριλάβουμε αυτές τις προκλήσεις στο σχεδιασμό των ασκήσεων/θεμάτων.
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

kyramas

  • Οπαδός
  • **
  • Μηνύματα: 10
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #74 στις: 26 Ιούν 2020, 02:10:25 μμ »
Καλησπέρα. Το γέμισμα των υπόλοιπων θέσεων της κάθε γραμμής προφανώς ζητείται για να διευκολύνει τους μαθητές στην καταμέτρηση των θετικών αποτελεσμάτων (δεν υπάρχουν άδειες θέσεις και συνεπώς η εσωτερική επανάληψη γίνεται μέχρι την τελευταία στήλη του πίνακα). Στην περίπτωση που ο μαθητής αποθηκεύεσει το δείκτη της τελευταίας θέσης που γεμίζει σε κάθε γραμμή σε ένα παράλληλο πίνακα προκειμένου να τον χρησιμοποιήσει ως όριο τέλους στις επόμενες επναλήψεις για την καταμέτρηση, θα χάσει μονάδες; Μια άλλη λύση για το Δ2 χωρίς ΟΣΟ ή ΜΕΧΡΙΣ_ΟΤΟΥ είναι:

ΑΠΟΤ ←’’
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
   ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 100
      ΑΝ (ΑΠΟΤ <> ‘ΤΕΛΟΣ’) ΤΟΤΕ
         ΔΙΑΒΑΣΕ ΑΠΟΤ
      ΤΕΛΟΣ_ΑΝ
      ΑΝ (ΑΠΟΤ <> ‘ΤΕΛΟΣ’) ΤΟΤΕ
        ΑΠ[Ι,J]← ΑΠΟΤ
     ΑΛΛΙΩΣ
        ΑΠ[Ι,J]← ‘Χ’
     ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Δ
« Απάντηση #75 στις: 26 Ιούν 2020, 02:30:00 μμ »
Η ρητή αλλαγή δείκτη στη Για, απαγορεύεται, αλλά στην ΟΣΟ/Μεχρις_Οτου;
Ένας μαθητής μου, έκανε αυτό στην εικόνα. Οι πιο έμπειροι βαθμολογικά, ξέρετε αν θα του κόψουν;
(edit, στις εξετάσεις έγραψε τον Απ ως 2Δ πίνακα, εδώ προφανώς μπερδεύτηκε)
« Τελευταία τροποποίηση: 26 Ιούν 2020, 03:14:39 μμ από akalest0s »
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #76 στις: 26 Ιούν 2020, 03:08:23 μμ »
Respect !

Γιαννούλης Γιώργος

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Θέμα Δ
« Απάντηση #77 στις: 30 Ιούν 2020, 08:35:27 μμ »
Η ρητή αλλαγή δείκτη στη Για, απαγορεύεται, αλλά στην ΟΣΟ/Μεχρις_Οτου;
Ένας μαθητής μου, έκανε αυτό στην εικόνα. Οι πιο έμπειροι βαθμολογικά, ξέρετε αν θα του κόψουν;
Η ΟΣΟ δεν έχει μετρητή, εξετάζει μια συνθήκη που μπορεί να τη χρησιμοποιήσεις με τη λογική του μετρητή όπως και με πολλές άλλες πιο σύνθετες συνθήκες.
Μέσα στη ΓΙΑ δεν πειράζει το ι (τον μετρητή της).
Οπότε δεν βλέπω για πιο λόγο να χάσει οποιαδήποτε μονάδα.

Υ.Γ.   Τ_Ε for ever

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Δ
« Απάντηση #78 στις: 01 Ιούλ 2020, 09:49:15 πμ »
Υ.Γ.   Τ_Ε for ever
;D ;D ό,τι και να τους πεις, δεν το βγάζουν από το μυαλό τους.. ελπίζω να μην το έκανε και στις εξετάσεις!
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #79 στις: 01 Ιούλ 2020, 10:06:34 πμ »
Ωστόσο το ερώτημα παραμένει, όταν ένας μαθητής ρωτήσει:
Τα παρακάτω τμήματα κώδικα δεν είναι ισοδύναμα? Δεν εκτελούν ακριβώς τα ίδια βήματα με την ίδια σειρά? Γιατί στην μια περίπτωση επιτρέπεται
η μεταβολή του μετρητή και στην άλλη όχι?
Τι είδους λάθος είναι στην μια περίπτωση?
Αφού στην μια είναι σωστό αλγοριθμικά δεν θα έπρεπε να είναι σωστό και στην άλλη?
Κώδικας: ΓΛΩΣΣΑ
  1. Ι <- 1
  2. ΟΣΟ Ι<=10 ΕΠΑΝΑΛΑΒΕ
  3.     ΔΙΑΒΑΣΕ Χ
  4.     ΑΝ Χ<0 ΤΟΤΕ
  5.        Ι<-10
  6.     ΤΕΛΟΣ_ΑΝ
  7.     Ι <- Ι + 1
  8. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Κώδικας: ΓΛΩΣΣΑ
  1. ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
  2.     ΔΙΑΒΑΣΕ Χ
  3.     ΑΝ Χ<0 ΤΟΤΕ
  4.        Ι<-10
  5.     ΤΕΛΟΣ_ΑΝ
  6. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Προφανώς πρέπει να δώσουμε κάποια επιστημονική εξήγηση και όχι να αναφερόμαστε σε εγκυκλίους του υπουργείου παιδείας, για να πείσουμε τον μαθητή ότι αυτό που διδάσκεται είναι επιστήμη.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5704
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Δ
« Απάντηση #80 στις: 01 Ιούλ 2020, 10:36:38 πμ »
Ο βασικότερος λόγος είναι η αναγνωσιμότητα του κώδικα. Δηλαδή ο ίδιος λόγος που υιοθετήθηκε ο δομημένος προγραμματισμός και μειώθηκε η χρήση της GOTO.
Σε μια ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 10, περιμένουμε η επανάληψη να γίνει 10 φορές, και έτσι διαβάζουμε τον κώδικα ευκολότερα.
Αν εντός της επανάληψης δούμε μεταβολή του μετρητή π.χ. Ι <- 3*Ι-2, τότε θα πάθουμε ένα σοκ και θα ψάχνουμε να καταλάβουμε τι παίζει, δεν ανταποκρίνεται στις γνωστές μας χρήσεις της ΓΙΑ.
Η break από την άλλη, που βγαίνει από μια ΓΙΑ, δεν δυσχεραίνει την ανάγνωση (κι ας αντιστοιχεί σε μη δομημένο διάγραμμα). Δεν είναι όμως ισοδύναμη σε αναγνωσιμότητα με την Ι <- 11.

Σάκης Δημόπουλος

  • Βετεράνος
  • ****
  • Μηνύματα: 96
  • Dimopoulos Informatics Tutorials
    • Dimopoulos Informatics Tutorials
Απ: Θέμα Δ
« Απάντηση #81 στις: 09 Ιούλ 2020, 11:24:43 μμ »
ΠΛΗΡΟΦΟΡΙΚΗ Πανελλήνιες 2020 Λύση Θέματος Δ: https://www.youtube.com/watch?v=xc0x-bMtpFE

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 334
Απ: Θέμα Δ
« Απάντηση #82 στις: 11 Ιούλ 2020, 06:16:58 μμ »
Προφανώς πρέπει να δώσουμε κάποια επιστημονική εξήγηση και όχι να αναφερόμαστε σε εγκυκλίους του υπουργείου παιδείας, για να πείσουμε τον μαθητή ότι αυτό που διδάσκεται είναι επιστήμη.

Δίνουν τα παιδιά Πανελλήνιες το 2018.
Πέφτει το αδόμητο διάγραμμα ροής.
Θυμίζω τι ζητούσε:
"Να κωδικοποιήσετε σε ΓΛΩΣΣΑ αντίστοιχο τμήμα προγράμματος που να εκτελεί ακριβώς την ίδια ακολουθία εντολών (βημάτων)."
Επιστημονικά τεκμηριωμένες απαντήσεις είναι αποδεκτές στις Πανελλήνιες.

Στο σενάριο να απαντά ένα παιδί πως:
"Σε ΓΛΩΣΣΑ είναι αδύνατο να δομήσεις πρόγραμμα που να εκτελεί ακριβώς την ίδια ακολουθία εντολών (βημάτων), επειδή είναι αδόμητο το διάγραμμα ροής και δεν υποστηρίζεται η GOTO από τη ΓΛΩΣΣΑ"
επιτροπές μπορεί να του κόψουν 100%, ενώ το παιδί έχει 100% δίκιο.
Δε το βγάζω από το κεφάλι μου αυτό, αλλά και δε κατηγορώ κανέναν γι' αυτό.

https://alkisg.mysch.gr/steki/index.php?topic=8330.msg91172#msg91172

Με την επιφύλλαξη ο συνάδελφος να μη κατάλαβε τι ρώτησα, συντακτικά αυτό που έγραψα δεν ήταν και τόσο καλό, παραθέτω αυτό, ως παράδειγμα, που τίθεται στο τραπέζι η πιθανότητα να κόψεις 100% σε σωστή επιστημονικά απάντηση, σε άστοχο θέμα Πανελληνίων. Και δε φταίει η Επιτροπή, ιδιαίτερα αν έχει ρητές οδηγίες λάθος απάντησης ως σωστές. Αν έχεις μία σωστή ενδεικτική λύση, έχεις λύση στα χέρια σου. Αν ο μαθητής πει πως δε λύνεται του κόβεις 100% κι ας έχει δίκιο. Δε μου αρέσει. Σε κανένα δεν αρέσει. Είναι σκληρή δουλειά η διόρθωση θεμάτων Πανελληνίων βάσει οδηγιών.

Το μάθημα χρειάζεται ριζική αλλαγή. Python3 που λέει το ΙΤΕ ας πούμε στη διημερίδα! Κι εγώ μαζί τους. Είναι και πολύ διαδεδομένη, και πολύ καλή για να διδάξεις σε Λύκειο, κοντά στη φυσική γλώσσα (όπως είναι η ΓΛΩΣΣΑ) δίχως όμως να γίνεται όμοια, καλώς ορισμένη και διατυπωμένη, αν το Υπουργείο βγάλει σωστά βιβλία, θα δούμε άσπρη μέρα!  ;)
Η ΓΛΩΣΣΑ δεν είναι χρήσιμο εργαλέιο στη μορφή που είναι, στο να άγει την επιστημονικότητα του μαθήματος, πώς να το κάνουμε;
Είναι τροχοπέδη.
« Τελευταία τροποποίηση: 11 Ιούλ 2020, 06:31:01 μμ από George Eco »