Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 3404 φορές)

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #30 στις: 24 Ιούν 2020, 11:53:37 πμ »
mikezante
Στο Δ3. (;)
Άλλο ζητάει !
 ... το όνομα ή τα ονόματα ...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #31 στις: 24 Ιούν 2020, 11:56:53 πμ »
Πράγματι αλλά τα σετ αυτά είναι σχεδόν ίδια!
Η επιτροπή έβγαλε 3 σετ θεμάτων
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #32 στις: 24 Ιούν 2020, 12:04:20 μμ »
Το διάβασμα του πίνακα δεν είναι τόσο απλή υπόθεση
Αν το j είναι 100, δεν έχει νόημα να διαβαστεί τιμή πριν το τέλος επανάληψης
Θέλει πολύ πρόσθετο κώδικα για να είναι σωστό σε όλα του
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #33 στις: 24 Ιούν 2020, 12:46:22 μμ »
Σωστό Πέτρο, θέλει διπλή συνθήκη!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #34 στις: 24 Ιούν 2020, 12:57:08 μμ »
Θεωρώ ότι οι περισσότερες λύσεις που θα ανέβουν στο διαδίκτυο για αυτό το ερώτημα θα είναι ελαττωματικές σε κάτι
Θέλει πολύ προγραμματιστική φροντίδα το συγκεκριμένο ερώτημα ώστε να μη διαβάζει περιττά δεδομένα, να μην βγαίνει εκτός ορίων και φυσικά να μην κάνει λάθος υλοποίηση του ζητούμενου
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 41
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #35 στις: 24 Ιούν 2020, 01:06:42 μμ »
.....
Θέλει πολύ προγραμματιστική φροντίδα το συγκεκριμένο ερώτημα ώστε να μη διαβάζει περιττά δεδομένα, να μην βγαίνει εκτός ορίων και φυσικά να μην κάνει λάθος υλοποίηση του ζητούμενου

Καλημέρα !
Συμφωνώ !!
Panos

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #36 στις: 24 Ιούν 2020, 01:08:24 μμ »
Και παρατηρώ ότι πολλά παιδιά δεν του έχουν δώσει σημασία και θεωρούν ότι το έχουν υλοποιήσει σωστά
Πολύ δύσκολα κάποιος θα πάρει 6/6
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #37 στις: 24 Ιούν 2020, 01:14:16 μμ »
Και επιπλέον οι υπόλοιπες θέσεις να γεμίσουν με 'Χ' !!!
Εκτός κι αν προβλέψει να αρχικοποιήσει τον ΑΠ[20,100] με 'Χ' ...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #38 στις: 24 Ιούν 2020, 01:26:40 μμ »
Τελικά η αρχικοποίηση του πίνακα με Χ μάλλον θα είναι το τελευταίο πρόβλημα που θα έχουν να σκεφτούν οι βαθμολογητές.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

mikezante

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Δ
« Απάντηση #39 στις: 24 Ιούν 2020, 01:29:38 μμ »
mikezante
Στο Δ3. (;)
Άλλο ζητάει !
 ... το όνομα ή τα ονόματα ...

Ναι ναι, το γράφω σαν σχόλιο πάνω από τον κώδικα ότι το Δ3 μου δεν είναι σωστό!
Γ. Β.

vlachakis

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Δ
« Απάντηση #40 στις: 24 Ιούν 2020, 02:03:26 μμ »
Δ3 θελει αλλαγη


!Δ5
ΔΙΑΔΙΚΑΣΙΑ ταξινομηση(Σ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ[20], ι, ζ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τομπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ ζ ΑΠΟ 20 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Σ[ζ - 1] < Σ[ζ] ΤΟΤΕ
        τεμπ <- Σ[ζ]
        Σ[ζ] <- Σ[ζ - 1]
        Σ[ζ - 1] <- τεμπ
        τομπ <- Π[ζ]
        Π[ζ] <- Π[ζ - 1]
        Π[ζ - 1] <- τομπ
      ΑΛΛΙΩΣ_ΑΝ Σ[ζ - 1] = Σ[ζ] ΤΟΤΕ
        ΑΝ Π[ζ - 1] > Π[ζ] ΤΟΤΕ
          τομπ <- Π[ζ]
          Π[ζ] <- Π[ζ - 1]
          Π[ζ - 1] <- τομπ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
εμένα έκαναν αυτή τη λύση

ΔΙΑΔΙΚΑΣΙΑ ταξινομηση(Σ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ[20], ι, ζ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τομπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ ζ ΑΠΟ 20 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Σ[ζ - 1] < Σ[ζ] ή Σ[ζ - 1] = Σ[ζ] και Π[ζ - 1] > Π[ζ] ΤΟΤΕ
        τεμπ <- Σ[ζ]
        Σ[ζ] <- Σ[ζ - 1]
        Σ[ζ - 1] <- τεμπ
        τομπ <- Π[ζ]
        Π[ζ] <- Π[ζ - 1]
        Π[ζ - 1] <- τομπ
   
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

η ερώτηση μου είναι. θα την καταλάβουν οι διορθωτές;

tsak

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 183
Απ: Θέμα Δ
« Απάντηση #41 στις: 24 Ιούν 2020, 02:28:52 μμ »
Να σας βάλω ένα πιο δύσκολο? Μαθητής μου στο Δ2 έκανε:

Για i από 1 μέχρι 20
  Για j από 1 μέχρι 100
   Διάβασε απ[ι,j]
   Αν απ[ι.j]='τέλος' τότε
      Για κ από j μέχρι 100
        Απ[ι,κ]<-'χ'
      Τέλος_επανάληψης
     J<-100
   Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

Του το δίνεις ολόσωστο?

vlachakis

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Δ
« Απάντηση #42 στις: 24 Ιούν 2020, 02:32:16 μμ »
μη δομημένος προγραμματισμός το να εκχωρούμε στον μετρητή της Για

tsak

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 183
Απ: Θέμα Δ
« Απάντηση #43 στις: 24 Ιούν 2020, 02:47:54 μμ »
μη δομημένος προγραμματισμός το να εκχωρούμε στον μετρητή της Για
Σύμφωνοι...υπάρχει σχετική οδηγία ότι απαγορεύεται και κόβουμε βαθμούς όμως ή είναι και αυτό στις ασάφειες?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #44 στις: 24 Ιούν 2020, 02:50:03 μμ »
Σύμφωνοι...υπάρχει σχετική οδηγία ότι απαγορεύεται και κόβουμε βαθμούς όμως ή είναι και αυτό στις ασάφειες?
Δεν είναι ασάφεια και πρέπει να κοπούν μονάδες γιατί έτσι ξεγλιστράει από τη δυσκολία του θέματος. Ουσιαστικά είναι σαν να χρησιμοποιεί break.
Είμαι από τους λίγους που πιστεύω ότι η αλλαγή του μετρητή μέσα στη Για δεν πρέπει να θεωρείται λάθος, σε κάποιες περιπτώσεις πρέπει να είμαστε ελαστικοί αλλά αυτή δεν είναι μια από αυτές τις περιπτώσεις.

Το θέμα δεν είναι αν θα κοπούν μονάδες αλλά πόσες, γιατί το σκεπτικό του είναι αλγοριθμικά σωστό.

ΥΓ. Υπάρχει σχετική οδηγία, είναι στις τελευταίες οδηγίες που είχαν στείλει που είχε μέσα και άλλες για τα υποπρογράμματα.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr