Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 3405 φορές)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #15 στις: 24 Ιούν 2020, 11:14:14 πμ »
Είναι σίγουρα λάθος οι μονάδες στο Δ4,Δ5...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #16 στις: 24 Ιούν 2020, 11:14:25 πμ »
Τώρα που το διαβάζω καλύτερα πράγματι η σειρά εισαγωγής δεν αλλάζει, άρα η συμπεριφορά του προγράμματος παραμένει η ίδια.
Ωστόσο η αλλαγή της σειράς των ενεργειών έχει αντίκτυπο στον τελικό αλγόριθμο και στη δυσκολία του.
Και επειδή πάντα σκεφτόμαστε τον μαθητή από τον οποίο κόβουμε να αντιστρέψω λίγο το ερώτημα:
 Ο μαθητής που θα το κάνει ακριβώς όπως το λέει η εκφώνηση είναι σωστό να πάρει τις ίδιες μονάδες με αυτόν/η που θα βάλει από την αρχή Χ?

ΥΓ. Το 2 μονάδες που είπα είναι υπερβολικό.


Έχεις δίκιο στο ότι το να βάλεις μετά τα Χ είναι (ελάχιστα) πιο απαιτητικό.  Από την εκτεταμένη εμπειρία σου στη βαθμολόγηση αυτό δικαιολογεί απώλεια μονάδων ενώ  γίνεται η δουλειά;
Εν τω μεταξύ οι 6 μονάδες δεν είναι: 0.5 - 1 στο ΓΙΑ i, 3-3.5 στο ΟΣΟ και 1.5-2 στο επικείμενο  ΓΙΑ των 'Χ';

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 608
    • Ανάπτυξη Εφαρμογών
Απ: Θέμα Δ
« Απάντηση #17 στις: 24 Ιούν 2020, 11:19:41 πμ »
Καλημέρα παιδιά.

Ευριπίδη από τη μία έχεις δίκιο αλλά από την άλλη και η άλλη απάντηση δεν στέκει να την κόψουμε. Εγώ πάντως όταν την έλυσα την έλυσα γεμίζοντας πρώτα τον πίνακα με Χ.

Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #18 στις: 24 Ιούν 2020, 11:20:16 πμ »
Είναι σίγουρα λάθος οι μονάδες στο Δ4,Δ5...

Λιγότερη αμοιβή (μονάδες) για περισσότερη δουλειά,
ακούγεται σαν σύγχρονο εργασιακό περιβάλλον

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #19 στις: 24 Ιούν 2020, 11:21:23 πμ »
Έχεις δίκιο στο ότι το να βάλεις μετά τα Χ είναι (ελάχιστα) πιο απαιτητικό.  Από την εκτεταμένη εμπειρία σου στη βαθμολόγηση αυτό δικαιολογεί απώλεια μονάδων ενώ  γίνεται η δουλειά;
Εν τω μεταξύ οι 6 μονάδες δεν είναι: 0.5 - 1 στο ΓΙΑ i, 3-3.5 στο ΟΣΟ και 1.5-2 στο επικείμενο  ΓΙΑ των 'Χ';
Λογικά οι περισσότεροι υποθέτω ότι δεν θα κόψουν αλλά κάποιοι πιθανόν να κόψουν μια μονάδα για τους λόγους που είπα, εκτός αν συμφωνήσουν και αυτοί για να μην υπάρξει πρόβλημα. Ωστόσο επειδή αυτός που το έχει κάνει όπως το ζητάνε (και νομίζω ότι δεν είναι ελάχιστα πιο απαιτητικό αλλά αρκετά απαιτητικό), θα έλεγα ότι πρέπει να πάρει κάτι παραπάνω.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #20 στις: 24 Ιούν 2020, 11:22:09 πμ »
Εσένα θα σου έκοβα σίγουρα για τα ονόματα που θα είχες βάλει στους μετρητές των επαναλήψεων  :D

Καλημέρα παιδιά.

Ευριπίδη από τη μία έχεις δίκιο αλλά από την άλλη και η άλλη απάντηση δεν στέκει να την κόψουμε. Εγώ πάντως όταν την έλυσα την έλυσα γεμίζοντας πρώτα τον πίνακα με Χ.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 608
    • Ανάπτυξη Εφαρμογών
Απ: Θέμα Δ
« Απάντηση #21 στις: 24 Ιούν 2020, 11:22:32 πμ »
Το ερώτημά μου είναι αν το Δ3 το λύση με τη βοήθεια του Δ4 θα πιαστεί σωστό?
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #22 στις: 24 Ιούν 2020, 11:24:59 πμ »
Το ερώτημά μου είναι αν το Δ3 το λύση με τη βοήθεια του Δ4 θα πιαστεί σωστό?

ωραίος..
Αν καλέσεις πρώτα την (κακοπληρωμένη) κα ΔΙΑΔΙΚΑΣΙΑ να σε βοηθήσει και μετά εμφανίσεις τα ζητούμενα, είσαι ατσαλάκωτος    8)
(μπορεί να είναι και πιο απαιτητική λύση αν δε γίνει με ΓΙΑ)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #23 στις: 24 Ιούν 2020, 11:25:44 πμ »
Πέτρο έχεις δίκιο!
Τους ξέφυγε!
Είναι σοβαρό! Έτσι όπως το έχουν όποιος γράψει μόνο με την κλήση παίρνει 3 μονάδες, τις ίδιες με το υποπρόγραμμα.
Πρέπει να στείλουν άμεσα οδηγία στα βαθμολογικά!
Ας ελπίσουμε οι βαθμολογητές των ΦΑ να το καταλάβουν και να δράσουν σωστά και με ψυχραιμία.

Είναι σίγουρα λάθος οι μονάδες στο Δ4,Δ5...
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #24 στις: 24 Ιούν 2020, 11:27:09 πμ »
Πέτρο έχεις δίκιο!
Τους ξέφυγε!
Είναι σοβαρό! Έτσι όπως το έχουν όποιος γράψει μόνο με την κλήση παίρνει 3 μονάδες, τις ίδιες με το υποπρόγραμμα.
Πρέπει να στείλουν άμεσα οδηγία στα βαθμολογικά!
Ας ελπίσουμε οι βαθμολογητές των ΦΑ να το καταλάβουν και να δράσουν σωστά και με ψυχραιμία.


είναι και η εμφάνιση παίδες. Μην πετροβολήσετε παρακαλώ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #25 στις: 24 Ιούν 2020, 11:28:17 πμ »
Συμφωνώ με τον Παναγιώτη. Αυτός που θα έχει το θράσος να το κάνει πρέπει να πάρει και παραπάνω

Το ερώτημά μου είναι αν το Δ3 το λύση με τη βοήθεια του Δ4 θα πιαστεί σωστό?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #26 στις: 24 Ιούν 2020, 11:29:57 πμ »
Πάντως το θέμα Δ και όσον αφορά την κατανομή των μονάδων και όσον αφορά ότι ζητάνε ταξινόμηση αφού πριν έχουν ζητήσει το μέγιστο δείχνει απειρία από την πλευρά των θεματοδοτών
ή κάτι συνέβη και δεν προλάβαιναν οπότε τελευταία στιγμή πέταξαν και μια ταξινόμηση. Κάτι δεν πήγε καλά εκεί πάντως.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα Δ
« Απάντηση #27 στις: 24 Ιούν 2020, 11:36:08 πμ »
Πάντως το θέμα Δ και όσον αφορά την κατανομή των μονάδων και όσον αφορά ότι ζητάνε ταξινόμηση αφού πριν έχουν ζητήσει το μέγιστο δείχνει απειρία από την πλευρά των θεματοδοτών
ή κάτι συνέβη και δεν προλάβαιναν οπότε τελευταία στιγμή πέταξαν και μια ταξινόμηση. Κάτι δεν πήγε καλά εκεί πάντως.

Η επιτροπή έβγαλε 3 σετ θεμάτων

(ή/και απλά ήθελαν να κυλήσει μία ήρεμη μέρα χωρίς lock down μετά την Βιολογία κλπ με εξέταση βασικών επεξεργασιών και κάποια πονηρά διασκορπισμένα όπως παλιά,
ναι θα μπορούσε με καθαρότερο μυαλό να βγει ένα ωραιότερο θέμα)

mikezante

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Δ
« Απάντηση #28 στις: 24 Ιούν 2020, 11:44:14 πμ »
Δ3 θελει αλλαγη

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ζ, μαξ, πλ, θεση, Σ[20], κ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], δειγμα, ΑΠ[20, 100]
ΑΡΧΗ
!Δ2
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ζ <- 1
    ΔΙΑΒΑΣΕ δειγμα
    ΟΣΟ δειγμα <> 'ΤΕΛΟΣ' ΚΑΙ ζ <= 100 ΕΠΑΝΑΛΑΒΕ
     
      ΑΠ[ι, ζ] <- δειγμα
       ζ <- ζ + 1
      ΔΙΑΒΑΣΕ δειγμα
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ κ ΑΠΟ ζ ΜΕΧΡΙ 100
      ΑΠ[ι, ζ] <- 'Χ'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ3
  μαξ <- -1
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    πλ <- 0
    ΓΙΑ ζ ΑΠΟ 1 ΜΕΧΡΙ 100
      ΑΝ ΑΠ[ι, ζ] = 'Θ' ΤΟΤΕ
        πλ <- πλ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Σ[ι] <- πλ
    ΑΝ πλ > μαξ ΤΟΤΕ
      μαξ <- πλ
      θεση <- ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Περισότερα κρούσματα στην περιοχή:', Π[θεση]
!Δ4
  ΚΑΛΕΣΕ ταξινομηση(Σ, Π)
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ Π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


!Δ5
ΔΙΑΔΙΚΑΣΙΑ ταξινομηση(Σ, Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ[20], ι, ζ, τεμπ
  ΧΑΡΑΚΤΗΡΕΣ: Π[20], τομπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ ζ ΑΠΟ 20 ΜΕΧΡΙ ι ΜΕ ΒΗΜΑ -1
      ΑΝ Σ[ζ - 1] < Σ[ζ] ΤΟΤΕ
        τεμπ <- Σ[ζ]
        Σ[ζ] <- Σ[ζ - 1]
        Σ[ζ - 1] <- τεμπ
        τομπ <- Π[ζ]
        Π[ζ] <- Π[ζ - 1]
        Π[ζ - 1] <- τομπ
      ΑΛΛΙΩΣ_ΑΝ Σ[ζ - 1] = Σ[ζ] ΤΟΤΕ
        ΑΝ Π[ζ - 1] > Π[ζ] ΤΟΤΕ
          τομπ <- Π[ζ]
          Π[ζ] <- Π[ζ - 1]
          Π[ζ - 1] <- τομπ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
« Τελευταία τροποποίηση: 24 Ιούν 2020, 12:02:49 μμ από mikezante »
Γ. Β.

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Θέμα Δ
« Απάντηση #29 στις: 24 Ιούν 2020, 11:52:52 πμ »
Λέει ποιες περιοχές είχαν περισσότερα θετικά κρούσματα, πρέπει να ελέγξεις όλο τον  πίνακα γιατί το μαχ μπορεί να εμφανίζεται παραπάνω από μιά φορά!