Αποστολέας Θέμα: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007  (Αναγνώστηκε 6312 φορές)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5256
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« στις: 31 Μάι 2007, 01:49:56 μμ »
Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007.
Δίνεται σε ΠΡΟΓΡΑΜΜΑ, παρόμοια είναι και σε αλγόριθμο.

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #1 στις: 31 Μάι 2007, 02:00:30 μμ »
Στο γ θέλει τα "ορχηστρικά" CD!!  ::) :)
« Τελευταία τροποποίηση: 31 Μάι 2007, 02:46:33 μμ από kLee »
Ανδροκλής Πολυμένης

Πληροφορικός


kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #3 στις: 31 Μάι 2007, 02:13:46 μμ »
LOL!!

Μόλις έκανα edit το ορχηστρικά σε ορχηστικά και είδα ότι έκανες το ίδιο λάθος - πλην 10 μόρια!!!  :D ;D
Ανδροκλής Πολυμένης

Πληροφορικός

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5256
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #4 στις: 31 Μάι 2007, 02:22:22 μμ »
LOL!!

Μόλις έκανα edit το ορχηστρικά σε ορχηστικά και είδα ότι έκανες το ίδιο λάθος - πλην 10 μόρια!!!  :D ;D

Ξανακάν'το edit, ορχηστρικά είναι!
Εντάξει, τα 10 μόρια αυτά είναι «φιλολογικά», οπότε πιάνουν λιγότερο από τα «πληροφορικά» μόρια! :P

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #5 στις: 31 Μάι 2007, 02:38:56 μμ »
Ηλίθιο Word! Αυτό μου το έδειχνε λάθος!!!   >:(

chris κοιτάω την απορία σου..
Ανδροκλής Πολυμένης

Πληροφορικός

johnny_xp

  • Θαμώνας
  • ***
  • Μηνύματα: 39
  • Null Argument Exception
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #6 στις: 31 Μάι 2007, 03:11:27 μμ »
@alkisg
Αν μπορέσετε δώστε και μια προσέγγιση χωρίς τη χρήση των πινάκων ετήσιες_πωλήσεις[20], πωλήσεις_α_εξαμήνου[20], πωλήσεις_β_εξαμήνου[20], αλλά με χρήση απλών μεταβλητών (η οποία ικανοποιεί και αυτό που λέει το σχολικό βιβλίο περί "εγκράτειας" στη χρήση πινάκων).

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5256
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #7 στις: 31 Μάι 2007, 03:18:53 μμ »
Κώδικας: Text
  1. !...
  2. !Ερώτημα γ. Λύση χωρίς βοηθητικό πίνακα.
  3.    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
  4.      ετήσιες_πωλήσεις <- 0
  5.      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 12
  6.        ετήσιες_πωλήσεις <- ετήσιες_πωλήσεις + μηνιαίες_πωλήσεις[ι, κ]
  7.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  8.      ΑΝ τύπος[ι] = 'ορχηστρική' ΚΑΙ ετήσιες_πωλήσεις >= 5000 ΤΟΤΕ
  9.        ΓΡΑΨΕ τίτλος[ι]
  10.      ΤΕΛΟΣ_ΑΝ
  11.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  12.  
  13. !Ερώτημα δ. Λύση χωρίς βοηθητικούς πίνακες.
  14.    πλήθος <- 0
  15.    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
  16.      πωλήσεις_α_εξαμήνου <- 0
  17.      πωλήσεις_β_εξαμήνου <- 0
  18.      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 6
  19.        πωλήσεις_α_εξαμήνου <- πωλήσεις_α_εξαμήνου + μηνιαίες_πωλήσεις[ι, κ]
  20.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  21.      ΓΙΑ κ ΑΠΟ 7 ΜΕΧΡΙ 12
  22.        πωλήσεις_β_εξαμήνου <- πωλήσεις_β_εξαμήνου + μηνιαίες_πωλήσεις[ι, κ]
  23.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  24.      ΑΝ πωλήσεις_β_εξαμήνου > πωλήσεις_α_εξαμήνου ΤΟΤΕ
  25.        πλήθος <- πλήθος + 1
  26.      ΤΕΛΟΣ_ΑΝ
  27.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  28.    ΓΡΑΨΕ πλήθος
  29.  

johnny_xp

  • Θαμώνας
  • ***
  • Μηνύματα: 39
  • Null Argument Exception
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #8 στις: 31 Μάι 2007, 03:22:37 μμ »
@alkisg
Ευχαριστώ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2244
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #9 στις: 31 Μάι 2007, 03:32:24 μμ »
Θα μπορούσαμε να υπολογίσουμε τις πωλήσεις του δευτέρου εξαμήνου αφαιρώντας τις πωλήσεις του πρώτου εξαμήνου από τις συνολικές που υπολογίστηκαν στο προηγούμενο ερώτημα...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5256
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #10 στις: 31 Μάι 2007, 03:36:40 μμ »
Ναι, αν χρησιμοποιήσαμε πίνακα ετήσιες_πωλήσεις (και όχι απλή μεταβλητή).

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3239
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #11 στις: 31 Μάι 2007, 04:25:55 μμ »
Κώδικας: Text
  1. !...
  2. !Ερώτημα γ. Λύση χωρίς βοηθητικό πίνακα  -  [b]τροποποίηση[/b]
  3.    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
  4.      ΑΝ τύπος[ι] = 'ορχηστρική' ΤΟΤΕ
  5.          Σ <- 0
  6.          ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 12
  7.             Σ <- Σ + μηνιαίες_πωλήσεις[ι, κ]
  8.          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  9.          ΑΝ Σ >= 5000 ΤΟΤΕ
  10.              ΓΡΑΨΕ τίτλος[ι]
  11.          ΤΕΛΟΣ_ΑΝ
  12.       ΤΕΛΟΣ_ΑΝ
  13.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  14.  

boutos3

  • Νέος
  • *
  • Μηνύματα: 7
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #12 στις: 31 Μάι 2007, 05:42:10 μμ »
ΘΕΜΑ 4 ΤΟ γ ΕΡΩΤΗΜΑ.....

Για ί από 1 μέχρι 20
    Αν ΤΥΠΟΣ[ί]="ορχηστρικά" Τότε
       Sum<--o
    Για j από 1 μέχρι 12
        Sum<--Sum+Π[i,j]
    Τέλος_Επανάληψης
    Αν Sum>=5000 Tότε
        Εκτύπωσε ΤΙΤΛΟΣ[ί]
    Τέλος_Αν
Τέλος_Επανάληψης

Σωστό???

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3239
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #13 στις: 31 Μάι 2007, 05:46:17 μμ »

το ίδιο γράψαμε (σου λείπει ένα Τέλος_αν εκ παραδρομής)

raniasgr

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #14 στις: 31 Μάι 2007, 06:53:20 μμ »
Γειά σας! Ένας μαθητής μου απάντησε το 4ο θέμα χωρίς τη χρήση πινάκων. Βέβαια δεν κατάφερε να εμφανίσει όλους τους τίτλους που ζητούσε το ερώτημα (β) αλλα μόνο του τελευταίου max . Πιστεύετε ότι θα πάρει το σύνολο των μονάδων για τα υπόλοιπα ερωτήματα αν έγραψε τον σωστό κώδικα?  ???
Καθηγήτρια Πληροφορικής - ΠΕ19

anasta

  • Βετεράνος
  • ****
  • Μηνύματα: 58
  • Ok, yes... Ok, yes...
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #15 στις: 31 Μάι 2007, 07:01:39 μμ »
ΘΕΜΑ 4 -ΕΡΩΤΗΜΑ Γ ΚΑΙ Δ 2ΙΝ1

Κώδικας: [Επιλογή]
ΠΛΗΘΟΣ<--0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΘΡ1<--0
    ΑΘΡ2<--0
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
       ΑΘΡ1<--ΑΘΡ1+Π[Ι,J]
       ΑΘΡ2<--ΑΘΡ2+Π[Ι,J+6]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    Sum<--ΑΘΡ1+ΑΘΡ2
    ΑΝ ΤΥΠΟΣ[Ι]='ορχηστρικά' ΚΑΙ Sum>=5000 ΤΟΤΕ
       ΓΡΑΨΕ ΤΙΤΛΟΣ[I]
    ΤΕΛΟΣ_ΑΝ

    ΑΝ ΑΘΡ1<ΑΘΡ2 ΤΟΤΕ
       ΠΛΗΘΟΣ<--ΠΛΗΘΟΣ+1
    ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΠΛΗΘΟΣ
« Τελευταία τροποποίηση: 31 Μάι 2007, 07:11:50 μμ από anasta »

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2244
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #16 στις: 31 Μάι 2007, 07:41:37 μμ »
Πάρα πολύ καλό
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

raniasgr

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #17 στις: 31 Μάι 2007, 08:28:51 μμ »
Γειά σας! Ένας μαθητής μου απάντησε το 4ο θέμα χωρίς τη χρήση πινάκων. Βέβαια δεν κατάφερε να εμφανίσει όλους τους τίτλους που ζητούσε το ερώτημα (β) αλλα μόνο του τελευταίου max . Πιστεύετε ότι θα πάρει το σύνολο των μονάδων για τα υπόλοιπα ερωτήματα αν έγραψε τον σωστό κώδικα? 


Συγνώμη που επαναλαμβάνω την ερώτηση...αλλα πραγματικά θα ήθελα να μου δώσετε μια απάντηση  :-[
Καθηγήτρια Πληροφορικής - ΠΕ19

Betty

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 12
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #18 στις: 31 Μάι 2007, 08:37:10 μμ »
Καλησπέρα παιδιά να σας δείξω μια λύση που έκανε ένας μαθητής μου θα ήθελα να τη δείτε και να μου πείτε με προσοχή πόσες μονάδες θα βάζατε;
ΑΛΓΟΡΙΘΜΟΣ  Θέμα4ο
ΜΑΧ<-0
Π<-0
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ τίτλος
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ τύπος
    ΜΕΧΡΙΣ_ΟΤΟΥ τύπος = 'ορχηστρική' Η τύπος = 'φωνητική'
    πωλήσεις_α_εξαμήνου <- 0
    πωλήσεις_β_εξαμήνου <- 0
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12
      ΔΙΑΒΑΣΕ μηνιαίες_πωλήσεις
      ΑΝ J<=6 TOTE
πωλήσεις_α_εξαμήνου<- πωλήσεις_α_εξαμήνου + μηνιαίες_πωλήσεις
      ΑΛΛΙΩΣ_ΑΝ J<=12 TOTE
         πωλήσεις_β_εξαμήνου<- πωλήσεις_β_εξαμήνου + μηνιαίες_πωλήσεις
      ΤΕΛΟΣ_ΑΝ
      ΑΝ J=3 ΚΑΙ μηνιαίες_πωλήσεις>ΜΑΧ ΤΟΤΕ
      Κ<-1
      ΜΕΓ[Κ]<- τίτλος
      Θ<-1
      ΑΛΛΙΩΣ_ΑΝ J=3 ΚΑΙ μηνιαίες_πωλήσεις = ΜΑΧ ΤΟΤΕ
      Κ<-Κ+1
ΜΕΓ[Κ]<- τίτλος
ΘΚ
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΑΝ πωλήσεις_β_εξαμήνου >πωλήσεις_α_εξαμήνου ΤΟΤΕ
      Π<-Π+1
   ΤΕΛΟΣ_ΑΝ
   ΑΝ πωλήσεις_α_εξαμήνου + πωλήσεις_β_εξαμήνου>=5000 ΚΑΙ τύπος = 'ορχηστρική' ΤΟΤΕ
      ΕΜΦΑΝΙΣΕ τίτλος
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Κ ΑΠΌ 1 ΜΈΧΡΙ Θ
   ΕΜΦΑΝΙΣΕ ΜΕΓ[Κ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΕΜΦΑΝΙΣΕ Π
ΤΕΛΟΣ_ Θέμα4ο
Ευχαριστώ
Και καλή αρχή στο διόρθωμα

tomtoub

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #19 στις: 31 Μάι 2007, 08:44:40 μμ »
Ωχ, μόλις κατάλαβα ότι έκανα βλακεία. Πήγα να κάνω αυτό, όπως και η anasta:

Κώδικας: Text
  1. ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
  2.     ΑΘΡ1<--0
  3.     ΑΘΡ2<--0
  4.     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
  5.        ΑΘΡ1<--ΑΘΡ1+Π[Ι,J]
  6.        ΑΘΡ2<--ΑΘΡ2+Π[Ι,J+6]
  7.     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  8.  

Αλλά πάνω στην βιασύνη μου, απ' ότι θυμάμαι πρέπει να έγραψα ΑΘΡ2<--ΑΘΡ2+Π[Ι+6,J+6]. Ελπίζω να μην μου κόψουν πολύ. Τι λέτε?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3181
  • to Iterate is human to Recurse divine
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #20 στις: 31 Μάι 2007, 08:55:35 μμ »
 Με μια γρήγορη ματιά, νομίζω ότι έχει σωστά τα 3 από τα 4 ερωτήματα (το β πρέπει να είναι λάθος), άρα πρέπει να πάρει τουλάχιστον 14 από τα 20 μόρια. Να σου πω την αλήθεια και μόνο που το έκανε χωρίς πίνακες θα του έβαζα 2 μόρια ακόμα. Ίσως να μου ξέφυγε κάποιο μικρολαθάκι αλλά η γενική ιδέα είναι καλή.
   
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Betty

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 12
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #21 στις: 31 Μάι 2007, 10:14:52 μμ »
αν η απάντηση είναι για μένα πιστεύω ότι και το β ερώτημα είναι σωστό...
Αν παρατηρήσουμε το θ που βρίσκεται σε κάθε αν και τη Για για την ποαρουσίαση του πίνακα με τους τίτλους στο τέλος
Ευχαριστώ πολύ για την ανταπόκριση

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3181
  • to Iterate is human to Recurse divine
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #22 στις: 31 Μάι 2007, 10:20:09 μμ »

   Περίμενε να το δούμε, το max που παίρνει τιμή? δεν παραμένει πάντα 0 ?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Betty

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 12
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #23 στις: 31 Μάι 2007, 10:26:49 μμ »
Αρχικοποιείται πριν τις επναλήψεις με max<--0
Όταν το J=3 αρχίζει να ψάχνει το max
την πρώτη φορά θα μπεί μέσα και θα πάρει το max έστω την τιμή 3 το κ =1 και το θ=1
έστω ότι τη δεύτερη φορά θα μπεί στην αλλιώς_αν το κα=2 και το θ=2
αν στην τρίτη επενάληψη το στοιχείο είναι μεγαλύτερο από το μέχρι τώρα max (3) τότε το κ θα ξαναγίνει 1 και το θ θα ξαναγίνει 1
εμάς με τη για που έχει μας δείχνει τα στοιχεία από το 1 μέχρι το θ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3181
  • to Iterate is human to Recurse divine
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #24 στις: 31 Μάι 2007, 10:32:39 μμ »
όχι για δες το καλύτερα στο max πρέπει κάθε φορά να αποθηκεύεις τη μέγιστη τιμή μέχρι εκείνη τη στιγμή ώστε αν ξαναβρείς την ίδια
να μπει στην δομή επιλογής για τη συνθήκη
Κώδικας: [Επιλογή]
μηνιαίες_πωλήσεις = MAX

δηλαδή να προσθέσεις την εντολή

Κώδικας: [Επιλογή]
MAX <- μηνιαίες_πωλήσεις

στο κομμάτι
Κώδικας: [Επιλογή]
ΑΛΛΙΩΣ_ΑΝ J=3 ΚΑΙ μηνιαίες_πωλήσεις = ΜΑΧ ΤΟΤΕ
      Κ<-Κ+1
ΜΕΓ[Κ]<- τίτλος
.... [b]ΕΔΩ[/b]

Ελπίζω να το ξέχασες εσύ και όχι ο μαθητής γιατί είναι κρίμα :'( είναι πολύ καλή λύση

ΥΓ. Επιμένω ότι έχω δίκιο, για ξαναδές το
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Betty

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 12
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #25 στις: 31 Μάι 2007, 10:50:12 μμ »
Έχω την εντύπωση ότι δε χρειάζεται γιατί δε χρειάζεται να αποθηκεύση το max στην αλλιώς_αν γιατί το έχει αποθηκευση κάτα την πρώτη είσοδο του στην Αν
Α!!! Τώρα είδα έχω ξεχάσει να αντιγράψω στο Τοτε ότι το max<-μηνιαίες_πωλήσεις
Παιδιά πιστεύω ότι είναι πάρα πολύ έξυπνη λύση !!! Τι λέτε;
Ευχαριστώ και πάλι..

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #26 στις: 02 Ιούν 2007, 04:58:33 μμ »
Γειά σας! Ένας μαθητής μου απάντησε το 4ο θέμα χωρίς τη χρήση πινάκων. Βέβαια δεν κατάφερε να εμφανίσει όλους τους τίτλους που ζητούσε το ερώτημα (β) αλλα μόνο του τελευταίου max . Πιστεύετε ότι θα πάρει το σύνολο των μονάδων για τα υπόλοιπα ερωτήματα αν έγραψε τον σωστό κώδικα? 

Όλα τα ερωτήματα εκτός του 3β μπορούν να απαντηθούν και χωρίς τη χρήση πίνακα.  Αν η λύση του είναι κατα τα άλλα σωστή, θα πρέπει να χάσει τις μισές μονάδες του β, δηλαδή 3 μονάδες οπότε να βαθμολογηθεί με 17.

Συγγνώμη για την καθυστέρηση :(
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Juan

  • Θαμώνας
  • ***
  • Μηνύματα: 26
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #27 στις: 02 Ιούν 2007, 08:18:36 μμ »
Καλησπέρα σε όλους
μια ερωτησόυλα σε αυτόυς που εξετάζουν ή έχουν προηγούμενη εμπειρία.
Στο β ερώτημα του θέματος 4, αν κάποιος μαθητής δεν έλαβε υπόψιν την περίπτωση ισοτιμίας στον πίνακα κι εμφάνισε ΜΟΝΟ το ένα CD με max πωλήσεις (χρησιμοποίησε μεταβλητή position για να κρατήσει τη θέση του max κι εμφάνισε τελικά το πρώτο CD που βρέθηκε να έχει max πωλήσεις τον 3ο μήνα), πόσες από τις 6 μονάδες του ερωτήματος θα πάρει;
Η γνώμη μου είναι ότι θα έπρεπε να πάρει 3 ή 4

Ευχαριστώ

Betty

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 12
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #28 στις: 02 Ιούν 2007, 10:29:23 μμ »
Το 4ο μπορεί να λύθεί με τη χρήση ενός πίνακα όπως αυτό που έχει αναθερθεί πιο πάνω
Όσο για το άν το έχει βρεί με θέση εμείς εδώ θα το βαθμολογίσουμε με 4 μόρια Γιατί έχει βρεί το max σωστά και έχει εμφανίσει ένα τουλάχιστον

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3181
  • to Iterate is human to Recurse divine
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #29 στις: 02 Ιούν 2007, 10:34:38 μμ »
 Εννοείται ότι θα πάρει κάτι, εξαρτάται και από την εικόνα του γραπτού. Πάντως το 3 είναι πολύ αυστηρό. Το πιο λογικό είναι το 4 στα 6 που δίνει το ερώτημα

Καλησπέρα σε όλους
μια ερωτησόυλα σε αυτόυς που εξετάζουν ή έχουν προηγούμενη εμπειρία.
Στο β ερώτημα του θέματος 4, αν κάποιος μαθητής δεν έλαβε υπόψιν την περίπτωση ισοτιμίας στον πίνακα κι εμφάνισε ΜΟΝΟ το ένα CD με max πωλήσεις (χρησιμοποίησε μεταβλητή position για να κρατήσει τη θέση του max κι εμφάνισε τελικά το πρώτο CD που βρέθηκε να έχει max πωλήσεις τον 3ο μήνα), πόσες από τις 6 μονάδες του ερωτήματος θα πάρει;
Η γνώμη μου είναι ότι θα έπρεπε να πάρει 3 ή 4

Ευχαριστώ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #30 στις: 03 Ιούν 2007, 01:15:03 πμ »
Καλησπέρα σε όλους
μια ερωτησόυλα σε αυτόυς που εξετάζουν ή έχουν προηγούμενη εμπειρία.
Στο β ερώτημα του θέματος 4, αν κάποιος μαθητής δεν έλαβε υπόψιν την περίπτωση ισοτιμίας στον πίνακα κι εμφάνισε ΜΟΝΟ το ένα CD με max πωλήσεις (χρησιμοποίησε μεταβλητή position για να κρατήσει τη θέση του max κι εμφάνισε τελικά το πρώτο CD που βρέθηκε να έχει max πωλήσεις τον 3ο μήνα), πόσες από τις 6 μονάδες του ερωτήματος θα πάρει;
Η γνώμη μου είναι ότι θα έπρεπε να πάρει 3 ή 4

Ευχαριστώ

Το ερώτημα β εξετάζει:
α. τη δυνατότητα να υλοποιηθεί ο μηχανισμός εύρεσης μέγιστου
β. την προσπέλαση / εμφάνιση στοιχείων πίνακα υπό συνθήκη
γ. την ικανότητα του μαθητή να αναλύσει το ερώτημα σε δύο επιμέρους ενέργειες

Το (α) είναι ασφαλώς πιό σύνθετο από το (β) οπότε αξίζει περισσότερες μονάδες.
Μία πρόχειρη κατανομή είναι:
α. 3 μονάδες
β. 2 μονάδες
γ. 1 μονάδα

Το γραπτό πρέπει να χάσει 3 μονάδες αφού απουσία του (β) σημαίνει και απουσία του (γ)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)