Αποστολέας Θέμα: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007  (Αναγνώστηκε 6576 φορές)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5582
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« στις: 31 Μάι 2007, 01:49:56 μμ »
Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007.
Δίνεται σε ΠΡΟΓΡΑΜΜΑ, παρόμοια είναι και σε αλγόριθμο.

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #1 στις: 31 Μάι 2007, 02:00:30 μμ »
Στο γ θέλει τα "ορχηστρικά" CD!!  ::) :)
« Τελευταία τροποποίηση: 31 Μάι 2007, 02:46:33 μμ από kLee »
Ανδροκλής Πολυμένης

Πληροφορικός


kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #3 στις: 31 Μάι 2007, 02:13:46 μμ »
LOL!!

Μόλις έκανα edit το ορχηστρικά σε ορχηστικά και είδα ότι έκανες το ίδιο λάθος - πλην 10 μόρια!!!  :D ;D
Ανδροκλής Πολυμένης

Πληροφορικός

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5582
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #4 στις: 31 Μάι 2007, 02:22:22 μμ »
LOL!!

Μόλις έκανα edit το ορχηστρικά σε ορχηστικά και είδα ότι έκανες το ίδιο λάθος - πλην 10 μόρια!!!  :D ;D

Ξανακάν'το edit, ορχηστρικά είναι!
Εντάξει, τα 10 μόρια αυτά είναι «φιλολογικά», οπότε πιάνουν λιγότερο από τα «πληροφορικά» μόρια! :P

kLee

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • Is the Singularity near?
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #5 στις: 31 Μάι 2007, 02:38:56 μμ »
Ηλίθιο Word! Αυτό μου το έδειχνε λάθος!!!   >:(

chris κοιτάω την απορία σου..
Ανδροκλής Πολυμένης

Πληροφορικός

johnny_xp

  • Θαμώνας
  • ***
  • Μηνύματα: 39
  • Null Argument Exception
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #6 στις: 31 Μάι 2007, 03:11:27 μμ »
@alkisg
Αν μπορέσετε δώστε και μια προσέγγιση χωρίς τη χρήση των πινάκων ετήσιες_πωλήσεις[20], πωλήσεις_α_εξαμήνου[20], πωλήσεις_β_εξαμήνου[20], αλλά με χρήση απλών μεταβλητών (η οποία ικανοποιεί και αυτό που λέει το σχολικό βιβλίο περί "εγκράτειας" στη χρήση πινάκων).

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5582
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #7 στις: 31 Μάι 2007, 03:18:53 μμ »
Κώδικας: ΓΛΩΣΣΑ
  1. !...
  2. !Ερώτημα γ. Λύση χωρίς βοηθητικό πίνακα.
  3.    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
  4.      ετήσιες_πωλήσεις <- 0
  5.      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 12
  6.        ετήσιες_πωλήσεις <- ετήσιες_πωλήσεις + μηνιαίες_πωλήσεις[ι, κ]
  7.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  8.      ΑΝ τύπος[ι] = 'ορχηστρική' ΚΑΙ ετήσιες_πωλήσεις >= 5000 ΤΟΤΕ
  9.        ΓΡΑΨΕ τίτλος[ι]
  10.      ΤΕΛΟΣ_ΑΝ
  11.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  12.  
  13. !Ερώτημα δ. Λύση χωρίς βοηθητικούς πίνακες.
  14.    πλήθος <- 0
  15.    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
  16.      πωλήσεις_α_εξαμήνου <- 0
  17.      πωλήσεις_β_εξαμήνου <- 0
  18.      ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 6
  19.        πωλήσεις_α_εξαμήνου <- πωλήσεις_α_εξαμήνου + μηνιαίες_πωλήσεις[ι, κ]
  20.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  21.      ΓΙΑ κ ΑΠΟ 7 ΜΕΧΡΙ 12
  22.        πωλήσεις_β_εξαμήνου <- πωλήσεις_β_εξαμήνου + μηνιαίες_πωλήσεις[ι, κ]
  23.      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  24.      ΑΝ πωλήσεις_β_εξαμήνου > πωλήσεις_α_εξαμήνου ΤΟΤΕ
  25.        πλήθος <- πλήθος + 1
  26.      ΤΕΛΟΣ_ΑΝ
  27.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  28.    ΓΡΑΨΕ πλήθος
  29.  

johnny_xp

  • Θαμώνας
  • ***
  • Μηνύματα: 39
  • Null Argument Exception
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #8 στις: 31 Μάι 2007, 03:22:37 μμ »
@alkisg
Ευχαριστώ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2307
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #9 στις: 31 Μάι 2007, 03:32:24 μμ »
Θα μπορούσαμε να υπολογίσουμε τις πωλήσεις του δευτέρου εξαμήνου αφαιρώντας τις πωλήσεις του πρώτου εξαμήνου από τις συνολικές που υπολογίστηκαν στο προηγούμενο ερώτημα...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5582
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #10 στις: 31 Μάι 2007, 03:36:40 μμ »
Ναι, αν χρησιμοποιήσαμε πίνακα ετήσιες_πωλήσεις (και όχι απλή μεταβλητή).

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3302
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #11 στις: 31 Μάι 2007, 04:25:55 μμ »
Κώδικας: ΓΛΩΣΣΑ
  1. !...
  2. !Ερώτημα γ. Λύση χωρίς βοηθητικό πίνακα  -  [b]τροποποίηση[/b]
  3.    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
  4.      ΑΝ τύπος[ι] = 'ορχηστρική' ΤΟΤΕ
  5.          Σ <- 0
  6.          ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 12
  7.             Σ <- Σ + μηνιαίες_πωλήσεις[ι, κ]
  8.          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  9.          ΑΝ Σ >= 5000 ΤΟΤΕ
  10.              ΓΡΑΨΕ τίτλος[ι]
  11.          ΤΕΛΟΣ_ΑΝ
  12.       ΤΕΛΟΣ_ΑΝ
  13.    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  14.  

boutos3

  • Νέος
  • *
  • Μηνύματα: 7
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #12 στις: 31 Μάι 2007, 05:42:10 μμ »
ΘΕΜΑ 4 ΤΟ γ ΕΡΩΤΗΜΑ.....

Για ί από 1 μέχρι 20
    Αν ΤΥΠΟΣ[ί]="ορχηστρικά" Τότε
       Sum<--o
    Για j από 1 μέχρι 12
        Sum<--Sum+Π[i,j]
    Τέλος_Επανάληψης
    Αν Sum>=5000 Tότε
        Εκτύπωσε ΤΙΤΛΟΣ[ί]
    Τέλος_Αν
Τέλος_Επανάληψης

Σωστό???

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3302
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #13 στις: 31 Μάι 2007, 05:46:17 μμ »

το ίδιο γράψαμε (σου λείπει ένα Τέλος_αν εκ παραδρομής)

raniasgr

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Λύσεις 4ου θέματος Ημερησίων Ιουνίου 2007
« Απάντηση #14 στις: 31 Μάι 2007, 06:53:20 μμ »
Γειά σας! Ένας μαθητής μου απάντησε το 4ο θέμα χωρίς τη χρήση πινάκων. Βέβαια δεν κατάφερε να εμφανίσει όλους τους τίτλους που ζητούσε το ερώτημα (β) αλλα μόνο του τελευταίου max . Πιστεύετε ότι θα πάρει το σύνολο των μονάδων για τα υπόλοιπα ερωτήματα αν έγραψε τον σωστό κώδικα?  ???
Καθηγήτρια Πληροφορικής - ΠΕ19