Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 1955 φορές)

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Δ
« Απάντηση #75 στις: 26 Ιούν 2020, 02:30:00 μμ »
Η ρητή αλλαγή δείκτη στη Για, απαγορεύεται, αλλά στην ΟΣΟ/Μεχρις_Οτου;
Ένας μαθητής μου, έκανε αυτό στην εικόνα. Οι πιο έμπειροι βαθμολογικά, ξέρετε αν θα του κόψουν;
(edit, στις εξετάσεις έγραψε τον Απ ως 2Δ πίνακα, εδώ προφανώς μπερδεύτηκε)
« Τελευταία τροποποίηση: 26 Ιούν 2020, 03:14:39 μμ από akalest0s »
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Θέμα Δ
« Απάντηση #76 στις: 26 Ιούν 2020, 03:08:23 μμ »
Respect !

Γιαννούλης Γιώργος

  • Βετεράνος
  • ****
  • Μηνύματα: 74
Απ: Θέμα Δ
« Απάντηση #77 στις: 30 Ιούν 2020, 08:35:27 μμ »
Η ρητή αλλαγή δείκτη στη Για, απαγορεύεται, αλλά στην ΟΣΟ/Μεχρις_Οτου;
Ένας μαθητής μου, έκανε αυτό στην εικόνα. Οι πιο έμπειροι βαθμολογικά, ξέρετε αν θα του κόψουν;
Η ΟΣΟ δεν έχει μετρητή, εξετάζει μια συνθήκη που μπορεί να τη χρησιμοποιήσεις με τη λογική του μετρητή όπως και με πολλές άλλες πιο σύνθετες συνθήκες.
Μέσα στη ΓΙΑ δεν πειράζει το ι (τον μετρητή της).
Οπότε δεν βλέπω για πιο λόγο να χάσει οποιαδήποτε μονάδα.

Υ.Γ.   Τ_Ε for ever

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Δ
« Απάντηση #78 στις: 01 Ιούλ 2020, 09:49:15 πμ »
Υ.Γ.   Τ_Ε for ever
;D ;D ό,τι και να τους πεις, δεν το βγάζουν από το μυαλό τους.. ελπίζω να μην το έκανε και στις εξετάσεις!
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3502
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #79 στις: 01 Ιούλ 2020, 10:06:34 πμ »
Ωστόσο το ερώτημα παραμένει, όταν ένας μαθητής ρωτήσει:
Τα παρακάτω τμήματα κώδικα δεν είναι ισοδύναμα? Δεν εκτελούν ακριβώς τα ίδια βήματα με την ίδια σειρά? Γιατί στην μια περίπτωση επιτρέπεται
η μεταβολή του μετρητή και στην άλλη όχι?
Τι είδους λάθος είναι στην μια περίπτωση?
Αφού στην μια είναι σωστό αλγοριθμικά δεν θα έπρεπε να είναι σωστό και στην άλλη?
Κώδικας: ΓΛΩΣΣΑ
  1. Ι <- 1
  2. ΟΣΟ Ι<=10 ΕΠΑΝΑΛΑΒΕ
  3.     ΔΙΑΒΑΣΕ Χ
  4.     ΑΝ Χ<0 ΤΟΤΕ
  5.        Ι<-10
  6.     ΤΕΛΟΣ_ΑΝ
  7.     Ι <- Ι + 1
  8. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Κώδικας: ΓΛΩΣΣΑ
  1. ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
  2.     ΔΙΑΒΑΣΕ Χ
  3.     ΑΝ Χ<0 ΤΟΤΕ
  4.        Ι<-10
  5.     ΤΕΛΟΣ_ΑΝ
  6. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Προφανώς πρέπει να δώσουμε κάποια επιστημονική εξήγηση και όχι να αναφερόμαστε σε εγκυκλίους του υπουργείου παιδείας, για να πείσουμε τον μαθητή ότι αυτό που διδάσκεται είναι επιστήμη.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5433
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Δ
« Απάντηση #80 στις: 01 Ιούλ 2020, 10:36:38 πμ »
Ο βασικότερος λόγος είναι η αναγνωσιμότητα του κώδικα. Δηλαδή ο ίδιος λόγος που υιοθετήθηκε ο δομημένος προγραμματισμός και μειώθηκε η χρήση της GOTO.
Σε μια ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 10, περιμένουμε η επανάληψη να γίνει 10 φορές, και έτσι διαβάζουμε τον κώδικα ευκολότερα.
Αν εντός της επανάληψης δούμε μεταβολή του μετρητή π.χ. Ι <- 3*Ι-2, τότε θα πάθουμε ένα σοκ και θα ψάχνουμε να καταλάβουμε τι παίζει, δεν ανταποκρίνεται στις γνωστές μας χρήσεις της ΓΙΑ.
Η break από την άλλη, που βγαίνει από μια ΓΙΑ, δεν δυσχεραίνει την ανάγνωση (κι ας αντιστοιχεί σε μη δομημένο διάγραμμα). Δεν είναι όμως ισοδύναμη σε αναγνωσιμότητα με την Ι <- 11.

Σάκης Δημόπουλος

  • Βετεράνος
  • ****
  • Μηνύματα: 94
  • Dimopoulos Informatics Tutorials
    • Dimopoulos Informatics Tutorials
Απ: Θέμα Δ
« Απάντηση #81 στις: 09 Ιούλ 2020, 11:24:43 μμ »
ΠΛΗΡΟΦΟΡΙΚΗ Πανελλήνιες 2020 Λύση Θέματος Δ: https://www.youtube.com/watch?v=xc0x-bMtpFE