Γενικό Λύκειο > Εξετάσεις 2014-2015

Θέμα Γ

<< < (3/13) > >>

vistrian:

--- Παράθεση από: theoL στις 27 Μαΐ 2015, 05:12:13 μμ ---ΠΡΟΓΡΑΜΜΑ  ΘΕΜΑ_Γ
! Γ1α---------------------------------------------------------
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ
!β------------------------------------------------------------
ΑΡΧΗ
  ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- 0
  ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β <-- 0
  ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ <-- 0
  ΓΡΑΨΕ 'ΜΕΓΕΘΟΣ ΕΛΕΥΘΕΡΟΥ ΧΩΡΟΥ ΑΠΟΘΗΚΗΣ Α'
  ΔΙΑΒΑΣΕ Α
  ΓΡΑΨΕ 'ΜΕΓΕΘΟΣ ΕΛΕΥΘΕΡΟΥ ΧΩΡΟΥ ΑΠΟΘΗΚΗΣ Β'
  ΔΙΑΒΑΣΕ Β
!γ------------------------------------------------------------
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΜΕΓΕΘΟΣ ΔΕΜΑΤΟΣ'
    ΔΙΑΒΑΣΕ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ
ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ <> 0 ΤΟΤΕ 
 ΑΝ Α=Β ΤΟΤΕ
      ΓΡΑΨΕ 'ΘΑ ΤΟΠΟΘΕΤΗΘΕΙ ΣΤΗΝ Α'
      ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α+1
    ΑΛΛΙΩΣ
      ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ<Α ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΑ ΤΟΠΟΘΕΤΗΘΕΙ ΣΤΗΝ Α'
        ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α+1
      ΑΛΛΙΩΣ_ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ<Β ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΑ ΤΟΠΟΘΕΤΗΘΕΙ ΣΤΗΝ Β'
        ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β+1
      ΑΛΛΙΩΣ_ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ>Α ΚΑΙ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ>Β ΤΟΤΕ
        ΓΡΑΨΕ 'Προοώθηση'
        ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ = 0
!δ--------------------------------------------------------------
  ΚΑΛΕΣΕ ΑΠΟΘΗΚΕΣ (ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΜΑ_Γ

!Γ2---------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ  ΑΠΟΘΗΚΕΣ (ΑΔΑ,ΑΔΒ,ΑΔΕ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ΑΔΑ,ΑΔΒ,ΑΔΕ
ΑΡΧΗ
  ΑΝ ΑΔΑ=ΑΔΒ ΚΑΙ ΑΔΑ <> 0 ΚΑΙ ΑΔΒ <> 0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ισάριθμα'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΑ>ΑΔΒ ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Α'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΒ>ΑΔΑ ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Β'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΑ=0 ΚΑΙ ΑΔΒ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Καμία αποθήκευση στο αεροδρόμιο'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

--- Τέλος παράθεσης ---

theoL:
 :-[
Γιατί αυτο...; μπορείς να μου εξηγήσεις ; σ' ευχαριστώ
καταλαβαααα οκ. :D

vistrian:

--- Παράθεση από: theoL στις 27 Μαΐ 2015, 05:22:33 μμ --- :-[
Γιατί αυτο...; μπορείς να μου εξηγήσεις ; σ' ευχαριστώ

--- Τέλος παράθεσης ---

Διότι δεν γνωρίζουμε εάν θα γίνει τουλάχιστον μία επανάληψη. Αν δώσουμε στην τιμή 0 στο δέμα τότε θα εκτελεστεί ο αλγόριθμος, κάτι το οποίο δεν είναι σωστό,

Εάν Η Α έχει μέγεθος 20 και η Β έχει μέγεθος 20 και το δέμα έχει την τιμή 0 τότε θα μπει στην πρώτη Αν
Εάν Η Α έχει μέγεθος 30 και η Β έχει μέγεθος 20 και το δέμα έχει την τιμή 0 τότε θα μπει στο Αλλιως

και στις δύο περιπτώσεις θα αυξηθεί η μεταβλητή ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α+1
κάτι που δεν έπρεπε να γίνει

Νίκος Αδαμόπουλος:

--- Παράθεση από: theoL στις 27 Μαΐ 2015, 05:12:13 μμ ---ΔΙΑΔΙΚΑΣΙΑ  ΑΠΟΘΗΚΕΣ (ΑΔΑ,ΑΔΒ,ΑΔΕ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ΑΔΑ,ΑΔΒ,ΑΔΕ
ΑΡΧΗ
  ΑΝ ΑΔΑ=ΑΔΒ ΚΑΙ ΑΔΑ <> 0 ΚΑΙ ΑΔΒ <> 0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ισάριθμα'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΑ>ΑΔΒ ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Α'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΒ>ΑΔΑ ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Β'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΑ=0 ΚΑΙ ΑΔΒ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Καμία αποθήκευση στο αεροδρόμιο'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

--- Τέλος παράθεσης ---

To ΑΔΕ πού σου χρειάζεται;

Επίσης, η τελευταία περίπτωση θα μπορούσε να είναι σκέτο ΑΛΛΙΩΣ.

theoL:
Το ΑΔΕ ΔΕΝ χρειάζεται πουθενα  :) κεκτημένη ταχυτητα...
το τελευταίο δεν μπαίνει σκετο γιατί είναι ΚΑΙ

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση