Ψηφοφορία

Πιστεύετε ότι η λύση με πίνακες στο Θέμα Γ  :

Είναι λάθος - να κοπούν 3-5 μονάδες
28 (8.2%)
Είναι λάθος - να κοπούν 1-2 μονάδες
23 (6.7%)
Είναι σωστή αλλά όχι ιδανική - να κοπούν 1-2 μονάδες
29 (8.5%)
Είναι σωστή αλλά όχι ιδανική - να μην κοπούν μονάδες
108 (31.7%)
Είναι σωστή - να μην κοπούν μονάδες
153 (44.9%)

Σύνολο ψηφοφόρων: 339

Αποστολέας Θέμα: Ημερήσια 2010  (Αναγνώστηκε 173032 φορές)

oneoxoritis

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Ημερήσια 2010
« Απάντηση #15 στις: 28 Μάι 2010, 10:14:26 πμ »
Καλήμερα. Έχουν αναρτηθεί κάπου τα θέματα?

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Ημερήσια 2010
« Απάντηση #16 στις: 28 Μάι 2010, 10:16:35 πμ »
πού τα βρήκατε παιδιά ?
Φιλικά,
Γιώργος Θαλασσινός

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2784
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Ημερήσια 2010
« Απάντηση #17 στις: 28 Μάι 2010, 10:18:06 πμ »

panastros

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 10
  • Audere EST Facere
Απ: Ημερήσια 2010
« Απάντηση #18 στις: 28 Μάι 2010, 10:18:20 πμ »
μολις... απ' το υπουργείο... :) :)

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Ημερήσια 2010
« Απάντηση #19 στις: 28 Μάι 2010, 10:21:27 πμ »
Θέματα!!!

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Ημερήσια 2010
« Απάντηση #20 στις: 28 Μάι 2010, 10:48:50 πμ »
Πόσο απογοητεύτηκαν όσοι περίμεναν 2D πίνακες και/με υποπρογράμματα ...
Τελικά η απλότητα αποδίδει γοητεία στα θέματα και κατατροπώνει τα παπαγαλάκια ;)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

p-p

  • Θαμώνας
  • ***
  • Μηνύματα: 47
Απ: Ημερήσια 2010
« Απάντηση #21 στις: 28 Μάι 2010, 10:57:53 πμ »
Θα μπορούσαν να πέσουν πιο εύκολα...Θα μπορούσαν να πέσουν πιο δύσκολα....

Τα φετινά θέματα ωστόσο έφεραν την απαραίτητη ισορροπία που χρειαζότανε το μάθημα....

Πιστεύω, είναι τέτοια η υφή τους, που δεν ενοχλούν και όσους ήθελαν πιο δύσκολα θέματα αλγοριθμικής σκέψης....

Νοιώθεις πως η επιτροπή στο μέτρο του δυνατού έκανε φέτος το καθήκον της....
“When Kepler found his long-cherished belief did not agree with the most precise observation, he accepted the uncomfortable fact. He preferred the hard truth to his dearest illusions; that is the heart of science.” - Carl Sagan

nef

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Ημερήσια 2010
« Απάντηση #22 στις: 28 Μάι 2010, 11:09:59 πμ »
Πολύ καλά θέματα. η ουσία της αλγοριθμικής.

Επισυνάπτω πρόχειρες λύσεις.

Τροποποίηση τελευταίας επανάληψης:

ΟΣΟ κ1<>3 Ή κ2<>3 Ή κ3<>3 ΕΠΑΝΑΛΑΒΕ
  ΑΝ ΚΑΤ[ι]="C1" KAI κ1<3 ΤΟΤΕ
   ΓΡΑΨΕ κ1,"ος κατηγορίας C1:", ΟΝ[ι]
   κ1<-κ1+1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ[ι]="C2" KAI κ2<3 ΤΟΤΕ
   ΓΡΑΨΕ κ2,"ος κατηγορίας C2:", ΟΝ[ι]
   κ2<-κ2+1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ[ι]="C3" KAI κ3<3 ΤΟΤΕ
   ΓΡΑΨΕ κ3,"ος κατηγορίας C3:", ΟΝ[ι]
   κ3<-κ3+1
  ΤΕΛΟΣ_ΑΝ
  ι<-ι+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
« Τελευταία τροποποίηση: 28 Μάι 2010, 11:30:44 πμ από nef »

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2452
  • I 'm not young enough to know everything
Απ: Ημερήσια 2010
« Απάντηση #23 στις: 28 Μάι 2010, 11:16:08 πμ »
Μου φάνηκε ενδιαφέρον ότι στο θέμα Γ δεν επιτρέπεται η χρήση πίνακα. 

olga_ath

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 64
Απ: Ημερήσια 2010
« Απάντηση #24 στις: 28 Μάι 2010, 11:17:56 πμ »
Πολύ καλά θέματα. η ουσία της αλγοριθμικής.

Επισυνάπτω πρόχειρες λύσεις.


ευχαριστουμε πολύ :-)
Doubt everyone and first of all yourself

denispyr

  • Βετεράνος
  • ****
  • Μηνύματα: 64
Απ: Ημερήσια 2010
« Απάντηση #25 στις: 28 Μάι 2010, 11:22:03 πμ »
Μου φάνηκε ενδιαφέρον ότι στο θέμα Γ δεν επιτρέπεται η χρήση πίνακα. 

??? Ποιός το απαγόρευσε?
Διονύσης

methenitis

  • Θαμώνας
  • ***
  • Μηνύματα: 42
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Ημερήσια 2010
« Απάντηση #26 στις: 28 Μάι 2010, 11:22:16 πμ »
Συγνώμη , αλλα που το λέει οτι δεν επιτρέπεται πίνακας?
@nef.
Στο 4 θέμα το τελευταίο ερώτημα νομίζω ότι το έχεις λύσει λάθος.Μπορεί στις πρώτες 4 θέσεις(Γενικές)να ειναι κατηγορία C1 οπότε ο μετρητής να φύγει και να πάει στο 4 και στην ΟΣΟ να ειναι ψευδής μέχρι τέλους.
Θα σου εμφανίσει τα σωστά αλλά θα συνεχίσει την εκτέλεση επ απειρον. Μπορεί βέβαια και να μην κατάλαβα σωστά.

nef

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Ημερήσια 2010
« Απάντηση #27 στις: 28 Μάι 2010, 11:27:01 πμ »
έχεις δίκιο methenitis. Σε κάθε ΑΝ χρειάζεται και ένα "ΚΑΙ κ1<=3", ΚΑΙ "κ2<=3" ΚΑΙ "κ3<=3", αλλά ο δείκτης αποκλείεται να ξεφύγει γιατί λέει θεωρείστε ότι υπάρχουν τουλάχιστον 3 από κάθε κατηγορία. Οπότε κάποτε θα γίνουν όλοι οι μετρητές 3.

methenitis

  • Θαμώνας
  • ***
  • Μηνύματα: 42
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Ημερήσια 2010
« Απάντηση #28 στις: 28 Μάι 2010, 11:29:50 πμ »
Μην βάλεις Κ1<=3...γιατι θα μπεί για 3 και θα γίνει 4. βάλε σκέτο < να μπεί για 2 , να γίνει 3 και μην ξαναμπέι.
Βασικά εγώ τα έχωσα όλα σε πίνακες και απλώς εμφάνισα τις 3 πρώτες θέσεις του κάθε πίνακα.

amavidis

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 81
Απ: Ημερήσια 2010
« Απάντηση #29 στις: 28 Μάι 2010, 11:30:44 πμ »
Συμφωνώ ότι στο θέμα Γ ΔΕΝ πρέπει να χρησιμοποιηθεί πίνακας. Εφόσον οι θέσεις δεν είναι γνωστές από την αρχή και ο πίνακας είναι Στατική Δομή , πρέπει να λυθεί μόνο με επαναλήψεις, μετρητές, αθροιστές