Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 8509 φορές)

Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: Θέμα Δ
« Απάντηση #30 στις: 28 Μάι 2015, 11:04:53 μμ »
Η λύση χωρίς πίνακες μέχρι και το Δ3 δεν πρέπει να χάσει πάντως μόρια.

Τώρα ένα κουφό που μου είπε ένας μαθητής ήταν ότι επαιξε μπάλα χωρίς πίνακες, αλλά μετα το συνέχισε θεωρώντας ότι ο μέγιστος βαθμός ειναι σώνει και καλά το 10.
Απο το Δ4 πόσο θα χάσει αυτό το παιδί?
Όλο ? 5 μόρια ? 2 και μισό να το αφήσω?

Εγώ του είπα ότι θα πάρει ένα μόριο απο το Δ4, ίσα για την Εμφάνισε και τις αρχικοποιήσεις. Και του χάλασα το πάρτυ :(
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #31 στις: 28 Μάι 2015, 11:14:03 μμ »
Γιατί η λύση χωρίς πίνακες να χάσει μόρια?
Αν είναι σωστή θα πρέπει να πάρει και παραπάνω, όχι να χάσει
Η λύση χωρίς πίνακες μέχρι και το Δ3 δεν πρέπει να χάσει πάντως μόρια.

Για τον μαθητή σου που είπες λογικά θα πάρει παραπάνω, αλλά αυτό εξαρτάται από την εικόνα του γραπτού και από το τι ακριβώς έχει κάνει.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

alpapanto

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • ΗΟΜΕ μοναχομ
Απ: Θέμα Δ
« Απάντηση #32 στις: 28 Μάι 2015, 11:24:31 μμ »
Ως προς την εκφώνηση και τα νούμερά της...
τι σόι διαγωνισμός ειναι αυτός που 6 κριτές δίνουν 7άρια, ένας δίνει 8άρι(50 στο σύνολο) και το τραγούδι μένει απ έξω;;;😈😈
ας την κάνανε 10μελή ρε παιδάκι μου...

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1133
Απ: Θέμα Δ
« Απάντηση #33 στις: 29 Μάι 2015, 12:18:13 πμ »
Όσοι μπόρεσαν και απάντησαν ορισμένα ερωτήματα από το Δ θέμα, χωρίς χρήση πινάκων εννοείται πως δεν πρέπει να κοπούν μόρια.
Εξάλλου ούτε η εκφώνηση του θέματος έλεγε για χρήση πινάκων!!!

netnick

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Θέμα Δ
« Απάντηση #34 στις: 29 Μάι 2015, 12:49:29 πμ »
Θεωρώ ότι η λύση χωρίς πίνακα δεν είναι ούτε πολύπλοκη ούτε μακροσκελής (δύσκολή ίσως είναι), και νομίζω λοιπόν ότι πρέπει να αναφερθεί:
Κώδικας: [Επιλογή]
Αλγόριθμος ΘεμαΔ
 κριτές ← 0
 προκρ ← 0
 Για ι από 1 μέχρι 45
   Διάβασε τιτλο
   πλ5 ← 0
   αθρ ← 0
   μαχ ← -1        ! για Δ4 ερώτημα
   πλ ← 0          ! για Δ4 ερώτημα
   Για j από 1 μέχρι 7
     Διάβασε βαθ
     αθρ ← αθρ + βαθ
     Αν βαθ > 5 τότε
       πλ5 ← πλ5 + 1
     Τέλος_αν
     ! η Αν που ακολουθεί είναι για το Δ4,
     ! υπολογίζω το μέγιστο βαθμό απο τους 7
     ! και πόσες φορές εμφανίστηκε
     Αν βαθ > μαχ τότε
       μαχ ← βαθ
       πλ ← 1
     αλλιώς_αν βαθ = μαχ τότε
       πλ ← πλ + 1
     Τέλος_αν
   Τέλος_επανάληψης
   ! για να ολοκληρωθει το Δ4 λοιπόν οι επόμενες 3 γραμμές
   Αν πλ = 1 τότε
     κριτές ← κριτές + 1
   Τέλος_αν
   Εμφάνισε αθρ
   Αν αθρ > 50 και πλ5 = 7 τότε
     Εμφάνισε τιτλο
     προκρ ← προκρ + 1
   Τέλος_αν
 Τέλος_επανάληψης
 
 Αν προκρ = 0 τότε
   Εμφάνισε "Κανένα τραγούδι δεν προκρίνεται."
 Τέλος_αν
 
 Εμφάνισε κριτές        !απάντηση στο Δ4
 Τέλος
Η λύση που αναφέρει ο gkatsion είναι καλή.
Θα μπορούσε επίσης να γίνει και με εύρεση δύο μεγίστων (στο τετράδιο του μαθητή αναφέρεται αλγόριθμος εύρεσης 2 ελαχίστων τιμών) - και με πίνακες και χωρίς-  και στη συνέχεια να συγκριθούν για να ελεγχθει εάν οι δύο τιμές είναι ίσες η όχι.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #35 στις: 29 Μάι 2015, 12:53:43 πμ »
Η λύση σου δεν είναι σωστή,
πρέπει να υπολογίσεις τη μέγιστη βαθμολογία ενός κριτή για τα 45 τραγούδια, ενώ εσύ υπολογίζεις τη μέγιστη που λαμβάνει κάθε τραγούδι από τους 7 κριτές.
Αυτή είναι η δυσκολία, ότι πρέπει να υλοποιήσεις δυο διαφορετικές επεξεργασίες στον "πίνακα" μια κατά γραμμές και μια κατά στήλες χωρίς πίνακα  :o.
Για να καταλάβεις το λάθος σου σκέψου ότι η μεταβλητή κριτές μπορεί να πάρει τιμή μεγαλύτερη του 7, 45 στην χειρότερη περίπτωση, στον δικό σου κώδικα

Θεωρώ ότι η λύση χωρίς πίνακα δεν είναι ούτε πολύπλοκη ούτε μακροσκελής (δύσκολή ίσως είναι), και νομίζω λοιπόν ότι πρέπει να αναφερθεί:
Κώδικας: [Επιλογή]
Αλγόριθμος ΘεμαΔ
 κριτές ← 0
 προκρ ← 0
 Για ι από 1 μέχρι 45
   Διάβασε τιτλο
   πλ5 ← 0
   αθρ ← 0
   μαχ ← -1        ! για Δ4 ερώτημα
   πλ ← 0          ! για Δ4 ερώτημα
   Για j από 1 μέχρι 7
     Διάβασε βαθ
     αθρ ← αθρ + βαθ
     Αν βαθ > 5 τότε
       πλ5 ← πλ5 + 1
     Τέλος_αν
     ! η Αν που ακολουθεί είναι για το Δ4,
     ! υπολογίζω το μέγιστο βαθμό απο τους 7
     ! και πόσες φορές εμφανίστηκε
     Αν βαθ > μαχ τότε
       μαχ ← βαθ
       πλ ← 1
     αλλιώς_αν βαθ = μαχ τότε
       πλ ← πλ + 1
     Τέλος_αν
   Τέλος_επανάληψης
   ! για να ολοκληρωθει το Δ4 λοιπόν οι επόμενες 3 γραμμές
   Αν πλ = 1 τότε
     κριτές ← κριτές + 1
   Τέλος_αν
   Εμφάνισε αθρ
   Αν αθρ > 50 και πλ5 = 7 τότε
     Εμφάνισε τιτλο
     προκρ ← προκρ + 1
   Τέλος_αν
 Τέλος_επανάληψης
 
 Αν προκρ = 0 τότε
   Εμφάνισε "Κανένα τραγούδι δεν προκρίνεται."
 Τέλος_αν
 
!απάντηση στο Δ4
 Εμφάνισε κριτές
 Τέλος
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

netnick

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Θέμα Δ
« Απάντηση #36 στις: 29 Μάι 2015, 01:00:25 πμ »
Ναι :-( , οκ

kkkerm

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 19
Λύση χωρίς χρήση πίνακα από μαθητή
« Απάντηση #37 στις: 29 Μάι 2015, 11:13:10 πμ »
Κάποιοι από εμάς που ασχολούμαστε χρόνια με  τον προγραμματισμό θα λέγαμε ότι όλα τα ερωτήματα ήταν κατανοητά. Για να καταλάβουμε το πρόβλημα που δημιουργούμε με τις διατυπώσεις των ασκήσεών μας θα πρέπει να θυμόμαστε συνέχεια ότι απευθυνόμαστε σε παιδιά και όχι σε συναδέλφους καθηγητές πληροφορικής.

…. Άραγε για τα παιδιά (γνωρίζω ένα από αυτά ) που έλυσαν το θέμα χωρίς πίνακες υπάρχει κάποιο ιδιαίτερο βραβείο…

Χωρίς διάθεση να προσβάλω κανέναν ας προσπαθήσουμε να δώσουμε στο μάθημά μας τη θέση που του αξίζει.
(έγινε διόρθωση ΑΝ Β>=5 ΤΟΤΕ Μετρ_β<-Μετρ_β+1)

Κ&Κ
« Τελευταία τροποποίηση: 29 Μάι 2015, 11:50:09 πμ από kkkerm »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #38 στις: 30 Μάι 2015, 02:09:31 πμ »
Μπα μην στεναχωριέσαι
και στον ΟΕΦΕ το συγκεκριμένο θέμα το έχουν λύσει λάθος
http://www.oefe.gr/panellinies/liseis_plir_kat_c_hmer_no_150527.pdf
Βρίσκουν για κάθε τράγουδι τη μέγιστη βαθμολογία

Πιο πριν είχαν λάθος και την μετατροπή στο θέμα Β
http://www.iefimerida.gr/sites/default/files/apantiseis_aepp_teliko.pdf

Ναι :-( , οκ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 843
Απ: Θέμα Δ
« Απάντηση #39 στις: 30 Μάι 2015, 10:41:12 πμ »
http://www.alfavita.gr/arthron/%CE%BC%CE%B5%CE%B3%CE%AC%CE%BB%CE%BF%CF%82-%CE%BC%CE%B5%CE%B3%CE%B1%CE%BB%CF%8D%CF%84%CE%B5%CF%81%CE%BF%CF%82-%CE%BC%CE%AD%CE%B3%CE%B9%CF%83%CF%84%CE%BF%CF%82-%CE%B1%CE%B5%CF%80%CF%80-2015-%CF%84%CE%BF%CF%85-%CE%BC%CE%B1%CE%B8%CE%B7%CF%84%CE%AE-%CF%80%CE%B1%CE%BD%CE%B1%CE%B3%CE%B9%CF%8E%CF%84%CE%B7-%CE%BA%CE%B1%CF%81%CE%B1%CE%BF%CF%85%CE%BB%CE%AC%CE%BD%CE%B7

θεωρώ σημαντικό σε τέτοια άρθρα να απαντάμε, αφού πρόκειται για απορία-ένσταση μαθητή

Εγώ προσπάθησα να απαντήσω απλά (βλέπε σχόλια). Αν νομίζει ότι κάποιος συνάδελφος μπορεί να προσθέσει κάτι...

« Τελευταία τροποποίηση: 30 Μάι 2015, 10:55:54 πμ από janag79 »

VAIOS

  • Βετεράνος
  • ****
  • Μηνύματα: 63
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Δ
« Απάντηση #40 στις: 30 Μάι 2015, 07:50:45 μμ »
Πόσα μόρια χάνει ο μαθητής αν θεωρεί ως μέγιστο το 10;

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 131
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Δ
« Απάντηση #41 στις: 30 Μάι 2015, 08:03:12 μμ »
3 μόρια...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Θέμα Δ
« Απάντηση #42 στις: 31 Μάι 2015, 12:01:11 πμ »
Ένας μαθητής έγραψε σήμερα το εξής στο θέμα Δ3. Μεταφέρω μόνο το τμήμα που έχει ενδιαφέρον

Κώδικας: Pascal
  1.  
  2. πέρασε <-- Σ[i]>50
  3. Για j από 1 μέχρι 7
  4.     πέρασε <-- πέρασε και ( B[i,j] >= 5)
  5. ΤΕ
  6. Αν πέρασε Τότε ....
  7.  

χωρίς λόγια  :o
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 131
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Δ
« Απάντηση #43 στις: 31 Μάι 2015, 12:09:28 πμ »
Ένας μαθητής έγραψε σήμερα το εξής στο θέμα Δ3. Μεταφέρω μόνο το τμήμα που έχει ενδιαφέρον

Κώδικας: Pascal
  1.  
  2. πέρασε <-- Σ[i]>50
  3. Για j από 1 μέχρι 7
  4.     πέρασε <-- πέρασε και ( B[i,j] >= 5)
  5. ΤΕ
  6. Αν πέρασε Τότε ....
  7.  

χωρίς λόγια  :o

!!!!
Όλα τα λεφτά ( με λόγια )

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέμα Δ
« Απάντηση #44 στις: 31 Μάι 2015, 01:00:44 πμ »
Απλά εξαιρετικό
Ουσιαστικά απλοποιείς όλα τα προβλήματα Απόφασης χωρίς την χρήση δομής επιλογής
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής