Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Γ΄ Λυκείου => Εξετάσεις 2014-2015 => Μήνυμα ξεκίνησε από: gpapargi στις 27 Μαΐ 2015, 10:21:47 πμ

Τίτλος: Θέμα Δ
Αποστολή από: gpapargi στις 27 Μαΐ 2015, 10:21:47 πμ
Εδώ σχολιάζουμε το θέμα Δ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: mantzu στις 27 Μαΐ 2015, 11:29:03 πμ
Η προσεγγιση μπορει να γινει με πινακες φανταζομαι και ας μην αναφερει την χρηση τους? διοτι με χρηση γινεται αρκετα ευκολη η επιλυση
Τίτλος: Απ: Θέμα Δ
Αποστολή από: ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ στις 27 Μαΐ 2015, 11:30:55 πμ
Λυνεται χωρις πινακες;
Τίτλος: Απ: Θέμα Δ
Αποστολή από: dihatzou στις 27 Μαΐ 2015, 12:02:28 μμ
Στο Δ4 ο μέγιστος βαθμός που έδωσε ο κάθε κριτής είναι
α) το 10;
β) ο max των βαθμών που έχει βάλει ο κριτής, όχι απαραίτητα το 10;
Τίτλος: Απ: Θέμα Δ
Αποστολή από: nightchild στις 27 Μαΐ 2015, 12:05:02 μμ
 το β
Τίτλος: Απ: Θέμα Δ
Αποστολή από: progmat στις 27 Μαΐ 2015, 12:27:24 μμ
Καμιά ιδέα για το Δ4;
Τίτλος: Απ: Θέμα Δ
Αποστολή από: soc_h στις 27 Μαΐ 2015, 12:33:48 μμ
Αν έχεις δίστηλο με 7 γραμμές (κριτές) και 45 στήλες (τραγούδια), κάνεις ανά γραμμή αναζήτηση μεγίστου και στη συνέχεια αναζήτηση πλήθους μεγίστου. Για κάθε αποτέλεσμα πλήθους 1, αυξάνεις το μετρητή των κριτών που έδωσαν μόνο ένα μέγιστο κατά ένα.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: elenitaaaaa στις 27 Μαΐ 2015, 12:44:01 μμ
Mία λύση:

πλ_κρ←0
Για j από 1 μέχρι 7
   max←BΑΘ [1, j]
   Για i από 2 μέχρι 45
      Αν ΒΑΘ [i,j]>max τοτε max←BΑΘ [i, j]
   Tέλος_επανάληψης
   πλ←0
   Για i από 1 μέχρι 45
      Αν ΒΑΘ [i,j]=max τοτε πλ←πλ+1
   Tέλος_επανάληψης
   Αν πλ=1 τότε πλ_κρ←πλ_κρ+1
Τέλος_επανάληψης
Εμφάνισε πλ_κρ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: progmat στις 27 Μαΐ 2015, 12:47:58 μμ
Kαι το Δ λοιπόν...

Κώδικας: [Επιλογή]
Αλγόριθμος ΘΕΜΑ_Δ
ΠΛ ← 0
ΠΛΚΡ ← 0

Για Ι από 1 μέχρι 7
  ΜΑΧ[Ι] ← 0
Τέλος_επανάληψης

Για Ι από 1 μέχρι 45
  ΣΥΝΒ ← 0
  Φ ← Αληθής
  Διάβασε ΤΙΤΛΟΣ
  Για Κ από 1 μέχρι 7
    Διάβασε ΒΑΘΜΟΣ[Ι, Κ]
    Αν ΒΑΘΜΟΣ[Ι, Κ] < 5 τότε
      Φ ← Ψευδής
    Τέλος_αν
    ΣΥΝΒ ← ΣΥΝΒ + ΒΑΘΜΟΣ[Ι, Κ]
  Τέλος_επανάληψης

  Εμφάνισε ΣΥΝΒ

  Αν ΣΥΝΒ > 50 και Φ = Αληθής τότε
    ΠΛ ← ΠΛ + 1
    Εμφάνισε ΤΙΤΛΟΣ, "ΠΕΡΝΑΕΙ ΣΤΗ ΔΕΥΤΕΡΗ ΦΑΣΗ"
  Τέλος_αν
Τέλος_επανάληψης

Αν ΠΛ = 0 τότε
  Εμφάνισε "ΔΕΝ ΥΠΑΡΧΕΙ ΤΡΑΓΟΥΔΙ ΣΤΗ ΔΕΥΤΕΡΗ ΦΑΣΗ"
Τέλος_αν

Για Κ από 1 μέχρι 7
  ΜΑΧ[Κ] ← ΒΑΘΜΟΣ[1, Κ]
  Για Ι από 1 μέχρι 45
    Αν ΒΑΘΜΟΣ[Ι, Κ] > ΜΑΧ[Κ] τότε
      ΜΑΧ[Κ] ← ΒΑΘΜΟΣ[Ι, Κ]
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

Για Κ από 1 μέχρι 7
  ΠΛΜΑΧ ← 0
  Για Ι από 1 μέχρι 45
    Αν ΒΑΘΜΟΣ[Ι, Κ] = ΜΑΧ[Κ] τότε
      ΠΛΜΑΧ ← ΠΛΜΑΧ + 1
    Τέλος_αν
  Τέλος_επανάληψης
  Αν ΠΛΜΑΧ = 1 τότε
    ΠΛΚΡ ← ΠΛΚΡ + 1
  Τέλος_αν
Τέλος_επανάληψης

Εμφάνισε ΠΛΚΡ
Τέλος ΘΕΜΑ_Δ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: andreas_p στις 27 Μαΐ 2015, 12:55:58 μμ
Και μια εναλλακτική για το Δ4.

πλ <- 0
Για κρ από 1 μέχρι 7
  μεγ <- Β[1,κρ]
  π <- 1
  Για τρ από 2 μέχρι 45
      Αν Β[τρ,κρ] > μεγ τότε
           μεγ <- Β[τρ,κρ]
           π <- 1
      αλλιώς_αν Β[τρ,κρ]=μεγ τότε
           π <- π+1
       Τέλος_αν
  Τέλος_επανάληψης
  Αν π=1 τότε πλ <- πλ+1
Τέλος_επανάληψης
Εμφάνισε πλ

Πυρόβολος Ανδρέας
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Loco-3 στις 27 Μαΐ 2015, 01:05:53 μμ
εύκολο για θέμα Δ δυστυχώς..
υπάρχει περίπτωση να μας κόψουν επειδή το κάναμε με πίνακες;;
Τίτλος: Απ: Θέμα Δ
Αποστολή από: themata στις 27 Μαΐ 2015, 01:08:39 μμ
 
εύκολο για θέμα Δ δυστυχώς..
υπάρχει περίπτωση να μας κόψουν επειδή το κάναμε με πίνακες;;
μα το θέμα λύνεται με πίνακες
Τίτλος: Απ: Θέμα Δ
Αποστολή από: soc_h στις 27 Μαΐ 2015, 01:12:50 μμ
Μα λύνεται χωρίς πίνακες;
Τίτλος: Απ: Θέμα Δ
Αποστολή από: elenitaaaaa στις 27 Μαΐ 2015, 01:13:12 μμ
Και μια εναλλακτική για το Δ4.

πλ <- 0
Για κρ από 1 μέχρι 7
  μεγ <- Β[1,κρ]
  π <- 1
  Για τρ από 2 μέχρι 45
      Αν Β[τρ,κρ] > μεγ τότε
           μεγ <- Β[τρ,κρ]
           π <- 1
      αλλιώς_αν Β[τρ,κρ]=μεγ τότε
           π <- π+1
       Τέλος_αν
  Τέλος_επανάληψης
  Αν π=1 τότε πλ <- πλ+1
Τέλος_επανάληψης
Εμφάνισε πλ

Πυρόβολος Ανδρέας

Στο ίδιο σκεπτικό με το περσινο Γ. επίσης μαθητριά μου τα πλήθη των max τα τοποθετούσε σε πίνακα κ μετα μετρούσε τα "1" του πίνακα
Τίτλος: Απ: Θέμα Δ
Αποστολή από: soc_h στις 27 Μαΐ 2015, 01:18:25 μμ
Τρελός κόπος χωρίς πίνακες
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Ανδρέας Φαρμακόρης στις 27 Μαΐ 2015, 02:00:53 μμ
1. Βρίσκεις πλήθος τραγουδιών με μέγιστη βαθμολογία από ένα κριτή, νομίζω. Δηλαδή το ΠλήθοςΚριτών δεν είναι αυτό που ζητάει.
2. Αντί 2 απλές επιλογές θέλει πολλαπλή γιατί αν περάσει από την πρώτη, περνάει και από τη δεύτερη και κάνει το  Πλήθοςmax 2 (λανθασμένα).
Όλγα έχεις δίκιο.  Έσβησα το παραπάνω σχόλιο για να μην μπερδέψω.  Sorry
Τίτλος: Απ: Θέμα Δ
Αποστολή από: theoL στις 27 Μαΐ 2015, 06:18:01 μμ
ΠΡΟΓΡΑΜΜΑ  ΘΕΜΑ_Δ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Χ,Υ,ΒΑΘΜΟΛΟΓΙΑ[45,7],ΣΥΝΟΛΙΚΗ_ΒΑΘΜΟΛΟΓΙΑ[45],ΑΡ_ΚΡΙΤ_ΜΕΓ_5,ΑΡ_ΚΡΙΤ_ΜΕΓ_ΒΑΘΜ
  ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
  ΧΑΡΑΚΤΗΡΕΣ: ΤΙΤΛΟΙ[45]
ΑΡΧΗ
  ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
  ΑΡ_ΚΡΙΤ_ΜΕΓ_5 <-- 0
  ΑΡ_ΚΡΙΤ_ΜΕΓ_ΒΑΘΜ <-- 0
  ΓΙΑ Χ ΑΠΟ 1 ΜΕΧΡΙ 45
    ΣΥΝΟΛΙΚΗ_ΒΑΘΜΟΛΟΓΙΑ[Χ] <-- 0
    ΓΡΑΨΕ 'ΔΟΣΕ ΤΟΝ ΤΙΤΛΟ ΤΟΥ ΤΡΑΓΟΥΔΙΟΥ'
    ΔΙΑΒΑΣΕ ΤΙΤΛΟΙ[Χ]
    ΓΙΑ Υ ΑΠΟ 1 ΜΕΧΡΙ 7
      ΓΡΑΨΕ 'ΔΟΣΕ ΤΗΝ ΒΑΘΜΟΛΟΓΙΑ ΤΟΥ ',Υ,'ου ΚΡΙΤΗ'
      ΔΙΑΒΑΣΕ ΒΑΘΜΟΛΟΓΙΑ[Χ,Υ]
      ΣΥΝΟΛΙΚΗ_ΒΑΘΜΟΛΟΓΙΑ[Χ] <-- ΣΥΝΟΛΙΚΗ_ΒΑΘΜΟΛΟΓΙΑ[Χ]+ΒΑΘΜΟΛΟΓΙΑ[Χ,Υ]
      ΑΝ ΒΑΘΜΟΛΟΓΙΑ[Χ,Υ]>=5 ΤΟΤΕ
        ΑΡ_ΚΡΙΤ_ΜΕΓ_5 <-- ΑΡ_ΚΡΙΤ_ΜΕΓ_5+1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ΒΑΘΜΟΛΟΓΙΑ[Χ,Υ]=10 ΤΟΤΕ
        ΑΡ_ΚΡΙΤ_ΜΕΓ_ΒΑΘΜ <-- ΑΡ_ΚΡΙΤ_ΜΕΓ_ΒΑΘΜ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΥΝΟΛΙΚΗ_ΒΑΘΜΟΛΟΓΙΑ[Χ]>50 ΚΑΙ ΑΡ_ΚΡΙΤ_ΜΕΓ_5=7 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΤΡΑΓΟΥΔΙ',ΤΙΤΛΟΙ[Χ],'ΠΕΡΝΑ ΣΤΗΝ ΔΕΥΤΕΡΗ ΦΑΣΗ'
      ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Κανένα τραγούδι δεν προκίνεται στην δεύτερη φάση'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΜΑ_Δ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: evry στις 27 Μαΐ 2015, 07:51:48 μμ
Το θέμα δεν ζητάει πίνακες. Μπορεί να λυθεί χωρίς πίνακα δυο διαστάσεων με δυο  μονοδιάστατους για τα μέγιστα και τους μετρητές.
Στα προφορικά έτυχε μαθητής ο οποίος (από ότι είπε δεν πήγαινε φροντιστήριο οπότε γλίτωσε την τυποίηση των πίνακων) και έδωσε ολόσωστη λύση χωρίς πίνακες. Απλά χρησιμοποίησε 7+7 μεταβλητές και πολλά Αν…τότε  :o :o :o (μας βγήκαν τα μάτια στη διόρθωση), αλλά ήταν σωστό
Παρακάτω δίνω μια άλλη λύση, στην οποία δεν χρησιμοποιούνται πίνακες παρά μόνο ο πίνακας των μετρητών που ανέφερα προηγουμένως.
Κώδικας: Pascal
  1. μ <-- 0  
  2. κριτές <-- 0
  3. Για κ από 1 μέχρι 7
  4.    μέγιστο[κ] <-- 0
  5. Τέλος_Επανάληψης
  6. Για τραγούδι από 1 μέχρι 45
  7.      Διάβασε Τίτλο
  8.      Σ <-- 0
  9.      Για j από 1 μέχρι 7
  10.           Διάβασε Β
  11.           Σ <-- Σ + Β
  12.           Αν Β >= 5 Τότε  κ <-- κ + 1
  13.           Αν Β > μέγιστο[j] Τότε
  14.               μέγιστο[j] <-- Β
  15.               φορές[ j ] <-- 1
  16.           Αλλιώς_Αν μέγιστο[j] = Β Τότε
  17.               φορές[ j ]  <-- φορές[ j ] + 1
  18.           Τέλος_Αν
  19.     Τέλος_Επανάληψης
  20.     Εμφάνισε Σ
  21.     Αν  κ = 7  και   Σ > 50  Τότε
  22.         Εμφάνισε Τίτλο
  23.         μ <-- μ + 1
  24.     Τέλος_Αν
  25.     Αν φορές[j] = 1 Τότε κριτές <-- κριτές + 1
  26. Τέλος_Επανάληψης
  27.  Εμφάνισε κριτές
  28.  Αν  μ = 0   Τότε Εμφάνισε   ‘κανένα τραγούδι δεν προκρίνεται’
  29.  
δεν αποκλείεται να μου ξέφυγε κάτι, αλλά νομίζω ότι η γενική ιδέα φαίνεται

οπότε όσοι συνάδεφοι βαθμολογούμε προσοχή γιατί θα δούμε πολλές λύσεις χωρίς πίνακες που θα είναι σωστές.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: epsilonXi στις 27 Μαΐ 2015, 09:36:56 μμ
εμένα ένας το έλυσε με ταξινόμηση... μάλιστα με ταξινόμηση μόνο των 2 πρώτων βαθμών ανά κριτή

κακή ιδέα η ταξινόμηση, αλλά καλή ιδέα η ταξινόμηση μόνο των 2 πρώτων



πλ <-- 0
για κ από 1 μέχρι 7
   για χ από 2 μέχρι 3
      για τ από 45 μέχρι χ με βήμα -1
        αν ΒΑΘ[κ,τ] > Β[κ,τ-1] τότε
           αντιμετάθεσε ΒΑΘ[κ,τ], ΒΑΘ[κ,τ-1]
        τέλος_αν
     τέλος_επανάληψης
   τέλος_επανάληψης
   αν ΒΑΘ[κ,1] > ΒΑΘ[κ,2] τότε
    πλ <-- πλ + 1
   τέλος_αν
τέλος_επανάληψης
εμφάνισε πλ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: theoL στις 28 Μαΐ 2015, 02:42:01 μμ
Ποια είναι η καλύτερη λύση ;
Όλες εφόσον δίνουν σωστό επιστημονικά αποτέλεσμα είναι σωστές και θα πρέπει να βαθμολογηθούν τουλάχιστον με το 80% της αξίας σε βαθμούς της ερώτησης.
Η καλύτερη θα πρέπει να έχει κάποια κριτήρια. Και ένα από αυτά είναι το μέγεθος του προγράμματος….! Και η πολυπλοκότητα
 8)
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Αθανάσιος Πέρδος στις 28 Μαΐ 2015, 05:50:38 μμ
Συγγνώμη που το έγραψα και στο γενικό σχολιασμό αλλά δεν είχα δει το μήνυμα σε αυτό το νήμα. Τι σχέση έχει το μέγεθος του προγράμματος και η πολυπλοκότητα με τη βαθμολόγηση.
Δηλαδή προτείνεις να μην πάρει όλες τις μονάδες η λύση που παρατίθεται παραπάνω;

Ποια είναι η καλύτερη λύση ;
Όλες εφόσον δίνουν σωστό επιστημονικά αποτέλεσμα είναι σωστές και θα πρέπει να βαθμολογηθούν τουλάχιστον με το 80% της αξίας σε βαθμούς της ερώτησης.
Η καλύτερη θα πρέπει να έχει κάποια κριτήρια. Και ένα από αυτά είναι το μέγεθος του προγράμματος….! Και η πολυπλοκότητα
 8)
Τίτλος: Απ: Θέμα Δ
Αποστολή από: gkatsion στις 28 Μαΐ 2015, 06:10:01 μμ
Η παρακάτω λύση για τους βαθμολογητές που θα κάτσουν να ασχοληθούν και να καταλάβουν τι κάνει θα πάρει πλήρη μόρια.
Είναι εντελώς σωστή.

Δεν έχει σχέση το μέγεθος ούτε η πολυπλοκότητα. Δεν εξετάζονται οι μαθητές σε αυτά. Δεν ελέγχουμε βελτιστοποίηση.

Τέλος να σχολιάσω ότι για κάθε έναν κριτή ο παρακάτω αλγόριθμος κανει 2 επαναλήψεις των 44 και 43 φορών.
Και η ενδεικτική επίλυση του υπουργείου έχει 2 επαναλήψεις για κάθε κριτή των 45 και 45 φορών.

Δεν υπάρχει καμία αύξηση της πολυπλοκότητας αφού δεν τα ταξινομεί όλα, αλλά μόνο τα 2 πρώτα αδιαφορώντας για τα άλλα.


εμένα ένας το έλυσε με ταξινόμηση... μάλιστα με ταξινόμηση μόνο των 2 πρώτων βαθμών ανά κριτή

κακή ιδέα η ταξινόμηση, αλλά καλή ιδέα η ταξινόμηση μόνο των 2 πρώτων



πλ <-- 0
για κ από 1 μέχρι 7
   για χ από 2 μέχρι 3
      για τ από 45 μέχρι χ με βήμα -1
        αν ΒΑΘ[κ,τ] > Β[κ,τ-1] τότε
           αντιμετάθεσε ΒΑΘ[κ,τ], ΒΑΘ[κ,τ-1]
        τέλος_αν
     τέλος_επανάληψης
   τέλος_επανάληψης
   αν ΒΑΘ[κ,1] > ΒΑΘ[κ,2] τότε
    πλ <-- πλ + 1
   τέλος_αν
τέλος_επανάληψης
εμφάνισε πλ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Αθανάσιος Πέρδος στις 28 Μαΐ 2015, 06:35:55 μμ
Θα μπορούσε να λυθεί και με μία επανάληψη. Άρα με την παραπάνω λογική και η ενδεικτική λύση του υπουργείου να μην πάρει όλα τα μόρια.
Το θέμα όπως πολύ σωστά επισημαίνεις   είναι ότι
Η παρακάτω λύση για τους βαθμολογητές που θα κάτσουν να ασχοληθούν και να καταλάβουν τι κάνει θα πάρει πλήρη μόρια.
Είναι εντελώς σωστή.
Δεν έχει σχέση το μέγεθος ούτε η πολυπλοκότητα. Δεν εξετάζονται οι μαθητές σε αυτά. Δεν ελέγχουμε βελτιστοποίηση.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Rathaniel στις 28 Μαΐ 2015, 09:09:58 μμ
Καταλαβαίνω την επίλυση χωρίς πίνακες για τα τρία πρώτα ερωτήματα.
Καιτην δίνω και παρακάτω :
Αλγόριθμος θέμαΔ_χάλια_μοριοδότηση
   προκρ<-0
   Για τρ από 1 μέχρι 45
       Διάβασε τ                                                          !ερ.Δ1
       Διάβασε β1,β2,β3,β4,β5,β6,β7
       βαθμ<- β1+β2+β3+β4+β5+β6+β7                     !ερ.Δ2
       Εμφάνισε βαθμ
       βπανω5<- β1>=5 ΚΑΙ β2>=5 β3>=5 ΚΑΙ β4>=5 β5>=5 ΚΑΙ β6>=5 ΚΑΙ β7>=5         ! ουφ. ερ.Δ3
       Αν βπανω5=αληθής και βαθμ>50 τότε
             προκρ<-προκρ + 1
             Εμφάνισε "Το  ",τ, "προκρίθηκε"
       Τέλος_αν
       ...............
       .............
   Τέλος_επανάληψης
    Αν προκρ=0 τότε
          Εμφάνισε "Δεν προκρίθηκε κανένα (κριτές τσεκούρια)."
    Τέλος_αν

Ειλικρινά γράψτε εδώ πως θα λυθεί το Δ4 χωρίς κανένα πίνακα
Τίτλος: Απ: Θέμα Δ
Αποστολή από: theoL στις 28 Μαΐ 2015, 09:12:38 μμ
Αν δεν κάνω λάθος στο βιβλίο αναφέρεται ότι θα πρέπει να δημιουργούμε το βέλτιστο δυνατών πρόγραμμα, ότι η χρήση της μίας ή της άλλης δομής εξαρτάτε από την εργασία την οποία έχουμε να κάνουμε, άρα θα έπρεπε να εξετάζεται και το ενδεχόμενο της πολυπλοκότητας ή του μεγέθους. Γιατί μπορώ να πάω και στην Αμερική μέσω Αυστραλίας.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: michaeljohn στις 28 Μαΐ 2015, 09:13:31 μμ
Ποια είναι η καλύτερη λύση ;
Όλες εφόσον δίνουν σωστό επιστημονικά αποτέλεσμα είναι σωστές και θα πρέπει να βαθμολογηθούν τουλάχιστον με το 80% της αξίας σε βαθμούς της ερώτησης.
Η καλύτερη θα πρέπει να έχει κάποια κριτήρια. Και ένα από αυτά είναι το μέγεθος του προγράμματος….! Και η πολυπλοκότητα
 8)

Ξέρουμε άραγε την βέλτιστη ενός προβλήματος που θα πάρει το άριστα ;....
Τίτλος: Απ: Θέμα Δ
Αποστολή από: theoL στις 28 Μαΐ 2015, 09:20:19 μμ
Μπορούμε να την βρούμε ΜΟΝΟ όταν το πρόβλημα είναι σωστά διατυπωμένο.
Μπορούμε όμως να καταλήξουμε μέσω μιας ομάδας ανθρώπων «επιστημόνων» ότι αυτή ή λύση είναι πολύ κοντά στα ζητούμενα. Π.χ. εάν η λύση μπορεί πρέπει να έχει πίνακες για να ικανοποιήσει το βέλτιστο τότε ναι είναι αποδεκτό και φυσικά το άλλο με 7 ή 8 μεταβλητές δεν είναι. Αλλά είναι επιστημονικά ορθό και πρέπει να βαθμολογηθεί.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Αθανάσιος Πέρδος στις 28 Μαΐ 2015, 09:37:00 μμ
Αν δεν κάνω λάθος στο βιβλίο αναφέρεται ότι θα πρέπει να δημιουργούμε το βέλτιστο δυνατών πρόγραμμα, ότι η χρήση της μίας ή της άλλης δομής εξαρτάτε από την εργασία την οποία έχουμε να κάνουμε, άρα θα έπρεπε να εξετάζεται και το ενδεχόμενο της πολυπλοκότητας ή του μεγέθους. Γιατί μπορώ να πάω και στην Αμερική μέσω Αυστραλίας.

Συγγνώμη και πάλι αλλά απάντησα και στο νήμα του γενικού σχολιασμού. Ας συνεχίσουμε τη συζήτηση μόνο σε αυτό το νήμα.

Που ακριβώς το λέει αυτό; Υπενθυμίζω ότι το 5ο κεφάλαιο είναι εκτός ύλης.

Τώρα για το παράδειγμα που αναφέρεις αν σε ενδιαφέρει το κόστος και όχι ο χρόνος μπορεί η διαδρομή Ελλάδα - Αυστραλία - Αμερική να είναι η βέλτιστη λύση αν τα αεροπορικά εισητήρια είναι πιο φτηνά από μία απευθείας διαδρομή Ελλάδα - Αμερική αλλά νομίζω ότι δεν είναι αυτό το θέμα μας.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: itt στις 28 Μαΐ 2015, 10:18:56 μμ
Αν δεν κάνω λάθος στο βιβλίο αναφέρεται ότι θα πρέπει να δημιουργούμε το βέλτιστο δυνατών πρόγραμμα, ότι η χρήση της μίας ή της άλλης δομής εξαρτάτε από την εργασία την οποία έχουμε να κάνουμε, άρα θα έπρεπε να εξετάζεται και το ενδεχόμενο της πολυπλοκότητας ή του μεγέθους. Γιατί μπορώ να πάω και στην Αμερική μέσω Αυστραλίας.

To βέλτιστο πρόγραμμα δεν μπορείς να το δημιουργήσεις, εννοείς να χρησιμοποιήσεις τον βέλτιστο αλγόρθμο για κάποια λειτουργία. Κάτι που είναι εκτός ύλης και φιλοσοφίας του μαθήματος.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: evry στις 28 Μαΐ 2015, 10:30:35 μμ
Γίνεται, αλλά θα γράφεις για πολλές σελίδες
Το έκανε μαθητής στα προφορικά και μας πήρε ώρα να σιγουρευτούμε ότι ήταν σωστό αλλά ... ήταν.
Τον ρώτησα που είδε κάτι τέτοιο και αν έχει υπόψη του κάποια λύση με πίνακες (αφού είχε δώσει το γραπτό του)
και μας είπε πως δεν είχε καμία βοήθεια από κανέναν γιατί δεν πήγαινε φροντιστήριο και στο σχολείο ο καθηγητής ήταν και υποδιευθυντής και τους έκανε σπάνια μάθημα. Μάλιστα το παιδί δεν ήξερε να διαβάσει έναν πίνακα δυο διαστάσεων!!!
Τι να πεις, απλά respect
Ειλικρινά γράψτε εδώ πως θα λυθεί το Δ4 χωρίς κανένα πίνακα

Λοιπόν πως το έκανε τώρα
Δες λίγο τη λύση που δίνω εδώ
https://alkisg.mysch.gr/steki/index.php?topic=6248.msg72589#msg72589 (https://alkisg.mysch.gr/steki/index.php?topic=6248.msg72589#msg72589)
και σκέψου πως θα ήταν αν αντικαταστήσεις τους δυο μικρούς μονοδιάστατους που έχω με εφτά μεταβλητές μέγιστο1, μέγιστο2, ... φορές1, φορές2 κλπ
Ουσιαστικά αντί για πίνακα χρησιμοποιείς 7 μεταβλητές, αντί να γράφεις φορές[1] γράφεις φορές1.
Απλά θα τρελαθείς στα Αν, θες 7 Αν, για κάθε περίπτωση μέσα και έξω από την επανάληψη, δηλαδή αν τα θυμάμαι καλά 7x4 = 28 Αν...τότε
Ελπίζω να μην θες να το γράψω γιατί δεν έχω τόσο χρόνο ούτε υπομονή ;)

Επίσης συνάδελφοι
Η συζήτηση για βελτιστοποίηση έχει ενδιαφέρον αλλά είναι άσχετη με το thread, με το μάθημα και με τα θέματα.
Παρακαλώ πολύ φτιάξτε ένα άλλο thread και μιλήστε για βελτιστοποίηση, εδώ μπαίνουν μαθητές και βαθμολογητές να ενημερωθούν για τα θέματα και το μόνο που προσφέρει αυτή η συζήτηση είναι να αποπροσανατολίζει.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Rathaniel στις 28 Μαΐ 2015, 11:04:53 μμ
Η λύση χωρίς πίνακες μέχρι και το Δ3 δεν πρέπει να χάσει πάντως μόρια.

Τώρα ένα κουφό που μου είπε ένας μαθητής ήταν ότι επαιξε μπάλα χωρίς πίνακες, αλλά μετα το συνέχισε θεωρώντας ότι ο μέγιστος βαθμός ειναι σώνει και καλά το 10.
Απο το Δ4 πόσο θα χάσει αυτό το παιδί?
Όλο ? 5 μόρια ? 2 και μισό να το αφήσω?

Εγώ του είπα ότι θα πάρει ένα μόριο απο το Δ4, ίσα για την Εμφάνισε και τις αρχικοποιήσεις. Και του χάλασα το πάρτυ :(
Τίτλος: Απ: Θέμα Δ
Αποστολή από: evry στις 28 Μαΐ 2015, 11:14:03 μμ
Γιατί η λύση χωρίς πίνακες να χάσει μόρια?
Αν είναι σωστή θα πρέπει να πάρει και παραπάνω, όχι να χάσει
Η λύση χωρίς πίνακες μέχρι και το Δ3 δεν πρέπει να χάσει πάντως μόρια.

Για τον μαθητή σου που είπες λογικά θα πάρει παραπάνω, αλλά αυτό εξαρτάται από την εικόνα του γραπτού και από το τι ακριβώς έχει κάνει.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: alpapanto στις 28 Μαΐ 2015, 11:24:31 μμ
Ως προς την εκφώνηση και τα νούμερά της...
τι σόι διαγωνισμός ειναι αυτός που 6 κριτές δίνουν 7άρια, ένας δίνει 8άρι(50 στο σύνολο) και το τραγούδι μένει απ έξω;;;😈😈
ας την κάνανε 10μελή ρε παιδάκι μου...
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Καρκαμάνης Γεώργιος στις 29 Μαΐ 2015, 12:18:13 πμ
Όσοι μπόρεσαν και απάντησαν ορισμένα ερωτήματα από το Δ θέμα, χωρίς χρήση πινάκων εννοείται πως δεν πρέπει να κοπούν μόρια.
Εξάλλου ούτε η εκφώνηση του θέματος έλεγε για χρήση πινάκων!!!
Τίτλος: Απ: Θέμα Δ
Αποστολή από: netnick στις 29 Μαΐ 2015, 12:49:29 πμ
Θεωρώ ότι η λύση χωρίς πίνακα δεν είναι ούτε πολύπλοκη ούτε μακροσκελής (δύσκολή ίσως είναι), και νομίζω λοιπόν ότι πρέπει να αναφερθεί:
Κώδικας: [Επιλογή]
Αλγόριθμος ΘεμαΔ
 κριτές ← 0
 προκρ ← 0
 Για ι από 1 μέχρι 45
   Διάβασε τιτλο
   πλ5 ← 0
   αθρ ← 0
   μαχ ← -1        ! για Δ4 ερώτημα
   πλ ← 0          ! για Δ4 ερώτημα
   Για j από 1 μέχρι 7
     Διάβασε βαθ
     αθρ ← αθρ + βαθ
     Αν βαθ > 5 τότε
       πλ5 ← πλ5 + 1
     Τέλος_αν
     ! η Αν που ακολουθεί είναι για το Δ4,
     ! υπολογίζω το μέγιστο βαθμό απο τους 7
     ! και πόσες φορές εμφανίστηκε
     Αν βαθ > μαχ τότε
       μαχ ← βαθ
       πλ ← 1
     αλλιώς_αν βαθ = μαχ τότε
       πλ ← πλ + 1
     Τέλος_αν
   Τέλος_επανάληψης
   ! για να ολοκληρωθει το Δ4 λοιπόν οι επόμενες 3 γραμμές
   Αν πλ = 1 τότε
     κριτές ← κριτές + 1
   Τέλος_αν
   Εμφάνισε αθρ
   Αν αθρ > 50 και πλ5 = 7 τότε
     Εμφάνισε τιτλο
     προκρ ← προκρ + 1
   Τέλος_αν
 Τέλος_επανάληψης
 
 Αν προκρ = 0 τότε
   Εμφάνισε "Κανένα τραγούδι δεν προκρίνεται."
 Τέλος_αν
 
 Εμφάνισε κριτές        !απάντηση στο Δ4
 Τέλος
Η λύση που αναφέρει ο gkatsion είναι καλή.
Θα μπορούσε επίσης να γίνει και με εύρεση δύο μεγίστων (στο τετράδιο του μαθητή αναφέρεται αλγόριθμος εύρεσης 2 ελαχίστων τιμών) - και με πίνακες και χωρίς-  και στη συνέχεια να συγκριθούν για να ελεγχθει εάν οι δύο τιμές είναι ίσες η όχι.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: evry στις 29 Μαΐ 2015, 12:53:43 πμ
Η λύση σου δεν είναι σωστή,
πρέπει να υπολογίσεις τη μέγιστη βαθμολογία ενός κριτή για τα 45 τραγούδια, ενώ εσύ υπολογίζεις τη μέγιστη που λαμβάνει κάθε τραγούδι από τους 7 κριτές.
Αυτή είναι η δυσκολία, ότι πρέπει να υλοποιήσεις δυο διαφορετικές επεξεργασίες στον "πίνακα" μια κατά γραμμές και μια κατά στήλες χωρίς πίνακα  :o.
Για να καταλάβεις το λάθος σου σκέψου ότι η μεταβλητή κριτές μπορεί να πάρει τιμή μεγαλύτερη του 7, 45 στην χειρότερη περίπτωση, στον δικό σου κώδικα

Θεωρώ ότι η λύση χωρίς πίνακα δεν είναι ούτε πολύπλοκη ούτε μακροσκελής (δύσκολή ίσως είναι), και νομίζω λοιπόν ότι πρέπει να αναφερθεί:
Κώδικας: [Επιλογή]
Αλγόριθμος ΘεμαΔ
 κριτές ← 0
 προκρ ← 0
 Για ι από 1 μέχρι 45
   Διάβασε τιτλο
   πλ5 ← 0
   αθρ ← 0
   μαχ ← -1        ! για Δ4 ερώτημα
   πλ ← 0          ! για Δ4 ερώτημα
   Για j από 1 μέχρι 7
     Διάβασε βαθ
     αθρ ← αθρ + βαθ
     Αν βαθ > 5 τότε
       πλ5 ← πλ5 + 1
     Τέλος_αν
     ! η Αν που ακολουθεί είναι για το Δ4,
     ! υπολογίζω το μέγιστο βαθμό απο τους 7
     ! και πόσες φορές εμφανίστηκε
     Αν βαθ > μαχ τότε
       μαχ ← βαθ
       πλ ← 1
     αλλιώς_αν βαθ = μαχ τότε
       πλ ← πλ + 1
     Τέλος_αν
   Τέλος_επανάληψης
   ! για να ολοκληρωθει το Δ4 λοιπόν οι επόμενες 3 γραμμές
   Αν πλ = 1 τότε
     κριτές ← κριτές + 1
   Τέλος_αν
   Εμφάνισε αθρ
   Αν αθρ > 50 και πλ5 = 7 τότε
     Εμφάνισε τιτλο
     προκρ ← προκρ + 1
   Τέλος_αν
 Τέλος_επανάληψης
 
 Αν προκρ = 0 τότε
   Εμφάνισε "Κανένα τραγούδι δεν προκρίνεται."
 Τέλος_αν
 
!απάντηση στο Δ4
 Εμφάνισε κριτές
 Τέλος
Τίτλος: Απ: Θέμα Δ
Αποστολή από: netnick στις 29 Μαΐ 2015, 01:00:25 πμ
Ναι :-( , οκ
Τίτλος: Λύση χωρίς χρήση πίνακα από μαθητή
Αποστολή από: kkkerm στις 29 Μαΐ 2015, 11:13:10 πμ
Κάποιοι από εμάς που ασχολούμαστε χρόνια με  τον προγραμματισμό θα λέγαμε ότι όλα τα ερωτήματα ήταν κατανοητά. Για να καταλάβουμε το πρόβλημα που δημιουργούμε με τις διατυπώσεις των ασκήσεών μας θα πρέπει να θυμόμαστε συνέχεια ότι απευθυνόμαστε σε παιδιά και όχι σε συναδέλφους καθηγητές πληροφορικής.

…. Άραγε για τα παιδιά (γνωρίζω ένα από αυτά ) που έλυσαν το θέμα χωρίς πίνακες υπάρχει κάποιο ιδιαίτερο βραβείο…

Χωρίς διάθεση να προσβάλω κανέναν ας προσπαθήσουμε να δώσουμε στο μάθημά μας τη θέση που του αξίζει.
(έγινε διόρθωση ΑΝ Β>=5 ΤΟΤΕ Μετρ_β<-Μετρ_β+1)

Κ&Κ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: evry στις 30 Μαΐ 2015, 02:09:31 πμ
Μπα μην στεναχωριέσαι
και στον ΟΕΦΕ το συγκεκριμένο θέμα το έχουν λύσει λάθος
http://www.oefe.gr/panellinies/liseis_plir_kat_c_hmer_no_150527.pdf (http://www.oefe.gr/panellinies/liseis_plir_kat_c_hmer_no_150527.pdf)
Βρίσκουν για κάθε τράγουδι τη μέγιστη βαθμολογία

Πιο πριν είχαν λάθος και την μετατροπή στο θέμα Β
http://www.iefimerida.gr/sites/default/files/apantiseis_aepp_teliko.pdf (http://www.iefimerida.gr/sites/default/files/apantiseis_aepp_teliko.pdf)

Ναι :-( , οκ
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Γιάννης Αναγνωστάκης στις 30 Μαΐ 2015, 10:41:12 πμ
http://www.alfavita.gr/arthron/%CE%BC%CE%B5%CE%B3%CE%AC%CE%BB%CE%BF%CF%82-%CE%BC%CE%B5%CE%B3%CE%B1%CE%BB%CF%8D%CF%84%CE%B5%CF%81%CE%BF%CF%82-%CE%BC%CE%AD%CE%B3%CE%B9%CF%83%CF%84%CE%BF%CF%82-%CE%B1%CE%B5%CF%80%CF%80-2015-%CF%84%CE%BF%CF%85-%CE%BC%CE%B1%CE%B8%CE%B7%CF%84%CE%AE-%CF%80%CE%B1%CE%BD%CE%B1%CE%B3%CE%B9%CF%8E%CF%84%CE%B7-%CE%BA%CE%B1%CF%81%CE%B1%CE%BF%CF%85%CE%BB%CE%AC%CE%BD%CE%B7

θεωρώ σημαντικό σε τέτοια άρθρα να απαντάμε, αφού πρόκειται για απορία-ένσταση μαθητή

Εγώ προσπάθησα να απαντήσω απλά (βλέπε σχόλια). Αν νομίζει ότι κάποιος συνάδελφος μπορεί να προσθέσει κάτι...

Τίτλος: Απ: Θέμα Δ
Αποστολή από: VAIOS στις 30 Μαΐ 2015, 07:50:45 μμ
Πόσα μόρια χάνει ο μαθητής αν θεωρεί ως μέγιστο το 10;
Τίτλος: Απ: Θέμα Δ
Αποστολή από: michaeljohn στις 30 Μαΐ 2015, 08:03:12 μμ
3 μόρια...
Τίτλος: Απ: Θέμα Δ
Αποστολή από: evry στις 31 Μαΐ 2015, 12:01:11 πμ
Ένας μαθητής έγραψε σήμερα το εξής στο θέμα Δ3. Μεταφέρω μόνο το τμήμα που έχει ενδιαφέρον

Κώδικας: Pascal
  1.  
  2. πέρασε <-- Σ[i]>50
  3. Για j από 1 μέχρι 7
  4.     πέρασε <-- πέρασε και ( B[i,j] >= 5)
  5. ΤΕ
  6. Αν πέρασε Τότε ....
  7.  

χωρίς λόγια  :o
Τίτλος: Απ: Θέμα Δ
Αποστολή από: michaeljohn στις 31 Μαΐ 2015, 12:09:28 πμ
Ένας μαθητής έγραψε σήμερα το εξής στο θέμα Δ3. Μεταφέρω μόνο το τμήμα που έχει ενδιαφέρον

Κώδικας: Pascal
  1.  
  2. πέρασε <-- Σ[i]>50
  3. Για j από 1 μέχρι 7
  4.     πέρασε <-- πέρασε και ( B[i,j] >= 5)
  5. ΤΕ
  6. Αν πέρασε Τότε ....
  7.  

χωρίς λόγια  :o

!!!!
Όλα τα λεφτά ( με λόγια )
Τίτλος: Απ: Θέμα Δ
Αποστολή από: petrosp13 στις 31 Μαΐ 2015, 01:00:44 πμ
Απλά εξαιρετικό
Ουσιαστικά απλοποιείς όλα τα προβλήματα Απόφασης χωρίς την χρήση δομής επιλογής
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Λαμπράκης Μανώλης στις 05 Ιουν 2015, 10:01:16 πμ
Καλημέρα

ήθελα να ρωτήσω το εξής: ένας μαθητής μου στο Δ4 κατάλαβε ότι η έκφραση "το μεγαλύτερο βαθμό σε ένα τραγούδι" αντιστοιχεί σε αναζήτηση...δηλαδή έκανε αναζήτηση, βρήκε σε ποια γραμμή βρίσκεται στο τραγούδι, βρήκε το μέγιστο κάθε κριτή και έλεγξε αν είναι πόσα μέγιστα έχουμε (έτσι μου το περιέγραψε) ... θα πάρει κάποια μόρια θεωρείτε ?? πολύ κρίμα για τον συγκεκριμένο, πολύ καλό παιδί και άριστος μαθητής, όλα τα άλλα μάλλον τα έχει σωστά ..
Τίτλος: Απ: Θέμα Δ
Αποστολή από: michaeljohn στις 05 Ιουν 2015, 02:04:06 μμ
Καλημέρα

ήθελα να ρωτήσω το εξής: ένας μαθητής μου στο Δ4 κατάλαβε ότι η έκφραση "το μεγαλύτερο βαθμό σε ένα τραγούδι" αντιστοιχεί σε αναζήτηση...δηλαδή έκανε αναζήτηση, βρήκε σε ποια γραμμή βρίσκεται στο τραγούδι, βρήκε το μέγιστο κάθε κριτή και έλεγξε αν είναι πόσα μέγιστα έχουμε (έτσι μου το περιέγραψε) ... θα πάρει κάποια μόρια θεωρείτε ?? πολύ κρίμα για τον συγκεκριμένο, πολύ καλό παιδί και άριστος μαθητής, όλα τα άλλα μάλλον τα έχει σωστά ..

Αρκετά από τα 9 μόρια.. τουλάχιστον 3 από το γεγονός ότι βρίσκει το μέγιστο κάθε κριτή... από κει και πέρα πρέπει να ξέρουμε ακριβώς αυτό που έκανε γιατί στην παραπάνω περιγραφή η κατάσταση είναι μπερδεμένη
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Λαμπράκης Μανώλης στις 05 Ιουν 2015, 02:09:23 μμ
ευχαριστώ για την απάντηση συνάδελφε....ναι όντως μπέρδεψε την αναζήτηση και δεν ξέρουμε πως ακριβώς θα βαθμολογηθεί ... και εγώ τώρα περιγράδω στο περίπου αυτα που μου είπε .... ωραία τουλάχιστον να πάρει κάποια γιατι είναι κρίμα
Τίτλος: Απ: Θέμα Δ
Αποστολή από: michaeljohn στις 12 Ιουν 2015, 07:04:12 μμ
Συνάδελφοι, κατά την  βαθμολόγηση  μου έκανε φοβερή εντύπωση μια «λανθασμένη» λύση που συνάντησα και αφορά το ερώτημα Δ4. Την παραθέτω και ζητάω την γνώμη σας για το πόσο πρέπει να βαθμολογηθεί με άριστα το 9.

!
Για j από 1 μέχρι 7
   MaxB[j] <-- B[1, j]
   Για i από 2 μέχρι 45
      Αν  B[i, j] >  MaxB[j] τότε
         MaxB[j] <--  B[i, j] 
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
!
Max <--   0
Για i από 1 μέχρι 45
   k <-- 0
   Για j από 1 μέχρι 7
      Αν  B[i, j] =  MaxB[j] τότε
          k <-- k + 1
      Τέλος_αν
   Τέλος_επανάληψης
   Αν  k > Max  τότε
      Max <-- k
   Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ‘πλήθος κριτών :’ , Max
!
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Dimi97 στις 13 Ιουν 2015, 02:26:50 μμ
Συνάδελφοι, κατά την  βαθμολόγηση  μου έκανε φοβερή εντύπωση μια «λανθασμένη» λύση που συνάντησα και αφορά το ερώτημα Δ4. Την παραθέτω και ζητάω την γνώμη σας για το πόσο πρέπει να βαθμολογηθεί με άριστα το 9.

!
Για j από 1 μέχρι 7
   MaxB[j] <-- B[1, j]
   Για i από 2 μέχρι 45
      Αν  B[i, j] >  MaxB[j] τότε
         MaxB[j] <--  B[i, j] 
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
!
Max <--   0
Για i από 1 μέχρι 45
   k <-- 0
   Για j από 1 μέχρι 7
      Αν  B[i, j] =  MaxB[j] τότε
          k <-- k + 1
      Τέλος_αν
   Τέλος_επανάληψης
   Αν  k > Max  τότε
      Max <-- k
   Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ‘πλήθος κριτών :’ , Max
!

το πρόβλημα ειναι στο τέλος μόνο,που πρέπει να γίνει

ΑΝ κ=1 τότε
Μax<--Max+1

σωστά?
Τίτλος: Απ: Θέμα Δ
Αποστολή από: michaeljohn στις 16 Ιουν 2015, 06:33:02 μμ
το πρόβλημα ειναι στο τέλος μόνο,που πρέπει να γίνει

ΑΝ κ=1 τότε
Μax<--Max+1

σωστά?

Όχι..Τότε θα έβρισκε το πλήθος των τραγουδιών στα οποία ένας μόνο κριτής έδωσε τον μέγιστο βαθμό του.
Η λύση που παρέθεσα απαντά στην εξής εκφώνηση :
Να βρίσκει και να εμφανίζει το μεγαλύτερο  πλήθος κριτών που σε ένα τραγούδι έδωσαν τον μέγιστο βαθμό τους.
Ενώ η εκφώνηση του Δ4 ήταν :
Να βρίσκει και να εμφανίζει το πλήθος των κριτών που έδωσαν τον μέγιστο βαθμό τους σε ένα μόνο τραγούδι.
Τίτλος: Απ: Θέμα Δ
Αποστολή από: Dimi97 στις 16 Ιουν 2015, 09:14:58 μμ
Όχι..Τότε θα έβρισκε το πλήθος των τραγουδιών στα οποία ένας μόνο κριτής έδωσε τον μέγιστο βαθμό του.
Η λύση που παρέθεσα απαντά στην εξής εκφώνηση :
Να βρίσκει και να εμφανίζει το μεγαλύτερο  πλήθος κριτών που σε ένα τραγούδι έδωσαν τον μέγιστο βαθμό τους.
Ενώ η εκφώνηση του Δ4 ήταν :
Να βρίσκει και να εμφανίζει το πλήθος των κριτών που έδωσαν τον μέγιστο βαθμό τους σε ένα μόνο τραγούδι.

ααα καταλαβα ευχαριστώ...οπότε στα τελευταια για πρεπει το 45 και το 7 να αντιστραφούνε...