Αποστολέας Θέμα: Θέμα Δ  (Αναγνώστηκε 8508 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2457
  • I 'm not young enough to know everything
Θέμα Δ
« στις: 27 Μάι 2015, 10:21:47 πμ »
Εδώ σχολιάζουμε το θέμα Δ

mantzu

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα Δ
« Απάντηση #1 στις: 27 Μάι 2015, 11:29:03 πμ »
Η προσεγγιση μπορει να γινει με πινακες φανταζομαι και ας μην αναφερει την χρηση τους? διοτι με χρηση γινεται αρκετα ευκολη η επιλυση

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 78
Απ: Θέμα Δ
« Απάντηση #2 στις: 27 Μάι 2015, 11:30:55 πμ »
Λυνεται χωρις πινακες;

dihatzou

  • Θαμώνας
  • ***
  • Μηνύματα: 26
Απ: Θέμα Δ
« Απάντηση #3 στις: 27 Μάι 2015, 12:02:28 μμ »
Στο Δ4 ο μέγιστος βαθμός που έδωσε ο κάθε κριτής είναι
α) το 10;
β) ο max των βαθμών που έχει βάλει ο κριτής, όχι απαραίτητα το 10;

nightchild

  • Νέος
  • *
  • Μηνύματα: 7
Απ: Θέμα Δ
« Απάντηση #4 στις: 27 Μάι 2015, 12:05:02 μμ »
 το β

progmat

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: Θέμα Δ
« Απάντηση #5 στις: 27 Μάι 2015, 12:27:24 μμ »
Καμιά ιδέα για το Δ4;

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 80
Απ: Θέμα Δ
« Απάντηση #6 στις: 27 Μάι 2015, 12:33:48 μμ »
Αν έχεις δίστηλο με 7 γραμμές (κριτές) και 45 στήλες (τραγούδια), κάνεις ανά γραμμή αναζήτηση μεγίστου και στη συνέχεια αναζήτηση πλήθους μεγίστου. Για κάθε αποτέλεσμα πλήθους 1, αυξάνεις το μετρητή των κριτών που έδωσαν μόνο ένα μέγιστο κατά ένα.
Σωκράτης

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: Θέμα Δ
« Απάντηση #7 στις: 27 Μάι 2015, 12:44:01 μμ »
Mία λύση:

πλ_κρ←0
Για j από 1 μέχρι 7
   max←BΑΘ [1, j]
   Για i από 2 μέχρι 45
      Αν ΒΑΘ [i,j]>max τοτε max←BΑΘ [i, j]
   Tέλος_επανάληψης
   πλ←0
   Για i από 1 μέχρι 45
      Αν ΒΑΘ [i,j]=max τοτε πλ←πλ+1
   Tέλος_επανάληψης
   Αν πλ=1 τότε πλ_κρ←πλ_κρ+1
Τέλος_επανάληψης
Εμφάνισε πλ_κρ

progmat

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: Θέμα Δ
« Απάντηση #8 στις: 27 Μάι 2015, 12:47:58 μμ »
Kαι το Δ λοιπόν...

Κώδικας: [Επιλογή]
Αλγόριθμος ΘΕΜΑ_Δ
ΠΛ ← 0
ΠΛΚΡ ← 0

Για Ι από 1 μέχρι 7
  ΜΑΧ[Ι] ← 0
Τέλος_επανάληψης

Για Ι από 1 μέχρι 45
  ΣΥΝΒ ← 0
  Φ ← Αληθής
  Διάβασε ΤΙΤΛΟΣ
  Για Κ από 1 μέχρι 7
    Διάβασε ΒΑΘΜΟΣ[Ι, Κ]
    Αν ΒΑΘΜΟΣ[Ι, Κ] < 5 τότε
      Φ ← Ψευδής
    Τέλος_αν
    ΣΥΝΒ ← ΣΥΝΒ + ΒΑΘΜΟΣ[Ι, Κ]
  Τέλος_επανάληψης

  Εμφάνισε ΣΥΝΒ

  Αν ΣΥΝΒ > 50 και Φ = Αληθής τότε
    ΠΛ ← ΠΛ + 1
    Εμφάνισε ΤΙΤΛΟΣ, "ΠΕΡΝΑΕΙ ΣΤΗ ΔΕΥΤΕΡΗ ΦΑΣΗ"
  Τέλος_αν
Τέλος_επανάληψης

Αν ΠΛ = 0 τότε
  Εμφάνισε "ΔΕΝ ΥΠΑΡΧΕΙ ΤΡΑΓΟΥΔΙ ΣΤΗ ΔΕΥΤΕΡΗ ΦΑΣΗ"
Τέλος_αν

Για Κ από 1 μέχρι 7
  ΜΑΧ[Κ] ← ΒΑΘΜΟΣ[1, Κ]
  Για Ι από 1 μέχρι 45
    Αν ΒΑΘΜΟΣ[Ι, Κ] > ΜΑΧ[Κ] τότε
      ΜΑΧ[Κ] ← ΒΑΘΜΟΣ[Ι, Κ]
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

Για Κ από 1 μέχρι 7
  ΠΛΜΑΧ ← 0
  Για Ι από 1 μέχρι 45
    Αν ΒΑΘΜΟΣ[Ι, Κ] = ΜΑΧ[Κ] τότε
      ΠΛΜΑΧ ← ΠΛΜΑΧ + 1
    Τέλος_αν
  Τέλος_επανάληψης
  Αν ΠΛΜΑΧ = 1 τότε
    ΠΛΚΡ ← ΠΛΚΡ + 1
  Τέλος_αν
Τέλος_επανάληψης

Εμφάνισε ΠΛΚΡ
Τέλος ΘΕΜΑ_Δ
« Τελευταία τροποποίηση: 27 Μάι 2015, 04:38:26 μμ από progmat »

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέμα Δ
« Απάντηση #9 στις: 27 Μάι 2015, 12:55:58 μμ »
Και μια εναλλακτική για το Δ4.

πλ <- 0
Για κρ από 1 μέχρι 7
  μεγ <- Β[1,κρ]
  π <- 1
  Για τρ από 2 μέχρι 45
      Αν Β[τρ,κρ] > μεγ τότε
           μεγ <- Β[τρ,κρ]
           π <- 1
      αλλιώς_αν Β[τρ,κρ]=μεγ τότε
           π <- π+1
       Τέλος_αν
  Τέλος_επανάληψης
  Αν π=1 τότε πλ <- πλ+1
Τέλος_επανάληψης
Εμφάνισε πλ

Πυρόβολος Ανδρέας

Loco-3

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Θέμα Δ
« Απάντηση #10 στις: 27 Μάι 2015, 01:05:53 μμ »
εύκολο για θέμα Δ δυστυχώς..
υπάρχει περίπτωση να μας κόψουν επειδή το κάναμε με πίνακες;;

themata

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Δ
« Απάντηση #11 στις: 27 Μάι 2015, 01:08:39 μμ »
 
εύκολο για θέμα Δ δυστυχώς..
υπάρχει περίπτωση να μας κόψουν επειδή το κάναμε με πίνακες;;
μα το θέμα λύνεται με πίνακες

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 80
Απ: Θέμα Δ
« Απάντηση #12 στις: 27 Μάι 2015, 01:12:50 μμ »
Μα λύνεται χωρίς πίνακες;
Σωκράτης

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: Θέμα Δ
« Απάντηση #13 στις: 27 Μάι 2015, 01:13:12 μμ »
Και μια εναλλακτική για το Δ4.

πλ <- 0
Για κρ από 1 μέχρι 7
  μεγ <- Β[1,κρ]
  π <- 1
  Για τρ από 2 μέχρι 45
      Αν Β[τρ,κρ] > μεγ τότε
           μεγ <- Β[τρ,κρ]
           π <- 1
      αλλιώς_αν Β[τρ,κρ]=μεγ τότε
           π <- π+1
       Τέλος_αν
  Τέλος_επανάληψης
  Αν π=1 τότε πλ <- πλ+1
Τέλος_επανάληψης
Εμφάνισε πλ

Πυρόβολος Ανδρέας

Στο ίδιο σκεπτικό με το περσινο Γ. επίσης μαθητριά μου τα πλήθη των max τα τοποθετούσε σε πίνακα κ μετα μετρούσε τα "1" του πίνακα

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 80
Απ: Θέμα Δ
« Απάντηση #14 στις: 27 Μάι 2015, 01:18:25 μμ »
Τρελός κόπος χωρίς πίνακες
Σωκράτης