Αποστολέας Θέμα: Επαναληπτικές  (Αναγνώστηκε 13327 φορές)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Επαναληπτικές
« στις: 09 Ιούν 2011, 09:59:33 πμ »
Όσοι .. μείναμε, ας τα "πούμε" εδώ, σχετικά με τα θέματα των επαναληπτικών :)
(όποιος τα βρει πρώτος ας .. το πει ;) )
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #1 στις: 09 Ιούν 2011, 10:32:45 πμ »
δεν τα έχουν βάλει ακόμη

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #2 στις: 09 Ιούν 2011, 11:19:58 πμ »
μήπως δεν υπάρχουν

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Επαναληπτικές
« Απάντηση #3 στις: 09 Ιούν 2011, 11:27:18 πμ »
Για όλα τα υπόλοιπα μαθήματα τα έχουν βάλει όμως..
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #4 στις: 09 Ιούν 2011, 11:31:08 πμ »
Παιδιά νομίζω ότι γράφουν το απόγευμα στις 17:00
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Επαναληπτικές
« Απάντηση #5 στις: 09 Ιούν 2011, 11:36:07 πμ »
Ναι ρε σύ.. Έτσι πρέπει να είναι.. Μόλις διάβασα σις ΟΔΗΓΙΕΣ (για τους εξεταζομένους) των χθεσινών θεμάτων της Φυσικής:

Χρόνος δυνατής αποχώρησης: 18:15
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #6 στις: 09 Ιούν 2011, 11:37:32 πμ »
μήπως αυτά τα ανεβάζουν στις 12:00 και όχι στις 9:30

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #7 στις: 09 Ιούν 2011, 11:40:01 πμ »
Παναγιώτη, δίνουν στις 17:00, μαζί εσπερινά και γενικά. Μάλλον επειδή έγινε σούσουρο στις κανονικές εξετάσεις, είπαν να το μοιράσουν!  :)
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Επαναληπτικές
« Απάντηση #8 στις: 09 Ιούν 2011, 11:40:21 πμ »
Εάν έχουν δυνατή αποχώρηση στις 18:15, μάλλον κατά τις 18:00 να τα περιμένουμε ..
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #9 στις: 09 Ιούν 2011, 11:40:47 πμ »
ΧΑΧΑ, νομίζω το είχα δει, αλλά ... γερνάω

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #10 στις: 09 Ιούν 2011, 11:50:48 πμ »
Αναρωτιέμαι τι στάση θα κρατήσουν οι θεματοδότες για το Γ και το Δ...
Πάντως τώρα που έχει δημιουργηθεί αυτή η κατάσταση με τους πίνακες, περιμένω με περισσότερο ενδιαφέρον τα θέματα...  :)  :)
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #11 στις: 09 Ιούν 2011, 11:51:43 πμ »
Άσκηση πολύπλοκη (ΘΕΜΑ Α), στη ... ΣΧΕ !!!

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #12 στις: 09 Ιούν 2011, 11:52:38 πμ »
Από δω και εμπρός ... Να γραφεί πρόγραμμα σε "ΓΛΩΣΣΑ" !!!

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 802
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Επαναληπτικές
« Απάντηση #13 στις: 09 Ιούν 2011, 11:54:49 πμ »
ΧΑΧΑ, νομίζω το είχα δει, αλλά ... γερνάω

.. αεί διδασκόμενος ;)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #14 στις: 09 Ιούν 2011, 12:26:36 μμ »
εκτός αν τα ξέρω ήδη όλα sergio

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Επαναληπτικές
« Απάντηση #15 στις: 09 Ιούν 2011, 01:22:09 μμ »
Πάντως γράφουν 22 ή 23 άτομα!  :P Και 5 από αυτούς δεν είχαν εξεταστεί σε σχεδόν κανένα μάθημα στις κανονικές..

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #16 στις: 09 Ιούν 2011, 06:19:23 μμ »
Μας ξεχάσανε νομίζω....
Γιατί δεν έχουν αναρτηθεί ακόμη?
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

alpapanto

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • ΗΟΜΕ μοναχομ
Απ: Επαναληπτικές
« Απάντηση #17 στις: 09 Ιούν 2011, 06:27:25 μμ »
τους ξεχασμενους???...

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/

alpapanto

  • Βετεράνος
  • ****
  • Μηνύματα: 88
  • ΗΟΜΕ μοναχομ
Απ: Επαναληπτικές
« Απάντηση #19 στις: 09 Ιούν 2011, 06:48:08 μμ »
επιτελους

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #20 στις: 09 Ιούν 2011, 07:07:04 μμ »
Να βάλουμε ένα χρονικό όριο μη σχολιασμού των θεμάτων και μη ανάρτησης λύσεων;

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #21 στις: 09 Ιούν 2011, 07:15:58 μμ »
Πρέπει μάλλον να περιμένουμε μέχρι τις 20:00.
Νομίζω πάντως ότι τέτοια θέματα περιμέναμε στις κανονικές, λαμβάνοντας υπ' όψη την αυξανόμενη δυσκολία κάθε χρόνο...
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #22 στις: 09 Ιούν 2011, 07:22:46 μμ »
Ας μη σχολιάσουμε   τα θέματα  ΠΡΙΝ τις 19.30.

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #23 στις: 09 Ιούν 2011, 07:37:12 μμ »
Θα ξεκινήσω ένα μικρό σχολιασμό (δε θα παραθέσω λύσεις, νομίζω πρέπει να περιμένουμε μισή ωρίτσα ακόμη).
Σε γενικές γραμμές μου άρεσαν τα θέματα.
Πιο συγκεκριμένα μου άρεσε το Α3 (πιο πολύ το β), το Α4 (πιο πολύ το 5ο), το Β θέμα (δεν υπάρχουν 20 εύκολες μονάδες όπως παλιά), το Γ θέμα (νομίζω από τα καλύτερά τους).
Το Δ τετριμμένο, εκτός από το Δ4 που είναι πολύ καλό.
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Επαναληπτικές
« Απάντηση #24 στις: 09 Ιούν 2011, 07:38:23 μμ »
Αυτό ήθελα να πω και εγώ.. το Δ4 πολύ καλό! Γενικά ωραία θέματα

soron80

  • Ομάδα διαγωνισμάτων 2011
  • *
  • Μηνύματα: 116
  • Back In Black
Απ: Επαναληπτικές
« Απάντηση #25 στις: 09 Ιούν 2011, 08:08:26 μμ »
κι εμένα με μια πρώτη ματιά μου αρέσουν
και το 3ο που αυξομειώνεται η ποσότητα στη δεξαμενή!!
και η συνθήκη(ες) τερματισμού που έχει
Τσισπαράς Βασίλης
Καθηγητής Πληροφορικής ΠΕ19

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #26 στις: 09 Ιούν 2011, 08:32:15 μμ »
Στα θετικά:

- Ωραία τα θέματα και αρκετά ισορροπημένα! Γενικά το επίπεδο δυσκολίας βρίσκεται στο σημείο που θα μου άρεσε...

- Ευτυχώς αυτή τη φορά δεν προσφέρονταν για αντιγραφή!

- Το θέμα Γ δείχνει πώς γίνεται να είναι αδύνατη η χρήση πίνακα! Από την άλλη, βέβαια, δεν ξέρω τι μπορεί να έχει σκεφτεί ο Παρασκευάς!

- Το Δ4 πολύ καλό!

Στα αρνητικά:

-



Τα θέματα του εσπερινού ήταν ίδια με του ημερησίου εκτός του Α4.5 και του Δ που ήταν πιο εύκολα...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #27 στις: 09 Ιούν 2011, 10:34:59 μμ »
όταν λέει τριετία στο θέμα Δ εννοεί συνεχόμενα χρόνια; δηλαδή είναι μόνο τα 2001, 2002, 2003 ή τα 2002, 2003, 2004 ή τα 2003, 2004, 2005
ή πρέπει να δούμε όλους τους συνδυασμούς τριάδων που υπάρχουν: π.χ. τα έτη 2001, 2004, 2005

ρωτάω γιατί δεν αναφέρεται στην εκφώνηση. οι μαθητές μπορεί να πάρουν όποια παραδοχή θέλουν;
(χώρος προβλήματος)

στο θέμα Γ μπορούμε να πάρουμε πίνακα 10.000x10 μιας και οι αντλίες μετράνε με ακρίβεια δέκατου την ποσότητα της βενζίνης που βάζουμε στο αμάξι;

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #28 στις: 09 Ιούν 2011, 11:43:16 μμ »
Λογικά όταν λέμε τριετία εννοούμε συνεχόμενα χρόνια...

Ο πίνακας στο Γ τι ακριβώς θα αποθήκευε και πώς μετά θα τον αξιοποιούσαμε;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #29 στις: 09 Ιούν 2011, 11:44:23 μμ »
ή πρέπει να δούμε όλους τους συνδυασμούς τριάδων που υπάρχουν: π.χ. τα έτη 2001, 2004, 2005
Αν εννοεί συνδυασμούς τριάδων, τότε Παναγιώτη, η απόσταση (σε βαθμό δυσκολίας)  από τις κανονικές, γίνεται ... χαοτική !!!
Α

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Επαναληπτικές
« Απάντηση #30 στις: 09 Ιούν 2011, 11:47:29 μμ »
Ε ναι αφού όταν μιλάμε για 10ετία εννοούμε συνεχόμενα χρόνια  :P

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #31 στις: 09 Ιούν 2011, 11:50:26 μμ »
Προς την Επιτροπή :


Αγαπητοί συνάδελφοι : Συγχαρητήρια για την ποιοτική σας επιλογή !!!

Για τις κανονικές :

Φέτος με την καθιέρωση του εθνικού απολυτηρίου, περιμέναμε  ότι η σκέψη σας θα απελευθερωνόταν πραγματικά (όπως κάνατε με τις Επαναληπτικές !!)

Αν όντως η σύνθεση (κανονικών , επαναληπτικών) είναι η ίδια, τότε γιατί στις κανονικές τα θέματά σας είναι τέτοια που αναδεικνύουν τον αντιγραφέα (ο ατσίδας !!), το μη σκεπτόμενο (παπαγάλο) και ταυτόχρονα απογοητεύουν εκείνο το μαθητή που 'ερωτεύτηκε' αυτό το μάθημα ;;;;;

Α

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Επαναληπτικές
« Απάντηση #32 στις: 10 Ιούν 2011, 12:44:27 πμ »
Να υποθέσω ότι η λύση για την μετατροπή σε ένα ΓΙΑ, στο δεύτερο παράδειγμα είναι

Για j από 1 μέχρι 100
        Εμφάνισε Α[50,j]
Τέλος_Επανάληψης;;;

Έχει το ίδιο αποτέλεσμα εξόδου, αλλά η εκφώνηση δεν ορίζει ότι αυτό είναι το ζητούμενο

Έχει λάθος η εκφώνηση ή λάθος καταλαβαίνω εγώ;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Επαναληπτικές
« Απάντηση #33 στις: 10 Ιούν 2011, 12:49:30 πμ »

Έχει το ίδιο αποτέλεσμα εξόδου, αλλά η εκφώνηση δεν ορίζει ότι αυτό είναι το ζητούμενο


Αυτό δεν ζητάει; Μία μόνο δομή ΓΙΑ ΚΑΙ ΟΧΙ( δομή Αν)!!  :P

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2302
Απ: Επαναληπτικές
« Απάντηση #34 στις: 10 Ιούν 2011, 12:52:00 πμ »
Δεν αναφέρει πουθενά για ίδιο αποτέλεσμα εξόδου
Στο παράδειγμα έχουμε 10000 επαναλήψεις και 100 εξόδους
Στην μετατροπή, έχουμε 100 επαναλήψεις και 100 εξόδους

Στο άλλο παράδειγμα, έχουμε 100 επαναλήψεις και 100 εξόδους και στο παράδειγμα και στην μετατροπή

Έξοδος μας ενδιαφέρει προφανώς αλλά δεν αναφέρεται στην εκφώνηση και είναι foul
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #35 στις: 10 Ιούν 2011, 12:54:40 πμ »

Έχει λάθος η εκφώνηση ή λάθος καταλαβαίνω εγώ;

1. Η εκφώνηση άριστη.
2. Σωστά κατάλαβες !

Α

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Επαναληπτικές
« Απάντηση #36 στις: 10 Ιούν 2011, 12:56:56 πμ »
Το μόνο που μας ενδιαφέρει είναι η μετατροπή, είναι σαφέστατη!  :)

PE19

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Επαναληπτικές
« Απάντηση #37 στις: 10 Ιούν 2011, 09:07:37 πμ »
Θέματα Α, Β, Γ : πολύ καλά!
Θέμα Δ: θα ήθελα περισσότερη φαντασία και μικρότερη σχέση με τα θέματα προηγούμενων ετών.

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Επαναληπτικές
« Απάντηση #38 στις: 10 Ιούν 2011, 09:41:23 πμ »
όταν λέει τριετία στο θέμα Δ εννοεί συνεχόμενα χρόνια; δηλαδή είναι μόνο τα 2001, 2002, 2003 ή τα 2002, 2003, 2004 ή τα 2003, 2004, 2005
ή πρέπει να δούμε όλους τους συνδυασμούς τριάδων που υπάρχουν: π.χ. τα έτη 2001, 2004, 2005

ρωτάω γιατί δεν αναφέρεται στην εκφώνηση. οι μαθητές μπορεί να πάρουν όποια παραδοχή θέλουν;
(χώρος προβλήματος)

στο θέμα Γ μπορούμε να πάρουμε πίνακα 10.000x10 μιας και οι αντλίες μετράνε με ακρίβεια δέκατου την ποσότητα της βενζίνης που βάζουμε στο αμάξι;
Πολύ σωστές παρατηρήσεις.
Μήπως όμως να μας έδινες και τις πιθανές λύσεις ώστε να μπορέσουμε να αξιολογήσουμε καλύτερα τις παραδοχές. Και για το Δ όσον αφορά τους συνδυασμούς αλλά ιδίως για το Γ γιατί δεν μπορώ να καταλάβω πως θα μπορούσε να αξιοποιηθεί ο πίνακας 10.000Χ10.


Τώρα όσον αφορά τα θέματα νομίζω ότι είναι πολύ καλά και καλύπτουν όλη την ύλη στο μέτρο του δυνατού. Νομίζω ότι οι θεματοδότες κινήθηκαν στη σωστή κατεύθυνση ενώ θα συμφωνήσω ότι το θέμα Γ βασίζεται σε ένα σενάριο που καταστά αδύνατη τη χρήση πίνακα. 

meteo_xampos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 186
Απ: Επαναληπτικές
« Απάντηση #39 στις: 10 Ιούν 2011, 12:07:25 μμ »
Πολύ καλά θέματα!!! Το 3ο ειδικά είναι πάρα πολύ ωραίο!!! Θα ήθελα να το έβλεπα στις εξετάσεις που έδωσαν τα παιδιά στις 23 του Μάη... Το 4ο εύκολο... Τα 1 και 2 είναι αρκετά καλά για να εξετάσουνε την πραγματική κατανόηση της ύλης (εκτός των υποπρογραμμάτων που εξετάζονται στο 4ο θέμα)...

Να μια λύση που έβγαλα για το 3ο θέμα...

Αλγόριθμος τάδε
Αρχή_επανάληψης
   Διάβασε ποσ  !ποσότητα καυσίμου στη δεξαμενή...
Μέχρις_ότου ποσ<=10000
Σβ← 0 !συνολικό βάρος καυσίμου που φέρνουν τα βυτιοφόρα...
Σ← 0 !συνολικό βάρος καυσίμου που παίρνουνε τα επιβατικά...
π← 0 !πόσα επιβατικά εξυπηρετήθηκαν...
οχ← 0 !οχήματα που δεν εξυπηρετήθηκαν...
Όσο (ποσ>0) ΚΑΙ (οχ<3) επανάλαβε
   Αρχή_επανάληψης
      Διάβασε τ
   Μέχρις_ότου τ="Β" Ή τ="Ε"
   Αν τ="Β" τότε
      δ← 10000-ποσ !πόσο θέλει ακόμα η δεξαμενή για να γεμίσει...
      Σβ← Σβ + δ !προσθέτουμε για να βρούμε συνολικά τι έβαλαν τα βυτιοφόρα...
      ποσ← 10000 !γεμίζει η δεξαμενή αν έρχεται βυτιοφόρο...
   Αλλιώς
      Διάβασε πκ !ποσότητα καυσίμου...
      Αν πκ<=ποσ τότε !αν μπορεί να εξυπηρετηθεί...
         ποσ← ποσ-πκ !μειώνουμε τη ποσότητα που υπάρχει στη δεξαμενή...
         Σ← Σ+πκ !προσθέτουμε τη ποσόσητα που πήρε το επιβατικό...
         π← π+1 !ακόμα ένα επιβατικό εξυπηρετήθηκε...
      Αλλιώς
         οχ← οχ + 1 !δεν εξυπηρετήθηκε...
      Τέλος_Αν
   Τέλος_Αν
Τέλος_επανάληψης
μο← Σ/π
Εμφάνισε "μέση ποσότητα...", μο
Εμφάνισε "συνολική ποσότητα καυσίμου από βυτιοφόρα...", Σβ
Τέλος τάδε
         


andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #40 στις: 10 Ιούν 2011, 12:09:35 μμ »
Αρχή_επανάληψης
   Διάβασε ποσ  !ποσότητα καυσίμου στη δεξαμενή...
Μέχρις_ότου ποσ<=10000  και ποσ > 0

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #41 στις: 10 Ιούν 2011, 12:12:38 μμ »
Αν τ="Β" τότε
      δ← 10000-ποσ !πόσο θέλει ακόμα η δεξαμενή για να γεμίσει...
      Σβ← Σβ + δ !προσθέτουμε για να βρούμε συνολικά τι έβαλαν τα βυτιοφόρα...
      ποσ← 10000 !γεμίζει η δεξαμενή αν έρχεται βυτιοφόρο...
   Αλλιώς
      Διάβασε πκ !ποσότητα καυσίμου...
      Αν πκ<=ποσ τότε !αν μπορεί να εξυπηρετηθεί...
         ποσ← ποσ-πκ !μειώνουμε τη ποσότητα που υπάρχει στη δεξαμενή...
         Σ← Σ+πκ !προσθέτουμε τη ποσόσητα που πήρε το επιβατικό...
         π← π+1 !ακόμα ένα επιβατικό εξυπηρετήθηκε...
         Σημείο 1
      Αλλιώς
         οχ← οχ + 1 !δεν εξυπηρετήθηκε...
      Τέλος_Αν
   Τέλος_Αν


Στο Σημείο 1   ... κάτι λείπει !!! ( Γ4.  ... τρία διαδοχικά επιβατηγά ...)

Α

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Επαναληπτικές
« Απάντηση #42 στις: 10 Ιούν 2011, 12:19:20 μμ »
Λείπει το οχ <- 0 γιατί η άσκηση μιλάει για 3 συνεχόμενα οχήματα που δεν εξυπηρετήθηκαν.

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 323
Απ: Επαναληπτικές
« Απάντηση #43 στις: 10 Ιούν 2011, 02:07:52 μμ »
...
- Το θέμα Γ δείχνει πώς γίνεται να είναι αδύνατη η χρήση πίνακα! Από την άλλη, βέβαια, δεν ξέρω τι μπορεί να έχει σκεφτεί ο Παρασκευάς!
...
Xχαχααχα, όχι Νίκο δε σκέφτηκα τίποτα, γι' αυτό είπα ότι το Γ για μένα είναι από τα καλύτερά τους! :)
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #44 στις: 10 Ιούν 2011, 02:51:06 μμ »
απ' όσο ξέρω οι πίνακες είναι "φάρμακο δια πάσαν νόσον", απλά δεν έχω τόση φαντασία πια (γερνάω) για να σκεφτώ όλες τις πιθανές εφαρμογές τους...

το θέμα Γ, είναι από τα καλύτερα, πιθανώς το καλύτερο, θέματα που έχουν ζητηθεί ποτέ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #45 στις: 10 Ιούν 2011, 02:53:19 μμ »
Αν τ="Β" τότε
      δ← 10000-ποσ !πόσο θέλει ακόμα η δεξαμενή για να γεμίσει...
      Σβ← Σβ + δ !προσθέτουμε για να βρούμε συνολικά τι έβαλαν τα βυτιοφόρα...
      ποσ← 10000 !γεμίζει η δεξαμενή αν έρχεται βυτιοφόρο...
   Αλλιώς
      Διάβασε πκ !ποσότητα καυσίμου...
      Αν πκ<=ποσ τότε !αν μπορεί να εξυπηρετηθεί...
         ποσ← ποσ-πκ !μειώνουμε τη ποσότητα που υπάρχει στη δεξαμενή...
         Σ← Σ+πκ !προσθέτουμε τη ποσόσητα που πήρε το επιβατικό...
         π← π+1 !ακόμα ένα επιβατικό εξυπηρετήθηκε...
         Σημείο 1
      Αλλιώς
         οχ← οχ + 1 !δεν εξυπηρετήθηκε...
      Τέλος_Αν
   Τέλος_Αν


Στο Σημείο 1   ... κάτι λείπει !!! ( Γ4.  ... τρία διαδοχικά επιβατηγά ...)

Α


το τρία διαδοχικά είναι μέρος της συνθήκης του βρόχου (όσο ή μέχρις_ότου)

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Επαναληπτικές
« Απάντηση #46 στις: 10 Ιούν 2011, 04:40:43 μμ »

το τρία διαδοχικά είναι μέρος της συνθήκης του βρόχου (όσο ή μέχρις_ότου)

Παναγιώτη μπορείς να γίνεις πιο σαφής γιατί ειλικρινά με έχεις μπερδέψει.

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #47 στις: 10 Ιούν 2011, 04:57:55 μμ »
Έτσι είναι Παναγιώτη. Είναι μέρος της συνθήκης.

Αλλά  αυτό που λείπει στο Σημείο 1 , επηρεάζει (κατά το σωστό τρόπο) τη συνθήκη της Μέχρις_ότου ή   Όσο.

Την απάντηση την έδωσε ήδη ο Βασίλης Παπαχρήστος.

Α

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #48 στις: 10 Ιούν 2011, 08:26:37 μμ »
οκ, μπερδέύτηκαι και νόμιζα οτι αναφέρεστε την αρχικοποίηση πριν το βρόχο
δεν είχα δει οτι έλειπε και μέσα, σορυ!!

meteo_xampos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 186
Απ: Επαναληπτικές
« Απάντηση #49 στις: 10 Ιούν 2011, 08:54:53 μμ »
Οκ, αποδεκτή η απροσεξία μου... Δεν πρόσεξα τη λέξη συνεχόμενα... :) Ξενύχτης από την προηγούμενη βραδιά δε πρέπει να λύνεις προβλήματα με το που θα ξυπνήσεις... :) Ευχαριστώ παιδιά!!!

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #50 στις: 10 Ιούν 2011, 10:31:32 μμ »
Παιδιά υπάρχουν πουθενά οι λύσεις, γιατί έκατσα να τα λύσω και θέλω να τσεκάρω τις λύσεις μου.

Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #51 στις: 10 Ιούν 2011, 11:17:32 μμ »
Ανέβασέ τες να τις τσεκάρουμε...!  ::)

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #52 στις: 10 Ιούν 2011, 11:23:51 μμ »
Δεν υπάρχουν πουθενά; Κανένας γενναίος, που να μη φοβάται να εκτεθεί;  :) Να κάτσω να αντιγράψω από το χαρτί τόσο κώδικα;  :o
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #53 στις: 10 Ιούν 2011, 11:42:22 μμ »
OK λοιπόν θα ανεβάσω μερικά, ΘΕΜΑ Β,  Β2:

θα εμφανίσει:

13,5,8
13,8,5
13,5,8
« Τελευταία τροποποίηση: 10 Ιούν 2011, 11:55:03 μμ από tom »
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #54 στις: 10 Ιούν 2011, 11:44:44 μμ »
ΘΕΜΑ Β,  Β1.α:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  π← 0
  μθ← 0
  Αρχή_επανάληψης
    π← π+1
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
    Τέλος_αν
    Αν α>0 και π=1 τότε
      Εμφάνισε "Σωστά"
    Τέλος_αν
  Μέχρις_ότου α>0
  Εμφάνισε μθ
Τέλος Β1

ΘΕΜΑ Β,  Β1.β:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  μθ← 0
  σμθ← 0
  Αρχή_επανάληψης
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
      σμθ← σμθ+α
    Τέλος_αν
  Μέχρις_ότου α>0
  Αν μθ>0 τότε
    Εμφάνισε σμθ/μθ
  αλλιώς
    Εμφάνισε "Δε δόθηκαν μη θετικοί"
  Τέλος_αν
Τέλος Β1
« Τελευταία τροποποίηση: 10 Ιούν 2011, 11:55:27 μμ από tom »
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #55 στις: 11 Ιούν 2011, 12:22:43 πμ »
ΘΕΜΑ Γ:

Κώδικας: [Επιλογή]
Αλγόριθμος ΘΕΜΑΓ
  πεπιβ← 0
  σεπιβ← 0
  σβυτ← 0
  άρνηση← 0
  Αρχή_επανάληψης
    Διάβασε δεξ
  Μέχρις_ότου δεξ<=10000
  Όσο δεξ>0 και άρνηση<3 επανάλαβε
    Διάβασε τυπ
    Αν τυπ="B" τότε
      βυτ← 10000-δεξ
      σβυτ← σβυτ + βυτ
      δεξ← 10000
    αλλιώς
      Διάβασε επιβ
      Αν επιβ<=δεξ τότε
         πεπιβ← πεπιβ+1
         σεπιβ← σεπιβ+επιβ
         δεξ← δεξ-επιβ
         άρνηση←0
      αλλιώς
         άρνηση← άρνηση + 1
         Εμφάνισε "Αδυναμία εξυπηρέτησης"
      Τέλος_αν
    Τέλος_αν
  Τέλος_επανάληψης
  Εμφάνισε σεπιβ/πεπιβ
  Εμφάνισε σβυτ
Τέλος ΘΕΜΑΓ
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #56 στις: 11 Ιούν 2011, 12:40:51 πμ »
ΘΕΜΑ Α4:

1. 1, 100, 1
2. 200, 10, -1
3. -200, -1, 1
4. 100, 200, 2
5. 13, 8128, 13

Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #57 στις: 11 Ιούν 2011, 12:46:51 πμ »
ΘΕΜΑ Α3:

α.
Κώδικας: [Επιλογή]
Για i από 1 μέχρι 100
  Εμφάνισε A[i,i]
Τέλος_επανάληψης

β.
Κώδικας: [Επιλογή]
Για j από 1 μέχρι 100
  Εμφάνισε A[50,j]
Τέλος_επανάληψης 



Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #58 στις: 11 Ιούν 2011, 12:49:11 πμ »
... Κανένας γενναίος, που να μη φοβάται να εκτεθεί;   

Δεν είναι θέμα γενναιότητας! Στα θέματα του ημερήσιου 3-4 συνάδελφοι είχαμε ανεβάσει ο καθένας τις λύσεις του... αμέσως μετά τη λήξη της εξέτασης... Απλά στα θέματα του επαναληπτικού δεν καθίσαμε να τα λύσουμε!

OK λοιπόν θα ανεβάσω μερικά, ΘΕΜΑ Β,  Β2:

θα εμφανίσει:

13,5,8
13,8,5
13,5,8

ΟΚ!

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #59 στις: 11 Ιούν 2011, 12:57:29 πμ »
ΘΕΜΑ Β,  Β1.α:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  π← 0
  μθ← 0
  Αρχή_επανάληψης
    π← π+1
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
    Τέλος_αν
    Αν α>0 και π=1 τότε
      Εμφάνισε "Σωστά"
    Τέλος_αν
  Μέχρις_ότου α>0
  Εμφάνισε μθ
Τέλος Β1


ΟΚ! Εναλλακτικά:

Κώδικας: [Επιλογή]
  π← 0
  Αρχή_επανάληψης
     π← π+1   
     Διάβασε α
  Μέχρις_ότου α>0
  Αν π=1 τότε Εμφάνισε "Σωστά"
  μθ← π-1
Εμφάνισε μθ

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #60 στις: 11 Ιούν 2011, 01:02:31 πμ »

ΘΕΜΑ Β,  Β1.β:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  μθ← 0
  σμθ← 0
  Αρχή_επανάληψης
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
      σμθ← σμθ+α
    Τέλος_αν
  Μέχρις_ότου α>0
  Αν μθ>0 τότε
    Εμφάνισε σμθ/μθ
  αλλιώς
    Εμφάνισε "Δε δόθηκαν μη θετικοί"
  Τέλος_αν
Τέλος Β1

ΟΚ!

Μόλις μου δημιουργήθηκε η εξής απορία: Ζητάνε διαφορετικά τμήματα αλγορίθμων ή όλα σε ένα; Αν ζητάνε διαφορετικά τότε γιατί στο α) δίνουν 4 μονάδες και στο β) μόνο 2 μονάδες;  :laugh:

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #61 στις: 11 Ιούν 2011, 01:09:05 πμ »
ΘΕΜΑ Α5:

Αληθής
table=key
Αληθής
table>key
Ψευδής
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #62 στις: 11 Ιούν 2011, 01:11:04 πμ »
ΘΕΜΑ Α4:

1. 1, 100, 1
2. 200, 10, -1
3. -200, -1, 1
4. 100, 200, 2
5. 13, 8128, 13

ΟΚ

Στο 5) θα έπρεπε κάποιος να διαπιστώσει πρώτα ότι το 8128 δεν είναι πολλαπλάσιο του 13 οπότε ικανοποιείται το "που είναι μικρότεροι του 8128". Αν ήθελε κάποιος να δώσει αμέσως απάντηση χωρίς να ελέγξει το παραπάνω, θα μπορούσε να δώσει:
5. 13, 8127, 13

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #63 στις: 11 Ιούν 2011, 01:12:52 πμ »

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #64 στις: 11 Ιούν 2011, 01:17:01 πμ »
ΘΕΜΑ Α5:

Αληθής
table=key
Αληθής
table>key
Ψευδής

[edit:] Μην κολλάς το i με τις αγκύλες γιατί τα πιάνει ως tag για τα italics!

Αληθής
table[ i ]=key
Αληθής
table[ i ]>key
Ψευδής

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #65 στις: 11 Ιούν 2011, 01:18:04 πμ »
Αληθής
table[ i ]=key
Αληθής
table[ i ]>key
Ψευδής
Ναι, ναι αυτό εννοώ ;-)
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #66 στις: 11 Ιούν 2011, 01:25:01 πμ »
ΘΕΜΑ Α2:

Κώδικας: [Επιλογή]
Αν Χ<>Α_Μ(Χ) τότε
    Γράψε "Λάθος"
Τέλος_αν
Αν Χ<=0 τότε
    Γράψε "Μη θετικός"
Τέλος_αν
Αν Χ=Α_Μ(Χ) και Χ>0 τότε
    Γράψε "θετικός"
Τέλος_αν
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #67 στις: 11 Ιούν 2011, 01:29:20 πμ »
ΘΕΜΑ Γ:
...

OK. Εκτός ίσως από αυτό:

Αρχή_επανάληψης
   Διάβασε ποσ  !ποσότητα καυσίμου στη δεξαμενή...
Μέχρις_ότου ποσ<=10000  και ποσ > 0

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #68 στις: 11 Ιούν 2011, 01:32:34 πμ »
ΘΕΜΑ Α2:

Αν Χ<>Α_Μ(Χ) τότε
    Γράψε "Λάθος"
Τέλος_αν
Αν Χ=Α_Μ(Χ) και Χ<=0 τότε
    Γράψε "Μη θετικός"
Τέλος_αν
Αν Χ=Α_Μ(Χ) και Χ>0 τότε
    Γράψε "θετικός"
Τέλος_αν

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #69 στις: 11 Ιούν 2011, 01:45:27 πμ »
καλημέρα
να βοηθήσω λίγο και εγώ
Συνάδελφοι μήπως ξεχάσατε το ερωτημα του Β1 γ (5 μονάδες)
θεμα Α2 οκ (του συναδέλφου Αδαμόπουλου)
θέμα Α3 οκ (στο α υπαρχει και 2ος τρόπος που ίσως 'εγραψαν οι περισσοτεροι)

i<-1
για j απο 1 μεχρι 100
   εμφανισε Α[i,j]
   i<-i+1
τελος_επανάληψης

θεμα Α4 και α4 οκ
θεμα β1 λειπει το γ
θεμα β2 οκ



 
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #70 στις: 11 Ιούν 2011, 01:47:04 πμ »
ΘΕΜΑ Β1.γ:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  μθ← 0
  μαχμθ← -9999999
  Αρχή_επανάληψης
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
      Αν Α_Τ(α)>μαχμθ τότε
        μαχμθ← Α_Τ(α)
      Τέλος_αν
    Τέλος_αν
  Μέχρις_ότου α>0
  Αν μθ>0 τότε
    Εμφάνισε μαχμθ
  αλλιώς
    Εμφάνισε "Δε δόθηκαν μη θετικοί"
  Τέλος_αν
Τέλος Β1
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #71 στις: 11 Ιούν 2011, 01:52:02 πμ »
Σωστό !!έτσι το έλυσα και εγώ
θεμα 3 ωραίο θέμα με πολλές εναλλακτικές λύσεις και παγίδες
θεμα 4 πέραν δ4 (δεν έχω προλάβει) τυποποιημένα και βατά
 
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #72 στις: 11 Ιούν 2011, 01:59:39 πμ »
θέμα Α3 οκ (στο α υπαρχει και 2ος τρόπος που ίσως 'εγραψαν οι περισσοτεροι)
i<-1
για j απο 1 μεχρι 100
   εμφανισε Α[i,j]
   i<-i+1
τελος_επανάληψης

Νομίζω είναι σωστό και αυτό:

Για i απο 1 μεχρι 100
   j=i
   Eμφανισε Α[i,j]
Tελος_επανάληψης
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #73 στις: 11 Ιούν 2011, 02:03:13 πμ »
οκ!! όπως και α3 β να θέσουν i<-50 έξω απο την Για
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #74 στις: 11 Ιούν 2011, 02:10:06 πμ »
Πιστεύω πως αν δεν είχαμε την σφαγή πριν το μάθημά μας θα ηταν
σε πολυ μεγάλο ποσοστό τα θέματα στα ημερήσια !!!
Γενικά πολυ καλά θέματα με φαντασία και όχι παπαγαλία ή αντιγραφή

Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #75 στις: 11 Ιούν 2011, 02:45:50 πμ »
θεμα 4 πέραν δ4 (δεν έχω προλάβει) τυποποιημένα και βατά

Για το Δ4 αν e[20], τα ονόματα των εταιριών και k[20,5] τα κέρδη των εταιριών για την πενταετία, θα το έλυνα ως εξής:

Κώδικας: [Επιλογή]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     μεγ <- -1
     ετμεγ <- 0
     πρωτετμεγ <- 0
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 4
       ΑΝ k[i, j - 1] + k[i, j] + k[i, j + 1] > μεγ ΤΟΤΕ
         μεγ <- k[i, j - 1] + k[i, j] + k[i, j + 1]
         ετμεγ <- i
         πρωτετμεγ <- j - 1
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ e[ετμεγ], " ", πρωτετμεγ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

Αυτό που δεν  καταλαβαίνω καλά στο ΘΕΜΑ Δ είναι το Δ3.

α. η συνάρτηση θα υπολογίζει  μόνο το συνολικό κέρδος της εταιρίας στην πενταετία ή και το μέσο ετήσιο κέρδος του ομίλου;
β. τι είναι το "μέσο ετήσιο κέρδος του ομίλου"; Ο μ.ο. κερδών όλων των εταιριών για κάθε έτος (5 αποτελέσματα) ή μ.ο. κερδών όλων των εταιριών για όλα τα έτη; (1 αποτέλεσμα)
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3502
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικές
« Απάντηση #76 στις: 11 Ιούν 2011, 09:13:27 πμ »
Λέει το μέσο ετήσιο κέρδος του ομίλου, άρα άθροισμα κερδών και μετά διά 5. Αυτό είναι και το δύσκολο, γιατί με την κλήση της συνάρτησης για κάθε εταιρία ο μαθητής βρίσκει το άθροισμα των γραμμών. Οπότε στο τέλος θα διαιρέσει διά 20 (από συνήθεια).
Μέχρι στιγμής σε 1-2 φροντιστήρια που είδα έχουν ανεβάσει λύσεις με αυτό το λάθος.


Αυτό που δεν  καταλαβαίνω καλά στο ΘΕΜΑ Δ είναι το Δ3.

α. η συνάρτηση θα υπολογίζει  μόνο το συνολικό κέρδος της εταιρίας στην πενταετία ή και το μέσο ετήσιο κέρδος του ομίλου;
β. τι είναι το "μέσο ετήσιο κέρδος του ομίλου"; Ο μ.ο. κερδών όλων των εταιριών για κάθε έτος (5 αποτελέσματα) ή μ.ο. κερδών όλων των εταιριών για όλα τα έτη; (1 αποτέλεσμα)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #77 στις: 11 Ιούν 2011, 11:41:52 πμ »
Λέει το μέσο ετήσιο κέρδος του ομίλου, άρα άθροισμα κερδών και μετά διά 5. Αυτό είναι και το δύσκολο, γιατί με την κλήση της συνάρτησης για κάθε εταιρία ο μαθητής βρίσκει το άθροισμα των γραμμών. Οπότε στο τέλος θα διαιρέσει διά 20 (από συνήθεια).
Μέχρι στιγμής σε 1-2 φροντιστήρια που είδα έχουν ανεβάσει λύσεις με αυτό το λάθος.
Οπότε η συνάρτηση θα δέχεται ως όρισμα κάθε φορά την εταιρία και τον πίνακα;
Κάπως έτσι;

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
 ΣΤΑΘΕΡΕΣ
   ετ = 20
 !Δ1
 ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: i, j, k[ετ, 5], μεγ, ετμεγ, πρωτετμεγ
   ΠΡΑΓΜΑΤΙΚΕΣ: συνκερδομ
   ΧΑΡΑΚΤΗΡΕΣ: e[ετ]
 ΑΡΧΗ
 !Δ2
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ετ
     ΔΙΑΒΑΣΕ e[i]
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
       ΔΙΑΒΑΣΕ k[i, j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 !Δ3
   συνκερδομ <- 0
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ετ
     συνκερδομ <- συνκερδομ + συνκερδετ5(i, k)
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΓΡΑΨΕ συνκερδομ/5
 !Δ4
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ετ
     μεγ <- -1
     ετμεγ <- 0
     πρωτετμεγ <- 0
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 4
       ΑΝ k[i, j - 1] + k[i, j] + k[i, j + 1] > μεγ ΤΟΤΕ
         μεγ <- k[i, j - 1] + k[i, j] + k[i, j + 1]
         ετμεγ <- i
         πρωτετμεγ <- j - 1
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ e[ετμεγ], " ", πρωτετμεγ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 !Δ5
 ΣΥΝΑΡΤΗΣΗ συνκερδετ5(et, p): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: j, et, p[20, 5], s
 ΑΡΧΗ
   s <- 0
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
     s <- s + p[et, j]
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   συνκερδετ5 <- s
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ 

Δεν ξέρω δεν είμαι σίγουρος αν έχω καταλάβει καλά... :-\
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Επαναληπτικές
« Απάντηση #78 στις: 11 Ιούν 2011, 11:42:20 πμ »
Λέει το μέσο ετήσιο κέρδος του ομίλου, άρα άθροισμα κερδών και μετά διά 5. Αυτό είναι και το δύσκολο, γιατί με την κλήση της συνάρτησης για κάθε εταιρία ο μαθητής βρίσκει το άθροισμα των γραμμών. Οπότε στο τέλος θα διαιρέσει διά 20 (από συνήθεια).
Μέχρι στιγμής σε 1-2 φροντιστήρια που είδα έχουν ανεβάσει λύσεις με αυτό το λάθος.


Ναι πολύ σωστός ο evry γιατί ουσιαστικά είναι το άθροισμα του δισδιάστατου πίνακα δια 5.

Για το Δ4 αν e[20], τα ονόματα των εταιριών και k[20,5] τα κέρδη των εταιριών για την πενταετία, θα το έλυνα ως εξής:

Κώδικας: [Επιλογή]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     μεγ <- -1
     ετμεγ <- 0
     πρωτετμεγ <- 0
     ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 4
       ΑΝ k[i, j - 1] + k[i, j] + k[i, j + 1] > μεγ ΤΟΤΕ
         μεγ <- k[i, j - 1] + k[i, j] + k[i, j + 1]
         ετμεγ <- i
         πρωτετμεγ <- j - 1
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ e[ετμεγ], " ", πρωτετμεγ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 


Θωμά που ακριβώς αποσκοπεί η χρήση της μεταβλητής ετμεγ; Δεν είναι το ίδιο το i; Μου διαφεύγει κάτι;

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #79 στις: 11 Ιούν 2011, 11:53:53 πμ »
Θωμά που ακριβώς αποσκοπεί η χρήση της μεταβλητής ετμεγ; Δεν είναι το ίδιο το i; Μου διαφεύγει κάτι;
Όχι, το i είναι.
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3502
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικές
« Απάντηση #80 στις: 11 Ιούν 2011, 12:06:40 μμ »
ακριβώς
καλείς τη συνάρτηση όπως λέει η εκφώνηση για τα συνολικά κέρδη κάθε εταιρίας και μετά τα προσθέτεις όλα αυτά σε μια μεταβλητή που είναι το συνολικό κέρδος του ομίλου.
Από ότι φαίνεται η εκφώνηση δεν τα δίνει όλα στο πιάτο. Θέλει αρκετή σκέψη πριν ξεκινήσει κάποιος τη λύση.
Επίσης είναι από τις λίγες φορές που μπαίνει υποπρόγραμμα για το οποίο θα πρέπει οι μαθητές να σκεφτούν μόνοι τους ποιες είναι οι παράμετροι. Δεν λέει πουθενά τι δέχεται.

Οπότε η συνάρτηση θα δέχεται ως όρισμα κάθε φορά την εταιρία και τον πίνακα;
Κάπως έτσι;

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #81 στις: 11 Ιούν 2011, 12:15:55 μμ »
ακριβώς
καλείς τη συνάρτηση όπως λέει η εκφώνηση για τα συνολικά κέρδη κάθε εταιρίας και μετά τα προσθέτεις όλα αυτά σε μια μεταβλητή που είναι το συνολικό κέρδος του ομίλου.
Από ότι φαίνεται η εκφώνηση δεν τα δίνει όλα στο πιάτο. Θέλει αρκετή σκέψη πριν ξεκινήσει κάποιος τη λύση.
Επίσης είναι από τις λίγες φορές που μπαίνει υποπρόγραμμα για το οποίο θα πρέπει οι μαθητές να σκεφτούν μόνοι τους ποιες είναι οι παράμετροι. Δεν λέει πουθενά τι δέχεται.
Δεν ξέρω κατά πόσο δικαιολογείται η επιλογή χρήσης συνάρτησης σε αυτή την περίπτωση. Δε θα μπορούσε να γίνει με μια διπλή επανάληψη στο κυρίως πρόγραμμα; Άσε που δεν  μου κάθεται καλά  να στέλνει κάθε φορά ολόκληρο πίνακα ως όρισμα, ενώ χρησιμοποιεί, μόνο τα πέντε στοιχεία του...
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3502
  • to Iterate is human to Recurse divine
Απ: Επαναληπτικές
« Απάντηση #82 στις: 11 Ιούν 2011, 12:27:22 μμ »
Δεν έχει σημασία ότι είναι 5, θα μπορούσαν να είναι περισσότερα. Απλά η ιδέα είναι ότι περνάει σαν παράμετρο έναν πίνακα και τον αριθμό γραμμής ή στήλης που θέλουμε να επεξεργαστεί. Απλά τυχαίνει και τα στοιχεία προς επεξεργασία είναι λίγα σε σχέση με το μέγεθος των ορισμάτων, για αυτό σου φαίνεται άσχημα. Προφανώς σαν προγραμματιστική τεχνική δεν είναι και ότι καλύτερο, αλλά ο σκοπός είναι μάλλον διδακτικός/εξεταστικός θα έλεγα.

Δεν ξέρω κατά πόσο δικαιολογείται η επιλογή χρήσης συνάρτησης σε αυτή την περίπτωση. Δε θα μπορούσε να γίνει με μια διπλή επανάληψη στο κυρίως πρόγραμμα; Άσε που δεν  μου κάθεται καλά  να στέλνει κάθε φορά ολόκληρο πίνακα ως όρισμα, ενώ χρησιμοποιεί, μόνο τα πέντε στοιχεία του...
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #83 στις: 11 Ιούν 2011, 07:34:57 μμ »
ΘΕΜΑ Β1.γ:

Κώδικας: [Επιλογή]
...
  μαχμθ← -9999999
...

Στη συγκεκριμένη περίπτωση (μεγαλύτερος κατ' απόλυτη τιμή ...) ο μαχθ θα μπορούσε να πάρει  σαν αρχική τιμή το 0 ή οποιαδήποτε μικρότερη από το 0. Το αναφέρω γιατί μπορεί κάποιος να μπερδευτεί προσπαθώντας να καταλάβει γιατί πήρε την τιμή -9999999.

Καμιά άποψη για το παρακάτω, κανείς ;;;;;
(αναφέρομαι στο Β1: http://dide.ilei.sch.gr/keplinet/education/docs/them_plir_kat_c_hmer_epan_1106.pdf)

Μόλις μου δημιουργήθηκε η εξής απορία: Ζητάνε διαφορετικά τμήματα αλγορίθμων ή όλα σε ένα; Αν ζητάνε διαφορετικά τότε γιατί στο α) δίνουν 4 μονάδες και στο β) μόνο 2 μονάδες;  :laugh:

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #84 στις: 11 Ιούν 2011, 09:36:58 μμ »
και σε κάποιο θέμα Γ ή Δ, δίνονται μόρια σε κάθε ερώτημα αλλά ζητάει ενιαίο αλγόριθμο.

Θεωρώ οτι ζητάει ενιαίο κώδικα, και αυτό ενισχύεται και από το ότι κάποιες μεταβλητές ενός ερωτήματος χρειάζονται στο επόμενο.
Θεωρώ οτι αν κάποιος μαθητής έδωσε διαφορετικές κωδικοποιήσεις δε θα χάσει καμία μονάδα...

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1508
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Επαναληπτικές
« Απάντηση #85 στις: 11 Ιούν 2011, 10:00:24 μμ »
Αρκετά καλά τα θέματα ... Θα προτιμούσα λίγο προσεκτικότερες διατυπώσεις στο Β1 και στο Δ3.
Θα ήθελα να δω τι θα γινόταν αν έμπαιναν στις κανονικές των ημερησίων ...
Για όσους συναδελφους ενδιαφέρονται οι λύσεις και τα θέματα σε doc μορφή βρίσκονται από σήμερα και εδώ :

http://users.sch.gr/gnikola/
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #86 στις: 11 Ιούν 2011, 10:38:07 μμ »
Γιώργο στο θέμα Γ πρέπει να λείπει η εντολή...


Διάβασε Καύσιμο
Αν Ποσότητα >= Καύσιμο τότε
          Ποσότητα ← Ποσότητα – Καύσιμο
          Πλήθος_Επιβατηγών ← Πλήθος_Επιβατηγών + 1
          Σύνολο_Επιβατηγών ← Σύνολο_Επιβατηγών + Καύσιμο
          Οχήματα 0
Αλλιώς
          Οχήματα ← Οχήματα + 1
Τέλος_αν

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1508
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Επαναληπτικές
« Απάντηση #87 στις: 12 Ιούν 2011, 07:15:56 μμ »
Σωστά Ηλία, ευχαριστώ πολύ για την υπόδειξη. Θα το διορθώσω αύριο με την επιστροφή μου  ;)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1424
  • There are always possibilities...
Απ: Επαναληπτικές
« Απάντηση #88 στις: 12 Ιούν 2011, 10:00:11 μμ »
Ωραία θεματάκια.
Σε ό,τι αφορά το Β1, που επισημαίνει ο Νίκος εγώ το εξέλαβα ως 3 διαφορετικοί αλγόριθμοι. Μπορεί να έκανα και λάθος.
Επίσης, αν θέλουμε να είμαστε απόλυτα σωστοί, νομίζω ότι στο Δ4 χρειαζόταν διευκρίνηση ότι η τριετία είναι συνεχόμενη. Αλλιώς το θέμα γίνεται αρκετά ενδιαφέρον. >:D

Γενικό ερώτημα: Ωραία δεν θα ήταν όλες οι πανελλήνιες να ξεκινούσαν στις 17:00  ;)

ΥΓ: Τώρα είδα ότι έχει ξανατεθεί το θέμα με τα συνεχόμενα ή όχι χρόνια της τριετίας.
« Τελευταία τροποποίηση: 12 Ιούν 2011, 10:22:20 μμ από pgrontas »
Programs must be written for people to read, and only incidentally for machines to execute - Harold Abelson

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Επαναληπτικές
« Απάντηση #89 στις: 13 Ιούν 2011, 10:21:08 πμ »
Επίσης, αν θέλουμε να είμαστε απόλυτα σωστοί, νομίζω ότι στο Δ4 χρειαζόταν διευκρίνηση ότι η τριετία είναι συνεχόμενη. Αλλιώς το θέμα γίνεται αρκετά ενδιαφέρον. >:D

Αν η εκφώνηση θεωρούσε ότι οι τριετίες δεν είναι συνεχόμενες τότε δεν θα ζητούσε το πρώτο έτος. Για παράδειγμα οι τριετίες με πρώτο το 2001 είναι 6. Αν εμφανιστεί μόνο το 2001 σε ποια από τις έξι μοναδικές αναφέρεται; Επίσης τα χρόνια από τις τριετίες πρέπει να εμφανίζονται σε αύξουσα σειρά; Δηλαδή τα 2002, 2001 και 2003 είναι ή όχι αποδεκτή τριετία.

Νομίζω ότι η εκφώνηση ήταν μια χαρά. Ένα "συνεχόμενη" μπορεί να την έκανε πιο πλήρη αλλά και πάλι εκτιμώ ότι αν δεν γινόταν όλες αυτές οι συζητήσεις στο στέκι δεν θα ήμαστε τόσο υποψιασμένοι. Επίσης το θέμα δεν γίνεται απλά ενδιαφέρον αλλά γίνεται πολύ δύσκολο εώς αδύνατο για μαθητές Γ Λυκείου να δώσουν λύση στο ασφυκτικό πλαίσιο των εξετάσεων.
 

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 795
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Επαναληπτικές
« Απάντηση #90 στις: 15 Ιούν 2011, 05:38:52 μμ »
Ξέρει κάποιος αν οι ενδεικτικές λύσεις έφτασαν γραμμένες σε υπολογιστή όπως ήρθαν οι λύσεις στα θέματα των ημερησίων και όχι με το χέρι;.
Να μην ξεχάσουμε να ευχαριστήσουμε αυτόν που έκατσε και έγραψε (γύρω στις 5-6 το πρωί και μετά από ξενύχτι)  τις λύσεις των ημερησίων σε υπολογιστή

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2804
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #91 στις: 15 Ιούν 2011, 10:37:33 μμ »
Ξέρει κάποιος αν οι ενδεικτικές λύσεις έφτασαν γραμμένες σε υπολογιστή όπως ήρθαν οι λύσεις στα θέματα των ημερησίων και όχι με το χέρι;.
Να μην ξεχάσουμε να ευχαριστήσουμε αυτόν που έκατσε και έγραψε (γύρω στις 5-6 το πρωί και μετά από ξενύχτι)  τις λύσεις των ημερησίων σε υπολογιστή

Πιο δύσκολο είναι να γράφεις με το χέρι!  :)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #92 στις: 02 Ιούλ 2011, 08:44:59 μμ »

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #93 στις: 02 Ιούλ 2011, 09:08:05 μμ »
Ωραίο και χρήσιμο  :)
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι