Αποστολέας Θέμα: Επαναληπτικές  (Αναγνώστηκε 14771 φορές)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #60 στις: 11 Ιούν 2011, 01:02:31 πμ »

ΘΕΜΑ Β,  Β1.β:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  μθ← 0
  σμθ← 0
  Αρχή_επανάληψης
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
      σμθ← σμθ+α
    Τέλος_αν
  Μέχρις_ότου α>0
  Αν μθ>0 τότε
    Εμφάνισε σμθ/μθ
  αλλιώς
    Εμφάνισε "Δε δόθηκαν μη θετικοί"
  Τέλος_αν
Τέλος Β1

ΟΚ!

Μόλις μου δημιουργήθηκε η εξής απορία: Ζητάνε διαφορετικά τμήματα αλγορίθμων ή όλα σε ένα; Αν ζητάνε διαφορετικά τότε γιατί στο α) δίνουν 4 μονάδες και στο β) μόνο 2 μονάδες;  :laugh:

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #61 στις: 11 Ιούν 2011, 01:09:05 πμ »
ΘΕΜΑ Α5:

Αληθής
table=key
Αληθής
table>key
Ψευδής
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #62 στις: 11 Ιούν 2011, 01:11:04 πμ »
ΘΕΜΑ Α4:

1. 1, 100, 1
2. 200, 10, -1
3. -200, -1, 1
4. 100, 200, 2
5. 13, 8128, 13

ΟΚ

Στο 5) θα έπρεπε κάποιος να διαπιστώσει πρώτα ότι το 8128 δεν είναι πολλαπλάσιο του 13 οπότε ικανοποιείται το "που είναι μικρότεροι του 8128". Αν ήθελε κάποιος να δώσει αμέσως απάντηση χωρίς να ελέγξει το παραπάνω, θα μπορούσε να δώσει:
5. 13, 8127, 13

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #63 στις: 11 Ιούν 2011, 01:12:52 πμ »

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #64 στις: 11 Ιούν 2011, 01:17:01 πμ »
ΘΕΜΑ Α5:

Αληθής
table=key
Αληθής
table>key
Ψευδής

[edit:] Μην κολλάς το i με τις αγκύλες γιατί τα πιάνει ως tag για τα italics!

Αληθής
table[ i ]=key
Αληθής
table[ i ]>key
Ψευδής

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #65 στις: 11 Ιούν 2011, 01:18:04 πμ »
Αληθής
table[ i ]=key
Αληθής
table[ i ]>key
Ψευδής
Ναι, ναι αυτό εννοώ ;-)
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #66 στις: 11 Ιούν 2011, 01:25:01 πμ »
ΘΕΜΑ Α2:

Κώδικας: [Επιλογή]
Αν Χ<>Α_Μ(Χ) τότε
    Γράψε "Λάθος"
Τέλος_αν
Αν Χ<=0 τότε
    Γράψε "Μη θετικός"
Τέλος_αν
Αν Χ=Α_Μ(Χ) και Χ>0 τότε
    Γράψε "θετικός"
Τέλος_αν
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #67 στις: 11 Ιούν 2011, 01:29:20 πμ »
ΘΕΜΑ Γ:
...

OK. Εκτός ίσως από αυτό:

Αρχή_επανάληψης
   Διάβασε ποσ  !ποσότητα καυσίμου στη δεξαμενή...
Μέχρις_ότου ποσ<=10000  και ποσ > 0

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2814
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #68 στις: 11 Ιούν 2011, 01:32:34 πμ »
ΘΕΜΑ Α2:

Αν Χ<>Α_Μ(Χ) τότε
    Γράψε "Λάθος"
Τέλος_αν
Αν Χ=Α_Μ(Χ) και Χ<=0 τότε
    Γράψε "Μη θετικός"
Τέλος_αν
Αν Χ=Α_Μ(Χ) και Χ>0 τότε
    Γράψε "θετικός"
Τέλος_αν

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #69 στις: 11 Ιούν 2011, 01:45:27 πμ »
καλημέρα
να βοηθήσω λίγο και εγώ
Συνάδελφοι μήπως ξεχάσατε το ερωτημα του Β1 γ (5 μονάδες)
θεμα Α2 οκ (του συναδέλφου Αδαμόπουλου)
θέμα Α3 οκ (στο α υπαρχει και 2ος τρόπος που ίσως 'εγραψαν οι περισσοτεροι)

i<-1
για j απο 1 μεχρι 100
   εμφανισε Α[i,j]
   i<-i+1
τελος_επανάληψης

θεμα Α4 και α4 οκ
θεμα β1 λειπει το γ
θεμα β2 οκ



 
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #70 στις: 11 Ιούν 2011, 01:47:04 πμ »
ΘΕΜΑ Β1.γ:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  μθ← 0
  μαχμθ← -9999999
  Αρχή_επανάληψης
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
      Αν Α_Τ(α)>μαχμθ τότε
        μαχμθ← Α_Τ(α)
      Τέλος_αν
    Τέλος_αν
  Μέχρις_ότου α>0
  Αν μθ>0 τότε
    Εμφάνισε μαχμθ
  αλλιώς
    Εμφάνισε "Δε δόθηκαν μη θετικοί"
  Τέλος_αν
Τέλος Β1
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #71 στις: 11 Ιούν 2011, 01:52:02 πμ »
Σωστό !!έτσι το έλυσα και εγώ
θεμα 3 ωραίο θέμα με πολλές εναλλακτικές λύσεις και παγίδες
θεμα 4 πέραν δ4 (δεν έχω προλάβει) τυποποιημένα και βατά
 
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #72 στις: 11 Ιούν 2011, 01:59:39 πμ »
θέμα Α3 οκ (στο α υπαρχει και 2ος τρόπος που ίσως 'εγραψαν οι περισσοτεροι)
i<-1
για j απο 1 μεχρι 100
   εμφανισε Α[i,j]
   i<-i+1
τελος_επανάληψης

Νομίζω είναι σωστό και αυτό:

Για i απο 1 μεχρι 100
   j=i
   Eμφανισε Α[i,j]
Tελος_επανάληψης
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #73 στις: 11 Ιούν 2011, 02:03:13 πμ »
οκ!! όπως και α3 β να θέσουν i<-50 έξω απο την Για
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές
« Απάντηση #74 στις: 11 Ιούν 2011, 02:10:06 πμ »
Πιστεύω πως αν δεν είχαμε την σφαγή πριν το μάθημά μας θα ηταν
σε πολυ μεγάλο ποσοστό τα θέματα στα ημερήσια !!!
Γενικά πολυ καλά θέματα με φαντασία και όχι παπαγαλία ή αντιγραφή

Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19