Αποστολέας Θέμα: Επαναληπτικές  (Αναγνώστηκε 13726 φορές)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3301
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #45 στις: 10 Ιούν 2011, 02:53:19 μμ »
Αν τ="Β" τότε
      δ← 10000-ποσ !πόσο θέλει ακόμα η δεξαμενή για να γεμίσει...
      Σβ← Σβ + δ !προσθέτουμε για να βρούμε συνολικά τι έβαλαν τα βυτιοφόρα...
      ποσ← 10000 !γεμίζει η δεξαμενή αν έρχεται βυτιοφόρο...
   Αλλιώς
      Διάβασε πκ !ποσότητα καυσίμου...
      Αν πκ<=ποσ τότε !αν μπορεί να εξυπηρετηθεί...
         ποσ← ποσ-πκ !μειώνουμε τη ποσότητα που υπάρχει στη δεξαμενή...
         Σ← Σ+πκ !προσθέτουμε τη ποσόσητα που πήρε το επιβατικό...
         π← π+1 !ακόμα ένα επιβατικό εξυπηρετήθηκε...
         Σημείο 1
      Αλλιώς
         οχ← οχ + 1 !δεν εξυπηρετήθηκε...
      Τέλος_Αν
   Τέλος_Αν


Στο Σημείο 1   ... κάτι λείπει !!! ( Γ4.  ... τρία διαδοχικά επιβατηγά ...)

Α


το τρία διαδοχικά είναι μέρος της συνθήκης του βρόχου (όσο ή μέχρις_ότου)

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Επαναληπτικές
« Απάντηση #46 στις: 10 Ιούν 2011, 04:40:43 μμ »

το τρία διαδοχικά είναι μέρος της συνθήκης του βρόχου (όσο ή μέχρις_ότου)

Παναγιώτη μπορείς να γίνεις πιο σαφής γιατί ειλικρινά με έχεις μπερδέψει.

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1052
Απ: Επαναληπτικές
« Απάντηση #47 στις: 10 Ιούν 2011, 04:57:55 μμ »
Έτσι είναι Παναγιώτη. Είναι μέρος της συνθήκης.

Αλλά  αυτό που λείπει στο Σημείο 1 , επηρεάζει (κατά το σωστό τρόπο) τη συνθήκη της Μέχρις_ότου ή   Όσο.

Την απάντηση την έδωσε ήδη ο Βασίλης Παπαχρήστος.

Α

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3301
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Επαναληπτικές
« Απάντηση #48 στις: 10 Ιούν 2011, 08:26:37 μμ »
οκ, μπερδέύτηκαι και νόμιζα οτι αναφέρεστε την αρχικοποίηση πριν το βρόχο
δεν είχα δει οτι έλειπε και μέσα, σορυ!!

meteo_xampos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 187
Απ: Επαναληπτικές
« Απάντηση #49 στις: 10 Ιούν 2011, 08:54:53 μμ »
Οκ, αποδεκτή η απροσεξία μου... Δεν πρόσεξα τη λέξη συνεχόμενα... :) Ξενύχτης από την προηγούμενη βραδιά δε πρέπει να λύνεις προβλήματα με το που θα ξυπνήσεις... :) Ευχαριστώ παιδιά!!!

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #50 στις: 10 Ιούν 2011, 10:31:32 μμ »
Παιδιά υπάρχουν πουθενά οι λύσεις, γιατί έκατσα να τα λύσω και θέλω να τσεκάρω τις λύσεις μου.

Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2805
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #51 στις: 10 Ιούν 2011, 11:17:32 μμ »
Ανέβασέ τες να τις τσεκάρουμε...!  ::)

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #52 στις: 10 Ιούν 2011, 11:23:51 μμ »
Δεν υπάρχουν πουθενά; Κανένας γενναίος, που να μη φοβάται να εκτεθεί;  :) Να κάτσω να αντιγράψω από το χαρτί τόσο κώδικα;  :o
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #53 στις: 10 Ιούν 2011, 11:42:22 μμ »
OK λοιπόν θα ανεβάσω μερικά, ΘΕΜΑ Β,  Β2:

θα εμφανίσει:

13,5,8
13,8,5
13,5,8
« Τελευταία τροποποίηση: 10 Ιούν 2011, 11:55:03 μμ από tom »
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #54 στις: 10 Ιούν 2011, 11:44:44 μμ »
ΘΕΜΑ Β,  Β1.α:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  π← 0
  μθ← 0
  Αρχή_επανάληψης
    π← π+1
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
    Τέλος_αν
    Αν α>0 και π=1 τότε
      Εμφάνισε "Σωστά"
    Τέλος_αν
  Μέχρις_ότου α>0
  Εμφάνισε μθ
Τέλος Β1

ΘΕΜΑ Β,  Β1.β:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  μθ← 0
  σμθ← 0
  Αρχή_επανάληψης
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
      σμθ← σμθ+α
    Τέλος_αν
  Μέχρις_ότου α>0
  Αν μθ>0 τότε
    Εμφάνισε σμθ/μθ
  αλλιώς
    Εμφάνισε "Δε δόθηκαν μη θετικοί"
  Τέλος_αν
Τέλος Β1
« Τελευταία τροποποίηση: 10 Ιούν 2011, 11:55:27 μμ από tom »
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #55 στις: 11 Ιούν 2011, 12:22:43 πμ »
ΘΕΜΑ Γ:

Κώδικας: [Επιλογή]
Αλγόριθμος ΘΕΜΑΓ
  πεπιβ← 0
  σεπιβ← 0
  σβυτ← 0
  άρνηση← 0
  Αρχή_επανάληψης
    Διάβασε δεξ
  Μέχρις_ότου δεξ<=10000
  Όσο δεξ>0 και άρνηση<3 επανάλαβε
    Διάβασε τυπ
    Αν τυπ="B" τότε
      βυτ← 10000-δεξ
      σβυτ← σβυτ + βυτ
      δεξ← 10000
    αλλιώς
      Διάβασε επιβ
      Αν επιβ<=δεξ τότε
         πεπιβ← πεπιβ+1
         σεπιβ← σεπιβ+επιβ
         δεξ← δεξ-επιβ
         άρνηση←0
      αλλιώς
         άρνηση← άρνηση + 1
         Εμφάνισε "Αδυναμία εξυπηρέτησης"
      Τέλος_αν
    Τέλος_αν
  Τέλος_επανάληψης
  Εμφάνισε σεπιβ/πεπιβ
  Εμφάνισε σβυτ
Τέλος ΘΕΜΑΓ
Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #56 στις: 11 Ιούν 2011, 12:40:51 πμ »
ΘΕΜΑ Α4:

1. 1, 100, 1
2. 200, 10, -1
3. -200, -1, 1
4. 100, 200, 2
5. 13, 8128, 13

Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

tom

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 488
Απ: Επαναληπτικές
« Απάντηση #57 στις: 11 Ιούν 2011, 12:46:51 πμ »
ΘΕΜΑ Α3:

α.
Κώδικας: [Επιλογή]
Για i από 1 μέχρι 100
  Εμφάνισε A[i,i]
Τέλος_επανάληψης

β.
Κώδικας: [Επιλογή]
Για j από 1 μέχρι 100
  Εμφάνισε A[50,j]
Τέλος_επανάληψης 



Θωμάς Σκυλογιάννης

- Ζήσε σα να' ταν να πεθάνεις αύριο. Μάθε σα να' ταν να ζεις για πάντα.
                                                                                     Μαχάτμα Γκάντι

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2805
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #58 στις: 11 Ιούν 2011, 12:49:11 πμ »
... Κανένας γενναίος, που να μη φοβάται να εκτεθεί;   

Δεν είναι θέμα γενναιότητας! Στα θέματα του ημερήσιου 3-4 συνάδελφοι είχαμε ανεβάσει ο καθένας τις λύσεις του... αμέσως μετά τη λήξη της εξέτασης... Απλά στα θέματα του επαναληπτικού δεν καθίσαμε να τα λύσουμε!

OK λοιπόν θα ανεβάσω μερικά, ΘΕΜΑ Β,  Β2:

θα εμφανίσει:

13,5,8
13,8,5
13,5,8

ΟΚ!

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2805
  • Πύργος Ηλείας
Απ: Επαναληπτικές
« Απάντηση #59 στις: 11 Ιούν 2011, 12:57:29 πμ »
ΘΕΜΑ Β,  Β1.α:

Κώδικας: [Επιλογή]
Αλγόριθμος Β1
  π← 0
  μθ← 0
  Αρχή_επανάληψης
    π← π+1
    Διάβασε α
    Αν α<=0  τότε
      μθ← μθ+1
    Τέλος_αν
    Αν α>0 και π=1 τότε
      Εμφάνισε "Σωστά"
    Τέλος_αν
  Μέχρις_ότου α>0
  Εμφάνισε μθ
Τέλος Β1


ΟΚ! Εναλλακτικά:

Κώδικας: [Επιλογή]
  π← 0
  Αρχή_επανάληψης
     π← π+1   
     Διάβασε α
  Μέχρις_ότου α>0
  Αν π=1 τότε Εμφάνισε "Σωστά"
  μθ← π-1
Εμφάνισε μθ