Ψηφοφορία

Πιστεύετε ότι η λύση με πίνακες στο Θέμα Γ  :

Είναι λάθος - να κοπούν 3-5 μονάδες
28 (8.2%)
Είναι λάθος - να κοπούν 1-2 μονάδες
23 (6.7%)
Είναι σωστή αλλά όχι ιδανική - να κοπούν 1-2 μονάδες
29 (8.5%)
Είναι σωστή αλλά όχι ιδανική - να μην κοπούν μονάδες
108 (31.7%)
Είναι σωστή - να μην κοπούν μονάδες
153 (44.9%)

Σύνολο ψηφοφόρων: 339

Αποστολέας Θέμα: Ημερήσια 2010  (Αναγνώστηκε 197133 φορές)

amilikas

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 38
Απ: Ημερήσια 2010
« Απάντηση #135 στις: 28 Μάι 2010, 02:34:57 μμ »
Το γεγονος ειναι οτι αδικηθηκε η τεχνολογικη κατευθυνση σε σχεση με την θετικη που η χημεια ηταν ευκολη και την θεωρητικη που γενικα ειχαν ευκολες εξετασεις. Γιαυτο πρεπει να κοπουν λιγες μοναδες αλλα οχι και καθολου. Οταν διδασκουμε πινακες δηλ πρεει να λεμε στα παιδια οτι μπορουν να τους χρησιμοποιούν παντα? Δεν ειναι μονο το γραψιμο του αλγοριθμου αλλα και σχεδιαση του, ο καθορισμος των απαιτησεων του. Σε ολα αυτα εξεταζονται. Εγω δεν προκειται ποτε στα παιδια να χρησιμοποιούν πινακες αν δεν ξερουν ακριβες μεγεθος ή καποια μεγιστη χωρηικοτητα την στιγμη που σχεδιαζουν τον αλγοριθμο. Θα ειναι λαθος να το πω. Και θα δημιουργησω κακους μαθητες ετσι.

savatage

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Ημερήσια 2010
« Απάντηση #136 στις: 28 Μάι 2010, 02:35:33 μμ »
ναι ήρθε διευκρίνηση
και φυσικά είναι λάθος να χρησιμοποιήσεις πίνακα

Γιώργο, αφέθηκε στην κρίση των εξεταστών ΠΟΣΟ θα κόψουν, όχι ΑΝ θα κόψουν

Οποτε τι λετε κ. Τσιωτακη οτι ηρθε διευκρινηση????????

Μονο σε εσας ηρθε και στους αλλους οχι?

Περιμενουμε την απαντηση σας.

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #137 στις: 28 Μάι 2010, 02:35:58 μμ »
ΓΛΩΣΣΑ  ;)

Αλγόριθμο ή πρόγραμμα σε ΓΛΩΣΣΑ ζητούσε στο Γ;  :-\
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

SotirisD

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: Ημερήσια 2010
« Απάντηση #138 στις: 28 Μάι 2010, 02:38:17 μμ »
Καλησπέρα και από εμένα, είμαι υποψήφιος και εγώ. Ευχαριστώ επίσης για τις λύσεις, να πω πως εγώ χρησιμοποίησα πίνακα επειδή μας ζήταγε αλγόριθμο ;). Ήθελα να ρωτήσω σχετικά με κάποιες λύσεις που έκανα εγώ, και κατά πόσο είναι σωστές και αν θα μου κόψουν μόρια.

Καταρχήν στο θέμα Α1 πειράζει που έβαλα ΑΛΛΙΩΣ_ΑΝ ΜΟ-ΒΑΘΜΟΣ <= 2 ΤΟΤΕ;

Επίσης στο θέμα γ το έλυσα με πίνακα αλλά στο τελευταίο ερώτημα έκανα τα εξείς:
Παράθεση
κ<-1
   Για i από 2 μέχρι ΑΡ
       Για j από ΑΡ μέχρι i με_βήμα -1
            Αν Ε[j-1]<E[j] τότε
                Αντιμετάθεσε Ε[j], Ε[j-1]
                Αν j-1=κ τότε
                     κ<-κ+1
                Τέλος_αν
            Τέλος_αν
       Τέλος_επανάληψης
   Τέλος_επανάληψης
   Εμφάνισε ''η θέση του περσινού πρωταθλητή είναι'', κ
Αυτό το έκανα με την έννοια ότι αφού ο αθλητής είναι στην πρώτη θέση, η θέση του στην αντιμετάθεση θα αλλάζει όταν αντιμεταθέτεται η επίδοση(j-1=κ) και θα γίνεται +1(κ<-κ+1).

Επίσης αντί για flag στο Γ4 είπα
Παράθεση
Αν π<>0 τότε
    Εμφάνισε π
Τέλος_αν


και τέλος για το θέμα δ, στο τελευταίο ερώτημα έκανα άλλους τρις πίνακες οι οποίου έχουν αντίστοιχα τις επιδώσεις και τα ονόματα των τριών κατηγοριών και τους ταξινόμησα όπως και το γενικό πίνακα.
Και στο ερώτημα για το μεγαλύτερο πλήθος σκαφών στις κατηγορίες αντί για
   
Παράθεση
Αν κ1>κ2 και κ1>κ3 τότε
      Εμφάνισε “C1”
   αλλιώς_αν κ2>κ1 και κ2>κ3 τότε
      Εμφάνισε “C2”
   αλλιώς
      Εμφάνισε “C3”
   Τέλος_αν

έκανα max στα τρία πλήθη.
   
Παράθεση
k1<-max
   o_max<-ON[1]
   Αν k2>max  τότε
      max<-k2
      o_max<-ON[2]
   Τέλος_αν
     Αν k3>max  τότε
      max<-k3
      o_max<-ON[3]
   Τέλος_αν

Ευχαριστώ!
θα παρακαλούσα αν είναι δυνατόν κάποιος να μου απαντήσει έστω σε κάποια από τα παραπάνω(και μην το κάνετε όμως δεν θα με πειράξει), ευχαριστώ.


dimpapadop

  • Πληροφορικοί Δυτικής Μακεδονίας
  • *
  • Μηνύματα: 60
Απ: Ημερήσια 2010
« Απάντηση #139 στις: 28 Μάι 2010, 02:39:37 μμ »
Με καθησυχάζει αυτό που λες dimpapadop
όμως, τότε αυτό τι ήταν ; απλώς φήμη?

σου αναφέρω ξανά ότι είμαι επιτροπή και υπεύθυνος VBI, δλδ εγώ παίρνω τα θέματα και κάθε οδηγία στο εξεταστικό κέντρο του σχολείου μου.

Δεν ήρθε ποτέ οδηγία ... ναι είναι ράδιο αρβύλα... χαλάρωσε.
(επίσης μέχρι τις 10 που είναι η δυνατή ώρα αποχώρησης θα έπρεπε να γίνει αυτό (απαγορεύεται αργότερα να δίνεται οιαδήποτε οδηία / διευκρίνιση), αλλά δεν έγινε ούτε ως τις 12.00 που έκλεισα μετά το πέρας των εξετάσεων)

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #140 στις: 28 Μάι 2010, 02:40:06 μμ »
ναι ήρθε διευκρίνηση
και φυσικά είναι λάθος να χρησιμοποιήσεις πίνακα

Γιώργο, αφέθηκε στην κρίση των εξεταστών ΠΟΣΟ θα κόψουν, όχι ΑΝ θα κόψουν

Διευκρίνηση που ήρθε; Στους εξεταστές δεν το καταλαβαίνω. Στα βαθμολογικά δεν έχει έρθει τίποτα!!!!
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3301
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Ημερήσια 2010
« Απάντηση #141 στις: 28 Μάι 2010, 02:40:36 μμ »
Όταν σε μια άσκηση, εισάγονται στοιχεία που δεν είναι γνωστό το πλήθος τους εκ των προτέρων (κατά τη φάση του προγραμματισμού) τότε δεν μπορούν να χρησιμοποιηθούν πίνακες
οι οποίες είναι στατικές δομές δεδομένων

οπότε κατά τη γνώμη μου, ορθώς πρέπει να κοπούν κάποιες μονάδες (όχι όλες σαφώς) από το θέμα Γ, περί τις 3-5/20

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2303
Απ: Ημερήσια 2010
« Απάντηση #142 στις: 28 Μάι 2010, 02:40:58 μμ »
Γ5. Να βρίσκει και να εμφανίζει τη θέση που κατέλαβε στην τελική κατάταξη ο περσινός πρωταθλητής.

Η συγκεκριμένη εκφώνηση οδηγεί κάποιον κατά 95% σε ταξινόμηση πίνακα
Όποιος διάβασε όλη την εκφώνηση πριν ξεκινήσει να γράφει, κατάλαβε ότι θα βάλει πίνακα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

amilikas

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 38
Απ: Ημερήσια 2010
« Απάντηση #143 στις: 28 Μάι 2010, 02:41:04 μμ »
Παραδειγμα γλωσσας προγραμματισμου που δεν υλοποιειται ο αλγοριθμος αν χρησιμοποιει πινακες...
Και εγω συναδελφοι θα ηθελα να μην κοπουν μοναδες. Μακαρι να διναν ανω οριο και να διαλεγει ο μαθητης τροπο λυσης. Αλλα δεν γινεται και να 'τιμωρουμε' αυτους που το σκεφτηκαν οτι δεν μπορουν να χρησιμοποιήσουν πινακες, ουτε να διδασκουμε λαθος πραγματα απο του χρονου λογω αυτου του θεματος Γ...

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 83
  • !!!!...!!!
Απ: Ημερήσια 2010
« Απάντηση #144 στις: 28 Μάι 2010, 02:42:00 μμ »
Μιας και το θέμα συζητείται έντονα να πω κι εγώ την άποψη μου.
Θεωρώ ότι δεν πρέπει να κοπούν μονάδες στους υποψηφίους που το έλυσαν χρησιμοποιώντας πίνακα.
Δέχομαι ότι υπάρχει αυτή η ελευθερία στην ψευδογλώσσα και ότι μπορεί να γίνει αυτή η υπέρβαση. Νομίζω ότι το γεγονός ότι το συντριπτικό ποσοστό των μαθητών το έλυσαν χρησιμοποιώντας πίνακα θα οδηγήσει τους βαθμολογητές να το θεωρήσουν σωστό.

Στο εξεταστικά κέντρα δεν ήρθε καμία διευκρίνηση σχετικά με τη χρήση πίνακα αυτό μπορώ να το βεβαιώσω ως χειριστής VBI.
Οι συνάδελφοι μάλλον μιλούν για τις οδηγίες στους εξεταστές των φυσικών αδυνάτων.


Ανδρέας Φαρμακόρης

  • Βετεράνος
  • ****
  • Μηνύματα: 99
Απ: Ημερήσια 2010
« Απάντηση #145 στις: 28 Μάι 2010, 02:42:08 μμ »
Στα γενικά Λύκεια δεν ήρθε καμία διευκρίνηση για το Γ θέμα.  Αν ειχε ερθει θα το ηξερα καθως ημουν χειριστης VBI.  Η θεση μου ειναι πως καθως το θεμα ζητα αλγόριθμο οι μαθητες μπορουν να χρησιμοποιησουν πινακα μιας και ο αλγοριθμος δεν εχει αυστηρους κανονες, και εξαλου το ιδιο κανει και το βιβλιο.  Αν ζηταγε Προγραμμα σε ΓΛΩΣΣΑ σαφως και δεν μπορει.  Θα ειναι τουλαχιστον αδικο να κοπουν μοναδες σε οσους χρησιμοποιησαν πινακες.  Προφανως η διευκρίνηση δωθηκε στους φυσικως αδυνατους καθως εκει μπαινει ταυτοχρονα ο βαθμος.
Καθηγητης Πληροφορικής ΠΕ19
Λυκειο Αμπελακίων Σαλαμίνας

dspanoud

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: Ημερήσια 2010
« Απάντηση #146 στις: 28 Μάι 2010, 02:42:38 μμ »
Από τη στιγμή που υπάρχουν όμως αντίστοιχα παραδείγματα κύριε Τσιωτάκη γιατί να κοπούν μονάδες;;;

Αν υπήρχε τέτοια οδηγία, ας ερχόταν ως διευκρίνιση στα σχολεία, όχι μόνο ως οδηγία στα βαθμολογικά..Αυτό θα ήταν το μόνο τίμιο!!!!

Οι μαθητές μου επικοινωνούν μαζί μου εξοργισμένοι, και δίκαια μάλιστα.....

tsak

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 183
Απ: Ημερήσια 2010
« Απάντηση #147 στις: 28 Μάι 2010, 02:44:20 μμ »
Θα συμφωνήσω κι εγώ με τους evry,jsari (γειά σου Σαρημπαλίδη!),ptsiotakis και την επιχειρηματολογία τους στο ότι η λύση με πίνακες είναι λάθος και δεν θα μακρυγορήσω (τα είπαν οι παραπάνω κύριοι νομίζω πολύ σωστά) αλλά επειδή βλέπω μεγάλο διχασμό στις απόψεις περί χρήσης πίνακας ή μη χρήσης και επειδή οι περισσότεροι μαθητές πήραν πίνακα, πιστεύω ότι θα δοθεί οδηγία ή να μην κόψουν  τίποτα ή να κόψουν λίγο. Το αν είναι δίκαιο ή άδικο είναι άλλη συζήτηση.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3301
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Ημερήσια 2010
« Απάντηση #148 στις: 28 Μάι 2010, 02:44:59 μμ »
ΦΥΣΙΚΩΣ ΑΔΥΝΑΤΟΙ
ΟΔΗΓΙΑ ΚΕΕ

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #149 στις: 28 Μάι 2010, 02:45:23 μμ »
Έχει έρθει σε κανένα βαθμολογικό οδηγία για το Γ;  :-\
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52