Αποστολέας Θέμα: Θέμα 4ο Ημερησίων  (Αναγνώστηκε 8766 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3514
  • to Iterate is human to Recurse divine
Απ: Θέμα 4ο Ημερησίων
« Απάντηση #30 στις: 02 Ιούν 2008, 12:56:32 πμ »
ναι που είναι το πρόβλημα, μια χαρά μου φαίνεται

Καλησπέρα σας!Συγχαρητήρια για την πολύ καλή δουλειά που κάνετε στο forum. Είμαι νέα συνάδελφος και θα ήθελα να μου πείτε τη γνώμη σας για μία τέτοια προσέγγιση του Θέματος 4β 4γ.

Για i από 1 μέχρι 16
  Για j από 1 μέχρι 3
     ΠΛ[i,j]<-0
  Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 16
  πλν<-0
  πλι<-0
  πλη<-0
  Για j από 1 μέχρι 30
    Αρχή_επανάληψης
       Διάβασε ΑΠ[i,j]
    Μέχρις_ότου ΑΠ[i,j]='Ν' ή ΑΠ[i,j]='Ι' ή ΑΠ[i,j]='Η'
    Αν ΑΠ[i,j]='Ν' τότε
      πλν<-πλν+1
    αλλιώς_αν ΑΠ[i,j]='Ι' τότε
      πλι<-πλι+1
   αλλιώς
      πλη<-πλη+1
   τέλος_αν
  τέλος_επανάληψης 
   ΠΛ[i,1]<-πλν
   ΠΛ[i,2]<-πλι
   ΠΛ[i,3]<-πλη
τέλος_επανάληψης

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

rek_d

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Θέμα 4ο Ημερησίων
« Απάντηση #31 στις: 02 Ιούν 2008, 01:06:44 πμ »
Κι εγώ μια χαρά το βρήκα και αρκετά διαφοροποιημένο από τον 'κλασικό' τρόπο που το έλυσαν οι περισσότεροι. Ένας μαθητής μου το έλυσε έτσι (ελπίζω δηλαδή να μου του ξέφυγε κάτι) και απλά ήθελα μια δεύτερη γνώμη. Ευχαριστώ!

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 795
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Θέμα 4ο Ημερησίων
« Απάντηση #32 στις: 02 Ιούν 2008, 11:06:04 πμ »
Ρένα
φυσιολογικά δεν θα σου έκοβαν μονάδες με οποιοδήποτε τρόπο αν το έλυνες (σωστά βέβαια).  Απλά το πρόγραμμα είναι ποιό τυποποιημένο και μπορεί κάποιος να σταθεί περισότερο στην σύνταξη των εντολών, δήλωση μεταβλητών κ.λπ και έτσι να χάσεις μονάδες.
Υπάρχει βέβαια και η περίπτωση να θεωρήσει κάποιος ότι θα πρέπει να λυθεί μόνο με αλγόριθμο -δυστηχώς υπάρχουν ορισμένοι καθηγητές με διάφορες αντιεπιστημονικές απόψεις-. 

klitos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 133
Απ: Θέμα 4ο Ημερησίων
« Απάντηση #33 στις: 02 Ιούν 2008, 12:16:01 μμ »
Μια χαρά λύση ειναι .... μη σου πω οτι ο μηδενισμός στην αρχή ειναι περιττός...
Αυτή τη λύση προτείνω και εγώ
κλητος χατζηγεωργιου

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: Θέμα 4ο Ημερησίων
« Απάντηση #34 στις: 03 Ιούν 2008, 09:11:53 πμ »
Πάντως και μερικοί δικοί μου (3-4) το έκαναν με τον παραπάνω τρόπο (και χωρίς τον αρχικό μηδενισμό).
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19