Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικές εξετάσεις => Γ΄ Λυκείου => Εξετάσεις 2007-2008 => Μήνυμα ξεκίνησε από: EleniK στις 30 Μαΐ 2008, 11:56:46 μμ

Τίτλος: Θέμα 4ο Ημερησίων
Αποστολή από: EleniK στις 30 Μαΐ 2008, 11:56:46 μμ
Συζητήσεις, απόψεις και προβληματισμοί για το θέμα 4 των ημερησίων.
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: evry στις 31 Μαΐ 2008, 12:31:40 πμ
εύκολο :D
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: clevercitizen στις 31 Μαΐ 2008, 12:03:34 μμ

***Να σημειώσω εδώ ότι υπάρχει η περίπτωση ισοβαθμίας δύο ομάδων, οπότε αν ήθελε ο μαθητής μπορούσε να κάνει έλεγχο και ταξινόμηση και με βάση τα ονόματα, κάτι όμως που δεν είναι απαραίτητο αφού δεν το ζητάει η άσκηση.

Hρθε διευκρύνιση που έλεγε ότι δεν υπάρχει περίπτωση ισοβαθμίας.

Εγώ τον ΠΛ τον γέμισα ως εξης:

Για ι απο 1 μεχτο 16
   Για ξ απο 1 μεχρι 30
      Αν ΑΠ[ι,ξ] ='Ν' τοτε
        ρ[ι]<- ρ[ι] + 1
Αν...
τ[ι]<--τ[ι] +1 κοκ

αν
ω[ι]<-ω[ι]+1
......................
και μετά
Για ι απο 1 μεχρι 16
ΠΛ[ι,1]<-ρ[ι]
ΠΛ[ι,2]<-τ[ι]
ΠΛ[ι,3]<-ω[ι]

etc
Σωστός δεν είμαι?

Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: P.Tsiotakis στις 31 Μαΐ 2008, 12:07:08 μμ
Οι ρ, ξ, ω, αρχικοποιήθηκαν;
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: clevercitizen στις 31 Μαΐ 2008, 12:07:26 μμ
εννοείται! (ξ=j e?)
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: klitos στις 31 Μαΐ 2008, 01:02:35 μμ
Κοινότατο έως απογοητευτικά τυποποιημένο ... δεν δινει δυνατότητα να φανει ο καλός μαθητής .... κριμα, κριμα , κριμα
Αλλη μια χρονιά που δεν δοθηκε η ευκαιρία στους καλούς μας μαθητές να ξεχωρισουν... απογοητευση
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: droopy στις 31 Μαΐ 2008, 03:19:00 μμ
Την περίπτωση να γεμίσει ο πίνακας  μόνο με Νικες ή μόνο Ηττες οπότε και δεν έχει καμία λογικη θα πρέπει να την προβλέψει ο μαθητής;
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: petrosp13 στις 31 Μαΐ 2008, 03:21:16 μμ
Γιατί να μην έχουν λογική οι 30 νίκες ή ήττες;
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: P.Tsiotakis στις 31 Μαΐ 2008, 03:23:02 μμ
Ο ολυμπιακός πχ λογικά, θα έχει μόνο νίκες  :D
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: droopy στις 31 Μαΐ 2008, 03:25:34 μμ
Αμα γεμίσει όλος ο πίνακας και για τις 16 ομάδες από νίκες τότε ποιον νικήσαν αφου δεν θα υπάρχουν ήττες???

πρέπει όσες νίκες υπάρχουν συνολικά στον πίνακα τόσες αντίστοιχες ήττες
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: petrosp13 στις 31 Μαΐ 2008, 03:28:09 μμ
Αυτό που λες ξεφεύγει κατά πολύ από την φιλοσοφία του θέματος μάλλον
Και επιπλέον, δεν είναι προγραμματιστικό πρόβλημα, αλλά θέμα ανάλυσης και απαιτήσεων που τίθενται για το πρόβλημα
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: clevercitizen στις 31 Μαΐ 2008, 05:20:36 μμ
Ψιλοάσχετο. Όταν έγραφα το 4 μου ήρθε φλασιά να το έλυνα κ αυτό με χρήση διαδικασιων(ΔΕΝ το έκανα). Λέτε άν το έκανα, και τα αποτελέσματα-λογική να ήταν σωστά, να μου έκοβαν μονάδες?
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: ρενα στις 31 Μαΐ 2008, 06:16:36 μμ
Ψιλοάσχετο. Όταν έγραφα το 4 μου ήρθε φλασιά να το έλυνα κ αυτό με χρήση διαδικασιων(ΔΕΝ το έκανα). Λέτε άν το έκανα, και τα αποτελέσματα-λογική να ήταν σωστά, να μου έκοβαν μονάδες?
Ζητουσε αλγοριθμο.. οχι προγραμμα στο 4ο.... Οποτε θα σου εκοβαν.. δεν ξερω βεβαια ποσο! ;)
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: evry στις 31 Μαΐ 2008, 06:17:17 μμ
και το πρόγραμμα αλγόριθμος είναι
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: ρενα στις 31 Μαΐ 2008, 06:19:11 μμ
και το πρόγραμμα αλγόριθμος είναι
Ε?! Εγω εχω διδαχθει παντως οτι οταν μ ζηταει αλγοριθμο.. κανω αλγοριθμο.. οταν μ ζηταει προγραμμα κανω προγραμμα.. κ αυτο απο καθηγητη που ειναι κ διορθωτης....!
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: evry στις 31 Μαΐ 2008, 06:29:06 μμ

 Ναι, γενικά κάνεις ότι σου ζητάει, αλλά και το πρόγραμμα δεν είναι η κωδικοποίηση ενός αλγορίθμου σε μια γλώσσα προγραμματισμού? και αυτό αναπαριστά έναν αλγόριθμο, όπως το διάγραμμα ροής και η ψευδογλώσσα.. Απλά το πρόγραμμα είναι πιο αυστηρό
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: xalastras στις 31 Μαΐ 2008, 06:30:01 μμ
Όταν ζητάει αλγόριθμο μπορούμε να γράψουμε από απλό αλγόριθμο μέχρι πρόγραμμα ή ακόμη και διάγραμμα ροής .. είναι εξίσου σωστά όλα αφού είναι μέθοδοι αναπαράστασης αλγορίθμων. Όταν ζητάει πρόγραμμα όμως γράφουμε ΜΟΝΟ πρόγραμμα.
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: petrosp13 στις 31 Μαΐ 2008, 06:33:34 μμ
Ζήτησαν διάγραμμα ροής από πρόγραμμα, αν και ξέρουμε ότι το διάγραμμα ροής είναι αναπαράσταση αλγορίθμου και άρα μόνο από αλγόριθμο σε ψευδογλώσσα μπορεί να προκύψει
Θεωρητικά πάντα, γιατί το πρόγραμμα είναι η υλοποίηση του αλγορίθμου σε κάποια γλώσσα
Γενικά, το πρόγραμμα θεωρείται αυστηρότερο και δυσκολότερο από έναν αλγόριθμο, με αποτέλεσμα να μην κόβονται μονάδες σε περιπτώσεις όπως η δική σου
Φυσικά, δεν ισχύει το αντίστροφο. Αν ζητηθεί πρόγραμμα, δεν μπορείς να καταφύγεις στις ευκολίες του αλγορίθμου
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: janag στις 31 Μαΐ 2008, 07:39:40 μμ
και το πρόγραμμα αλγόριθμος είναι
Ε?! Εγω εχω διδαχθει παντως οτι οταν μ ζηταει αλγοριθμο.. κανω αλγοριθμο.. οταν μ ζηταει προγραμμα κανω προγραμμα.. κ αυτο απο καθηγητη που ειναι κ διορθωτης....!

Ο αλγόριθμος είναι μία πολύ ευρύτερη έννοια. Όταν αναφέρει "Να κατασκευαστεί αλγόριθμος" είναι στην διακριτική σου ευχέρεια το αν θα το κάνεις σε Πρόγραμμα ή σε Ψευδοκώδικα. Διαφορετικά θα έπρεπε να γράφει "Να κατασκευαστεί αλγόριθμος με την μορφή ψευδοκώδικα"

Έλεος πια....
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: nplatis στις 31 Μαΐ 2008, 08:22:00 μμ
Σχετικά με το (γ): Αν ο μηδενισμός του πίνακα ΠΛ γινόταν μαζί με το γέμισμά του είναι σωστό; Δηλ. κάτι σαν

ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 16
    ΠΛ[ι,1] <- 0
    ΠΛ[ι,2] <- 0
    ΠΛ[ι,3] <- 0
    ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 30
        ΑΝ ΑΠ[ι,ξ] ...

Στην εκφώνηση λέει "προηγουμένως να έχει μηδενιστεί" αλλά το "προηγουμένως" μπορεί να εκληφθεί ως μία ευγενική υπενθύμιση και όχι ακριβώς χρονικός προσδιορισμός...
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: Χάρης Τσιαΐρης στις 31 Μαΐ 2008, 08:36:47 μμ
Συνάδελφε αυτό εγώ θα το βαθμολογούσα σωστό και πιστεύω και οι περισσότεροι, αλλά πιστεύω αλλού είναι το μεγάλο πρόβλημα σχετικά με τον μηδενισμό του πίνακα. Η ακριβής διατύπωση είναι:
Ο πίνακας αυτός πρέπει προηγουμένως να έχει μηδενισθεί.

Αυτό το "πρέπει" μπορούμε να το πάρουμε σαν:

Προσωπικά θα ήθελα να ισχύει το δεύτερο αλλά ή εκφώνηση δεν με βοηθάει. Εσεις τι πιστεύετε; Θα πρέπει να ληφθεί βαθμολογικά υπόψη ή όχι;

Χάρης Τσιαΐρης
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: EleniK στις 31 Μαΐ 2008, 08:50:34 μμ
Ευτυχώς που έλεγε για το μηδενισμό. Να βοηθηθούν τα παιδιά γιατί κατα τα αλλα ήταν δυσκολο το θ4  :o  :o  :D  :D
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: karaba στις 31 Μαΐ 2008, 09:45:16 μμ
βασικα κακως βαλανε ασκησεις τωρα που το σκεφτομαι...
τι τους θελουν τους εξυπνους και μαθητες στο πανεπιστημιο???
δημιουργουν προβληματα αυτοι αυριο μεθαυριο....
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: mokasa στις 31 Μαΐ 2008, 10:32:56 μμ
Αμα γεμίσει όλος ο πίνακας και για τις 16 ομάδες από νίκες τότε ποιον νικήσαν αφου δεν θα υπάρχουν ήττες???

πρέπει όσες νίκες υπάρχουν συνολικά στον πίνακα τόσες αντίστοιχες ήττες

Νομίζω κι εγώ οτι έχεις δίκιο. Για την ακρίβεια αν κάθε στήλη του πίνακα είναι μια αγωνιστική, τότε θα πρέπει σε αυτή τη στήλη να υπάρχει ίσος αριθμός "Ν" και "Η", καθώς και άρτιο πλήθος από "Ι".
Δυστυχώς δεν ζητήθηκε αυτό ξεκάθαρα, οπότε δεν πρέπει να το ελέγξουν οι μαθητές. Κρίμα γιατί θα έκανε το θέμα λίγο πιο ...πικάντικο!
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: EleniK στις 01 Ιουν 2008, 11:40:16 πμ
Θα μπορούσε να ήταν πικάντικο αν απλά έβαζαν σαν την άσκηση του Eurobasket  που έχει το τετράδιο του μαθητή. Από ότι φάνηκε όμως στην επιτροπή δεν αρέσουν τα πικάντικα, αλλά τα νερόβραστα (και χωρίς ίχνος αλάτι).
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: ntzios kostas στις 01 Ιουν 2008, 03:30:11 μμ
αυτά κάνουν ορισμένοι καθηγητές και χάνεται η ουσία του μαθήματος.
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: Katerina m στις 01 Ιουν 2008, 04:03:33 μμ
Σχετικά με το μηδενισμό του πίνακα, αν όντως μπήκε στο θέμα για να βοηθήσει τους μαθητές, τι γίνεται στην περίπτωση που κάποιος δεν τον μηδένισε αλλά έγραψε σωστά τον αλγόριθμο; Θα του κόψουν μονάδες;
Αν είναι δυνατόν, ας απαντήσει κάποιος βαθμολογητής!
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: andreas_p στις 01 Ιουν 2008, 04:07:21 μμ
OXI.
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: rek_d στις 02 Ιουν 2008, 12:41:24 πμ
Καλησπέρα σας!Συγχαρητήρια για την πολύ καλή δουλειά που κάνετε στο forum. Είμαι νέα συνάδελφος και θα ήθελα να μου πείτε τη γνώμη σας για μία τέτοια προσέγγιση του Θέματος 4β 4γ.

Για i από 1 μέχρι 16
  Για j από 1 μέχρι 3
     ΠΛ[i,j]<-0
  Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 16
  πλν<-0
  πλι<-0
  πλη<-0
  Για j από 1 μέχρι 30
    Αρχή_επανάληψης
       Διάβασε ΑΠ[i,j]
    Μέχρις_ότου ΑΠ[i,j]='Ν' ή ΑΠ[i,j]='Ι' ή ΑΠ[i,j]='Η'
    Αν ΑΠ[i,j]='Ν' τότε
      πλν<-πλν+1
    αλλιώς_αν ΑΠ[i,j]='Ι' τότε
      πλι<-πλι+1
   αλλιώς
      πλη<-πλη+1
   τέλος_αν
  τέλος_επανάληψης 
   ΠΛ[i,1]<-πλν
   ΠΛ[i,2]<-πλι
   ΠΛ[i,3]<-πλη
τέλος_επανάληψης
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: arisbasil στις 02 Ιουν 2008, 12:44:52 πμ
βασικα κακως βαλανε ασκησεις τωρα που το σκεφτομαι...
τι τους θελουν τους εξυπνους και μαθητες στο πανεπιστημιο???
δημιουργουν προβληματα αυτοι αυριο μεθαυριο....


 ;D ;D 
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: evry στις 02 Ιουν 2008, 12:56:32 πμ
ναι που είναι το πρόβλημα, μια χαρά μου φαίνεται

Καλησπέρα σας!Συγχαρητήρια για την πολύ καλή δουλειά που κάνετε στο forum. Είμαι νέα συνάδελφος και θα ήθελα να μου πείτε τη γνώμη σας για μία τέτοια προσέγγιση του Θέματος 4β 4γ.

Για i από 1 μέχρι 16
  Για j από 1 μέχρι 3
     ΠΛ[i,j]<-0
  Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι 16
  πλν<-0
  πλι<-0
  πλη<-0
  Για j από 1 μέχρι 30
    Αρχή_επανάληψης
       Διάβασε ΑΠ[i,j]
    Μέχρις_ότου ΑΠ[i,j]='Ν' ή ΑΠ[i,j]='Ι' ή ΑΠ[i,j]='Η'
    Αν ΑΠ[i,j]='Ν' τότε
      πλν<-πλν+1
    αλλιώς_αν ΑΠ[i,j]='Ι' τότε
      πλι<-πλι+1
   αλλιώς
      πλη<-πλη+1
   τέλος_αν
  τέλος_επανάληψης 
   ΠΛ[i,1]<-πλν
   ΠΛ[i,2]<-πλι
   ΠΛ[i,3]<-πλη
τέλος_επανάληψης

Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: rek_d στις 02 Ιουν 2008, 01:06:44 πμ
Κι εγώ μια χαρά το βρήκα και αρκετά διαφοροποιημένο από τον 'κλασικό' τρόπο που το έλυσαν οι περισσότεροι. Ένας μαθητής μου το έλυσε έτσι (ελπίζω δηλαδή να μου του ξέφυγε κάτι) και απλά ήθελα μια δεύτερη γνώμη. Ευχαριστώ!
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: Vangelis στις 02 Ιουν 2008, 11:06:04 πμ
Ρένα
φυσιολογικά δεν θα σου έκοβαν μονάδες με οποιοδήποτε τρόπο αν το έλυνες (σωστά βέβαια).  Απλά το πρόγραμμα είναι ποιό τυποποιημένο και μπορεί κάποιος να σταθεί περισότερο στην σύνταξη των εντολών, δήλωση μεταβλητών κ.λπ και έτσι να χάσεις μονάδες.
Υπάρχει βέβαια και η περίπτωση να θεωρήσει κάποιος ότι θα πρέπει να λυθεί μόνο με αλγόριθμο -δυστηχώς υπάρχουν ορισμένοι καθηγητές με διάφορες αντιεπιστημονικές απόψεις-. 
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: klitos στις 02 Ιουν 2008, 12:16:01 μμ
Μια χαρά λύση ειναι .... μη σου πω οτι ο μηδενισμός στην αρχή ειναι περιττός...
Αυτή τη λύση προτείνω και εγώ
Τίτλος: Απ: Θέμα 4ο Ημερησίων
Αποστολή από: EleniK στις 03 Ιουν 2008, 09:11:53 πμ
Πάντως και μερικοί δικοί μου (3-4) το έκαναν με τον παραπάνω τρόπο (και χωρίς τον αρχικό μηδενισμό).