Γενικό Λύκειο > Διερμηνευτής της ΓΛΩΣΣΑΣ

Τι μετράει ως εντολή;

(1/1)

FANBOY_21:
Δοκίμαζα την ψευδογλώσσα και τη ΓΛΩΣΣΑ βάζοντας μια κενή ΓΙΑ με σκοπό να εμφανίσω το παράθυρο διαλόγου περί 100.000 ήδη εκτελεσμένων εντολών, και παρατήρησα ότι το πετάει 5-6 εντολές νωρίτερα, μετρώντας τις φορές που θεωρητικά πατάω το F7. Οπότε το θέμα μου είναι:

Τι μετράει ως 1 εντολή ακριβώς; Μήπως υπάρχουν "εντολές" που εκτελούνται κατά την έναρξη της εκτέλεσης του αλγορίθμου (το ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ δε φαίνεται να πιάνεται για εντολή, ούτε το τμήμα δήλωσης μεταβλητών...);


--- Κώδικας: ---Αλγόριθμος α
Για ι από 1 μέχρι 99995
Τέλος_επανάληψης
Τέλος

--- Τέλος κώδικα ---


--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99994
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

--- Τέλος κώδικα ---

Οι αριθμοί είναι οι ελάχιστοι που προκαλούν εμφάνιση του μηνύματος περί πιθανού ατέρμονα βρόχου.

alkisg:
Μη δίνεις σημασία δεν είναι κάποια επίσημη μέτρηση εντολών. Απλά μια ένδειξη ότι μπορεί ο μαθητής να έκανε άπειρο loop.

FANBOY_21:
Α οπότε είναι "περίπου" 100.000, κατάλαβα.

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση