Αποστολέας Θέμα: Σχεδιαγράμματα για τη θεωρία του μαθήματος ΑΕΠΠ  (Αναγνώστηκε 11123 φορές)

novaro

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Σχεδιαγράμματα για τη θεωρία του μαθήματος ΑΕΠΠ
« Απάντηση #15 στις: 09 Απρ 2014, 10:17:15 πμ »
Αυτό συνάδελφοι δουλεύει κανονικά με βάση το προηγούμενο ποστ

ΠΡΟΓΡΑΜΜΑ τεστ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[5], Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    Α[Ι] <- Ι
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'ΠΡΙΝ'
  ΓΡΑΨΕ Α[2], ',', Α[3]
  ΓΡΑΨΕ 'ΜΕΤΑ'

  ΚΑΛΕΣΕ ΑΝΤΙΜ(Α[2], Α[3])
  ΓΡΑΨΕ Α[2], ',', Α[3]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΑΝΤΙΜ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Τ
ΑΡΧΗ
  Τ <- Α
  Α <- Β
  Β <- Τ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ