Αποστολέας Θέμα: Τρόπος επιστροφής από ΣΥΝΑΡΤΗΣΗ  (Αναγνώστηκε 777 φορές)

sstauross

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Τρόπος επιστροφής από ΣΥΝΑΡΤΗΣΗ
« στις: 10 Απρ 2014, 10:07:45 μμ »
Καλησπέρα συνάδελφοι,
θα ήθελα να μου λύσετε τον εξής προβληματισμό:

Τρόπος 1
-----------
ΣΥΝΑΡΤΗΣΗ max(α,β):ΠΡΑΓΜΑΤΙΚΗ
..
ΑΡΧΗ
 ΑΝ α>β τότε
    max<-α
 ΑΛΛΙΩΣ
    max<-β
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τρόπος 2
-----------
ΣΥΝΑΡΤΗΣΗ max(α,β):ΠΡΑΓΜΑΤΙΚΗ
..
ΑΡΧΗ
 ΑΝ α>β τότε
    x<-α
 ΑΛΛΙΩΣ
    x<-β
 ΤΕΛΟΣ_ΑΝ
  max<-x
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Είναι σωστοί και οι δύο τρόποι για επιστροφή απο συνάρτηση ή μήπως πάντα επιστρέφω στο τέλος χρησιμοποιώντας το όνομα της;

Ευχαριστώ πολύ!

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Τρόπος επιστροφής από ΣΥΝΑΡΤΗΣΗ
« Απάντηση #1 στις: 10 Απρ 2014, 10:56:12 μμ »
Σωστοί και οι δυο τρόποι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής