Αποστολέας Θέμα: Επαναληπτικές 2013 ΘΕΜΑ Α1β  (Αναγνώστηκε 1049 φορές)

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 126
Επαναληπτικές 2013 ΘΕΜΑ Α1β
« στις: 08 Απρ 2014, 09:22:48 μμ »
Καλησπέρα θα ήθελα να ρωτήσω για το παρακάτω θέμα:

ΓΙΑ i ΑΠΟ 0 ΜΕΧΡΙ 20
 ΓΡΑΨΕ ‘Χ’
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ j ΑΠΟ i ΜΕΧΡΙ 56
 ΓΡΑΨΕ ‘Χ’
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

είχε σε αντιστοίχιση πόσες φορές θα εμφανιστεί το χ και βλέπω απάντηση απο γνωστό φροντστήριο που θεωρεί το i όταν τελειώσει η επανάληψη του πρώτου βρόχου 20 ενώ εγώ θεωρώ ότι είναι 21 με αποτέλεσμα αυτόσ να το αντιστοιχίζει στο ότι συνολικά θα εμφανιστεί 57 φορές ενώ εγώ 56.
Τι έχει γίνει τελικά με το ζήτημα αυτό για το i?

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Επαναληπτικές 2013 ΘΕΜΑ Α1β
« Απάντηση #1 στις: 08 Απρ 2014, 10:06:39 μμ »
Η γνώμη μου είναι πως έξω από την επανάληψη η τιμή του i είνια 21, όμως οι επαναληψεις αν δεν κάνω λαθος είναι όντως 57...
η πρώτη αρχίζει από 0 έως 20, --->21 επαναλήψεις
η δεύτερη από 21 μέχρι 56 ---- > 36 επαναλήψεις

σύνολο 57 επαναλήψεις....αν δεν μετράω κάτι λάθος....μήπως δεν παρατήρησες ότι η πρώτη αρχίζει από 0 ??? λέω έτσι μια άποψη... επαναλαμβάνω αν μετράω σωστά

apoldem

  • Βετεράνος
  • ****
  • Μηνύματα: 86
Απ: Επαναληπτικές 2013 ΘΕΜΑ Α1β
« Απάντηση #2 στις: 08 Απρ 2014, 10:34:00 μμ »
Άλλο ένα απαράδεκτο θέμα, το οποίο δεν έχει καμία σχέση με προγραμματισμό ή αλγοριθμικό τρόπο σκέψης. Και έπεσε μόλις πέρσι! Αντί να προετοιμάζουμε τους αυριανούς προγραμματιστές, μαθαίνουμε τα παιδιά ότι η πληροφορική περιλαμβάνει και λίγο μαντική επιστήμη. Δεν φτάνει που χρησιμοποιούμε μια εντολή επανάληψης που έχει πεθάνει εδώ και πολλά χρόνια, απαιτούμε από τους μαθητές να μαντέψουν πως υλοποιείται η εντολή "Για" από τον διερμηνευτή. Ακόμη και όταν υπήρχε η εντολή Για, υπήρχε σαφής κανόνας να μην χρησιμοποιείται η τιμή του μετρητή μετά το τέλος του βρόγχου. Το "i" το χρησιμοποιούμε μόνο όσο διαρκεί ο βρόγχος. Από την μία απαγορεύουμε την αλλαγή του μετρητή μέσα στον βρόγχο (πάγια και συνηθισμένη πρακτική σε όλες τις σύγχρονες γλώσσες) και από την άλλη προτείνουμε την χρήση του μετρητή μετά το τέλος του βρόγχου (στις σύγχρονες γλώσσες ο μετρητής πεθαίνει μαζί με τον βρόγχο). Η κατάντια του μαθήματος.
Η σωστή απάντηση είναι φυσικά 57, λόγω του ότι ξεκινάμε από το μηδέν, όπως πολύ σωστά απάντησε ο mkouv.

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 126
Απ: Επαναληπτικές 2013 ΘΕΜΑ Α1β
« Απάντηση #3 στις: 08 Απρ 2014, 11:31:37 μμ »
Ναι αυτο λέω κι εγώ ότι είναι 57 ενώ αυτός το εχει βάλει 56 στον κελαφα. ξερουμε τι απαντηση έδωσε το υπουργείο?

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 126
Απ: Επαναληπτικές 2013 ΘΕΜΑ Α1β
« Απάντηση #4 στις: 08 Απρ 2014, 11:33:29 μμ »
οχι λάθος εγώ λέω 56 γιατι το i μόλις βγει από τον βροχο θα είναι 22,
αρα 21 για τον πάνω βρόχο και 35 για τον κάτω δηλαδή
η πρώτη αρχίζει από 0 έως 20, --->21 επαναλήψεις
η δεύτερη από 22 μέχρι 56 ---- > 35 επαναλήψεις
ο διερμηνευτής τουλάχιστον έτσι το βγάζει. τι απάντηση έδωσε το υπουργείο ξέρουμε?

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 128
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Επαναληπτικές 2013 ΘΕΜΑ Α1β
« Απάντηση #5 στις: 08 Απρ 2014, 11:42:36 μμ »
To i από τον πρώτο βρόχο θα βγει 21 γιατί ισοδυναμεί με:
i <- 0
Όσο i <= 20 επανάλαβε
       Γράψε 'Χ'
       i <- i + 1
Τέλος_επανάληψης

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 126
Απ: Επαναληπτικές 2013 ΘΕΜΑ Α1β
« Απάντηση #6 στις: 08 Απρ 2014, 11:45:05 μμ »
α σωστα μετρησα 21 φορές και το εβαλα 22 ενώ ηταν 21... βιασύνη, ευχαριστώ πολύ