Αποστολέας Θέμα: Λύσεις και Σχολιασμός των θεμάτων  (Αναγνώστηκε 2407 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Λύσεις και Σχολιασμός των θεμάτων
« στις: 23 Ιούν 2020, 09:25:41 μμ »
Εδώ ανεβάζουμε τα θέματα τις λύσεις τους και σχολιάζουμε.
Καλή επιτυχία στην επιτροπή (λογικά είναι ήδη μέσα).
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #1 στις: 23 Ιούν 2020, 09:28:49 μμ »
Σαφή θέματα με διαβάθμιση δυσκολίας, που να μην περιλαμβάνουν θολά σημεία της ύλης...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 334
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #2 στις: 23 Ιούν 2020, 09:32:51 μμ »
Ευχόμαστε όλοι ολόψυχα τα θέματα να είναι όσο πιο σαφή γίνεται.

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 78
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #3 στις: 24 Ιούν 2020, 07:57:44 πμ »
Καλημέρα και καλή τύχη σε όλα τα παιδιά! Εύχομαι τα θέματα να είναι σωστά διατυπωμένα!

Θα σχολιάσουμε και τα θέματα με το παλιό σύστημα;

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #4 στις: 24 Ιούν 2020, 08:28:03 πμ »
Εύχομαι ολόψυχα τα θέματα να ειναι αυτά που έλυσα χθες βράδυ στα παιδιά.











Χαχαχαχαχαχα πλάκα κάνω, καλη επιτυχία! Μακάρι να απαλλαγουμε φέτος από κάθε ασάφεια..
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #5 στις: 24 Ιούν 2020, 10:06:50 πμ »
Θέματα Πληροφορικής 2020
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

methenitis

  • Θαμώνας
  • ***
  • Μηνύματα: 45
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #6 στις: 24 Ιούν 2020, 10:46:32 πμ »
Μια πρώτη εκτίμηση..
Δεν βλέπω τεράστια διαφορά με πέρσι.

Υπάρχουν βέβαια αρκετά σημεία που πρέπει να ειναι προσεκτικός ο μαθητής.
Το 5ο σωστο λάθος δεν μου άρεσε ιδιαίτερα.
Α-Β πιστεύω ανετα τα βγάζουν οι διαβασμένοι.
Το θέμα Γ μου άρεσε, άρκετα μεγάλο και σύνθετο αλλά δεν είναι κάτι που δεν έχουμε ασχοληθεί οι περισσότεροι.
Το θεμα Δ θα ηθελα ενα πιο δύσκολο ερώτημα.
Εκτός απο το Δ2β που οι περισσότεροι θα έχουν χάσει κάποιες μονάδες απο τις 5 , κατα τα άλλα ηταν πολύ στρωτο.

Αντε , ελπίζω ολοι να είχαν καθαρό μυαλό και να πήραν το καλύτερο που μπορούσαν.

Καλά αποτελέσματα σε όλους.

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #7 στις: 24 Ιούν 2020, 11:17:47 πμ »
Λύσεις στο πολύ μπαμ μπάμ
Ωραίο το Δ' θέμα τυπικές επεξεργασίες πινάκων απλά με "ιδιαίτερο" διάβασμα πινάκων
το θέμα 3ο με πονηριές (στην εκφώνηση του κλιμακωτού κυρίως + τον έλεγχο για μη υπέρβαση ορίου βάρους)
Α-Β είχαν απ' όλα τα καλά!

Κώδικας: [Επιλογή]
!!ΘΕΜΑ_Α
Α1.
1. Λ
2. Σ
3. Σ
4. Λ
5. Σ

Α2.
α)
1) εύρεση αθροισμάτων
2) υπολογισμός μέγιστων-ελαχίστων
3) ταξινόμηση
4) αναζήτησ
5) συγχώνευση

β)
1. Ο αριθμός των πραγματικών και τυπικών παραμέτρων πρέπει να είναι ο ίδιος.
2. Κάθε πραγματική παράμετρος αντιστοιχεί στην αντίστοιχη τυπική.
3. Η πραγματική παράμετρος και η αντίστοιχή της τυπική πρέπει να είναι του ίδιου τύπου
γ) 4 εκ των
 ΗΜ(),ΣΥΝ(),ΛΟΓ(),Ε(),Τ_Ρ(),Α_Τ(),Τ_Ρ(),Α_Μ()

 Α3.
 α)
 ι)3 απωθήσεις
 ιι) το top βρίσκεται στην 3η θέση, άρα Η στοίβα έχει 3 στοιχεία, άρα χρειάζονται 3 απωθήσεις
 β)
 ι) 2 εξαγωγές
 ιι) το πλήθος των στοιχείων της ουράς είναι
     rear-front+1=4-3+1=2, οπότε 2 εξαγωγές

Α4.
 α)
 ι) 3
 ιι) 0
 ιιι) 1
 β) Α+10


 !!ΘΕΜΑ Β
 Β1.
  ΑΝ Χ=7 ΤΟΤΕ
   ΓΡΑΨΕ 'Α'
  ΑΛΛΙΩΣ_ΑΝ Χ=11 Η Χ=13 ΤΟΤΕ
   ΓΡΑΨΕ 'Β'
  ΑΛΛΙΩΣ_ΑΝ Χ<20 ΤΟΤΕ
   ΓΡΑΨΕ 'Γ'
  ΑΛΛΙΩΣ_ΑΝ Χ>=50 ΚΑΙ Χ<=100 ΤΟΤΕ
   ΓΡΑΨΕ 'Δ'
  ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Ε'
  ΤΕΛΟΣ_ΑΝ

Β2.
 1. ΑΛΗΘΗΣ
 2. 2
 3.  Ν MOD ι
 4.  ΨΕΥΔΗΣ
 5.  ΠΡΩΤΟΣ=ΨΕΥΔΗΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_3
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:Π,ΔΕ_ΜΠΗΚΑΝ
 ΠΡΑΓΜΑΤΙΚΕΣ:ΟΡΙΟ,ΜΕΣΑ,ΒΑΡΟΣ,ΧΡ,ΣΥΝΟΛΟ
 ΧΑΡΑΚΤΗΡΕΣ:ΑΠΑΝΤΗΣΗ
ΑΡΧΗ
    ΔΙΑΒΑΣΕ ΟΡΙΟ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΜΕΣΑ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΣΑ<ΟΡΙΟ
    ΔΕ_ΜΠΗΚΑΝ<--0
    ΣΥΝΟΛΟ<--0
    Π<--0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΒΑΡΟΣ
     ΑΝ ΜΕΣΑ+ΒΑΡΟΣ<=ΟΡΙΟ ΤΟΤΕ
        ΜΕΣΑ<--ΜΕΣΑ+ΒΑΡΟΣ
        ΑΝ ΒΑΡΟΣ>1000 ΤΟΤΕ
           Π<--Π+1
        ΤΕΛΟΣ_ΑΝ
        ΑΝ ΒΑΡΟΣ<=500 ΤΟΤΕ
         ΧΡ<--0.5*ΒΑΡΟΣ
        ΑΛΛΙΩΣ_ΑΝ ΒΑΡΟΣ<=1500 ΤΟΤΕ
         ΧΡ<--500*0.5+(ΒΑΡΟΣ-500)*0.3
        ΑΛΛΙΩΣ
         ΧΡ<--500*0.5+100*0.3+(ΒΑΡΟΣ-1500)*0.1
        ΤΕΛΟΣ_ΑΝ
        ΣΥΝΟΛΟ<--ΣΥΝΟΛΟ+ΧΡ
     ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΤΟ ΔΕΜΑ ΔΕ ΧΩΡΑΕΙ'
        ΔΕ_ΜΠΗΚΑΝ<--ΔΕ_ΜΠΗΚΑΝ+1
     ΤΕΛΟΣ_ΑΝ
     ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΣΥΝΕΧΙΣΕΙΣ;;'
     ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤΗΣΗ='ΟΧΙ'
    ΓΡΑΨΕ ΔΕ_ΜΠΗΚΑΝ,ΣΥΝΟΛΟ,Π
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Κ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],ΔΕΙΓΜΑ,ΑΠ[20,100]
ΑΡΧΗ

 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
  ΔΙΑΒΑΣΕ Π[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     Κ<--0
     ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΟΣΟ ΔΕΙΓΜΑ<>'ΤΕΛΟΣ' ΚΑΙ Κ<100 ΕΠΑΝΑΛΑΒΕ
         Κ<--Κ+1
         ΑΠ[Ι,Κ]<--ΔΕΙΓΜΑ
         ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Ξ ΑΠΟ Κ+1 ΜΕΧΡΙ 100
         ΑΠ[Ι,Ξ]<--'Χ'
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΘΕΤΙΚΑ[Ι]<--0
     ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ
         ΑΝ ΑΠ[Ι,Ξ]='Θ' ΤΟΤΕ
            ΘΕΤΙΚΑ[Ι]<--ΘΕΤΙΚΑ[Ι]+1
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΜΑΧ<-- -1
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]>ΜΑΧ ΤΟΤΕ
        ΜΑΧ<--ΘΕΤΙΚΑ[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]=ΜΑΧ ΤΟΤΕ
        ΓΡΑΨΕ Π[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΡΑΨΕ Π[Ι],ΘΕΤΙΚΑ[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Τ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],Τ2
 ΑΡΧΗ
     ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
      ΓΙΑ Ξ ΑΠΟ 20 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
       ΑΝ ΘΕΤΙΚΑ[Ξ-1]<ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          Τ<--ΘΕΤΙΚΑ[Ξ-1]
          ΘΕΤΙΚΑ[Ξ-1]<--ΘΕΤΙΚΑ[Ξ]
          ΘΕΤΙΚΑ[Ξ]<--Τ
          Τ2<--Π[Ξ-1]
          Π[Ξ-1]<--Π[Ξ]
          Π[Ξ]<--Τ2
       ΑΛΛΙΩΣ_ΑΝ ΘΕΤΙΚΑ[Ξ-1]=ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          ΑΝ Π[Ξ-1]>Π[Ξ] ΤΟΤΕ
            Τ2<--Π[Ξ-1]
            Π[Ξ-1]<--Π[Ξ]
            Π[Ξ]<--Τ2
          ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

methenitis

  • Θαμώνας
  • ***
  • Μηνύματα: 45
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #8 στις: 24 Ιούν 2020, 11:20:15 πμ »
νομιζω στο Α4 β ειναι Μ=Α+8

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 39
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #9 στις: 24 Ιούν 2020, 11:20:25 πμ »
Στην λύση σου στο Α4 β) θεωρώ οτι το Α+10 δεν είναι σωστό.. θα μπείς 6 φορές!!

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 78
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #10 στις: 24 Ιούν 2020, 11:21:21 πμ »
Στο Α4β με Α+10 θα κανει 6 επαναληψεις


Λύσεις στο πολύ μπαμ μπάμ
Ωραίο το Δ' θέμα τυπικές επεξεργασίες πινάκων απλά με "ιδιαίτερο" διάβασμα πινάκων
το θέμα 3ο με πονηριές (στην εκφώνηση του κλιμακωτού κυρίως + τον έλεγχο για μη υπέρβαση ορίου βάρους)
Α-Β είχαν απ' όλα τα καλά!

Κώδικας: [Επιλογή]
!!ΘΕΜΑ_Α
Α1.
1. Λ
2. Σ
3. Σ
4. Λ
5. Σ

Α2.
α)
1) εύρεση αθροισμάτων
2) υπολογισμός μέγιστων-ελαχίστων
3) ταξινόμηση
4) αναζήτησ
5) συγχώνευση

β)
1. Ο αριθμός των πραγματικών και τυπικών παραμέτρων πρέπει να είναι ο ίδιος.
2. Κάθε πραγματική παράμετρος αντιστοιχεί στην αντίστοιχη τυπική.
3. Η πραγματική παράμετρος και η αντίστοιχή της τυπική πρέπει να είναι του ίδιου τύπου
γ) 4 εκ των
 ΗΜ(),ΣΥΝ(),ΛΟΓ(),Ε(),Τ_Ρ(),Α_Τ(),Τ_Ρ(),Α_Μ()

 Α3.
 α)
 ι)3 απωθήσεις
 ιι) το top βρίσκεται στην 3η θέση, άρα Η στοίβα έχει 3 στοιχεία, άρα χρειάζονται 3 απωθήσεις
 β)
 ι) 2 εξαγωγές
 ιι) το πλήθος των στοιχείων της ουράς είναι
     rear-front+1=4-3+1=2, οπότε 2 εξαγωγές

Α4.
 α)
 ι) 3
 ιι) 0
 ιιι) 1
 β) Α+10


 !!ΘΕΜΑ Β
 Β1.
  ΑΝ Χ=7 ΤΟΤΕ
   ΓΡΑΨΕ 'Α'
  ΑΛΛΙΩΣ_ΑΝ Χ=11 Η Χ=13 ΤΟΤΕ
   ΓΡΑΨΕ 'Β'
  ΑΛΛΙΩΣ_ΑΝ Χ<20 ΤΟΤΕ
   ΓΡΑΨΕ 'Γ'
  ΑΛΛΙΩΣ_ΑΝ Χ>=50 ΚΑΙ Χ<=100 ΤΟΤΕ
   ΓΡΑΨΕ 'Δ'
  ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Ε'
  ΤΕΛΟΣ_ΑΝ

Β2.
 1. ΑΛΗΘΗΣ
 2. 2
 3.  Ν MOD ι
 4.  ΨΕΥΔΗΣ
 5.  ΠΡΩΤΟΣ=ΨΕΥΔΗΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_3
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:Π,ΔΕ_ΜΠΗΚΑΝ
 ΠΡΑΓΜΑΤΙΚΕΣ:ΟΡΙΟ,ΜΕΣΑ,ΒΑΡΟΣ,ΧΡ,ΣΥΝΟΛΟ
 ΧΑΡΑΚΤΗΡΕΣ:ΑΠΑΝΤΗΣΗ
ΑΡΧΗ
    ΔΙΑΒΑΣΕ ΟΡΙΟ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΜΕΣΑ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΣΑ<ΟΡΙΟ
    ΔΕ_ΜΠΗΚΑΝ<--0
    ΣΥΝΟΛΟ<--0
    Π<--0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΒΑΡΟΣ
     ΑΝ ΜΕΣΑ+ΒΑΡΟΣ<=ΟΡΙΟ ΤΟΤΕ
        ΜΕΣΑ<--ΜΕΣΑ+ΒΑΡΟΣ
        ΑΝ ΒΑΡΟΣ>1000 ΤΟΤΕ
           Π<--Π+1
        ΤΕΛΟΣ_ΑΝ
        ΑΝ ΒΑΡΟΣ<=500 ΤΟΤΕ
         ΧΡ<--0.5*ΒΑΡΟΣ
        ΑΛΛΙΩΣ_ΑΝ ΒΑΡΟΣ<=1500 ΤΟΤΕ
         ΧΡ<--500*0.5+(ΒΑΡΟΣ-500)*0.3
        ΑΛΛΙΩΣ
         ΧΡ<--500*0.5+100*0.3+(ΒΑΡΟΣ-1500)*0.1
        ΤΕΛΟΣ_ΑΝ
        ΣΥΝΟΛΟ<--ΣΥΝΟΛΟ+ΧΡ
     ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΤΟ ΔΕΜΑ ΔΕ ΧΩΡΑΕΙ'
        ΔΕ_ΜΠΗΚΑΝ<--ΔΕ_ΜΠΗΚΑΝ+1
     ΤΕΛΟΣ_ΑΝ
     ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΣΥΝΕΧΙΣΕΙΣ;;'
     ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤΗΣΗ='ΟΧΙ'
    ΓΡΑΨΕ ΔΕ_ΜΠΗΚΑΝ,ΣΥΝΟΛΟ,Π
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Κ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],ΔΕΙΓΜΑ,ΑΠ[20,100]
ΑΡΧΗ

 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
  ΔΙΑΒΑΣΕ Π[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     Κ<--0
     ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΟΣΟ ΔΕΙΓΜΑ<>'ΤΕΛΟΣ' ΚΑΙ Κ<100 ΕΠΑΝΑΛΑΒΕ
         Κ<--Κ+1
         ΑΠ[Ι,Κ]<--ΔΕΙΓΜΑ
         ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Ξ ΑΠΟ Κ+1 ΜΕΧΡΙ 100
         ΑΠ[Ι,Ξ]<--'Χ'
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΘΕΤΙΚΑ[Ι]<--0
     ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ
         ΑΝ ΑΠ[Ι,Ξ]='Θ' ΤΟΤΕ
            ΘΕΤΙΚΑ[Ι]<--ΘΕΤΙΚΑ[Ι]+1
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΜΑΧ<-- -1
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]>ΜΑΧ ΤΟΤΕ
        ΜΑΧ<--ΘΕΤΙΚΑ[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]=ΜΑΧ ΤΟΤΕ
        ΓΡΑΨΕ Π[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΡΑΨΕ Π[Ι],ΘΕΤΙΚΑ[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Τ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],Τ2
 ΑΡΧΗ
     ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
      ΓΙΑ Ξ ΑΠΟ 20 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
       ΑΝ ΘΕΤΙΚΑ[Ξ-1]<ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          Τ<--ΘΕΤΙΚΑ[Ξ-1]
          ΘΕΤΙΚΑ[Ξ-1]<--ΘΕΤΙΚΑ[Ξ]
          ΘΕΤΙΚΑ[Ξ]<--Τ
          Τ2<--Π[Ξ-1]
          Π[Ξ-1]<--Π[Ξ]
          Π[Ξ]<--Τ2
       ΑΛΛΙΩΣ_ΑΝ ΘΕΤΙΚΑ[Ξ-1]=ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          ΑΝ Π[Ξ-1]>Π[Ξ] ΤΟΤΕ
            Τ2<--Π[Ξ-1]
            Π[Ξ-1]<--Π[Ξ]
            Π[Ξ]<--Τ2
          ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #11 στις: 24 Ιούν 2020, 11:29:45 πμ »
Και το Α+9 είναι σωστό
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

NIKOS_KALYVAS

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #12 στις: 24 Ιούν 2020, 11:30:39 πμ »
Ενδεικτικές απαντήσεις
« Τελευταία τροποποίηση: 24 Ιούν 2020, 11:45:33 πμ από NIKOS_KALYVAS »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #13 στις: 24 Ιούν 2020, 11:32:35 πμ »
Το Α4 έχει παραπάνω από μια απαντήσεις. Προσοχή!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #14 στις: 24 Ιούν 2020, 11:36:18 πμ »
Έχετε δίκιο παιδιά, ευχαριστώ.