Αποστολέας Θέμα: Λύσεις και Σχολιασμός των θεμάτων  (Αναγνώστηκε 2406 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Λύσεις και Σχολιασμός των θεμάτων
« στις: 23 Ιούν 2020, 09:25:41 μμ »
Εδώ ανεβάζουμε τα θέματα τις λύσεις τους και σχολιάζουμε.
Καλή επιτυχία στην επιτροπή (λογικά είναι ήδη μέσα).
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #1 στις: 23 Ιούν 2020, 09:28:49 μμ »
Σαφή θέματα με διαβάθμιση δυσκολίας, που να μην περιλαμβάνουν θολά σημεία της ύλης...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 334
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #2 στις: 23 Ιούν 2020, 09:32:51 μμ »
Ευχόμαστε όλοι ολόψυχα τα θέματα να είναι όσο πιο σαφή γίνεται.

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 78
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #3 στις: 24 Ιούν 2020, 07:57:44 πμ »
Καλημέρα και καλή τύχη σε όλα τα παιδιά! Εύχομαι τα θέματα να είναι σωστά διατυπωμένα!

Θα σχολιάσουμε και τα θέματα με το παλιό σύστημα;

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #4 στις: 24 Ιούν 2020, 08:28:03 πμ »
Εύχομαι ολόψυχα τα θέματα να ειναι αυτά που έλυσα χθες βράδυ στα παιδιά.











Χαχαχαχαχαχα πλάκα κάνω, καλη επιτυχία! Μακάρι να απαλλαγουμε φέτος από κάθε ασάφεια..
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #5 στις: 24 Ιούν 2020, 10:06:50 πμ »
Θέματα Πληροφορικής 2020
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

methenitis

  • Θαμώνας
  • ***
  • Μηνύματα: 45
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #6 στις: 24 Ιούν 2020, 10:46:32 πμ »
Μια πρώτη εκτίμηση..
Δεν βλέπω τεράστια διαφορά με πέρσι.

Υπάρχουν βέβαια αρκετά σημεία που πρέπει να ειναι προσεκτικός ο μαθητής.
Το 5ο σωστο λάθος δεν μου άρεσε ιδιαίτερα.
Α-Β πιστεύω ανετα τα βγάζουν οι διαβασμένοι.
Το θέμα Γ μου άρεσε, άρκετα μεγάλο και σύνθετο αλλά δεν είναι κάτι που δεν έχουμε ασχοληθεί οι περισσότεροι.
Το θεμα Δ θα ηθελα ενα πιο δύσκολο ερώτημα.
Εκτός απο το Δ2β που οι περισσότεροι θα έχουν χάσει κάποιες μονάδες απο τις 5 , κατα τα άλλα ηταν πολύ στρωτο.

Αντε , ελπίζω ολοι να είχαν καθαρό μυαλό και να πήραν το καλύτερο που μπορούσαν.

Καλά αποτελέσματα σε όλους.

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #7 στις: 24 Ιούν 2020, 11:17:47 πμ »
Λύσεις στο πολύ μπαμ μπάμ
Ωραίο το Δ' θέμα τυπικές επεξεργασίες πινάκων απλά με "ιδιαίτερο" διάβασμα πινάκων
το θέμα 3ο με πονηριές (στην εκφώνηση του κλιμακωτού κυρίως + τον έλεγχο για μη υπέρβαση ορίου βάρους)
Α-Β είχαν απ' όλα τα καλά!

Κώδικας: [Επιλογή]
!!ΘΕΜΑ_Α
Α1.
1. Λ
2. Σ
3. Σ
4. Λ
5. Σ

Α2.
α)
1) εύρεση αθροισμάτων
2) υπολογισμός μέγιστων-ελαχίστων
3) ταξινόμηση
4) αναζήτησ
5) συγχώνευση

β)
1. Ο αριθμός των πραγματικών και τυπικών παραμέτρων πρέπει να είναι ο ίδιος.
2. Κάθε πραγματική παράμετρος αντιστοιχεί στην αντίστοιχη τυπική.
3. Η πραγματική παράμετρος και η αντίστοιχή της τυπική πρέπει να είναι του ίδιου τύπου
γ) 4 εκ των
 ΗΜ(),ΣΥΝ(),ΛΟΓ(),Ε(),Τ_Ρ(),Α_Τ(),Τ_Ρ(),Α_Μ()

 Α3.
 α)
 ι)3 απωθήσεις
 ιι) το top βρίσκεται στην 3η θέση, άρα Η στοίβα έχει 3 στοιχεία, άρα χρειάζονται 3 απωθήσεις
 β)
 ι) 2 εξαγωγές
 ιι) το πλήθος των στοιχείων της ουράς είναι
     rear-front+1=4-3+1=2, οπότε 2 εξαγωγές

Α4.
 α)
 ι) 3
 ιι) 0
 ιιι) 1
 β) Α+10


 !!ΘΕΜΑ Β
 Β1.
  ΑΝ Χ=7 ΤΟΤΕ
   ΓΡΑΨΕ 'Α'
  ΑΛΛΙΩΣ_ΑΝ Χ=11 Η Χ=13 ΤΟΤΕ
   ΓΡΑΨΕ 'Β'
  ΑΛΛΙΩΣ_ΑΝ Χ<20 ΤΟΤΕ
   ΓΡΑΨΕ 'Γ'
  ΑΛΛΙΩΣ_ΑΝ Χ>=50 ΚΑΙ Χ<=100 ΤΟΤΕ
   ΓΡΑΨΕ 'Δ'
  ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Ε'
  ΤΕΛΟΣ_ΑΝ

Β2.
 1. ΑΛΗΘΗΣ
 2. 2
 3.  Ν MOD ι
 4.  ΨΕΥΔΗΣ
 5.  ΠΡΩΤΟΣ=ΨΕΥΔΗΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_3
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:Π,ΔΕ_ΜΠΗΚΑΝ
 ΠΡΑΓΜΑΤΙΚΕΣ:ΟΡΙΟ,ΜΕΣΑ,ΒΑΡΟΣ,ΧΡ,ΣΥΝΟΛΟ
 ΧΑΡΑΚΤΗΡΕΣ:ΑΠΑΝΤΗΣΗ
ΑΡΧΗ
    ΔΙΑΒΑΣΕ ΟΡΙΟ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΜΕΣΑ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΣΑ<ΟΡΙΟ
    ΔΕ_ΜΠΗΚΑΝ<--0
    ΣΥΝΟΛΟ<--0
    Π<--0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΒΑΡΟΣ
     ΑΝ ΜΕΣΑ+ΒΑΡΟΣ<=ΟΡΙΟ ΤΟΤΕ
        ΜΕΣΑ<--ΜΕΣΑ+ΒΑΡΟΣ
        ΑΝ ΒΑΡΟΣ>1000 ΤΟΤΕ
           Π<--Π+1
        ΤΕΛΟΣ_ΑΝ
        ΑΝ ΒΑΡΟΣ<=500 ΤΟΤΕ
         ΧΡ<--0.5*ΒΑΡΟΣ
        ΑΛΛΙΩΣ_ΑΝ ΒΑΡΟΣ<=1500 ΤΟΤΕ
         ΧΡ<--500*0.5+(ΒΑΡΟΣ-500)*0.3
        ΑΛΛΙΩΣ
         ΧΡ<--500*0.5+100*0.3+(ΒΑΡΟΣ-1500)*0.1
        ΤΕΛΟΣ_ΑΝ
        ΣΥΝΟΛΟ<--ΣΥΝΟΛΟ+ΧΡ
     ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΤΟ ΔΕΜΑ ΔΕ ΧΩΡΑΕΙ'
        ΔΕ_ΜΠΗΚΑΝ<--ΔΕ_ΜΠΗΚΑΝ+1
     ΤΕΛΟΣ_ΑΝ
     ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΣΥΝΕΧΙΣΕΙΣ;;'
     ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤΗΣΗ='ΟΧΙ'
    ΓΡΑΨΕ ΔΕ_ΜΠΗΚΑΝ,ΣΥΝΟΛΟ,Π
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Κ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],ΔΕΙΓΜΑ,ΑΠ[20,100]
ΑΡΧΗ

 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
  ΔΙΑΒΑΣΕ Π[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     Κ<--0
     ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΟΣΟ ΔΕΙΓΜΑ<>'ΤΕΛΟΣ' ΚΑΙ Κ<100 ΕΠΑΝΑΛΑΒΕ
         Κ<--Κ+1
         ΑΠ[Ι,Κ]<--ΔΕΙΓΜΑ
         ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Ξ ΑΠΟ Κ+1 ΜΕΧΡΙ 100
         ΑΠ[Ι,Ξ]<--'Χ'
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΘΕΤΙΚΑ[Ι]<--0
     ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ
         ΑΝ ΑΠ[Ι,Ξ]='Θ' ΤΟΤΕ
            ΘΕΤΙΚΑ[Ι]<--ΘΕΤΙΚΑ[Ι]+1
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΜΑΧ<-- -1
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]>ΜΑΧ ΤΟΤΕ
        ΜΑΧ<--ΘΕΤΙΚΑ[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]=ΜΑΧ ΤΟΤΕ
        ΓΡΑΨΕ Π[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΡΑΨΕ Π[Ι],ΘΕΤΙΚΑ[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Τ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],Τ2
 ΑΡΧΗ
     ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
      ΓΙΑ Ξ ΑΠΟ 20 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
       ΑΝ ΘΕΤΙΚΑ[Ξ-1]<ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          Τ<--ΘΕΤΙΚΑ[Ξ-1]
          ΘΕΤΙΚΑ[Ξ-1]<--ΘΕΤΙΚΑ[Ξ]
          ΘΕΤΙΚΑ[Ξ]<--Τ
          Τ2<--Π[Ξ-1]
          Π[Ξ-1]<--Π[Ξ]
          Π[Ξ]<--Τ2
       ΑΛΛΙΩΣ_ΑΝ ΘΕΤΙΚΑ[Ξ-1]=ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          ΑΝ Π[Ξ-1]>Π[Ξ] ΤΟΤΕ
            Τ2<--Π[Ξ-1]
            Π[Ξ-1]<--Π[Ξ]
            Π[Ξ]<--Τ2
          ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

methenitis

  • Θαμώνας
  • ***
  • Μηνύματα: 45
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #8 στις: 24 Ιούν 2020, 11:20:15 πμ »
νομιζω στο Α4 β ειναι Μ=Α+8

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 39
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #9 στις: 24 Ιούν 2020, 11:20:25 πμ »
Στην λύση σου στο Α4 β) θεωρώ οτι το Α+10 δεν είναι σωστό.. θα μπείς 6 φορές!!

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ

  • Βετεράνος
  • ****
  • Μηνύματα: 78
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #10 στις: 24 Ιούν 2020, 11:21:21 πμ »
Στο Α4β με Α+10 θα κανει 6 επαναληψεις


Λύσεις στο πολύ μπαμ μπάμ
Ωραίο το Δ' θέμα τυπικές επεξεργασίες πινάκων απλά με "ιδιαίτερο" διάβασμα πινάκων
το θέμα 3ο με πονηριές (στην εκφώνηση του κλιμακωτού κυρίως + τον έλεγχο για μη υπέρβαση ορίου βάρους)
Α-Β είχαν απ' όλα τα καλά!

Κώδικας: [Επιλογή]
!!ΘΕΜΑ_Α
Α1.
1. Λ
2. Σ
3. Σ
4. Λ
5. Σ

Α2.
α)
1) εύρεση αθροισμάτων
2) υπολογισμός μέγιστων-ελαχίστων
3) ταξινόμηση
4) αναζήτησ
5) συγχώνευση

β)
1. Ο αριθμός των πραγματικών και τυπικών παραμέτρων πρέπει να είναι ο ίδιος.
2. Κάθε πραγματική παράμετρος αντιστοιχεί στην αντίστοιχη τυπική.
3. Η πραγματική παράμετρος και η αντίστοιχή της τυπική πρέπει να είναι του ίδιου τύπου
γ) 4 εκ των
 ΗΜ(),ΣΥΝ(),ΛΟΓ(),Ε(),Τ_Ρ(),Α_Τ(),Τ_Ρ(),Α_Μ()

 Α3.
 α)
 ι)3 απωθήσεις
 ιι) το top βρίσκεται στην 3η θέση, άρα Η στοίβα έχει 3 στοιχεία, άρα χρειάζονται 3 απωθήσεις
 β)
 ι) 2 εξαγωγές
 ιι) το πλήθος των στοιχείων της ουράς είναι
     rear-front+1=4-3+1=2, οπότε 2 εξαγωγές

Α4.
 α)
 ι) 3
 ιι) 0
 ιιι) 1
 β) Α+10


 !!ΘΕΜΑ Β
 Β1.
  ΑΝ Χ=7 ΤΟΤΕ
   ΓΡΑΨΕ 'Α'
  ΑΛΛΙΩΣ_ΑΝ Χ=11 Η Χ=13 ΤΟΤΕ
   ΓΡΑΨΕ 'Β'
  ΑΛΛΙΩΣ_ΑΝ Χ<20 ΤΟΤΕ
   ΓΡΑΨΕ 'Γ'
  ΑΛΛΙΩΣ_ΑΝ Χ>=50 ΚΑΙ Χ<=100 ΤΟΤΕ
   ΓΡΑΨΕ 'Δ'
  ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Ε'
  ΤΕΛΟΣ_ΑΝ

Β2.
 1. ΑΛΗΘΗΣ
 2. 2
 3.  Ν MOD ι
 4.  ΨΕΥΔΗΣ
 5.  ΠΡΩΤΟΣ=ΨΕΥΔΗΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_3
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:Π,ΔΕ_ΜΠΗΚΑΝ
 ΠΡΑΓΜΑΤΙΚΕΣ:ΟΡΙΟ,ΜΕΣΑ,ΒΑΡΟΣ,ΧΡ,ΣΥΝΟΛΟ
 ΧΑΡΑΚΤΗΡΕΣ:ΑΠΑΝΤΗΣΗ
ΑΡΧΗ
    ΔΙΑΒΑΣΕ ΟΡΙΟ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΜΕΣΑ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΣΑ<ΟΡΙΟ
    ΔΕ_ΜΠΗΚΑΝ<--0
    ΣΥΝΟΛΟ<--0
    Π<--0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ ΒΑΡΟΣ
     ΑΝ ΜΕΣΑ+ΒΑΡΟΣ<=ΟΡΙΟ ΤΟΤΕ
        ΜΕΣΑ<--ΜΕΣΑ+ΒΑΡΟΣ
        ΑΝ ΒΑΡΟΣ>1000 ΤΟΤΕ
           Π<--Π+1
        ΤΕΛΟΣ_ΑΝ
        ΑΝ ΒΑΡΟΣ<=500 ΤΟΤΕ
         ΧΡ<--0.5*ΒΑΡΟΣ
        ΑΛΛΙΩΣ_ΑΝ ΒΑΡΟΣ<=1500 ΤΟΤΕ
         ΧΡ<--500*0.5+(ΒΑΡΟΣ-500)*0.3
        ΑΛΛΙΩΣ
         ΧΡ<--500*0.5+100*0.3+(ΒΑΡΟΣ-1500)*0.1
        ΤΕΛΟΣ_ΑΝ
        ΣΥΝΟΛΟ<--ΣΥΝΟΛΟ+ΧΡ
     ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΤΟ ΔΕΜΑ ΔΕ ΧΩΡΑΕΙ'
        ΔΕ_ΜΠΗΚΑΝ<--ΔΕ_ΜΠΗΚΑΝ+1
     ΤΕΛΟΣ_ΑΝ
     ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΣΥΝΕΧΙΣΕΙΣ;;'
     ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤΗΣΗ='ΟΧΙ'
    ΓΡΑΨΕ ΔΕ_ΜΠΗΚΑΝ,ΣΥΝΟΛΟ,Π
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Κ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],ΔΕΙΓΜΑ,ΑΠ[20,100]
ΑΡΧΗ

 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
  ΔΙΑΒΑΣΕ Π[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     Κ<--0
     ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΟΣΟ ΔΕΙΓΜΑ<>'ΤΕΛΟΣ' ΚΑΙ Κ<100 ΕΠΑΝΑΛΑΒΕ
         Κ<--Κ+1
         ΑΠ[Ι,Κ]<--ΔΕΙΓΜΑ
         ΔΙΑΒΑΣΕ ΔΕΙΓΜΑ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Ξ ΑΠΟ Κ+1 ΜΕΧΡΙ 100
         ΑΠ[Ι,Ξ]<--'Χ'
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΘΕΤΙΚΑ[Ι]<--0
     ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ
         ΑΝ ΑΠ[Ι,Ξ]='Θ' ΤΟΤΕ
            ΘΕΤΙΚΑ[Ι]<--ΘΕΤΙΚΑ[Ι]+1
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΜΑΧ<-- -1
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]>ΜΑΧ ΤΟΤΕ
        ΜΑΧ<--ΘΕΤΙΚΑ[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ ΘΕΤΙΚΑ[Ι]=ΜΑΧ ΤΟΤΕ
        ΓΡΑΨΕ Π[Ι]
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΡΑΨΕ Π[Ι],ΘΕΤΙΚΑ[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(Π,ΘΕΤΙΚΑ)
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ξ,Τ,ΘΕΤΙΚΑ[20]
  ΧΑΡΑΚΤΗΡΕΣ:Π[20],Τ2
 ΑΡΧΗ
     ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
      ΓΙΑ Ξ ΑΠΟ 20 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
       ΑΝ ΘΕΤΙΚΑ[Ξ-1]<ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          Τ<--ΘΕΤΙΚΑ[Ξ-1]
          ΘΕΤΙΚΑ[Ξ-1]<--ΘΕΤΙΚΑ[Ξ]
          ΘΕΤΙΚΑ[Ξ]<--Τ
          Τ2<--Π[Ξ-1]
          Π[Ξ-1]<--Π[Ξ]
          Π[Ξ]<--Τ2
       ΑΛΛΙΩΣ_ΑΝ ΘΕΤΙΚΑ[Ξ-1]=ΘΕΤΙΚΑ[Ξ] ΤΟΤΕ
          ΑΝ Π[Ξ-1]>Π[Ξ] ΤΟΤΕ
            Τ2<--Π[Ξ-1]
            Π[Ξ-1]<--Π[Ξ]
            Π[Ξ]<--Τ2
          ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #11 στις: 24 Ιούν 2020, 11:29:45 πμ »
Και το Α+9 είναι σωστό
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

NIKOS_KALYVAS

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #12 στις: 24 Ιούν 2020, 11:30:39 πμ »
Ενδεικτικές απαντήσεις
« Τελευταία τροποποίηση: 24 Ιούν 2020, 11:45:33 πμ από NIKOS_KALYVAS »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #13 στις: 24 Ιούν 2020, 11:32:35 πμ »
Το Α4 έχει παραπάνω από μια απαντήσεις. Προσοχή!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #14 στις: 24 Ιούν 2020, 11:36:18 πμ »
Έχετε δίκιο παιδιά, ευχαριστώ.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #15 στις: 24 Ιούν 2020, 11:39:20 πμ »
Δεν βλέπω τεράστια διαφορά με πέρσι.

Υπάρχουν βέβαια αρκετά σημεία που πρέπει να ειναι προσεκτικός ο μαθητής.

πέρσι δεν ... υπήρχαν τέτοια σημεία


Καλή επιτυχία και καλή συνέχεια...

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 152
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #16 στις: 24 Ιούν 2020, 03:12:33 μμ »
καλά τα θέματα, εύκολα γενικά,
ίσως τόσο εύκολα που δε θα ξεχωρίσει ο άριστος από τον πολύ καλό

φέτος πιστεύω τα ποσοστά μας κάτω από τη βάση θα μειωθούνε

απ'όσους έχω μιλήσει, προβλήματα υπάρχουν κυρίως στο Δ2 και στο Α3

NiColas1957

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 319
  • Animus Facit Nobilem
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #17 στις: 24 Ιούν 2020, 03:41:56 μμ »
Το Α4 έχει παραπάνω από μια απαντήσεις. Προσοχή!

Νίκος Καλυβάς  Πολύ καλά :)
Όμως, στο Θέμα_Γ  νομίζω θέλει να προσθέσεις και μια εντολή  ΓΡΑΨΕ Κ   
πριν το ΣΕ<--ΣΕ + Κ
Γιατί θέλει να υπολογίζει και να Εμφανίζει το κόστος κάθε φορτίου. 


P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #18 στις: 24 Ιούν 2020, 03:47:12 μμ »
αν έχουν διαβαστεί 100 στοιχεία (στο Δ2)
δεν πρέπει να διαβαστεί 101 στοιχείο

Στο Β2, το κενό 3 είναι:   n > 2 ΚΑΙ n mod i

NIKOS_KALYVAS

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #19 στις: 24 Ιούν 2020, 04:03:08 μμ »
αν έχουν διαβαστεί 100 στοιχεία (στο Δ2)
δεν πρέπει να διαβαστεί 101 στοιχείο

Παναγιώτη  η Για και με 101 να ξεκινήσει δε θα κάνει καμία επανάληψη

NIKOS_KALYVAS

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #20 στις: 24 Ιούν 2020, 04:05:34 μμ »
Νίκος Καλυβάς  Πολύ καλά :)
Όμως, στο Θέμα_Γ  νομίζω θέλει να προσθέσεις και μια εντολή  ΓΡΑΨΕ Κ   
πριν το ΣΕ<--ΣΕ + Κ
Γιατί θέλει να υπολογίζει και να Εμφανίζει το κόστος κάθε φορτίου. 


Σωστή παρατηρηση

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #21 στις: 24 Ιούν 2020, 04:16:05 μμ »
αν έχουν διαβαστεί 100 στοιχεία (στο Δ2)
δεν πρέπει να διαβαστεί 101 στοιχείο
https://alkisg.mysch.gr/steki/Themes/default/images/smflogo.png
Στο Β2, το κενό 3 είναι:   n > 2 ΚΑΙ n mod i

Παναγιώτη θεωρείς πως το έβαλαν έτσι από την αρχή, έτσι το σκέφτηκαν δηλαδή να λυθεί ?? κατά την ταπεινή μου γνώμη τους "ξέφυγε" το 2, όλα καλά συμβαίνουν αυτά (αν και σε πανελλήνιες θα έπρεπε να μη συμβάινουν προφανώς, αλλά οκ) ... αλλά θε πρέπει να το πάρουν σωστό μόνο με το nmod2, όταν το κενό είναι   ____=0  ""προφανώς"" (σε πολλά "") λείπει αριθμητική έκφραση, όχι μισή αριθμητική και μισή λογική ...

ΔΗΜΗΤΡΗΣ Χ

  • Βετεράνος
  • ****
  • Μηνύματα: 69
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #22 στις: 24 Ιούν 2020, 04:18:01 μμ »
Μια ερωτηση.
Τελικα το νεο βιβλιο γιατι εμεινε στην υλη και τρεχαμε;
Γιατι και το επιλεξε υπηρχε, και οι θεωρητικες για την στοιβα ουρα, και το σ-λ για τα λαθη μπορουσε να βγει...
Αντε πες για τις τελειες στο επιλεξε...
Γιατι οταν βγηκε η υλη δεν αφαιρεθηκε και ολα τα συγγενη κεφαλαια;
Με καθε σεβασμο προς επιτροπη κλπ, νομιζω πως τελικα το καινουριο βιβλιο, επρεπε τελικα να ειχε αφαιρεθει, βασει των θεματων, και να μην παιδευονταν οι μαθητες και οι καθηγητες αδικα...
Οπως και να εχει, καλη συνεχεια σε ολους.

Υγ : συμφωνω με Μανωλη Λαμπρακη για το Β2 οτι τους ξεφυγε... Εδω δεν το ειχαμε παρει ειδηση ολοι εμεις τοσες ωρες, θα το επαιρνε ο μαθητης;

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #23 στις: 24 Ιούν 2020, 04:19:08 μμ »
Μια ερωτηση.
Τελικα το νεο βιβλιο γιατι εμεινε στην υλη και τρεχαμε;
Γιατι και το επιλεξε υπηρχε, και οι θεωρητικες για την στοιβα ουρα, και το σ-λ για τα λαθη μπορουσε να βγει...
Αντε πες για τις τελειες στο επιλεξε...
Γιατι οταν βγηκε η υλη δεν αφαιρεθηκε και ολα τα συγγενη κεφαλαια;
Με καθε σεβασμο προς επιτροπη κλπ, νομιζω πως τελικα το καινουριο βιβλιο, επρεπε τελικα να ειχε αφαιρεθει, βασει των θεματων, και να μην παιδευονταν οι μαθητες και οι καθηγητες αδικα...
Οπως και να εχει, καλη συνεχεια σε ολους.

Συμφωνώ Δημήτρη ..

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #24 στις: 24 Ιούν 2020, 04:20:26 μμ »
Παναγιώτη θεωρείς πως το έβαλαν έτσι από την αρχή, έτσι το σκέφτηκαν δηλαδή να λυθεί ?? κατά την ταπεινή μου γνώμη τους "ξέφυγε" το 2, όλα καλά συμβαίνουν αυτά (αν και σε πανελλήνιες θα έπρεπε να μη συμβάινουν προφανώς, αλλά οκ) ... αλλά θε πρέπει να το πάρουν σωστό μόνο με το nmod2, όταν το κενό είναι   ____=0  ""προφανώς"" (σε πολλά "") λείπει αριθμητική έκφραση, όχι μισή αριθμητική και μισή λογική ...
Συμφωνώ απόλυτα με το Μανώλη και αναρωτιέμαι αν ο Παναγιώτης δίνει τη γνώμη του ή τη λύση που έδωσε η επιτροπή ;
Φιλικά,
Γιώργος Θαλασσινός

themata

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #25 στις: 24 Ιούν 2020, 05:43:06 μμ »
καλησπέρα, ιδιαίτερες εκπλήξεις δεν είδαμε στα θέματα περαν των λεπτομερειων που αναφερθηκαν,
θεωρώ και εγώ ότι τα ποσοστά κάτω απο τη βάση λογικά θα μειωθούν φέτος

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #26 στις: 24 Ιούν 2020, 06:27:27 μμ »
αν έχουν διαβαστεί 100 στοιχεία (στο Δ2)
δεν πρέπει να διαβαστεί 101 στοιχείο
Παναγιώτη  η Για και με 101 να ξεκινήσει δε θα κάνει καμία επανάληψη


J<-1
ΔΙΑΒΑΣΕ ΑΔ ! αποτέλεσμα δείγματος με τιμές Θ,Α,ΤΕΛΟΣ
ΟΣΟ (J<=100 ΚΑΙ ΑΔ<>’ΤΕΛΟΣ’) ΕΠΑΝΑΛΑΒΕ
ΑΠ[Ι,J]<-ΑΔ
J<-J+1
AN J <= 100 TOTE
ΔΙΑΒΑΣΕ ΑΔ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΟΙ ΠΡΟΣΘΗΚΕΣ ΣΤΗ ΛΥΣΗ ΣΟΥ ΝΙΚΟ ΜΕ ΕΝΤΟΝΑ ΓΡΑΜΜΑΤΑ

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 565
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #27 στις: 24 Ιούν 2020, 06:29:17 μμ »
Στο ΑΝ Πάνο ξέχασες το = ....

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #28 στις: 24 Ιούν 2020, 06:29:27 μμ »
Συμφωνώ απόλυτα με το Μανώλη και αναρωτιέμαι αν ο Παναγιώτης δίνει τη γνώμη του ή τη λύση που έδωσε η επιτροπή ;

Ο Παναγιώτης πάντοτε δίνει τη γνώμη του. Αν είχε σχέση με την επιτροπή θα έβλεπες τριμορφικούς, αναζήτηση σε αραιό πίνακα, ισοβαθμίες μετά από ταξινόμηση και ολίσθηση σε ουρά...

αα και κρυπτογραφία
« Τελευταία τροποποίηση: 24 Ιούν 2020, 06:39:28 μμ από P.Tsiotakis »

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #29 στις: 24 Ιούν 2020, 06:30:08 μμ »
ΟΚ Βαγγέλη, το διόρθωσα.... thanks

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #30 στις: 24 Ιούν 2020, 06:30:24 μμ »
Κώδικας: [Επιλογή]
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
   j <− 1
   διακοπή <− ψευδής
   ΟΣΟ j <= 100 ΚΑΙ διακοπή = ψευδής ΕΠΑΝΑΛΑΒΕ
      ΔΙΑΒΑΣΕ δ
      ΑΝ δ <> 'ΤΕΛΟΣ' ΤΟΤΕ
         ΑΠ[i, j] <− δ
         j <− j + 1
      ΑΛΛΙΩΣ
         διακοπή <− αληθής
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   γεμ <− j
   ΓΙΑ j ΑΠΟ γεμ ΜΕΧΡΙ 100
      ΑΠ[i, j] <− 'X'
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #31 στις: 24 Ιούν 2020, 06:34:52 μμ »
Παναγιώτη θεωρείς πως το έβαλαν έτσι από την αρχή, έτσι το σκέφτηκαν δηλαδή να λυθεί ?? κατά την ταπεινή μου γνώμη τους "ξέφυγε" το 2, όλα καλά συμβαίνουν αυτά (αν και σε πανελλήνιες θα έπρεπε να μη συμβάινουν προφανώς, αλλά οκ) ... αλλά θε πρέπει να το πάρουν σωστό μόνο με το nmod2, όταν το κενό είναι   ____=0  ""προφανώς"" (σε πολλά "") λείπει αριθμητική έκφραση, όχι μισή αριθμητική και μισή λογική ...

το Β2 τους ξέφυγε συμφωνώ και γω
αλλά εμείς νομίζω ότι πρέπει να δώσουμε λύση στο ερώτημα

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #32 στις: 24 Ιούν 2020, 06:46:36 μμ »
το Β2 τους ξέφυγε συμφωνώ και γω
αλλά εμείς νομίζω ότι πρέπει να δώσουμε λύση στο ερώτημα

Απλά Παναγιώτη έγραψα και παραπάνω, άντε και εδώ μπορεί να μπει σε κάποιο κενό, αν ήταν έτσι τα κενά που αυτό δεν ήταν εφικτό ?? για αυτό αναφέρω το "ήταν εξ αρχής κάπως προβληματικό" .. έτσι σαν ιδέα το λέω, μου φαίνεται λίγο περίεργο , όλα καλά  :angel: >:D :D

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #33 στις: 24 Ιούν 2020, 07:23:07 μμ »
Αν όντως  η  ΚΕΕ  στο Β2. (3) έδωσε (αρχικά)   n mod i  και όχι  n <> 2 ΚΑΙ n mod i  , ας μην αναζητούμε την ευθύνη στον μαθητή.

NIKOS_KALYVAS

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #34 στις: 24 Ιούν 2020, 07:52:26 μμ »
Παναγιώτη  η Για και με 101 να ξεκινήσει δε θα κάνει καμία επανάληψη



J<-1
ΔΙΑΒΑΣΕ ΑΔ ! αποτέλεσμα δείγματος με τιμές Θ,Α,ΤΕΛΟΣ
ΟΣΟ (J<=100 ΚΑΙ ΑΔ<>’ΤΕΛΟΣ’) ΕΠΑΝΑΛΑΒΕ
ΑΠ[Ι,J]<-ΑΔ
J<-J+1
AN J <= 100 TOTE
ΔΙΑΒΑΣΕ ΑΔ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΟΙ ΠΡΟΣΘΗΚΕΣ ΣΤΗ ΛΥΣΗ ΣΟΥ ΝΙΚΟ ΜΕ ΕΝΤΟΝΑ ΓΡΑΜΜΑΤΑ
ΟΚ Παναγιώτη. Σε ευχαριστώ.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #35 στις: 24 Ιούν 2020, 11:59:00 μμ »
Θεωρώ αστοχία το "φτύσιμο" στο κεφάλαιο της Εκσφαλμάτωσης στα φετινά θέματα
Είναι ένα κεφάλαιο που διαπερνά όλα τα προηγούμενα, δίνει ωραίες ασκήσεις και ερωτήσεις και θα μπορούσε να ζητηθεί ένα θέμα από εκεί
Είναι ένα κεφάλαιο που δεν απαιτεί διάβασμα από έναν μαθητή, απαιτεί κατανόηση και εξάσκηση σε όλα τα Κεφάλαια

Αλήθεια, το Κεφάλαιο 6 με την ατέλειωτη θεωρία, ενδιαφέρουσα και σημαντική σε κάποια σημεία, γιατί συνεχίζει να υπάρχει στην ύλη, ενώ σπανίως προτιμάται στα θέματα; 3 ερωτήσεις ανάπτυξης, 5 ερωτήσεις κλειστού τύπου και καμία προτίμηση από εκεί
Τελικά, ας πάρουμε μια απόφαση σαν κλάδος να τελειώσουμε την αχρείαστη θεωρία, να δώσουμε 25 μονάδες σε κάθε θέμα και να επιβραβεύσουμε επιτέλους τον μαθητή που μπήκε στο πνεύμα και όχι το γράμμα της επιστήμης μας 

Καλώς δεν ζητήθηκε τίποτα από το Κεφάλαιο 4, μακάρι να μας χαιρετίσει άμεσα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 795
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #36 στις: 25 Ιούν 2020, 01:20:05 μμ »
Να κάνω λίγο τον δικηγόρο του Διαβόλου
Τα θέμα είναι μόνο τέσσερα δεν μπορούν να καλύψουν όλη την ύλη εκτός αν και στα τέσσερα βάλουν 5 υποερωτήματα. 
Η εκσφαλμάτωση ειδικά στον χαρακτηρισμό λάθους είναι ιδιαίτερα προβληματική και έχει δημιουργήσει αρκετές συζητήσεις στο στέκι (π.χ τι λάθος είναι ένας ατέρμων βρόχος;). Άσε που τα δύο βιβλία διαφέρουν ως προς τις κατηγορίες των λαθών.
Θεωρία πρέπει να υπάρχει για πολλούς παιδαγωγικούς λόγους.
Πως μου φάνηκαν τα θέματα;
Γενικά καλά θέματα.
Δυσκολότερα  από τα περσινά, 20 μονάδες γράφουν σχεδόν όλοι (οι άσχετοι). Γύρω στο 60-80 μονάδες ένας σχετικά καλός μαθητής, πάνω από 90 θα είναι λιγότεροι από πέρυσι. 

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #37 στις: 25 Ιούν 2020, 03:11:02 μμ »
Θα κάνω κι εγώ λίγο το δικηγόρο του διαβόλου όσον αφορά τα λάθη Βαγγέλη,
παίρνοντας πάτημα από τη φράση του Πέτρου
Θεωρώ αστοχία το "φτύσιμο" στο κεφάλαιο της Εκσφαλμάτωσης στα φετινά θέματα
Εγώ Πέτρο, δε στεναχωρέθηκα από την απουσία εκσφαλμάτωσης.
Θεωρώ ότι το μόνο κομμάτι που είχε ενδιαφέρον και είχε και ένα νόημα να διδαχθεί από το κεφάλαιο αυτό, ήταν το μαύρο κουτί και τα σενάρια, που αφαιρέθηκε.
Γιατί το θεωρούσα ενδιαφέρον; Γιατί είναι το μόνο που εισάγει μια μεθοδολογία στο πώς δοκιμάζεται ένα πρόγραμμα για να βρεθούν τα λάθη του.
Ήταν το κεφάλαιο που δεν αφήνει την εύρεση λαθών στην τύχη και στην παρατηρητικότητα. Οι ωραιότερες ασκήσεις από εκεί (πριν αφαιρεθεί), ήταν εκείνες που δίναν τις προδιαγραφές και ζητούσαν να φτιάξεις σενάρια ελέγχου.
Από την άλλη πλευρά δυσκολεύομαι να καταλάβω τη σπουδαιότητα των ασκήσεων που δίνουν έναν κώδικά και αφήνουν το μαθητή να περιπλανιέται με τα μάτια του μέχρι να εντοπίσει κάποια λάθη (κι αν δεν είναι τυχερός να χάσει κάποια), όπως δεν καταλαβαίνω γιατί είναι τόσο σημαντικό να χαρακτηρίσει το είδος τους. Δεν εκμηδενίζω τη σπουδαιότητά τους αλλά αλλά δεν τη θεωρώ και ύψιστη.
Φιλικά,
Γιώργος Θαλασσινός

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #38 στις: 25 Ιούν 2020, 06:49:14 μμ »
Από την άλλη πλευρά δυσκολεύομαι να καταλάβω τη σπουδαιότητα των ασκήσεων που δίνουν έναν κώδικά και αφήνουν το μαθητή να περιπλανιέται με τα μάτια του μέχρι να εντοπίσει κάποια λάθη (κι αν δεν είναι τυχερός να χάσει κάποια), όπως δεν καταλαβαίνω γιατί είναι τόσο σημαντικό να χαρακτηρίσει το είδος τους. Δεν εκμηδενίζω τη σπουδαιότητά τους αλλά αλλά δεν τη θεωρώ και ύψιστη.

Γιατί εξασκεί τον εκπαιδευόμενο προγραμματιστή σε ένα πολύ σημαντικό στοιχείο της διαδικασίας προγραμματισμού, το debugging, που συνήθως περιλαμβάνει το 80% της διαδικασίας
Γιατί αναγκάζει τον μαθητή μας, να ασχολείται με αυτή την πρακτική, η οποία (κακά τα ψέμματα), δεν ακολουθείται από τους περισσότερους ακόμα και για τον κώδικα τους
Ακόμα κι αν μιλάμε για τον κώδικα άλλου, η διαδικασία οξύνει την προγραμματιστική ικανότητα

Όταν μιλάω για "φτύσιμο" του κεφαλαίου της Εκσφαλμάτωσης, δεν εννοώ ότι θα έπρεπε να ζητηθεί κάποια παρόμοια (ανούσια) άσκηση με αυτές που περιέχονται, ή να ζητηθεί κάτι που να αφορά κάποιο θολό σημείο στις κατηγορίες λαθών
Να αποτελέσει αφορμή για ένα ωραίο θέμα, όπως και όλα τα υπόλοιπα ελλιπή κεφάλαια του βιβλίου
Γιατί να μην ζητηθεί το θέμα με τους πρώτους αριθμούς σαν άσκηση εκσφαλμάτωσης;

Εγώ δεν καταλαβαίνω τι νόημα έχει η συμπλήρωση κενών σε κώδικα άλλου, ενώ δεν βρίσκουμε νόημα στο να βρούμε λάθη σε συμπληρωμένο κώδικα
Έχουν επικρατήσει κάθε χρόνο θέματα συμπλήρωσης κενού, εύκολα αντιγράψιμα, πολλές φορές απαντώνται στην τύχη
Διδάσκουμε ελευθερία σκέψης και υλοποίησης λύσης, αλλά βάζουμε τα παιδιά να "πατήσουν" σε έτοιμους κώδικες, που είναι επίτηδες (κάποις φορές) "πειραγμένοι" ώστε να κάνουμε την απάντηση δυσκολότερη
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

fan

  • Βετεράνος
  • ****
  • Μηνύματα: 64
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #39 στις: 25 Ιούν 2020, 07:10:07 μμ »
Καλησπέρα
Οι θεματοδοτες δεν θέλησαν να προσαρμόσουν την νέα υλη μέσα στα θέματα
Η άσκηση της ουράς στοίβας είναι μια άσκηση εισαγωγική και έχει ξαναμπεί σε πανελλαδικές  απλά είχε φέτος μια μικρή διαφοροποίηση στο σχεδιασμό της.
Η εκσφαλματωση θα δημιουργούσε πρόβλημα στους μετρίους μαθητές και η άσκηση ουρα στοίβα θα τους αποτελείωνε. Νομιζω ότι ο τρόπος που διδάχτηκε η εκσφαλματωση   εξ αποστάσεως στα σχολεία οδήγησε να μην βάλουν θεματα.(κακώς για μενα).
Αυτό που εμενα δεν μου αρεσει είναι ότι πολλοι μαθητες αφιερωσαν πολλες ωρες για θεωρια( και φετος και με αποστήθιση) .
Tελος νομιζω ότι πρεπει να περιμένουμε φετος το πρόγραμμα σπουδων- οδηγιες στην Β ταξη και ποσο αυτές θα επηρεάσουν την Γ, αν και εκει βλεπω παλι ατολμιες δηλαδή καντε λιγο από όλα και ξανακάντε τα στη Γ.....


gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #40 στις: 26 Ιούν 2020, 04:30:04 μμ »
Γιατί εξασκεί τον εκπαιδευόμενο προγραμματιστή σε ένα πολύ σημαντικό στοιχείο της διαδικασίας προγραμματισμού, το debugging, που συνήθως περιλαμβάνει το 80% της διαδικασίας
Γιαυτό λέω ότι χρειαζότανε το κομμάτι του μαύρου κουτιού. Γιατί θα τον εξασκούσε σε ένα μεθοδευμένο τρόπο να κάνει debugging. Να σκεφτεί τα σενάρια που έχει νόημα να ελέγξει, να εντοπίσει/ελέγξει ακραίες τιμές και να εστιάσει για το πού θα κοιτάξει για το λάθος. Όχι έτσι, κοιτάζοντας τυχαία.
Όσο το να ψάχνει για κάτι συντακτικά, του τύπου λείπει η ΕΠΑΝΑΛΑΒΕ σε μια ΟΣΟ  ή ΤΕΛΟΣ_ΟΣΟ αντί ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ, που κάποιες στιγμές γίνονταν σχεδόν διασκεδαστικά, αλλά και άλλες το μάτι εύκολα μπορούσε να τα παραβλέπει, τι νόημα έχει από τη στιγμή που εντοπίζονται από τα μεταφραστικά προγράμματα και τους σύγχρονους συντάκτες και δεν ξεφεύγεις από αυτά.
« Τελευταία τροποποίηση: 27 Ιούν 2020, 06:37:42 πμ από gthal »
Φιλικά,
Γιώργος Θαλασσινός

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #41 στις: 26 Ιούν 2020, 05:09:38 μμ »
Ο εντοπισμός συντακτικών λαθών, δείχνει αν οι μαθητές ξέρουν το συντακτικό της γλώσσας. Η αυτόματες διορθώσεις, έρχονται κατόπιν εορτής.

Όσο για το να "κοιτάς τυχαία", το υποτιμάς πολύ. Είναι βασικό κομμάτι του debugging, όσο κατσαπλιάδικο και αν φαίνεται. Όταν γράφουμε κώδικα, ειδικά όσο πιο μεγάλο είναι ένα πρόγραμμα, δημιουργούμε μια σειρά από λάθη. Μερικά από αυτά λύνονται με μεθόδους όπως η μαύρο κουτί, και εκεί συμφωνώ ότι είναι καλό να διδάσκονται τέτοιες προσεγγίσεις, σε κεφάλαια εκσφαλμάτωσης. Μερικά όμως δεν λύνονται έτσι. Θέλει εξέταση ο κώδικας, τι να κάνουμε. Δεν μπορείς να λες ότι δεν χρειάζεται, είναι βασική διαδικασία αποσφαλμάτωσης! Η εξάσκηση σε αυτήν, είναι παραπάνω από χρήσιμη.
Επιπρόσθετα, το χειρότερο που κάνουν οι μαθητές συνήθως, είναι ότι γράφουν μια φορά κώδικα και δεν θέλουν να ξανασχοληθούν μαζί του. Το να γυρίσουν να εντοπίσουν τι δεν γράψαν οι ίδιοι σωστά την πρώτη φορά, αντί να τους το υποδείξω εγώ, βρίσκω ότι βοηθάει σημαντικά στην επιπολαιότητα με την οποία αντιμετωπίζουν τις ίδιες τις λύσεις τους. Και όταν διορθώνουν έτοιμο κώδικα, οξύνεται η αντίληψή τους.
Φυσικά συμφωνώ ότι χρειάζεται πολύ πιο σοβαρή αντιμετώπιση για το κεφάλαιο αυτό, και συμφωνώ με Πέτρο, ότι περίμενα κάτι να μπει από εκεί, παρά αυτή η σιωπή.
@ Vangelis
Αυτά είναι προβλήματα που έπρεπε να λυθούν στην τελευταία τροποποίηση της ύλης. Αφού δεν λύθηκαν εκεί, μπορούσαν να μπουν προσεκτικά, κάποια πεδία, ασφαλή. Πχ, βρείτε τα λάθη, χωρίς να ζητάει τι τύπου είναι.
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Λύσεις και Σχολιασμός των θεμάτων
« Απάντηση #42 στις: 26 Ιούν 2020, 05:44:49 μμ »
Ο εντοπισμός συντακτικών λαθών, δείχνει αν οι μαθητές ξέρουν το συντακτικό της γλώσσας. Η αυτόματες διορθώσεις, έρχονται κατόπιν εορτής.
Το δέχομαι για πολύ μικρά κομματάκια κώδικα αλλά βρήκα και ασκήσεις ως και 30 και πλέον γραμμές κώδικα να ψάχνεις για τα συντακτικά.

Όσο για το να "κοιτάς τυχαία", το υποτιμάς πολύ. Είναι βασικό κομμάτι του debugging, όσο κατσαπλιάδικο και αν φαίνεται.
Όχι δε θέλω να το ισοπεδώνω δεν είναι άχρηστο αλλά περιλαμβάνει και τυχαιότητα και δεξιότητες που για κάποιο λόγο δε μου κάθονται ή δε βρίσκω σκόπιμο να αφιερωθεί χρόνος για να ενισχυθούν στα πλαίσια του περιορισμένου χρόνου του μαθήματος κλπ.
Φιλικά,
Γιώργος Θαλασσινός