Αποστολέας Θέμα: Σφάλμα κατά τη σύνδεση του Appinventor2 στον Emulator (aiStarter)  (Αναγνώστηκε 268 φορές)

ilias_s

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 418
Αντιμετώπισα πριν λίγες μέρες το παρακάτω πρόβλημα στον Appinventor στο ένα από τα δύο εργαστήρια στα οποία είμαι υπεύθυνος. Παραθέτω το πρόβλημα (και τη λύση) σε περίπτωση που κάποιος το συναντήσει και προκειμένου να γλιτώσει χρόνο και ψάξιμο!

Πρόβλημα :

Σε εγκατάσταση Ubuntu LTS 18.04.03 64bit (amd64) μετά την εγκατάσταση του appinventor2-setup, ενώ ο aiStarter ξεκινάει κανονικά και περιμένει νέες συνδέσεις, η σύνδεση με τον Emulator δεν είναι δυνατή και το παράθυρο του aiStarter παρουσιάζει το παρακάτω σφάλμα :



Λύση :

Ο aiStarter είναι 32bit εφαρμογή και υπάρχουν ορισμένα (γνωστά) θέματα όταν προσπαθούμε να τον τρέξουμε σε 64bit συστήματα και χρειάζεται ενδεχομένως η εγκατάσταση επιπλέον libraries. Ενώ υπάρχουν οδηγίες ΕΔΩ και αναφέρεται ότι πιθανώς θα χρειαστεί η εγκατάσταση της lib32z1 αυτό δεν ήταν αρκετό στη δική μου περίπτωση.

Εγώ χρειάστηκε να εγκαταστήσω και την lib32stdc++6. Εγκαθίσταται με την εντολή :

Κώδικας: [Επιλογή]
sudo apt-get install lib32stdc++6
Σημείωση :

Toν Appinventor εγκατέστησα και στο δεύτερο εργαστήριο (λυκείου) στο οποίο είμαι υπεύθυνος αλλά εκεί χρειάστηκε μόνο η εγκατάσταση της lib32z1. Προφανώς η άλλη βιβλιοθήκη υπήρχε ήδη και καθώς οι εγκαταστάσεις είναι παρόμοιες, πιθανολογώ ότι αυτό που έκανε τη διαφορά ήταν η εγκατάσταση του Διερμηνευτή (+wine).

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5650
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Σφάλμα κατά τη σύνδεση του Appinventor2 στον Emulator (aiStarter)
« Απάντηση #1 στις: 20 Ιαν 2020, 07:20:01 μμ »
Thanks Ηλία θα κοιτάξω να το προσθέσω στις εξαρτήσεις (Depends:) με την πρώτη ευκαιρία ώστε να προστίθεται αυτόματα.