Αποστολέας Θέμα: Τι μετράει ως εντολή;  (Αναγνώστηκε 238 φορές)

FANBOY_21

  • Οπαδός
  • **
  • Μηνύματα: 14
Τι μετράει ως εντολή;
« στις: 19 Οκτ 2019, 08:15:02 μμ »
Δοκίμαζα την ψευδογλώσσα και τη ΓΛΩΣΣΑ βάζοντας μια κενή ΓΙΑ με σκοπό να εμφανίσω το παράθυρο διαλόγου περί 100.000 ήδη εκτελεσμένων εντολών, και παρατήρησα ότι το πετάει 5-6 εντολές νωρίτερα, μετρώντας τις φορές που θεωρητικά πατάω το F7. Οπότε το θέμα μου είναι:

Τι μετράει ως 1 εντολή ακριβώς; Μήπως υπάρχουν "εντολές" που εκτελούνται κατά την έναρξη της εκτέλεσης του αλγορίθμου (το ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ δε φαίνεται να πιάνεται για εντολή, ούτε το τμήμα δήλωσης μεταβλητών...);

Κώδικας: [Επιλογή]
Αλγόριθμος α
Για ι από 1 μέχρι 99995
Τέλος_επανάληψης
Τέλος

Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 99994
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Οι αριθμοί είναι οι ελάχιστοι που προκαλούν εμφάνιση του μηνύματος περί πιθανού ατέρμονα βρόχου.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Τι μετράει ως εντολή;
« Απάντηση #1 στις: 19 Οκτ 2019, 11:17:51 μμ »
Μη δίνεις σημασία δεν είναι κάποια επίσημη μέτρηση εντολών. Απλά μια ένδειξη ότι μπορεί ο μαθητής να έκανε άπειρο loop.

FANBOY_21

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Τι μετράει ως εντολή;
« Απάντηση #2 στις: 20 Οκτ 2019, 12:40:23 πμ »
Α οπότε είναι "περίπου" 100.000, κατάλαβα.