Αποστολέας Θέμα: ΘΕΜΑΤΑ 2018  (Αναγνώστηκε 8157 φορές)

ΤΙΜ

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 36
ΘΕΜΑΤΑ 2018
« στις: 13 Ιούν 2018, 12:05:29 μμ »
Καλημέρα σε όλους πως σας φάνηκαν τα θέματα ;

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #1 στις: 13 Ιούν 2018, 12:12:10 μμ »
Παγιδούλα στο διάγραμμα ροής, όλα τα άλλα μου φάνηκαν φυσιολογικά. Θα ήθελα το υποπρόγραμμα να πιάνει λιγότερο στο 4ο θέμα και το Δ4 που ήθελε άθροισμα γραμμής, ταξινόμηση και εμφάνιση μετά να πιάνει πιο πολλές μονάδες από 4.

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 563
  • There can be only one...may it be AEPP.
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #2 στις: 13 Ιούν 2018, 12:53:40 μμ »
Στο Α4 δεχόμαστε και αναποδα τις ακολουθίες;
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #3 στις: 13 Ιούν 2018, 12:59:58 μμ »
Λογικά θέματα ... ανεβάζω τις λύσεις να ρίξετε και εσείς μία ματιά μήπως ξέφυγε τίποτα ...

Ευχαριστώ.


P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3304
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #4 στις: 13 Ιούν 2018, 01:09:32 μμ »
έχουμε λύσει τις ασκήσεις με τον ίδιο τρόπο, απλά ειχα άλλα άλλα ονόματα μεταβλητών ...

π.χ. i, j  :P

Λογικά θέματα ... ανεβάζω τις λύσεις να ρίξετε και εσείς μία ματιά μήπως ξέφυγε τίποτα ...

Ευχαριστώ.



petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #5 στις: 13 Ιούν 2018, 01:13:10 μμ »
Αρκετά πιο δύσκολα σε σχέση με πέρσι για τον μέσο μαθητή
Προσωπική αποψη
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #6 στις: 13 Ιούν 2018, 01:18:04 μμ »
έχουμε λύσει τις ασκήσεις με τον ίδιο τρόπο, απλά ειχα άλλα άλλα ονόματα μεταβλητών ...

π.χ. i, j  :P


Μάλλον γιατί είναι ο πλέον λογικός τρόπος λύσεις τους ...  ;)

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #7 στις: 13 Ιούν 2018, 01:42:01 μμ »
Θεωρητικά το διάγραμμα ροής δε γίνεται και με ΜΕΧΡΙΣ_ΟΤΟΥ;;

ΔΙΑΒΑΣΕ Σ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ Α
   ΑΝ Α<>0 ΤΟΤΕ
      Σ<-Σ+Α
      ΔΙΑΒΑΣΕ Α
   ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΕΜΦΑΝΙΣΕ Σ

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #8 στις: 13 Ιούν 2018, 01:48:54 μμ »
Θεωρητικά το διάγραμμα ροής δε γίνεται και με ΜΕΧΡΙΣ_ΟΤΟΥ;;

ΔΙΑΒΑΣΕ Σ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ Α
   ΑΝ Α<>0 ΤΟΤΕ
      Σ<-Σ+Α
      ΔΙΑΒΑΣΕ Α
   ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΕΜΦΑΝΙΣΕ Σ


Νομίζω το δεύτερο διάβασε πρέπει να φύγει ...


ΔΙΑΒΑΣΕ Σ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ Α
   ΑΝ Α<>0 ΤΟΤΕ
      Σ<-Σ+Α
   ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΕΜΦΑΝΙΣΕ Σ

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #9 στις: 13 Ιούν 2018, 01:52:00 μμ »
Ναι έχεις δίκιο, από τη βιασύνη μου.
Ευχαριστώ.

ilias_s

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 418
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #10 στις: 13 Ιούν 2018, 01:52:33 μμ »
Έχω την αίσθηση πως ήταν δυσκολότερα από πέρυσι. Περιμένω πως ο μέσος μαθητής θα αντιμετώπιζε μία δυσκολία στο Θέμα Γ λόγω του αριθμού των μεταβλητών που έπρεπε να χρησιμοποιεί. Νομίζω πως το υποπρόγραμμα του Δ5, που έδινε 8 μονάδες, δεν ήταν κάτι δύσκολο αλλά ζόρικο ήταν το Δ4 που έδινε μόνο 4 μονάδες.

Επίσης υπήρχαν σημεία και στα Α και Β που θα έπρεπε κάποιος να προσέξει περισσότερο (π.χ Α1(4), Β2)

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 126
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #11 στις: 13 Ιούν 2018, 02:10:35 μμ »
ξέρετε τις οδηγίες βαθμολόγησης που δοθηκαν στα Φ.Α κέντρα?

xara_pap

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 126
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #12 στις: 13 Ιούν 2018, 02:12:10 μμ »
ξερετε αν θα κοψουν στο διαγραμμα ροης αν κάποιος κάνει ισοδύναμο κώδικα με μεχρις οτου αλλά σωστο?

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #13 στις: 13 Ιούν 2018, 02:38:47 μμ »
Διάβασε Σ
Διάβασε Α
Αν Α <>0 τότε
    Αρχή επανάληψης
         Σ<--Σ+Α
         Διάβασε Α
    Μέχρις ότου Α=0
Τέλος αν
Ενφανισε Σ

Για αυτό το λέτε ?

panawths

  • Νέος
  • *
  • Μηνύματα: 8
Απ: ΘΕΜΑΤΑ 2018
« Απάντηση #14 στις: 13 Ιούν 2018, 02:50:31 μμ »
Θεωρητικά το διάγραμμα ροής δε γίνεται και με ΜΕΧΡΙΣ_ΟΤΟΥ;;

ΔΙΑΒΑΣΕ Σ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ Α
   ΑΝ Α<>0 ΤΟΤΕ
      Σ<-Σ+Α
      ΔΙΑΒΑΣΕ Α
   ΤΕΛΟΣ_ΑΝ
ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΕΜΦΑΝΙΣΕ Σ
Καλησπέρα, σχετικά με την παρακάτω λύση τι παρατηρήσεις έχετε;;
ΔΙΑΒΑΣΕ Σ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΔΙΑΒΑΣΕ Α   
   Σ<-Σ+Α
ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
ΕΜΦΑΝΙΣΕ Σ
Στην περίπτωση που το Α είναι ίσο με 0 εκτελέιται μια παραπάνω εντολη (Σ<-Σ+Α) αλλά το αποτέλεσμα της εντολής ΕΜΦΑΝΙΣΕ Σ δεν αλλάζει καθόλου γιατί γίνεται πρόσθεση με το μήδεν.
Πως θα το βαθμολογούσατε;