Αποστολέας Θέμα: Σταθερές σε αλγόριθμους  (Αναγνώστηκε 2658 φορές)

Wizard

  • Επισκέπτης
Σταθερές σε αλγόριθμους
« στις: 19 Ιαν 2007, 03:37:01 μμ »
Στο τμήμα αλγορίθμου:

Αν χ = 0 τότε
    ψ <- αληθής
Τέλος_αν

οι τιμές 0 και αληθής θεωρούνται σταθερές;

Το ρωτάω αυτό γιατί αν η απάντηση είναι ναι, τότε για το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ:

Κώδικας: Text
  1. ΠΡΟΓΡΑΜΜΑ άσκηση
  2. ΣΤΑΘΕΡΕΣ
  3.     α = 5
  4. ΜΕΤΑΒΛΗΤΕΣ
  5.     ΑΚΕΡΑΙΕΣ: β
  6. ΑΡΧΗ
  7. ΓΡΑΨΕ 'Δώσε αριθμό'
  8. ΔΙΑΒΑΣΕ β
  9. β <-- β + α + 10
  10. ΓΡΑΨΕ 'Η απάντηση είναι', β
  11. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
  12.  

ποιες θεωρούνται σταθερές;
« Τελευταία τροποποίηση: 19 Ιαν 2007, 04:09:53 μμ από Wizard »

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: Σταθερές σε αλγόριθμους
« Απάντηση #1 στις: 20 Ιαν 2007, 11:15:14 πμ »
Δεν αποτελεί η κάθε τιμή σταθερά. Σταθερά θα ήταν π.χ. το ΦΠΑ=19% σε μια άσκηση που σου ζητάει να υπολογίσεις την τελική τιμή, δεχόμενος ως είσοδος την αρχική τιμή 100 προϊόντων. Τότε το ΦΠΑ μπορείς να το χρησιμοποιήσεις σαν σταθερά.Δλδ

ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
ΣΤΑΘΕΡΕΣ
ΦΠΑ=0.19
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ι
ΠΡΑΓΜΑΤΙΚΕΣ:ΑΤ, ΤΤ
ΑΡΧΗ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
ΔΙΑΒΑΣΕ ΑΤ
ΤΤ<- ΑΤ+ΑΤ*ΦΠΑ
ΓΡΑΨΕ ΤΤ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

στο παραπάνω παράδειγμα δεν αποτελούν σταθερές το 1 και το 100, έτσι όπως τα δίνω. Σταθερές είναι μεταβλητές με σταθερή τιμή. Ο λόγος που χρησιμοποιούνται είναι για να αλλάζεις την τιμή τους (π.χ. αν αλλάξει το ΦΠΑ σε 20%) στην αρχή και όχι σε κάθε σημείο του προγράμματος. Σταθερές θα μπορούσες να είχες θέσει και τα άκρα μια επανάληψηςπ.χ.
ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
ΣΤΑΘΕΡΕΣ
ΦΠΑ=0.19
Β=100
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ι
ΠΡΑΓΜΑΤΙΚΕΣ:ΑΤ, ΤΤ
ΑΡΧΗ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Β
ΔΙΑΒΑΣΕ ΑΤ
ΤΤ<- ΑΤ+ΑΤ*ΦΠΑ
ΓΡΑΨΕ ΤΤ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

οπότε αν σου ζητούσαν να "τρέξεις" το πρόγραμμα για 200 προϊόντα να άλλαζες το Β σε 200 στην αρχή και όχι παντού μέσα σε ένα πρόγραμμα.
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

Wizard

  • Επισκέπτης
Απ: Σταθερές σε αλγόριθμους
« Απάντηση #2 στις: 20 Ιαν 2007, 12:33:55 μμ »
Στην ψευδογλώσσα κάθε τιμή αποτελεί σταθερά (θέμα 1γ, http://users.kor.sch.gr/ptsiotakis/aepp/aepp_panel_epanen_2003.htm)
Στη ΓΛΩΣΣΑ, ως σταθερές αναφέρουμε μόνο τα "ονόματα" των σταθερών και όχι τις σταθερές τιμές;
« Τελευταία τροποποίηση: 20 Ιαν 2007, 01:20:56 μμ από Wizard »

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5166
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Σταθερές σε αλγόριθμους
« Απάντηση #3 στις: 20 Ιαν 2007, 01:17:56 μμ »
Σταθερές είναι όλα.

Συμβολικές σταθερές (σελ. 149 του βιβλίου) ονομάζονται οι σταθερές που έχουν όνομα, π.χ.

Κώδικας: Text
  1. ΣΤΑΘΕΡΕΣ
  2.   ΠΙ = 3.14
  3.  

Wizard

  • Επισκέπτης
Απ: Σταθερές σε αλγόριθμους
« Απάντηση #4 στις: 20 Ιαν 2007, 01:25:07 μμ »
Σταθερές είναι όλα.

Συμβολικές σταθερές (σελ. 149 του βιβλίου) ονομάζονται οι σταθερές που έχουν όνομα, π.χ.

Κώδικας: Text
  1. ΣΤΑΘΕΡΕΣ
  2.   ΠΙ = 3.14
  3.  

Αυτό είχα κι εγώ στο νου. Αν όμως ζητηθεί σε πρόγραμμα σε ΓΛΩΣΣΑ να αναφέρουν τις σταθερές, τι πιστεύετε; Πρέπει να τα αναφέρουν όλα γράφοντας "σταθερές είναι..." και "συμβολικές σταθερές είναι..." ;

johnny_xp

  • Θαμώνας
  • ***
  • Μηνύματα: 39
  • Null Argument Exception
Απ: Σταθερές σε αλγόριθμους
« Απάντηση #5 στις: 20 Ιαν 2007, 03:50:11 μμ »
Σε κάθε γλώσσα προγραμματισμού υπάρχουν δυο ειδών σταθερές:
α) Συμβολικές (symbolic)
β) Κυριολεκτικές (literal)

Παράδειγμα:
Κώδικας: [Επιλογή]
ΣΤΑΘΕΡΕΣ
ΦΠΑ = 0.19 !Συμβολική σταθερά

Χ <- 3*ΦΠΑ !το 3 είναι κυριολεκτική σταθερά

Άρα αυτό που λέει ο alkisg είναι σωστό.
Σε επίπεδο ψευδογλώσσας είναι κάπως περίεργο το ζήτημα......

Υστερόγραφο: Τέτοιο ζήτημα έχει τεθεί ήδη στις Εξετάσεις. Καλόν θα ήταν κάποιος που είχε βαθμολογήσει εκείνη τη χρονιά να μας έλεγε τι θεωρούσε σωστό η επιτροπή, δοθέντος του ότι δινόταν ένα τμήμα αλγορίθμου σε ψευδογλώσσα στο οποίο εμφανιζόταν μια "κυριολεκτική" σταθερά και υπήρχε ερώτημα να εντοπίσουν οι μαθητές τις εμφανιζόμενες σταθερές.