Αποστολέας Θέμα: ΘΕΜΑ Γ  (Αναγνώστηκε 11497 φορές)

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1095
ΘΕΜΑ Γ
« στις: 12 Ιούν 2017, 10:24:49 πμ »
Εδώ σχολιάζουμε το θέμα Γ

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: ΘΕΜΑ Γ
« Απάντηση #1 στις: 12 Ιούν 2017, 10:26:31 πμ »
παιδιά πολύ δύσκολο... ""πινακες μετρητών"" σε δισδιάστατο με περίεργη σχετικά λογική, ταξινόμηση δισδι'αστατου με δεύτερο κριτήριο και διατήρηση παραλληλότητας ...αν τα λύνω σωστώ

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: ΘΕΜΑ Γ
« Απάντηση #2 στις: 12 Ιούν 2017, 10:34:42 πμ »
Έτσι όπως το βλέπω θα χρειαστούν 3 σελίδες κώδικα για να το λύσουν (όσοι το λύσουν, που τους βλέπω λίγους!!!), πολύ ιδιόρρυθμη η ενημέρωση των δεδομένων στον πίνακα Α και πολλές αντιμεταθέσεις στη φάση της ταξινόμησης!

Υπάρχει τρόπος να μαζευτεί αλλά δεν ξέρω πόσοι μαθητές θα έχουν την ψυχραιμία να τον εντοπίσουν!
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 893
Απ: ΘΕΜΑ Γ
« Απάντηση #3 στις: 12 Ιούν 2017, 11:03:00 πμ »
Το Γ και το Δ είναι  Δύσκολα !!
Φιλικά,
Γιώργος Θαλασσινός

akalest0s

  • Βετεράνος
  • ****
  • Μηνύματα: 69
Απ: ΘΕΜΑ Γ
« Απάντηση #4 στις: 12 Ιούν 2017, 11:15:38 πμ »
Με ένα πρώτο λύσιμο που έκανα στο Γ, δεν μου φάνηκε πολύ δύσκολο. Αν καταλάβεις πως να περάσεις τις τιμές στον πίνακα Α σωστά, τότε τα υποερωτήματα Γ3 και Γ4 βγαίνουν αμέσως. Εκτός και αν έχω κάτι παραβλέψει.
Όλη η δυσκολία είναι στο Γ2, νομίζω. Είναι πολύ εύκολο να περάσεις λάθος τις τιμές.
(με επιφύλαξη, θα την ξαναλύσω, μετά τα λεγόμενά σας...)

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: ΘΕΜΑ Γ
« Απάντηση #5 στις: 12 Ιούν 2017, 11:17:00 πμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2017
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Α[5, 3], J, ΣΧ1, ΣΧ2, ΣΕΤ1, ΣΕΤ2, ΒΑΘ[5], ΣΕΤΥΠ[5], Τ1, Τ3, Τ4, ΣΕΤΚ[5]
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[5], Τ2
ΑΡΧΗ
!Γ1
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΔΙΑΒΑΣΕ ΟΝ[Ι]
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
      Α[Ι, J] <- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Γ2
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
     ΔΙΑΒΑΣΕ ΣΧ1, ΣΧ2, ΣΕΤ1, ΣΕΤ2
     ΑΝ ΣΕΤ1 > ΣΕΤ2 ΤΟΤΕ
       Α[ΣΧ1, 1] <- Α[ΣΧ1, 1] + 2
       Α[ΣΧ2, 1] <- Α[ΣΧ2, 1] + 1
     ΑΛΛΙΩΣ_ΑΝ ΣΕΤ1 < ΣΕΤ2 ΤΟΤΕ
       Α[ΣΧ1, 1] <- Α[ΣΧ1, 1] + 1
       Α[ΣΧ2, 1] <- Α[ΣΧ2, 1] + 2
    ΤΕΛΟΣ_ΑΝ
    Α[ΣΧ1, 2] <- Α[ΣΧ1, 2] + ΣΕΤ1
    Α[ΣΧ1, 3] <- Α[ΣΧ1, 3] + ΣΕΤ2
    Α[ΣΧ2, 2] <- Α[ΣΧ2, 2] + ΣΕΤ2
    Α[ΣΧ2, 3] <- Α[ΣΧ2, 3] + ΣΕΤ1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Γ3
!ΒΑΖΩ ΒΑΘΜΟΛΟΓΙΕΣ, ΣΕΤ ΥΠΕΡ, ΣΕΤ ΚΑΤΑ ΣΕ ΜΟΝΟΔΙΑΣΤΑΤΟΥΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΒΑΘ[Ι] <- Α[Ι, 1]
    ΣΕΤΥΠ[Ι] <- Α[Ι, 2]
    ΣΕΤΚ[Ι] <- Α[Ι, 3]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 5
    ΓΙΑ J ΑΠΟ 5 ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
      ΑΝ ΒΑΘ[J - 1] < ΒΑΘ[J] ΤΟΤΕ
        Τ1 <- ΒΑΘ[J - 1]
        ΒΑΘ[J - 1] <- ΒΑΘ[J]
        ΒΑΘ[J] <- Τ1
        Τ2 <- ΟΝ[J - 1]
        ΟΝ[J - 1] <- ΟΝ[J]
        ΟΝ[J] <- Τ2
        Τ3 <- ΣΕΤΥΠ[J - 1]
        ΣΕΤΥΠ[J - 1] <- ΣΕΤΥΠ[J]
        ΣΕΤΥΠ[J] <- Τ3
        Τ4 <- ΣΕΤΚ[J - 1]
        ΣΕΤΚ[J - 1] <- ΣΕΤΚ[J]
        ΣΕΤΚ[J] <- Τ4
      ΑΛΛΙΩΣ_ΑΝ ΒΑΘ[J - 1] = ΒΑΘ[J] ΤΟΤΕ
        ΑΝ ΣΕΤΥΠ[J - 1] < ΣΕΤΥΠ[J] ΤΟΤΕ
          Τ2 <- ΟΝ[J - 1]
          ΟΝ[J - 1] <- ΟΝ[J]
          ΟΝ[J] <- Τ2
          Τ3 <- ΣΕΤΥΠ[J - 1]
          ΣΕΤΥΠ[J - 1] <- ΣΕΤΥΠ[J]
          ΣΕΤΥΠ[J] <- Τ3
          Τ4 <- ΣΕΤΚ[J - 1]
          ΣΕΤΚ[J - 1] <- ΣΕΤΚ[J]
          ΣΕΤΚ[J] <- Τ4
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


! Δ4
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ ΟΝ[Ι], ΒΑΘ[Ι], ΣΕΤΥΠ[Ι], ΣΕΤΚ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Νομίζω είναι οκ ή κάτι μου έφυγε; Ψυχραιμία στα παιδιά και καλή επιτυχία!

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 680
Απ: ΘΕΜΑ Γ
« Απάντηση #6 στις: 12 Ιούν 2017, 11:20:53 πμ »
Οντως η εισαγωγή βαθμών είναι το πιο δύσκολο, θέλει αρκετά καλή αντίληψη...αλλά και μετα θέλει ταξινόμηση σε δισδιάστατο αν δεν κανει αντιγραφή κάποιος οπότε είναι δύσκολα θεωρώ

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #7 στις: 12 Ιούν 2017, 11:30:01 πμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2017
...................
Νομίζω είναι οκ ή κάτι μου έφυγε; Ψυχραιμία στα παιδιά και καλή επιτυχία!
[/quote]


Ακριβώς έτσι έχω τη δική μου λύση , νομίζω είναι οκ
Αν δεν χρησιμοποιούσα άλλα ονόματα στις μεταβλητές θα έλεγαν ότι αντιγράφουμε

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Απ: ΘΕΜΑ Γ
« Απάντηση #8 στις: 12 Ιούν 2017, 11:40:45 πμ »
μην σκέφτεστε ως εκπαιδευτικοί σκεφτείτε ως μαθητές, είναι από τα πιο δύσκολα θέματα που έχουν ζητηθεί

progmat

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: ΘΕΜΑ Γ
« Απάντηση #9 στις: 12 Ιούν 2017, 11:45:14 πμ »
Συνάδελφοι όντως για διάστημα 3 ωρών, δεδομένου ότι εξετάζονται μαθητές Λυκείου (έχοντας και την πίεση του άγχους) τα θέματα είναι λίγο απαράδεκτα. Στο μυαλό μου έχω ότι αν εγώ το λύνω όλο το διαγώνισμα σε 1,5 ώρα ένα καλός μαθητής θέλει τριπλάσιο χρόνο. Δυστυχώς έγινε ό,τι έγινε και στα Μαθηματικά, ογκώδη θέματα(προγράμματα) και απαιτητικά. Η θεωρία έχω την άποψη, όμως, ότι ήταν καλή και από άποψη χρόνου και σε δυσκολία. Καλή επιτυχία στα παιδιά καλή δύναμη σε όλους!

jimmy

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: ΘΕΜΑ Γ
« Απάντηση #10 στις: 12 Ιούν 2017, 11:45:40 πμ »
Προσωπικά θεωρώ δύσκολο το υποερώτημα με την ανάθεση τιμών στον πίνακα, αλλά με σχήμα πιστεύω ότι λίγο πολύ βγαίνει, αν κάποιος είναι ψύχραιμος. Το θέμα της ταξινόμησης το έχουμε δει στα θέματα του 2004 (ταξινόμηση με ισοβαθμία) και του 2013 (ταξινόμηση σε όλες τις στήλες ενός δισδιάστατου, βέβαια εκεί ήταν 2 στήλες και όχι 3), οπότε λίγο πολύ θεωρείται γνωστή η διαχείρισή του. Έχουν υπάρξει και δυσκολότερα θέματα γενικά, παρόλα αυτά ανεβασμένο σε σχέση με πέρσι κατά πολύ.

pstasinos

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 44
Απ: ΘΕΜΑ Γ
« Απάντηση #11 στις: 12 Ιούν 2017, 11:47:33 πμ »
μην σκέφτεστε ως εκπαιδευτικοί σκεφτείτε ως μαθητές, είναι από τα πιο δύσκολα θέματα που έχουν ζητηθεί

Συμφωνώ απόλυτα , το ΘΕΜΑ Γ είναι απαιτητικό , δύσκολο ως προς την κατανόηση και θα απαιτήσει πολύ χρόνο.Καλή δύναμη στα παιδιά.

meteo_xampos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 182
Απ: ΘΕΜΑ Γ
« Απάντηση #12 στις: 12 Ιούν 2017, 11:53:00 πμ »
Παιδιά καλημέρα.ζορικο αρκετά το Γ θέμα για κοπελια που έχουν καταλάβει καλά τους πίνακες.πολυ απαιτητικό.υο σηματάκι σώζει!!! Και το δ ήταν ζόρικο!!!γενικά πιστεύω ότι ήταν αρκετά ζορικα γ και δ και εύκολα α και Β.

Rathaniel

  • Βετεράνος
  • ****
  • Μηνύματα: 77
  • Έπρεπε να είχα γίνει Χημικός......
Απ: ΘΕΜΑ Γ
« Απάντηση #13 στις: 12 Ιούν 2017, 12:24:28 μμ »
Den
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2017
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Α[5, 3], J, ΣΧ1, ΣΧ2, ΣΕΤ1, ΣΕΤ2, ΒΑΘ[5], ΣΕΤΥΠ[5], Τ1, Τ3, Τ4, ΣΕΤΚ[5]
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[5], Τ2
ΑΡΧΗ
!Γ1
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΔΙΑΒΑΣΕ ΟΝ[Ι]
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
      Α[Ι, J] <- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Γ2
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
     ΔΙΑΒΑΣΕ ΣΧ1, ΣΧ2, ΣΕΤ1, ΣΕΤ2
     ΑΝ ΣΕΤ1 > ΣΕΤ2 ΤΟΤΕ
       Α[ΣΧ1, 1] <- Α[ΣΧ1, 1] + 2
       Α[ΣΧ2, 1] <- Α[ΣΧ2, 1] + 1
     ΑΛΛΙΩΣ_ΑΝ ΣΕΤ1 < ΣΕΤ2 ΤΟΤΕ
       Α[ΣΧ1, 1] <- Α[ΣΧ1, 1] + 1
       Α[ΣΧ2, 1] <- Α[ΣΧ2, 1] + 2
    ΤΕΛΟΣ_ΑΝ
    Α[ΣΧ1, 2] <- Α[ΣΧ1, 2] + ΣΕΤ1
    Α[ΣΧ1, 3] <- Α[ΣΧ1, 3] + ΣΕΤ2
    Α[ΣΧ2, 2] <- Α[ΣΧ2, 2] + ΣΕΤ2
    Α[ΣΧ2, 3] <- Α[ΣΧ2, 3] + ΣΕΤ1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Γ3
!ΒΑΖΩ ΒΑΘΜΟΛΟΓΙΕΣ, ΣΕΤ ΥΠΕΡ, ΣΕΤ ΚΑΤΑ ΣΕ ΜΟΝΟΔΙΑΣΤΑΤΟΥΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΒΑΘ[Ι] <- Α[Ι, 1]
    ΣΕΤΥΠ[Ι] <- Α[Ι, 2]
    ΣΕΤΚ[Ι] <- Α[Ι, 3]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 5
    ΓΙΑ J ΑΠΟ 5 ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
      ΑΝ ΒΑΘ[J - 1] < ΒΑΘ[J] ΤΟΤΕ
        Τ1 <- ΒΑΘ[J - 1]
        ΒΑΘ[J - 1] <- ΒΑΘ[J]
        ΒΑΘ[J] <- Τ1
        Τ2 <- ΟΝ[J - 1]
        ΟΝ[J - 1] <- ΟΝ[J]
        ΟΝ[J] <- Τ2
        Τ3 <- ΣΕΤΥΠ[J - 1]
        ΣΕΤΥΠ[J - 1] <- ΣΕΤΥΠ[J]
        ΣΕΤΥΠ[J] <- Τ3
        Τ4 <- ΣΕΤΚ[J - 1]
        ΣΕΤΚ[J - 1] <- ΣΕΤΚ[J]
        ΣΕΤΚ[J] <- Τ4
      ΑΛΛΙΩΣ_ΑΝ ΒΑΘ[J - 1] = ΒΑΘ[J] ΤΟΤΕ
        ΑΝ ΣΕΤΥΠ[J - 1] < ΣΕΤΥΠ[J] ΤΟΤΕ
          Τ2 <- ΟΝ[J - 1]
          ΟΝ[J - 1] <- ΟΝ[J]
          ΟΝ[J] <- Τ2
          Τ3 <- ΣΕΤΥΠ[J - 1]
          ΣΕΤΥΠ[J - 1] <- ΣΕΤΥΠ[J]
          ΣΕΤΥΠ[J] <- Τ3
          Τ4 <- ΣΕΤΚ[J - 1]
          ΣΕΤΚ[J - 1] <- ΣΕΤΚ[J]
          ΣΕΤΚ[J] <- Τ4
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


! Δ4
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ ΟΝ[Ι], ΒΑΘ[Ι], ΣΕΤΥΠ[Ι], ΣΕΤΚ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Νομίζω είναι οκ ή κάτι μου έφυγε; Ψυχραιμία στα παιδιά και καλή επιτυχία!
[
Με ένα πρώτο λύσιμο που έκανα στο Γ, δεν μου φάνηκε πολύ δύσκολο. Αν καταλάβεις πως να περάσεις τις τιμές στον πίνακα Α σωστά, τότε τα υποερωτήματα Γ3 και Γ4 βγαίνουν αμέσως. Εκτός και αν έχω κάτι παραβλέψει.
Όλη η δυσκολία είναι στο Γ2, νομίζω. Είναι πολύ εύκολο να περάσεις λάθος τις τιμές.
(με επιφύλαξη, θα την ξαναλύσω, μετά τα λεγόμενά σας...)

Δεν υπάρχει λόγος για περασμα σε μονοδιάστατους. Τα περισσοτερα παιδια έχουν κάνει σε 2D ταξινόμηση με διπλό φίλτρο.
Χρηστίδης Αλέξανδρος,
Μηχανικός Επ/κών και Πλη/κών Συστημάτων,
Msc Στα Προηγμένα Συστήματα Πληροφορικής

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΘΕΜΑ Γ
« Απάντηση #14 στις: 12 Ιούν 2017, 12:27:59 μμ »
Δεν υπάρχει λόγος για περασμα σε μονοδιάστατους. Τα περισσοτερα παιδια έχουν κάνει σε 2D ταξινόμηση με διπλό φίλτρο.

...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής