Αποστολέας Θέμα: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα  (Αναγνώστηκε 3351 φορές)

Kalli

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 41
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« στις: 16 Νοέ 2006, 01:57:59 μμ »
Εχω μια ερώτηση...Μετά από το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ γράφω το όνομα του προγράμματος;Το βιβλίο μια το γραφεί και μια όχι.Ποιο είναι το σωστό;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #1 στις: 16 Νοέ 2006, 03:15:58 μμ »
Όντως, υπάρχει διάσταση απόψεων μεταξύ των μελών της συγγραφικής ομάδας (αν και στο τετράδιο μαθητή έχουν σταθερή άποψη).

Προσωπικά θεωρώ οτι βάζοντας το όνομα (όπως πράττουμε και στην ψευδογλώσσα) στο τέλος του προγράμματος είναι εντάξει. Δε νομίζω να στεκόταν κάποιος διορθωτής σε αυτό πάντως (ή έτσι θέλω να ελπίζω για όλους τους διορθωτές)

Με εκτίμηση,

Τσιωτάκης Παναγιώτης

ΥΓ: έχω την αίσθηση οτι δεν ταιριάζει σε αυτό το θέμα η ερώτησή σου...

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #2 στις: 16 Νοέ 2006, 03:30:08 μμ »
Όντως δεν ταίριαζε, το έβαλα σε ξεχωριστό θέμα.

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #3 στις: 16 Νοέ 2006, 07:16:03 μμ »
Θα συμφωνήσω και εγώ με τον Παναγιωτη ότι βάζεις όνομα κατ'αντιστοιχία με τους αλγορίθμους.
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

filippos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 139
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #4 στις: 17 Νοέ 2006, 07:59:06 πμ »
θα συμφωνήσω με τον παναγιωτη στο ένα σκελος, ότι δηλαδή το θέμα δεν είναι ... άξιο λόγου και ΑΠΟΚΛΕΙΕΤΑΙ να αποτελέσει αιτία απώλειας μονάδων από σκεπτόμενο βαθμολογητή.

Από την άλλη, προσωπικά διδάσκω τη δήλωση τερματισμού του αλγόριθμου σε αλγοριθμική ψευδογλώσσα με το:

τέλος Όνομα

ενώ σε προγραμματιστικό περιβάλλον με το

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΧΩΡΙΣ όνομα.  Νομίζω ότι με αρκετή ασφάλεια θα μπορούσε να θεωρηθεί πλεονασμός (και όχι βέβαια λάθος) η αναγραφή του ονόματος τη στιγμή που η σημασιολογία της δήλωσης (ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ) δεν το απαιτεί.

Θεωρώ ταυτόχρονα ότι η (σωστά εντοπισμένη) ποικιλία απόψεων των συγγραφέων του βιβλίου και η αδυναμία τους (σε αρκετά σημεία) να παρουσιάσουν ένα ενιαίο πρόσωπο (ευτυχώς μόνο σε επουσιώδη) μας κάνει τώρα να συζητάμε για αυτά τα επουσιώδη.

θεωρώντας ότι σε επίπεδο (τουλάχιστον) λεξιλογίου η ΓΛΩΣΣΑ αντιγράφει (ή αν θέλετε μεταφράζει) την Pascal, η "σωστή" (??) άποψη είναι ότι το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πρέπει (??) να γράφεται μόνο του.  Διαφορετικά, θα πρέπει να ακολουθήσουμε την ίδια (πλουραλοστική;;) θέση και στα:

ΣΥΝΑΡΤΗΣΗ Τάδε
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Τάδε

ΔΙΑΔΙΚΑΣΙΑ Δείνα
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Δείνα

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2225
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #5 στις: 17 Νοέ 2006, 12:18:31 μμ »
Πιστεύω ότι είναι καλύτερο να υπάρχει το όνομα του προγράμματος
Αποφεύγουμε τον κίνδυνο να κοπούν μονάδες από την έλλειψη αυτού
Ο πλεονασμός δεν νομίζω να δυσαρεστήσει κάποιον εξεταστή
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #6 στις: 17 Νοέ 2006, 12:44:18 μμ »
Δεν υπάρχει λόγος να έχουμε τέτοιες ανησυχίες.

ΚΑΝΕΝΑΣ βαθμολογητής δε θα στερήσει έστω και μία μονάδα από μαθητή για τέτοιο λόγο.

Είναι εντελώς επουσιώδες ως θέμα σε σχέση με τους πραγματικούς διδακτικούς στόχους του μαθήματος.

Προσωπικά με πείθει περισσότερο η άποψη του Φίλιππου, αν και πραγματικά θεωρώ ότι ο όλος προβληματισμός είναι χωρίς πραγματικό νόημα
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3168
  • to Iterate is human to Recurse divine
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #7 στις: 17 Νοέ 2006, 01:50:41 μμ »
 Σχετικά με το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πράγματι δεν είναι άξιο λόγου πάντως αν θέλουμε
κάποιο επιχείρημα για να πείσουμε κάποιον, το γεγονός ότι χρησιμοποιούνται και οι δυο τρόποι
στο βιβλίο μάλλον τους κάνει και τους 2 σωστούς, δε νομίζετε;

Σχετικα τώρα με το θέμα του ατέρμονος βρόχου για να είμαι ειλικρίνης ούτε εγώ κατάλαβα ποιο ακριβώς είναι το ερώτημα. Απλά ήθελα να συμπληρώσω ότι σχετικά με τους βρόχους των διεργασιών-server και τελος πάντων όπου βλέπουμε κάτι σαν (for ; ;) ο βρόχος δεν είναι τόσο ατέρμων όσο φαίνεται. Σίγουρα θα υπάρχει συγκεκριμένος signal handler ο οποίος θα κάνει catch events σχετικά με λάθη ή οποιαδήποτε ανώμαλη λειτουργία. Δηλαδή είναι ένας βρόχος του στυλ
(Όσο δεν έχεις λάβει τα τάδε σήματα Επανάλαβε). Δηλαδή συντακτικά μπορεί να φαίνεται ατέρμων αλλά ουσιαστικά δεν είναι.
    Είναι τόσο ατέρμων όσο και το 

     Όσο (x<>0) Επανάλαβε
            Διάβασε x
     Τέλος_Επανάληψης


What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Kalli

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 41
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #8 στις: 17 Νοέ 2006, 02:38:38 μμ »
Σας ευχαριστώ πολύ όλους για τις απαντήσεις

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
« Απάντηση #9 στις: 17 Νοέ 2006, 04:54:30 μμ »
Το

Διάβασε x
Όσο (x<>0) Επανάλαβε
    Διάβασε x
Τέλος_Επανάληψης
δεν είναι ατέρμων βρόχος, κάποτε θα τελειώσει, κάποτε θα τερματίσει

Το:
Διάβασε x
Όσο (χ^2 >= 0) Επανάλαβε
     Διάβασε x
Τέλος_Επανάληψης
είναι ατέρμων βρόχος

Το:
Διάβασε x
Όσο (1 <> 2) Επανάλαβε
     Διάβασε x
Τέλος_Επανάληψης
είναι ατέρμων βρόχος