Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Δομή ακολουθίας => Μήνυμα ξεκίνησε από: Kalli στις 16 Νοέ 2006, 01:57:59 μμ

Τίτλος: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: Kalli στις 16 Νοέ 2006, 01:57:59 μμ
Εχω μια ερώτηση...Μετά από το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ γράφω το όνομα του προγράμματος;Το βιβλίο μια το γραφεί και μια όχι.Ποιο είναι το σωστό;
Τίτλος: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: Παναγιώτης Τσιωτάκης στις 16 Νοέ 2006, 03:15:58 μμ
Όντως, υπάρχει διάσταση απόψεων μεταξύ των μελών της συγγραφικής ομάδας (αν και στο τετράδιο μαθητή έχουν σταθερή άποψη).

Προσωπικά θεωρώ οτι βάζοντας το όνομα (όπως πράττουμε και στην ψευδογλώσσα) στο τέλος του προγράμματος είναι εντάξει. Δε νομίζω να στεκόταν κάποιος διορθωτής σε αυτό πάντως (ή έτσι θέλω να ελπίζω για όλους τους διορθωτές)

Με εκτίμηση,

Τσιωτάκης Παναγιώτης

ΥΓ: έχω την αίσθηση οτι δεν ταιριάζει σε αυτό το θέμα η ερώτησή σου...
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: alkisg στις 16 Νοέ 2006, 03:30:08 μμ
Όντως δεν ταίριαζε, το έβαλα σε ξεχωριστό θέμα.
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: EleniK στις 16 Νοέ 2006, 07:16:03 μμ
Θα συμφωνήσω και εγώ με τον Παναγιωτη ότι βάζεις όνομα κατ'αντιστοιχία με τους αλγορίθμους.
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: filippos στις 17 Νοέ 2006, 07:59:06 πμ
θα συμφωνήσω με τον παναγιωτη στο ένα σκελος, ότι δηλαδή το θέμα δεν είναι ... άξιο λόγου και ΑΠΟΚΛΕΙΕΤΑΙ να αποτελέσει αιτία απώλειας μονάδων από σκεπτόμενο βαθμολογητή.

Από την άλλη, προσωπικά διδάσκω τη δήλωση τερματισμού του αλγόριθμου σε αλγοριθμική ψευδογλώσσα με το:

τέλος Όνομα

ενώ σε προγραμματιστικό περιβάλλον με το

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΧΩΡΙΣ όνομα.  Νομίζω ότι με αρκετή ασφάλεια θα μπορούσε να θεωρηθεί πλεονασμός (και όχι βέβαια λάθος) η αναγραφή του ονόματος τη στιγμή που η σημασιολογία της δήλωσης (ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ) δεν το απαιτεί.

Θεωρώ ταυτόχρονα ότι η (σωστά εντοπισμένη) ποικιλία απόψεων των συγγραφέων του βιβλίου και η αδυναμία τους (σε αρκετά σημεία) να παρουσιάσουν ένα ενιαίο πρόσωπο (ευτυχώς μόνο σε επουσιώδη) μας κάνει τώρα να συζητάμε για αυτά τα επουσιώδη.

θεωρώντας ότι σε επίπεδο (τουλάχιστον) λεξιλογίου η ΓΛΩΣΣΑ αντιγράφει (ή αν θέλετε μεταφράζει) την Pascal, η "σωστή" (??) άποψη είναι ότι το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πρέπει (??) να γράφεται μόνο του.  Διαφορετικά, θα πρέπει να ακολουθήσουμε την ίδια (πλουραλοστική;;) θέση και στα:

ΣΥΝΑΡΤΗΣΗ Τάδε
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Τάδε

ΔΙΑΔΙΚΑΣΙΑ Δείνα
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Δείνα
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: petrosp13 στις 17 Νοέ 2006, 12:18:31 μμ
Πιστεύω ότι είναι καλύτερο να υπάρχει το όνομα του προγράμματος
Αποφεύγουμε τον κίνδυνο να κοπούν μονάδες από την έλλειψη αυτού
Ο πλεονασμός δεν νομίζω να δυσαρεστήσει κάποιον εξεταστή
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: Sergio στις 17 Νοέ 2006, 12:44:18 μμ
Δεν υπάρχει λόγος να έχουμε τέτοιες ανησυχίες.

ΚΑΝΕΝΑΣ βαθμολογητής δε θα στερήσει έστω και μία μονάδα από μαθητή για τέτοιο λόγο.

Είναι εντελώς επουσιώδες ως θέμα σε σχέση με τους πραγματικούς διδακτικούς στόχους του μαθήματος.

Προσωπικά με πείθει περισσότερο η άποψη του Φίλιππου, αν και πραγματικά θεωρώ ότι ο όλος προβληματισμός είναι χωρίς πραγματικό νόημα
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: evry στις 17 Νοέ 2006, 01:50:41 μμ
 Σχετικά με το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πράγματι δεν είναι άξιο λόγου πάντως αν θέλουμε
κάποιο επιχείρημα για να πείσουμε κάποιον, το γεγονός ότι χρησιμοποιούνται και οι δυο τρόποι
στο βιβλίο μάλλον τους κάνει και τους 2 σωστούς, δε νομίζετε;

Σχετικα τώρα με το θέμα του ατέρμονος βρόχου για να είμαι ειλικρίνης ούτε εγώ κατάλαβα ποιο ακριβώς είναι το ερώτημα. Απλά ήθελα να συμπληρώσω ότι σχετικά με τους βρόχους των διεργασιών-server και τελος πάντων όπου βλέπουμε κάτι σαν (for ; ;) ο βρόχος δεν είναι τόσο ατέρμων όσο φαίνεται. Σίγουρα θα υπάρχει συγκεκριμένος signal handler ο οποίος θα κάνει catch events σχετικά με λάθη ή οποιαδήποτε ανώμαλη λειτουργία. Δηλαδή είναι ένας βρόχος του στυλ
(Όσο δεν έχεις λάβει τα τάδε σήματα Επανάλαβε). Δηλαδή συντακτικά μπορεί να φαίνεται ατέρμων αλλά ουσιαστικά δεν είναι.
    Είναι τόσο ατέρμων όσο και το 

     Όσο (x<>0) Επανάλαβε
            Διάβασε x
     Τέλος_Επανάληψης


Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: Kalli στις 17 Νοέ 2006, 02:38:38 μμ
Σας ευχαριστώ πολύ όλους για τις απαντήσεις
Τίτλος: Απ: ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ και όνομα
Αποστολή από: Παναγιώτης Τσιωτάκης στις 17 Νοέ 2006, 04:54:30 μμ
Το

Διάβασε x
Όσο (x<>0) Επανάλαβε
    Διάβασε x
Τέλος_Επανάληψης
δεν είναι ατέρμων βρόχος, κάποτε θα τελειώσει, κάποτε θα τερματίσει

Το:
Διάβασε x
Όσο (χ^2 >= 0) Επανάλαβε
     Διάβασε x
Τέλος_Επανάληψης
είναι ατέρμων βρόχος

Το:
Διάβασε x
Όσο (1 <> 2) Επανάλαβε
     Διάβασε x
Τέλος_Επανάληψης
είναι ατέρμων βρόχος