Αποστολέας Θέμα: Εκκίνηση LTSP clients με UEFI  (Αναγνώστηκε 3631 φορές)

jim_katsar

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 104
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #30 στις: 15 Απρ 2019, 11:15:26 πμ »
Τα αποτελέσματα των εντολών φαίνονται στο παρακάτω screenshot

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5264
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #31 στις: 15 Απρ 2019, 12:37:32 μμ »
Δημήτρη τα είδαμε και στο IRC, αναφέρω τα αποτελέσματα μήπως τα χρειαστεί κανείς:

Το πρόβλημα ήταν ότι χρησιμοποίησες το παράδειγμά μου, sda3, αντί να το αντικαταστήσεις με το partition όπου είναι εγκατεστημένο το Ubuntu, στην περίπτωσή σου sda1.

Η γρήγορη λύση είναι η εκτέλεση της παρακάτω τεράστιας εντολής μέσα από τον Επόπτη, στους clients που έχουν το πρόβλημα:
Κώδικας: Bash
  1. sudo mount /dev/sda1 /mnt && sed 's|sda3|sda1|' -i /mnt/etc/grub.d/09_ltsp /mnt/boot/grub/grub.cfg && umount /mnt && reboot

(άσχετη προσωπική σημείωση: στα Raspberry PIs που έχουν fat αντί για ext4, θέλει και `insmod ./nls_iso8859-1.ko` από τον παλιό kernel για να κάνει mount το fat partition)

jim_katsar

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 104
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #32 στις: 15 Απρ 2019, 01:27:44 μμ »
Πράγματι δεν είχα ελέγξει σε ποιο partition ήταν τα ubuntu!!!
Συμπέρασμα: πρέπει να διαβάζεις καλά πριν να πράττεις...  :D

ilias_s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 282
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #33 στις: 24 Σεπ 2019, 10:40:44 μμ »
Καλησπέρα!

Έχω ένα θέμα με την εκκίνηση των LTSP clients όταν ενεργοποιήσω την εκκίνηση από δίκτυο σε UEFI (σε legacy mode δουλεύει μία χαρά). Έχω την αίσθηση πως κάτι δεν έχω κάνει αλλά δεν ξέρω τι!

Πιο συγκεκριμένα...

Στο σχολικό συγκρότημα παραλλάβαμε 2 εργαστήρια με 12 clients + 1 server το καθένα (μηχανήματα της Dell όλα). Στους server έκανα "φρέσκια" εγκατάσταση ubuntu 18.04 x64 σε UEFI mode. Μπήκαν τα entries κανονικά και bootάρουν μία χαρά (secure boot off καλού κακού)... Μέχρι εδώ όλα καλά!

Αν ρυθμίσω τους clients να κάνουν εκκίνηση από το δίκτυο σε UEFI mode δεν ξεκινάνε και απλά που βγάζει ένα μήνυμα "medium not present" αν θυμάμαι καλά (θα το επιβεβαιώσω αύριο). Σε legacy mode κάνουν εκκίνηση κανονικά και προς το παρόν δουλεύουμε έτσι. Για εμένα δεν είναι μεγάλο πρόβλημα καθώς δεν έχω σκοπό να χρησιμοποιήσω windows ΑΛΛΑ σκεφτόμουν το εξής...

Προκειμένου να διευκολύνω όποιο συνάδελφο χρειαστεί να μπει σε περιβάλλον windows, χωρίς πολύ φασαρία, θα μπορούσα να ρυθμίσω το boot sequence σε

1. network
2. windows boot loader

ώστε, όποιος θέλει windows, με τον server κλειστό... εκκινεί τους clients και αφού δεν μπορέσουν να bootάρουν από δίκτυο θα bootάρουν από τον τοπικό δίσκο σε περιβάλλον windows!

Σε legacy mode μπορώ να ορίσω μόνο network, usb, floppy ... όχι όμως hdd (αυτό πρέπει να είναι "παραξενιά" της Dell). Σε UEFI mode μπορώ να ρυθμίσω το boot sequence όπως θέλω ΑΛΛΑ δε bootάρει από δίκτυο και πάντα γυρίζει στο δίσκο.

Καμία ιδέα..;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5264
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #34 στις: 24 Σεπ 2019, 11:15:06 μμ »
Το firmware ξεκινάει σε UEFI και αν θέλει μετά μπορεί να μεταβεί σε κατάσταση BIOS.
Αφού πάει σε BIOS, δεν μπορεί να ξαναγυρίσει σε UEFI.
Επομένως δεν γίνεται να δοκιμάσει πρώτα BIOS boot from network και μετά UEFI boot from disk.
Στο νέο LTSP έχω προσθέσει υποστήριξη για UEFI clients, στο παλιό LTSP5 όχι.
Άρα, ή κάνετε υπομονή μέχρι του χρόνου, ή έρχεσαι από το http://ts.sch.gr/wiki/IRC να κάνουμε κάποιες ρυθμίσεις στο LTSP5 ώστε να υποστηρίζει κι αυτό UEFI, ή να βάλουμε το νέο LTSP...

ilias_s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 282
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #35 στις: 25 Σεπ 2019, 02:26:43 μμ »
Εννοείται πως άπαξ και πάει σε BIOS mode δε γίνεται να ξαναγυρίσει σε UEFI.

Αυτό που δεν ήξερα είναι ότι δεν υπάρχει υποστήριξη στο (παλιό) LTSP5 για UEFI clients. Να σου πω την αλήθεια δεν με στεναχωρεί γιατί εγώ σε ubuntu θα δουλέυω ούτως ή άλλως!

Οι μαθητές προσαρμόστηκαν τόσα χρόνια μία χαρά...  ας προσαρμοστούν και οι συνάδελφοι (όποιος αποφασίσει να κάνει το βήμα και χρησιμοποιήσει σοβαρά Η/Υ).

Πόσο "μανίκι" είναι η ρύθμιση του LTSP5 για υποστήριξη UEFI; Δεν είναι κάτι που επείγει και πιθανώς να μην αξίζει τον κόπο αφού έχεις ενσωματώσει τη δυνατότητα αυτή στο νέο LTSP! Πιο πολύ ρωτάω από περιέργεια. Μόλις ξελασκάρουμε λίγο και μπει το σχολείο σε μία σειρά θα μπορούσα και δοκιμαστικά να βάλω το νέο LTSP σε ένα σύγχρονο "spare" μηχάνημα ... έτσι για δοκιμή!


alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5264
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #36 στις: 25 Σεπ 2019, 10:59:52 μμ »
Το έχω κάνει σε 2 σχολεία αλλά επειδή θέλει αλλαγή από syslinux σε ipxe δεν είναι και το ευκολότερο, γι' αυτό και δεν έχω ανεβάσει αρχεία και οδηγίες, και λέω για IRC...
Αλλά άμα θα βάλεις και το νέο LTSP κάπου τότε δεν αξίζει, μπουτάρει από εκεί σε UEFI τους clients.

ilias_s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 282
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #37 στις: 25 Σεπ 2019, 11:17:02 μμ »
...
Αλλά άμα θα βάλεις και το νέο LTSP κάπου τότε δεν αξίζει, μπουτάρει από εκεί σε UEFI τους clients.

Ε ναι! Απλά δεν ξέρω σε τι φάση είναι το νέο LTSP... Θα δω το σχετικό θέμα και αν έχω κάποια αποροία θα ρωτήσω εκεί! Ευχαριστώ!

Yannis Siahos

  • Βετεράνος
  • ****
  • Μηνύματα: 63
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #38 στις: 27 Ιαν 2020, 11:53:15 πμ »
Έχω δοκιμάσει και το εξής που είναι σχετικά πιο απλό (γνώμη  μου)
  • Παίρνεις Acronis True Image την Windows UEFI εγκατάσταση σε άλλον δίσκο (πχ 2ο εσωτερικό ή εξωτερικό)
  • Διαγράφεις εντελώς το σκληρό δίσκο (πχ Gparted)
  • Κάνεις restore την εγκατάσταση και του επισημαίνεις να γίνει MBR
  • Ενεργοποιείς το NON-UEFI mode (BIOS)
  • Ελέγχεις ότι τα Windows είναι ΟΚ
  • Βάζεις στο bios και το PXE boot

Δημήτρης Γκίνης

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 494
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #39 στις: 11 Φεβ 2020, 06:19:35 μμ »
Μία (πιο) εύκολη και (πιο) γρήγορη λύση:
1) Βεβαιώνεσαι ότι το m/b υποστηρίζει λειτουργία σε legacy mode
2) Στα windows εγκαθιστάς το AOMEI Partition Assistant Pro (η demo version δεν σε αφήνει να ολοκληρώσεις τις αλλαγές, πρέπει να κάνεις register. Η τρέχουσα έκδοση είναι η 8.6, εγώ το δοκίμασα με την 7.1...γιατί είχα τους λόγους μου)
3) Επιλέγεις τον δίσκο-> δεξί κλικ->convert to MBR-> Apply (το σχετικό button πάνω αριστερά). Αφού κάνει τα δικά του, κάνει restart και μπαίνει σε δικό του session όπου προφανώς ολoκληρώνει τις αλλαγές στα partitions, κατά τη διάρκεια αυτού επιλέγεις με σχετικό check box για το αν μετά την ολοκλήρωση της διαδικασίας θα κάνει shut down ή reboot
4) Enter bios-> αλλαγή από UEFI σε Legacy Mode-> Save->Μπουτάρουν τα windows και τέλος

Ελλείψει φυσικού μηχανήματος με windows σε GBT, τα παραπάνω δοκιμάστηκαν σε VM και όλα πήγαν καλά.
Χρόνος<5 min.
Τα παραπάνω μπορούν να γίνουν και με άλλη εφαρμογή, δεν θυμάμαι ποια αυτή τη στιγμή (και αυτή όμως θέλει αγορά).

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5264
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #40 στις: 11 Φεβ 2020, 08:55:45 μμ »
Να κάνω λινκ στη νέα λύση κι από εδώ:
Υποστήριξη UEFI clients σε LTSP5

...και σε ένα λεπτάκι είναι όλα έτοιμα.

Δημήτρης Γκίνης

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 494
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #41 στις: 11 Φεβ 2020, 09:07:49 μμ »
Ναι βέβαια, εννοείται ότι η καλύτερη λύση είναι η μετάβαση από το LTSP 5 στο νέο LTSP.
Τα προηγούμενα ήταν για όσους δεν την έχουν κάνει/δεν έχουν σκοπό να την κάνουν σύντομα.

ΥΓ: Α παπα, είναι και παρεξηγιάρης....  ;D ;D
« Τελευταία τροποποίηση: 11 Φεβ 2020, 09:45:07 μμ από Δημήτρης Γκίνης »

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5264
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #42 στις: 11 Φεβ 2020, 09:15:12 μμ »
Καλέ η λύση εκεί είναι για το παλιό LTSP 5 όχι για το νέο LTSP 20... δηλαδή δουλεύει μέχρι και σε Ubuntu 12.04...   :angel:

Δημήτρης Γκίνης

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 494
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #43 στις: 11 Φεβ 2020, 09:59:41 μμ »
1. Το πιο σύντομο και πιο γρήγορο αφορούσε το προηγούμενο post του Γιάννη.
2. Διόρθωσα τα περί μετάβασης στο LTSP 5 για να μην εκτίθεμαι.
3. Η λύση αυτή μπορεί να εφαρμοστεί και στην περίπτωση που κάποιος έχει server με στημένα windows σε GPT, clients 32bit-> άρα χρειάζεται Ubuntu 32bit  και δεν μπορεί/θέλει να κάνει τη πατέντα για την εγκατάσταση του efi grub.
4.  :P

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5264
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Εκκίνηση LTSP clients με UEFI
« Απάντηση #44 στις: 12 Φεβ 2020, 08:18:20 πμ »
Δώσαμε λοιπόν συνεργατικά 3 ωραίες εναλλακτικές προτάσεις για όλες τις περιπτώσεις!

Δεν χρειάζεται καθόλου γκρίνια!!! Καλημέρα!!!