Αποστολέας Θέμα: Γενικός σχολιασμός  (Αναγνώστηκε 27401 φορές)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2823
  • Πύργος Ηλείας
Απ: Γενικός σχολιασμός
« Απάντηση #30 στις: 27 Μάι 2015, 04:06:40 μμ »
Και βγαίνει μετά η ΟΕΦΕ με επίσης λάθος λύση στο Β1.β

Έχουν δώσει:

Αν x>1 τότε
   Για y από x-2 μέχρι 1 με_βήμα –2
      Εμφάνισε y
   Tέλος_επανάληψης


αν δεν κάνω λάθος έχουν και στο Γ  , μήνυμα για την προώθηση σε λάθος δομή επιλογής

Επιπλέον:

Στο Β1 το διάγραμμα ροής τουλάχιστον σε εμένα δεν φαίνεται καλά.

Στο Β2 πρέπει i-1 αντί i+1

Στο Γ, επίσης, έχουν βάλει 3 παραμέτρους στη διαδικασία ενώ χρησιμοποιούνται μονάχα οι 2!

Στο Δ δεν κλείνει ο αλγόριθμος.

Η βιασύνη είναι κακός σύμβουλος!
Οι συνάδελφοι του ΟΕΦΕ θα πρέπει να τα διορθώσουν άμεσα...
« Τελευταία τροποποίηση: 27 Μάι 2015, 05:03:53 μμ από Νίκος Αδαμόπουλος »

Loco-3

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Γενικός σχολιασμός
« Απάντηση #31 στις: 27 Μάι 2015, 04:19:55 μμ »
Επιστρέψαμε σε επίπεδο δυσκολίας στο 2012
Καλό ή κακό, θα δείξει
Πάντως ήταν αρκετά ενδιαφέρον σε αρκετά σημεία και εξέταζε σχεδόν όλη την ύλη
Παραφωνίες η μετατροπή, το 3ο ΣΛ και οι 2 τελευταίες προτάσεις της φυσικής γλώσσας που ήταν ασαφείς
εγώ εκει πήγα με την λογικη του οτι δεν μπορει α,β Σ και να κάτσει και το γ Σ  8)

netnick

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: Γενικός σχολιασμός
« Απάντηση #32 στις: 27 Μάι 2015, 05:58:13 μμ »
Το θέμα Δ λύνεται και χωρίς πίνακες.

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 564
  • There can be only one...may it be AEPP.
Απ: Γενικός σχολιασμός
« Απάντηση #33 στις: 27 Μάι 2015, 06:08:07 μμ »
Το θέμα Δ λύνεται και χωρίς πίνακες.
Ίσως έτσι....

Κώδικας: [Επιλογή]
Αλγόριθμος Θ4
!ερωτήματα Δ1, Δ2 και Δ3
πλ ← 0                                                                !για το Δ4
υπάρχει ← Ψευδής
Για ι από 1 μέχρι 45
  Διάβασε Τ[ι]
  Σ[ι] ← 0
  περασε ← Αληθής
  Για ξ από 1 μέχρι 7
    Διάβασε Β[ι, ξ]
    Αν ξ = 1 τότε                                                     !για το Δ4
      μαχ ← Β[ι, ξ]
      κ ← 1
    αλλιώς
      Αν Β[ι, ξ] > μαχ τότε
        μαχ ← Β[ι, ξ]
        κ ← 1
      αλλιώς_αν Β[ι, ξ] = μαχ τότε
        κ ← κ + 1
      Τέλος_αν
    Τέλος_αν
    Σ[ι] ← Σ[ι] + Β[ι, ξ]
    Αν Β[ι, ξ] < 5 τότε
      περασε ← Ψευδής
    Τέλος_αν
  Τέλος_επανάληψης
  Αν κ > 1 τότε
    πλ ← πλ + 1
  Τέλος_αν
  Εμφάνισε Σ[ι]
  Αν περασε και Σ[ι] > 50 τότε
    Εμφάνισε Τ[ι]
    υπάρχει ← Αληθής
  Τέλος_αν
Τέλος_επανάληψης
Αν όχι υπάρχει τότε
  Εμφάνισε "ΔΕΝ ΥΠΑΡΧΕΙ ΚΑΝΕΝΑ ΤΡΑΓΟΥΔΙ ΠΟΥ ΝΑ ΠΡΟΚΡΙΝΕΤΑΙ ΣΤΗ ΔΕΥΤΕΡΗ ΦΑΣΗ"
Τέλος_αν
Εμφάνισε πλ
Τέλος Θ4   

βγάζοντας τους δείκτες...

edit: Βασίλη έχει πρόβλημα!!! ;)

Και οι δικές μου λύσεις...

Έχουν κάποια προβλήματα γι'αυτό δεν χρειάζεται να δώσει κάποος και τη δέουσα προσοχή.
Ένα επίσης θέμα έχω με τη συνάρτηση η οποία πιστεύω πως μπορεί να είναι αποδεκτή σαν λύση. Αλλά αυτή είναι η προσωπική μου άποψη.
Είναι πολύ εύκολο να στερηθούν πολύτιμα μόρια σε κάποιον που ξέρει τί κάνει.. ;)

Καλά αποτελέσματα σε όλους του μαθητές ......
« Τελευταία τροποποίηση: 28 Μάι 2015, 12:10:28 πμ από nikolasmer »
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Γενικός σχολιασμός
« Απάντηση #34 στις: 27 Μάι 2015, 07:32:19 μμ »
καλησπέρα σε όλους

εγώ αυτό που θέλω να πω είναι πως για άλλη μία χρονιά ΔΕΝ καλύπτεται όλο το φάσμα της ύλης....τζάμπα κάναμε όλ τη χρονιά ταξινόμηση, αναζήτηση. συγχώνευση κτλ κτλ ... εμένα θα μου άρεσε μια "ποικιλία" θεμάτων....

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 152
Απ: Γενικός σχολιασμός
« Απάντηση #35 στις: 27 Μάι 2015, 09:14:55 μμ »
γεια σας ειμαι μαθητης που μολις έδωσε,και το θέμα β1.β το σκεφτόμουν μέχρι τα τελευταια λεπτα...

τι λετε για αυτο:

αν χ>1 τοτε

για y απο (χ-2) μέχρι 0.1 με_βήμα -2
εμφάνισε y
τέλος_επανάληψης

εμφάνισε y
τέλος_αν

αν υποθέσουμε ότι αρχικά το χ ισούται με 2, ο αλγόριθμός σου δεν θα κάνει καμμία επανάληψη, ενώ εκείνος της εκφώνησης κάνει

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 152
Απ: Γενικός σχολιασμός
« Απάντηση #36 στις: 27 Μάι 2015, 09:46:06 μμ »

λοιπόν μόλις τώρα παρατήρησα ότι έχει αλλάξει η γραμματοσειρά στα θέματα των πανελλαδικών...

και γυρνάω να δω τα παλιά θέματα, και βλέπω ότι άλλαξε από το 2013




Άρης Κεσογλίδης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 141
Απ: Γενικός σχολιασμός
« Απάντηση #37 στις: 27 Μάι 2015, 09:59:52 μμ »
εγώ αυτό που θέλω να πω είναι πως για άλλη μία χρονιά ΔΕΝ καλύπτεται όλο το φάσμα της ύλης....τζάμπα κάναμε όλ τη χρονιά ταξινόμηση, αναζήτηση. συγχώνευση κτλ κτλ ... εμένα θα μου άρεσε μια "ποικιλία" θεμάτων....


Συμφωνώ απόλυτα...
Εύκολα θέματα, και μάλιστα "χαζά" εύκολα.
Το 10ο κεφάλαιο και πάλι σχεδόν έξω, με μία μόνο χλιαρή διαδικασία, ενώ πέρυσι ήταν εντελώς εκτός.
Τόσες καλές επεξεργασίες να κάνουν σε πίνακα, και μείναμε σε άθροισμα και πλήθος σε γραμμές, και μέγιστο και πλήθος σε στήλες.

Κι ενώ γενικά είναι εύκολα, μπαίνει το Β1β, που θα το έχουν κάνει ελάχιστοι σωστά, και πιάνει και πολλές μονάδες.
Όπως και στο Δ4 που τελικά είναι θέμα που μπερδεύει στην διατύπωση, ενώ αν το καταλάβεις είναι εύκολο στην υλοποίηση. Και πιάνει κι αυτό πολλές μονάδες.

 :(
Άρης Κεσογλίδης
Μαθηματικός
Μεταπτυχιακό στη "Θεωρητική Πληροφορική και Θεωρία Συστημάτων και Ελέγχου"

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Γενικός σχολιασμός
« Απάντηση #38 στις: 27 Μάι 2015, 10:03:02 μμ »
Τα θέματα Α και Β νομίζω ότι ήταν καλά, πέρα από κάποιες μικροασάφειες (βλέπε μετατροπή)
Δυστυχώς τα Γ και Δ ήταν αρκετά τυποποιημένα, έτσι ώστε να είναι πανεύκολα για όποιον έχει εξασκηθεί στις "γνωστές" τεχνικές.
Ωστόσο αυτό δε σημαίνει ότι όλοι έχουν γράψει καλά.
Η δυσκολία των θεμάτων την οποία εμείς ως καθηγητές δεν βλέπουμε είναι οι διατυπώσεις τους. Ειδικά στο θέμα Γ η διατύπωση γίνεται πολύ δύσκολα κατανοητή από τους μαθητές. Οι μαθητές που εξετάζαμε προφορικά είχαν μεγάλο πρόβλημα εκεί.
Κάποιοι νόμισαν έτσι όπως διάβαζαν το θέμα ότι θα έπρεπε όλη η "δουλειά" να γίνει μέσα στο υποπρόγραμμα, οπότε πήραν έναν δυναμικό πίνακα στον οποίο έβαλαν τα μεγέθη και τον πέρασαν παράμετρο στο υποπρόγραμμα. Από εκεί και πέρα όλα τα έκαναν σωστά.

Δεν λέω ότι η διατύπωση ήταν κακή, απλά δεν ήταν στο στυλ των κλασικών διατυπώσεων των προηγούμενων ετών διότι δεν όριζε επακριβώς τις παραμέτρους του υποπρόγραμματος δίνοντας μια σχετική ελευθερία στον μαθητή. Αυτό ναι μεν παιδαγωγικά είναι πολύ καλό αλλά στις συγκεκριμένες εξετάσεις μπορεί να αποβεί καταστροφικό. Για να δούμε, ίσως οι περιπτώσεις που είδα (2) να ήταν απλά μειοψηφία.

Η ουσία είναι πως φάνηκε ότι πολλά παιδιά αν δεν δουν ακριβώς την διατύπωση που περιμένουν, μπλοκάρουν και αυτό ίσως είναι και δίκο μας φταίξιμο.

Τέλος το Δ3 είναι το ίδιο με το ερώτημα από το θέμα Δ του 2011 που ζητούσε πόσοι είναι αυτοί που δεν ψήφισαν κανέναν, όπου πάλι έπρεπε να έχεις έναν μετρητή μέσα και έναν έξω ή το αντίστοιχο με λογικές μεταβλητές.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Γενικός σχολιασμός
« Απάντηση #39 στις: 27 Μάι 2015, 10:25:32 μμ »
ΑΕΠΠ: Λύσεις και Σχολιασμός Θεμάτων από την ΠΕΚΑΠ

http://www.greekinformatics.gr/ekpedeysi/ekpaideusi/pekap-liseis-aepp-2015/
VR in Computing

NiColas1957

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 319
  • Animus Facit Nobilem
Απ: Γενικός σχολιασμός
« Απάντηση #40 στις: 27 Μάι 2015, 10:52:36 μμ »
Ο   FUPAT2   δεν θα προτείνει λύσεις ???   ?
Ούτε ένα σχόλιο ???
Έχω πάθει στέρηση  :D

Καλό καλοκαίρι !  :angel:

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Γενικός σχολιασμός
« Απάντηση #41 στις: 27 Μάι 2015, 11:04:35 μμ »
Θα ήταν εξαιρετικό να γράψει κάποιος που θα συμμετάσχει σε βαθμολόγηση των γραπτών, τι ακριβώς συμφωνήθηκε για τα συνηθισμένα λάθη σε κάθε θέμα
Π.χ.
Όσοι στο Δ4 θεώρησαν μέγιστο βαθμό το 10
Όσοι έκαναν τις διάφορες σωστές ή μη παραλλαγές στο Β2
Όσοι έκαναν συνάρτηση στο θέμα Γ
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3525
  • to Iterate is human to Recurse divine
Απ: Γενικός σχολιασμός
« Απάντηση #42 στις: 27 Μάι 2015, 11:28:07 μμ »
το θέμα αυτό το συζητήσαμε σήμερα αλλά δεν καταλήξαμε σε κάτι συγκεκριμένο, γιατί αύριο θα αποφασιστούν αυτά
Η δική μου προταση ήταν η εξής:
Το συγκεκριμένο ερώτημα χωρίζεται σε δυο μέρη
1) Εύρεση max
2) εύρεση όσων είναι ίσοι με το max
Όσοι στο Δ4 θεώρησαν μέγιστο βαθμό το 10
Αυτοί που θεώρησαν μέγιστο βαθμό το 10 πρέπει να χάσουν τουλάχιστον το 1. άρα όσα μόρια συμφωνήσουν ότι πάνε στο 1 τα χάνουν σίγουρα.
Αυτό στην καλύτερη περίπτωση
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Γενικός σχολιασμός
« Απάντηση #43 στις: 27 Μάι 2015, 11:30:07 μμ »
Συμφωνούμε
Αν μπορείς να μας ενημερώσεις αναλυτικά αύριο, θα σου χρωστάμε πολλά
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Γενικός σχολιασμός
« Απάντηση #44 στις: 27 Μάι 2015, 11:30:50 μμ »
Το ίδιο...

το θέμα αυτό το συζητήσαμε σήμερα αλλά δεν καταλήξαμε σε κάτι συγκεκριμένο, γιατί αύριο θα αποφασιστούν αυτά
Η δική μου προταση ήταν η εξής:
Το συγκεκριμένο ερώτημα χωρίζεται σε δυο μέρη
1) Εύρεση max
2) εύρεση όσων είναι ίσοι με το maxΑυτοί που θεώρησαν μέγιστο βαθμό το 10 πρέπει να χάσουν τουλάχιστον το 1. άρα όσα μόρια συμφωνήσουν ότι πάνε στο 1 τα χάνουν σίγουρα.
Αυτό στην καλύτερη περίπτωση