Αποστολέας Θέμα: Attansic Boot Agent - Atheros Network Card  (Αναγνώστηκε 1517 φορές)

tsarmis

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Attansic Boot Agent - Atheros Network Card
« στις: 23 Ιούν 2014, 06:15:30 μμ »
Σε καινούργια εγκατάσταση LTSP 12.04.3 στον server έχει 2 κάρτες δικτύου σε bond σε 100Mbps δίκτυο, dhcp είναι το modem/router του σχολείου.
SERVER:
Κώδικας: [Επιλογή]
yper@SERVER:~$ lspci -nn -k | grep -A 2 Ethernet
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
Subsystem: Gigabyte Technology Co., Ltd Motherboard [1458:e000]
Kernel driver in use: r8169
--
04:01.0 Ethernet controller [0200]: D-Link System Inc RTL8139 Ethernet [1186:1300] (rev 10)
Subsystem: D-Link System Inc DFE-528TX 10/100 Fast Ethernet PCI Adapter [1186:1303]
Kernel driver in use: 8139too
Kernel modules: 8139too

Τα client είναι όλα Core2Duo 2.60GHz με 1G RAM και μητρική την Asus P5GC-MX/1333 η οποία έχει:
Κώδικας: [Επιλογή]
ubuntu@ubuntu:~$ lspci -nn -k | grep -A 2 Ethernet
02:00.0 Ethernet controller [0200]: Qualcomm Atheros Attansic L2 Fast Ethernet [1969:2048] (rev a0)
Subsystem: ASUSTeK Computer Inc. Device [1043:8233]
Kernel driver in use: atl2

Η εγκατάσταση δουλεύει κανονικά και συνδέω client ενα virtual machine απο το laptop μου.
Απο τα client του σχολείου όμως συνδέεται μόνο ένα!! Όλα τα άλλα βγάζουν error είτε τα βάλω να κάνουν PXE boot απο το bios είτε με το win32-loader απο τον boot loader των Win XP.

Η καλωδίωση δουλεύει σωστά και την έχω ελέγξει και με μηχάνημα που κάνει πιστοποίηση αλλά και όταν τα PC μπαίνουν στα XP έχουν κανονικά internet απο τον dhcp server.

Τί να ψάξω?
« Τελευταία τροποποίηση: 23 Ιούν 2014, 06:28:27 μμ από tsarmis »

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5206
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Attansic Boot Agent - Atheros Network Card
« Απάντηση #1 στις: 23 Ιούν 2014, 08:26:01 μμ »
Μου φαίνεται ότι είναι πρόβλημα του firmware της μητρικής σου, το οποίο λύνεται αν φλασάρεις νεότερη έκδοση:

http://support.asus.com/Download.aspx?SLanguage=en&m=p5gc-mx%2f1333&p=1&os=
OS: Linux
[+] Bios
Κατεβάζεις το τελευταίο P5GC-MX/1333 0413 BIOS, 2009.07.29 update και το φλασάρεις στη μητρική.

Παρεμπιπτόντως, κοιτάς μόνο το P5GC-MX/1333 0407 Bios, 2008.11.04 update, χωρίς να το κατεβάσεις:
"Fix PXE Boot fail after enable LAN option ROM and install LAN driver in OS"

Δηλαδή σε εκείνη την έκδοση έλυσαν ένα πρόβλημα με το PXE boot, το οποίο ίσως να είναι αυτό που αναφέρεις.

tsarmis

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: Attansic Boot Agent - Atheros Network Card
« Απάντηση #2 στις: 24 Ιούν 2014, 11:53:15 πμ »
Κάτι τόσο απλό αλλά μερικές φορές κολλάμε και δεν το σκεφτόμαστε.
Update το bios σε 0413 και αλλαγή στο bios boot order να κάνει boot πρώτα απο το δίκτυο και όλα παίξανε κανονικά.

Βέβαια με το win32-loader εξακολουθεί να μην κάνει boot, αλλά αφού κάνει boot απο το LAN ROM, όλα καλά.

Server :
Intel Pentium G2030 @ 3.00GHz
4GB RAM,
240 GB HDD partition,
dual boot Win 7

10 FAT client:
Intel Pentium E2180 @ 2.00GHz
1GB RAM
250 GB HDD
dual boot Win XP

Ευχαριστώ για την βοήθεια.