Αποστολέας Θέμα: Πρόβλημα σε εργαστήριο με cisco router  (Αναγνώστηκε 2271 φορές)

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Πρόβλημα σε εργαστήριο με cisco router
« στις: 18 Οκτ 2012, 08:50:10 μμ »
Το πρόβλημά μου είναι ότι μόλις εγκατέστησα το ubuntu 12.04 LTS στο εργαστήριο του σχολείου δημιουργήθηκε πρόβλημα στο δίκτυο του σχολείου. Καταρχήν ο router σταμάτησε να είναι ο primary dhcp & dns server και τα πέρασε όλα στον server του εργαστηρίου. Το πρόβλημα είναι ότι και κλειστός να είναι ο server του εργαστηρίου από εκεί ψάχνουν όλοι οι υπολογιστές του δικτύου τις ρυθμίσεις (έχει αποθηκεύσει τις ρυθμίσεις ο router στο configuration file του?). Το πρόβλημα είναι ότι δεν βγαίνει κανένα μηχάνημα στο δίκτυο, ενώ τα thin-fat clients του εργαστηρίου λειτουργούν κανονικά. Έχει αντιμετωπίσει κανείς κάτι αντίστοιχο? Ο router είναι cisco 876.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5705
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #1 στις: 18 Οκτ 2012, 11:15:04 μμ »
Μερικές πληροφορίες που ίσως σε βοηθήσουν να βγάλεις άκρη:
  • Ο LTSP server (και γενικά οποιοσδήποτε Η/Υ του εργαστηρίου) δεν μπορεί να πειράξει τον προγραμματισμό του cisco router, αυτό γίνεται μέσω μπλε καλωδίου στη θύρα "κονσόλας" του router με τον κατάλληλο κωδικό πρόσβασης.
  • Οι cisco routers δεν λειτουργούν ως DNS servers αλλά μόνο ως DHCP servers.
  • Αν στον LTSP server τρέξεις: sudo /usr/lib/klibc/bin/ipconfig -n eth0, θα δεις τις πληροφορίες που στέλνει ο router σου. Επικόλλησέ τες εδώ αν θες.
  • Λογικά το πρόβλημά σου θα είναι ότι δεν έχεις DNS server στο εργαστήριο (στην IP 10.x.y.10), όταν είναι κλειστός ο LTSP server. Εκεί θεωρητικά έπρεπε να υπάρχει DNS server, είτε Windows είτε Linux. Από την παραπάνω εντολή θα δεις ποιους DNS servers σου στέλνει ο router, λογικά θα είναι ο .10 και ο nic.sch.gr ή αντίστοιχοι.
  • Από έναν Windows client που δεν βλέπει Internet, δοκίμασε ping 8.8.8.8 για να βεβαιωθείς ότι είναι πρόβλημα DNS και όχι κάτι άλλο.

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #2 στις: 19 Οκτ 2012, 12:53:18 πμ »
Θα τα εφαρμόσω αύριο και θα ενημερώσω.
Είχα διαβάσει ένα θέμα που είχες γράψεις σχετικά με την ρύθμιση των cisco router, αλλά αναφερόσουν σε παλαιότερη έκδοση την 10.04 LTS αν δεν κάνω λάθος. Πρόσβαση πάντως στο cisco μέσω μπλε καλωδίου στη θύρα "κονσόλας" του router με τον κατάλληλο κωδικό πρόσβαση έχω αν απαιτείται κάποια ρύθμιση εκεί.

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #3 στις: 19 Οκτ 2012, 11:32:23 πμ »
έτρεξα την εντολή που μου έδωσες και να τα αποτελέσματα:

Κώδικας: [Επιλογή]
IP-Config: eth1 hardware address 00:0e:0c:4a:57:31 mtu 1500 DHCP RARP
IP-Config: eth1 complete (from 10.96.25.157):
 address: 10.96.25.167     broadcast: 255.255.255.255  netmask: 255.255.255.0   
 gateway: 10.96.25.1       dns0     : 10.96.25.10      dns1   : 208.67.222.222 
 domain : domain                                                         
 rootserver: 10.96.25.157 rootpath:
 filename  : �
έχω μόνο ububtu (εκτός εργαστηρίου) μηχανάκια χωρίς internet. Ο ένας με τα windows τον σύνδεσα πάνω στο cisco router απευθείας και για την ώρα παίζει κανονικά. (Δεν μπορώ και να τον πολυπειράξω καθότι είναι του διευθυντή  :angel: )

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5705
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #4 στις: 19 Οκτ 2012, 11:48:02 πμ »
Τυπικά, οι cisco routers διαχειρίζονται από το ΠΣΔ, δηλαδή θεωρητικά δεν θα έπρεπε να είχες βάλει τον opendns ως dns server, ενώ επίσης θα έπρεπε να είχες τουλάχιστον έναν από τους dns servers του ΠΣΔ.

Θα πρότεινα να ανοίξεις ένα ticket στο http://helpdesk.sch.gr να επαναπρογραμματίσουν τον router σου με βάση τις default ρυθμίσεις που βάζουν στα σχολεία.

Αν για κάποιο λόγο δεν το θες αυτό, προτείνω να σβήσεις rootserver και filename από το config, και ως dns να έχεις:
1) Τον LTSP server, εφόσον είναι συνήθως ανοιχτός,
2) Τον nic.sch.gr
3) Τον opendns ή τον public dns της google σαν τελευταία εναλλακτική.

Τώρα για τα ubuntu μηχανάκια που δεν παίρνουν internet, δοκίμασες το ping 8.8.8.8;
Ή, ανέβασε τα αποτελέσματα της εντολής nm-tool.

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #5 στις: 19 Οκτ 2012, 12:46:09 μμ »
Τον κωδικό του router τον έχω επειδή έτυχε να πέσει στα χέρια μου. Το cisco τον είχαμε ρυθμίσει εκ νέου με την τεχνική υποστήριξη πριν το καλοκαίρι με το default script λόγω προβλήματος με την γραμμή. Δεν έχω προσθέσει opendns server στον router!

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #6 στις: 19 Οκτ 2012, 01:09:05 μμ »
και το αποτέλεσμα της εντολής nm-tool
Κώδικας: [Επιλογή]
NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sis900
  State:             disconnected
  Default:           no
  HW Address:        00:11:09:30:01:27

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5705
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #7 στις: 19 Οκτ 2012, 01:12:47 μμ »
> Δεν έχω προσθέσει opendns server στον router
... η γραμμή dns1   : 208.67.222.222  αυτό λέει...  ???

State disconnected; Δηλαδή δεν υπάρχει ενεργή σύνδεση δικτύου, δοκίμασε να δημιουργήσεις μία Auto eth0...
Επίσης μπορείς προσωρινά να δοκιμάσεις και αυτό από κονσόλα:
sudo dhclient eth0

apapakL

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 366
    • ΕΛ/ΛΑΚ και εκπαίδευση - Πληροφορική στο Δημοτικό
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #8 στις: 19 Οκτ 2012, 08:32:56 μμ »
Μήπως έχει και 2η κάρτα δικτύου η οποία θα είναι και η ενεργή...

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #9 στις: 20 Οκτ 2012, 01:35:37 πμ »
> Δεν έχω προσθέσει opendns server στον router
... η γραμμή dns1   : 208.67.222.222  αυτό λέει...  ???

Στο configuration file του router οι dns server που υπάρχουν είναι οι του σχολικού δικτύου. Και για του λόγου το αληθές:
Κώδικας: [Επιλογή]
ip dhcp excluded-address 10.96.25.0 10.96.25.127
!
 ip dhcp pool lan
 network 10.96.25.0 255.255.255.0
 domain-name chi.sch.gr
 dns-server  10.96.25.10 194.63.239.36  194.63.239.164  194.63.237.4
 default-router 10.96.25.1
 netbios-node-type b-node
 lease 30
!
ip domain-name chi.sch.gr
ip name-server 194.63.239.36
ip name-server  194.63.239.164
ip name-server  194.63.237.4

Την εγκατάσταση την έκανα χρησιμοποιώντας αυτό το cd-dvd http://ts.sch.gr/repo/livecd/ubuntu-12.04.1-desktop-i386-sch.iso .

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5705
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #10 στις: 20 Οκτ 2012, 07:11:08 πμ »
...καλά τα λες κι εσύ, καλά τα λέω κι εγώ...  :o
...οπότε προφανώς κάποιος άλλος DHCP server, και όχι ο router, απάντησε στην εντολή ipconfig που δοκίμασες παραπάνω:

IP-Config: eth1 complete (from 10.96.25.157):

1) Ποιο PC έχει IP=10.96.25.157; Αυτός μάλλον είναι DHCP server που παρακάμπτει τον router. Είναι ο LTSP server;
2) Ανέβασε όλα τα αρχεία που υπάρχουν στο /etc/dnsmasq.d/ σε αυτό το PC.
3) Τι συνδεσμολογία τοπικού δικτύου έχεις; Π.χ. η προτεινόμενη είναι: μια κάρτα δικτύου στον LTSP server και όλα, τα πάντα, στο ίδιο switch. Εσύ όμως μπορεί να έχεις δύο κάρτες δικτύου στον LTSP server, και "απομονωμένους" τους clients σε ένα ξεχωριστό switch.
4) Από έναν client με πρόβλημα (δηλαδή που δεν έχει Internet), δοκίμασε τα παρακάτω, και ανέβασε το αποτέλεσμα:
Κώδικας: Text
  1. ip -oneline -family inet addr show
  2. sudo dhclient eth0
  3. ip -oneline -family inet addr show
  4. ping www.google.com
  5. ping 8.8.8.8
  6. cat /etc/network/interfaces
  7.  

chew

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Πρόβλημα σε εργαστήριο με cisco router
« Απάντηση #11 στις: 23 Οκτ 2012, 12:07:52 μμ »
Τελικά ένα ρημάδι Wi-Fi access point έκανε όλη την ζημία  >:(
Τώρα θα του αλλάξω τις ρυθμίσεις και μάλλον θα είμαστε ΟΚ.
Ευχαριστώ για την βοήθειά (και πάλι) Άλκη!  :)