Αποστολέας Θέμα: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....  (Αναγνώστηκε 7616 φορές)

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #30 στις: 28 Μάι 2012, 08:28:39 μμ »
Για να μην παρεξηγηθώ.
Δεν λέω οτι ο τρόπος σου είναι λάθος.
Απλά θεωρώ οτι θα ήταν καλύτερο να τα βάλεις σε ξεχωριστές επαναλήψεις: 1ο για να μπορείς και εσύ ο ίδιος να το ελέγξεις μετά πιο εύκολα και 2ο αυτός που θα πάει να το διορθώσει, να μην μπει στην διαδικασία να προσπαθήσει  να καταλάβει τι κάνεις.
 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #31 στις: 28 Μάι 2012, 10:08:10 μμ »
μπαααα δεν σε παρεξηγώ.....δεν ξέρω την μέρα των εξετάσεων πως θα μου έρθει να λύσω ένα θέμα πάντως συνήθως χωρίς να ξέρω τον λόγο δεν βλέπω τον εύκολο και πιο κατανοητό τρόπο αλλά πολλές φορές τα σκέφτομαι λίγο πολύπλοκα και έτσι τα προβάλλω....το πολύ πολύ (έτσι κι αλλιώς θα έχω ώρα) θα βάλω και κανένα σχόλιο να μην μπερδευτεί ο βαθμολογητής  ;)

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #32 στις: 28 Μάι 2012, 10:18:21 μμ »
θα βάλω και κανένα σχόλιο να μην μπερδευτεί ο βαθμολογητής  ;)

ε αν βάλεις και σχόλια θα είσαι αρχηγός  ;) κανονικά έτσι πρέπει, όταν δίνεις ένα πρόγραμμα σε κάποιον πρέπει να βάζεις και σχόλια, να εξηγήσεις αυτό που κάνεις τέλος πάντων!  :D

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #33 στις: 28 Μάι 2012, 11:39:36 μμ »
Άσκηση με διαγωνισμό φωτογραφίας. Για απορίες, παρατηρήσεις, λάθη κτλ περιμένω σχόλια :)

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #34 στις: 29 Μάι 2012, 12:21:36 πμ »
γιατί το λες????? ::)

Δεν φαίνεται ο πίνακας για τους μαθητές.

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #35 στις: 29 Μάι 2012, 12:44:22 πμ »
Παράθεση
Δεν φαίνεται ο πίνακας για τους μαθητές.
...
Έχεις απόλυτο δίκιο!!!!
Ο πίνακας είναι
ΜΟ    ΤΜΗΜΑ
<10       Α
10-15    Β
>15       Γ

Ευχαριστώ για την παρατήρηση!!
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

alfabit

  • Θαμώνας
  • ***
  • Μηνύματα: 32
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #36 στις: 29 Μάι 2012, 09:41:29 μμ »
Άσκηση με διαγωνισμό φωτογραφίας. Για απορίες, παρατηρήσεις, λάθη κτλ περιμένω σχόλια :)

Συγχαρητήρια, πολύ καλή άσκηση!
Έχω ένα θέμα με τον πίνακα των τάξεων. Μήπως θα έπρεπε να γίνεται πιο ξεκάθαρο τι τιμές περιέχει ο πίνακας αυτός;Υπάρχει βέβαια μια αναφορά στο 4. για την εμφάνιση του γράμματος της τάξης, οπότε υποθέτω ότι μιλάμε για Α,Β,Γ?

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #37 στις: 29 Μάι 2012, 09:58:30 μμ »
Σ'ευχαριστώ!  :)

Ναι, έχεις απόλυτο δίκιο, σε κάποια φάση είχα μια παρένθεση στο ερώτημα δίπλα στη λέξη τάξη... (Α,Β,Γ) αλλά την έβγαλα. Θα έπρεπε  να είναι ξεκάθαρο!

alfabit

  • Θαμώνας
  • ***
  • Μηνύματα: 32
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #38 στις: 29 Μάι 2012, 10:17:42 μμ »
μερικές τελευταίες προτάσεις..

Συνάδελφε έχω να κάνω μια παρατήρηση. Ζητείται από τη διαδικασία ΔΙΑΧ να δημιουργήσει πίνακες μέσω του διαχωρισμού του αρχικού πίνακα ΜΟ. Πώς όμως θα δημιουργηθούν πίνακες όταν δεν γνωρίζουμε εκ των προτέρων τα μεγέθη τους; Δεν ξέρω αν κάνω λάθος σε κάτι αλλά αν έχω καταλάβει καλά την άσκηση,  μου φαίνεται για δυναμική παραχώρηση μνήμης.

metestaki

  • Θαμώνας
  • ***
  • Μηνύματα: 45
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #39 στις: 29 Μάι 2012, 11:48:57 μμ »
Δεν φαίνεται ο πίνακας για τους μαθητές.
Με πρόλαβαν άλλοι!  :D

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #40 στις: 30 Μάι 2012, 01:27:35 πμ »
Νέα άσκηση με τον δείκτη UV εμπνευσμένη από γνωστό site καιρού! Το τελευταίο ερώτημα το έβαλα σαν κομμάτι εφαρμογής κινητού που θα ενημερώνει τον άνθρωπο - χρήστη και θα τον προειδοποιεί  μιας και την ακτινοβολία δεν την καταλαβαίνουμε την άτιμη  :P ! Επίσης με την άσκηση αυτή θέλω να δείξω πόσο σχετίζεται η πληροφορική με τη ζωή μας και τις άλλες επιστήμες και πόσο μπορεί να μας βοηθήσει να αποφύγουμε καταστάσεις και προβλήματα, άσχετα αν και η ίδια μας δημιουργεί άλλα προβλήματα  :(

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #41 στις: 30 Μάι 2012, 03:07:53 πμ »
Και μερικές ασκήσεις  :D

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #42 στις: 30 Μάι 2012, 08:04:46 πμ »
Συνάδελφε έχω να κάνω μια παρατήρηση. Ζητείται από τη διαδικασία ΔΙΑΧ να δημιουργήσει πίνακες μέσω του διαχωρισμού του αρχικού πίνακα ΜΟ. Πώς όμως θα δημιουργηθούν πίνακες όταν δεν γνωρίζουμε εκ των προτέρων τα μεγέθη τους; Δεν ξέρω αν κάνω λάθος σε κάτι αλλά αν έχω καταλάβει καλά την άσκηση,  μου φαίνεται για δυναμική παραχώρηση μνήμης.

Οι πίνακες θα δηλωθούν κανονικά 50 θέσεων όμως επειδή η διαδικασία λέει θα μας επιστρέφει και τον αριθμό των μαθητών του κάθε τμήματος όταν πάμε να εμφανίσουμε ανάλογα ποιο τμήμα θέλουμε θα φτάνουμε μέχρι εκείνη τη θέση που είναι γεμάτος ο πίνακας.

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #43 στις: 30 Μάι 2012, 07:19:31 μμ »
η απάντησή μου για την άσκηση με τα UV....για τυχόν λάθη ή διευκρινίσεις ενημερώστε  ;D

Αλγόριθμος Θεμα_UV
!1
Για ι από 1 μέχρι 22
  Διάβασε ον[ι]
  Για κ από 1 μέχρι 11
    Διάβασε UV[ι, κ]
  Τέλος_επανάληψης
Τέλος_επανάληψης
!2
πλ ← 0
Για ι από 1 μέχρι 22
  Αν UV[ι, 6] < 2.9 τότε
    Εμφάνισε ον[ι], " Χαμηλός"
  αλλιώς_αν UV[ι, 6] ≤ 5.9 τότε
    Εμφάνισε ον[ι], " Μέτριος"
  αλλιώς_αν UV[ι, 6] ≤ 7.9 τότε
    Εμφάνισε ον[ι], " Υψηλός"
    πλ ← πλ + 1
  αλλιώς_αν UV[ι, 6] ≤ 10.9 τότε
    Εμφάνισε ον[ι], " Πολύ υψηλός"
  αλλιώς
    Εμφάνισε "Λαθος δεδομενα"
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε πλ
!3
Για ι από 1 μέχρι 22
  αθ[ι] ← 0
  Για κ από 3 μέχρι 6
    αθ[ι] ← αθ[ι] + UV[ι, κ]
  Τέλος_επανάληψης
  αθ[ι] ← αθ[ι]/4
Τέλος_επανάληψης
max ← αθ[1]
ονmax ← ον[1]
Για ι από 2 μέχρι 22
  Αν αθ[ι] > max τότε
    max ← αθ[ι]
    ονmax ← ον[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ονmax
!4
πλ2 ← 0
Για ι από 1 μέχρι 22
  Σ ← Ψευδής
  κ ← 2
  Αρχή_επανάληψης
    κ ← κ + 1
    Σ ← UV[ι, κ] ≥ 6 και UV[ι, κ] ≤ 7.9
  Μέχρις_ότου κ = 6 ή Σ
  Αν Σ τότε
    πλ2 ← πλ2 + 1
    ΟΝ2[πλ2] ← ον[ι]
  Τέλος_αν
Τέλος_επανάληψης
!5
Διάβασε περ, δερ, μαλ
Αν δερ = "Α" ή μαλ = "Ξ" ή μαλ = "Κ" τότε
  ι ← 1
  βρεθηκε ← Ψευδής
  Όσο ι ≤ 22 και όχι βρεθηκε επανάλαβε
    Αν περ = ον[ι] τότε
      βρεθηκε ← Αληθής
    αλλιώς
      ι ← ι + 1
    Τέλος_αν
  Τέλος_επανάληψης
  Για κ από 1 μέχρι 11
    Αν UV[ι, κ] > 5.9 τότε
      Αν κ ≤ 3 τότε
        Εμφάνισε 9 + κ, "πμ"
      αλλιώς
        Εμφάνισε κ - 3, "μμ"
      Τέλος_αν
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_αν
Τέλος Θεμα_UV

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #44 στις: 31 Μάι 2012, 10:48:59 πμ »
Stefevan να φανταστώ στην άσκηση με τον κανόνα του Μοντέ δεν ζητούσες αυτό ε??

Αλγόριθμος Μοντε
Εμφάνισε 0.4
Για ι από 0 μέχρι 8
  Εμφάνισε ((2^ι)*3 + 4)/10
Τέλος_επανάληψης
Τέλος Μοντε

επίσης θα ήθελα ένα tip για την Τ3.....  :)

τέλος θα ήθελα να ρωτήσω κάτι για το θεμα Α2 των επαναληπτικών 2011...έλεγε να ξαναγράψουμε το παρακάτω τμήμα αλγορίθμου μόνο με την χρήση μιας Για...απο...μεχρι...δεν μπήκα στον κόπο να δω όλες τις λύσεις που προτείνουν στο διαδίκτυο αλλά αυτή που βρήκα ήταν διαφορετική από αυτή που έκανα....

αυτό που δινόταν:
i ← 1
j ← 1
Αρχή_επανάληψης
Εμφάνισε Α[i,j]
i ← i + 1
j ← j + 1
Μέχρις_ότου j > 100


θέλω να μου πείτε κατά την γνώμη σας αν θεωρούσατε την παρακάτω απάντηση σωστή....

η λύση μου:
Για ι απο 1 μεχρι 100
Εμφανισε Α[ι,ι]
τελος_επαναληψης

το ξέρω οτι γίνεται χρήση μόνο μιας ακέραιας μεταβλητής αλλά το αποτέλεσμα είναι το ίδιο..
« Τελευταία τροποποίηση: 31 Μάι 2012, 02:46:19 μμ από Πανάγος94 »