Αποστολέας Θέμα: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....  (Αναγνώστηκε 7612 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #15 στις: 25 Μάι 2012, 05:17:03 μμ »
Ένα λεπτάκι, ποια πλειοψηφία πιστεύει το αντίθετο, αφού 2-3 άτομα έχουν γράψει. Δεν είναι το θέμα αυτό.
Το λες και μόνο σου. Ζητείται να εφαρμόσει την τεχνική.
Η τεχνική καθαυτή μαζί με την εξήγηση και την τεκμηρίωσή της δεν αναφέρεται πουθενά. Αυτό είναι το πρόβλημα.

Το βιβλίο αναφέρει σε διάφορα σημεία απίθανα πράγματα. Το ότι τα αναφέρει δεν σημαίνει ότι μπορεί να ζητηθούν. Δυστυχώς στο μάθημά μας δεν είναι τόσο απλά τα πράγματα.

Απλά θεωρώ οτι απο την στιγμή που το αναφέρει στο βιβλίο, οτι με αριστερή ολίσθηση διπλασιάζεται ένας αριθμός και με δεξιά υπερδιπλασιάζεται, και αναφέρει  τον τρόπο με τον οποίο κάνουμε ολίσθηση μπορεί να του ζητήσει να εφαρμόσει αυτήν την τεχνική.
Αλλά απο την στιγμή που η πλειοψηφία πιστεύει το αντίθετο με μένα τότε εγώ κάνω λάθος και ζητώ συγνώμη.   
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #16 στις: 25 Μάι 2012, 05:33:05 μμ »
Θα διαφωνήσω.
Την τεχνική την αναφέρει.
Απλά δεν κάνει την απόδειξη.
Αν κληθούμε να αναπτύξουμε μια ιατρική εφαρμογή θα πρέπει να γνωρίζουμε απο ιατρική; Ή μας αρκεί να έχουμε έναν έγκυρο τύπο, τον οποίο θα εφαρμόσουμε;
« Τελευταία τροποποίηση: 29 Μάι 2012, 04:19:44 μμ από manosteach »
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #17 στις: 25 Μάι 2012, 06:51:23 μμ »
Stefevan αν γίνεται στείλτο λίγο σε άλλη μορφή γιατί δεν μου το ανοίγει και πρέπει να κάνω κάτι εγκατάσταση στο word και πραγματικά δεν έχω καθόλου όρεξη.....αμα συνεχίσουν με αυτόν τον ρυθμό οι πανελλήνιες μας έχουν διαλύσει....το τελειωτικό χτύπημα θα έρθει με τα μαθηματικά και πραγματικά απορώ πως θα βρούμε την θέληση στο τέλος να γράψουμε και αεππ :/ απλά απογοητευτικό.......

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #18 στις: 25 Μάι 2012, 09:35:26 μμ »
οκ τώρα θα το ανοίξεις :P

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #19 στις: 25 Μάι 2012, 09:53:52 μμ »
Αλλά απο την στιγμή που η πλειοψηφία πιστεύει το αντίθετο με μένα τότε εγώ κάνω λάθος και ζητώ συγνώμη.

Γιατί συγνώμη???  :o Αυτό έλειπε να συμφωνούμε όλοι σε όλα

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #20 στις: 26 Μάι 2012, 09:20:28 μμ »
παραδίδω την λύση μου  :) ....για τυχόν λάθη ειδοποιήστε!!

Αλγόριθμος Θεμα_Γ
πλ ← 0
Για ι από 1 μέχρι 300
  Διάβασε ΒΙ[ι], ΔΙ[ι]
  Αν ΔΙ[ι] = "Δ" τότε
    Αρχή_επανάληψης
      Διάβασε ΠΟ[ι]
    Μέχρις_ότου ΠΟ[ι] ≥ 1
    πλ ← πλ + ΠΟ[ι]
  αλλιώς
    ΠΟ[ι] ← 0
  Τέλος_αν
  πωλησεις[ι] ← 0
Τέλος_επανάληψης
Εμφάνισε πλ
Αρχή_επανάληψης
  Αρχή_επανάληψης
    Διάβασε τιτλος
    Αν τιτλος ≠ " " τότε
      ι ← 1
      βρεθηκε ← Ψευδής
      Όσο ι ≤ 300 και όχι βρεθηκε επανάλαβε
        Αν ΒΙ[ι] = τιτλος τότε
          βρεθηκε ← Αληθής
        αλλιώς
          ι ← ι + 1
        Τέλος_αν
      Τέλος_επανάληψης
    Τέλος_αν
  Μέχρις_ότου βρεθηκε ή τιτλος = " "
  Αν βρεθηκε και ΔΙ[ι] = "Δ" τότε !edited
    ΠΟ[ι] ← ΠΟ[ι] - 1
    πωλησεις[ι] ← πωλησεις[ι] + 1
    Αν ΠΟ[ι] = 0 και ΔΙ[ι] = "ΜΔ" τότε
    Τέλος_αν
  Τέλος_αν
Μέχρις_ότου τιτλος = " "
max ← πωλησεις[1]
ονομα ← ΒΙ[1]
Για ι από 2 μέχρι 300
  Αν πωλησεις[ι] > max τότε
    max ← πωλησεις[ι]
    ονομα ← ΒΙ[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ονομα
Τέλος Θεμα_Γ
« Τελευταία τροποποίηση: 26 Μάι 2012, 10:04:36 μμ από Πανάγος94 »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #21 στις: 26 Μάι 2012, 09:40:35 μμ »
τι εννοείς εδώ?

  Αν Σ και ΔΙ[ι] = "Δ" τότε
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #22 στις: 26 Μάι 2012, 10:05:46 μμ »
πφφφ...απλώς στο τετράδιο την συνθήκη την έβαλα Σ (από Συνθήκη) και μετά που την έγραφα στον διερμηνευτή το έβαλα βρέθηκε για να γίνει πιο κατανοητό...αλλά από ότι φαίνεται κάτι ξέχασα  ;D

metestaki

  • Θαμώνας
  • ***
  • Μηνύματα: 45
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #23 στις: 27 Μάι 2012, 12:12:24 πμ »
Μπορεί μήπως κανείς από σας να δημοσιεύσει σε αυτό το ΘΕΜΑ καμιά άσκηση προτεινόμενη για 2ο,3ο,4ο θέμα (θέλω να είναι δύσκολες αλλά πάντα στα πλαίσια του μαθήματος) .....σας ευχαριστώ!!! αν και υπάρχει χρόνος μέχρι την αεππ δεν πειράζει βάλτε καμιά άσκηση  ;)

Συμφωνώ... Λύσαμε πολλά και διάφορα θέματα πάλι φέτος. Και βέβαια το διαγώνισμα από το Στέκι! Άλλες ασκήσεις "ψαγμένες";  :)

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #24 στις: 27 Μάι 2012, 10:27:51 μμ »
μερικές τελευταίες προτάσεις..
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

metestaki

  • Θαμώνας
  • ***
  • Μηνύματα: 45
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #25 στις: 28 Μάι 2012, 10:44:15 πμ »
μερικές τελευταίες προτάσεις..

Μήπως λείπει καμμιά σελίδα;  :)

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #26 στις: 28 Μάι 2012, 10:52:48 πμ »
παραδίδω την λύση μου  :) ....για τυχόν λάθη ειδοποιήστε!!

  Αν βρεθηκε και ΔΙ[ι] = "Δ" τότε !edited
    ΠΟ[ι] ← ΠΟ[ι] - 1
    πωλησεις[ι] ← πωλησεις[ι] + 1
    Αν ΠΟ[ι] = 0 και ΔΙ[ι] = "ΜΔ" τότε
    Τέλος_αν

  Τέλος_αν
Μέχρις_ότου τιτλος = " "

Γιατί έχεις βάλει αυτήν την δομή επιλογής χωρίς κάποια εντολή;
 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #27 στις: 28 Μάι 2012, 03:05:48 μμ »
Παράθεση
Μήπως λείπει καμμιά σελίδα;

γιατί το λες????? ::)
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #28 στις: 28 Μάι 2012, 07:37:45 μμ »


manosteach αν σου πω ότι θυμάμαι θα είναι ψέμα.....το τετράδιο που την είχα κάνει τελείωσε και το πέταξα  :D .....αν και τώρα που το βλέπω μάλλον ήθελα να βάλω
Αν ΠΟ[ι] = 0 τότε ΔΙ[ι] = "ΜΔ"


manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #29 στις: 28 Μάι 2012, 08:12:07 μμ »

manosteach αν σου πω ότι θυμάμαι θα είναι ψέμα.....το τετράδιο που την είχα κάνει τελείωσε και το πέταξα  :D .....αν και τώρα που το βλέπω μάλλον ήθελα να βάλω
Αν ΠΟ[ι] = 0 τότε ΔΙ[ι] = "ΜΔ"
Μα κατάλαβα οτι κάτι θα έχεις ξεχάσει ή κάτι θα ήθελες να γράψεις διαφορετικό.

Μου επιτρέπεις να κάνω μια παρατήρηση;
Απο την στιγμή που απ' οτι μπορώ να καταλάβω έχεις πολύ καλές γνώσεις πάνω στο μάθημα.
1ο Δεν υπάρχει λόγος να αγχώνεσαι.
2ο Προσωπικά θα προτιμούσα να μην τα βάζεις όλα σε μία επανάληψη. Όχι οτι είναι λάθος απλά με ξεχωριστές επαναλήψεις δεν επιτρέπεις στον βαθμολογητή να μπερδευτεί.   Με απλά λόγια γίνεται πιο ευανάγνωστο το γραπτό σου.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com