Αποστολέας Θέμα: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....  (Αναγνώστηκε 7613 φορές)

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« στις: 24 Μάι 2012, 07:37:23 μμ »
Μπορεί μήπως κανείς από σας να δημοσιεύσει σε αυτό το ΘΕΜΑ καμιά άσκηση προτεινόμενη για 2ο,3ο,4ο θέμα (θέλω να είναι δύσκολες αλλά πάντα στα πλαίσια του μαθήματος) .....σας ευχαριστώ!!! αν και υπάρχει χρόνος μέχρι την αεππ δεν πειράζει βάλτε καμιά άσκηση  ;)

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #1 στις: 25 Μάι 2012, 01:29:47 πμ »
έχω ένα με βιβλιοθήκη :)

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #2 στις: 25 Μάι 2012, 06:38:16 πμ »
Σαν 2ο Θέμα στέλνω το παρακάτω.
Στην ουσία δεν είναι καθόλου δύσκολο. Προϋποθέτει όμως να γνωρίσεις με ποιον τρόπο διπλασιάζουμε και υποδιπλασιάζουμε έναν αριθμό.


ΘΕΜΑ 2
Να γραφεί αλγόριθμος που με δεδομένο έναν πίνακα Α[100], ο οποίος έχει αποθηκευμένο στις θέσεις του έναν αριθμό σε δυαδική μορφή, να ρωτάει τον χρήστη αν θέλει να διπλασιάσει ή να υποδιπλασιάσει τον αριθμό. Στην συνέχεια ανάλογα με την απάντηση να υλοποιεί διπλασιασμό ή υποδιπλασιασμό. 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #3 στις: 25 Μάι 2012, 02:56:18 μμ »
Σαν 2ο Θέμα στέλνω το παρακάτω.
Στην ουσία δεν είναι καθόλου δύσκολο. Προϋποθέτει όμως να γνωρίσεις με ποιον τρόπο διπλασιάζουμε και υποδιπλασιάζουμε έναν αριθμό.


ΘΕΜΑ 2
Να γραφεί αλγόριθμος που με δεδομένο έναν πίνακα Α[100], ο οποίος έχει αποθηκευμένο στις θέσεις του έναν αριθμό σε δυαδική μορφή, να ρωτάει τον χρήστη αν θέλει να διπλασιάσει ή να υποδιπλασιάσει τον αριθμό. Στην συνέχεια ανάλογα με την απάντηση να υλοποιεί διπλασιασμό ή υποδιπλασιασμό. 


Γιατί Α[100] ;;;;

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #4 στις: 25 Μάι 2012, 03:13:44 μμ »
Σαν 2ο Θέμα στέλνω το παρακάτω.
Στην ουσία δεν είναι καθόλου δύσκολο. Προϋποθέτει όμως να γνωρίσεις με ποιον τρόπο διπλασιάζουμε και υποδιπλασιάζουμε έναν αριθμό.


το shift δεν εξετάζεται μόνο θεωρητικά? μπορεί να μπει έτσι?

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #5 στις: 25 Μάι 2012, 03:26:03 μμ »
προφανώς και δεν μπορεί αφού οι δυαδικοί αριθμοί είναι εκτός ύλης.
Τα παδιά δεν έχουν διδαχθεί την αναπαράσταση δυαδικών αριθμών.


το shift δεν εξετάζεται μόνο θεωρητικά? μπορεί να μπει έτσι?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #6 στις: 25 Μάι 2012, 04:39:54 μμ »
Μα δεν θα ζητήσει να μετατρέψει έναν αριθμό σε δυαδική μορφή.
Δεν είμαι απόλυτα σίγουρος, απλά θεωρώ οτι αν ζητούσε κάτι τέτοιο δεν θα ήταν εκτός ύλης.
Αυτό που ζητάει είναι να μεταφέρεις όλα τα δεδομένα ενός πίνακα, μια θέση προς τα δεξιά και να προσθέσεις ένα μηδενικό στην πρώτη θέση του πίνακα  ή μία προς τα αριστερά και να προσθέσεις ένα μηδενικό στην τελευταία θέση του πίνακα.

Είναι η ολίσθηση εκτός ύλης;Που το αναφέρει αυτό;
 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #7 στις: 25 Μάι 2012, 04:42:50 μμ »
Γιατί Α[100] ;;;;
Δεν σημαίνει κάτι το Α[100].
Στην τύχη το έβαλα.
Το ζητούμενο είναι άλλο, δεν έχει να κάνει με το μέγεθος του πίνακα.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #8 στις: 25 Μάι 2012, 04:45:39 μμ »
Συνήθως στα βιβλία αναφέρονται αυτά που είναι εντός ύλης και όχι αυτά που είναι εκτός.
Η αναπαράσταση δυαδικών αριθμών δεν υπάρχει σε αυτό το μάθημα άρα και δεν εξετάζεται, απλά.
Το θέμα σου προυποθέτει ότι οι μαθητές γνωρίζουν αυτή την αναπαράσταση κάτι που δεν ισχύει

Είναι η ολίσθηση εκτός ύλης;Που το αναφέρει αυτό;

Επειδή πλησιάζουν οι εξετάσεις και ήδη έχουν βάλει δύσκολα θέματα στα προηγούμενα μαθήματα και η ψυχολογία των μαθητών δεν είναι και στα καλύτερά της ειδικά σήμερα
καλό θα ήταν να είμαστε λίγο προσεκτικοί στα θέματα που προτείνουμε αυτές τις μέρες, διότι το στέκι το διαβάζουν και μαθητές.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #9 στις: 25 Μάι 2012, 04:51:03 μμ »
Στο βιβλίο λέει για την ολίσθηση τα παρακάτω
Στα κυκλώματα του υπολογιστή τα δεδομένα αποθηκεύονται με δυα-
δική μορφή, δηλαδή 0 και 1, ανεξάρτητα από το πως τα ορίζει ο προ-
γραμματιστής, όπως ακεραίους ή πραγματικούς σε δεκαδικό σύστημα, ή
ακόμη χαρακτήρες κ.λπ. Έτσι ο αριθμός 17 του δεκαδικού συστήματος ι-
σοδυναμεί με τον αριθμό 00010001 του δυαδικού συστήματος, ο οποίος
μπορεί να αποθηκευθεί σε ένα byte. Αν μετακινήσουμε τα ψηφία αυτά
κατά μία θέση προς τα αριστερά, δηλαδή αν προσθέσουμε ένα 0 στο τέ-
λος του αριθμού και αγνοήσουμε το αρχικό 0, τότε προκύπτει ο αριθμός
00100010 του δυαδικού συστήματος, που ισοδυναμεί με το αριθμό 34
του δεκαδικού συστήματος. Επίσης, με παρόμοιο τρόπο, αν μετακινή-
σουμε τα ψηφία κατά μία θέση δεξιά, δηλαδή αποκόψουμε το τελευταίο
ψηφίο 1 και θεωρήσουμε ένα ακόμη αρχικό 0, τότε προκύπτει ο αριθμός
00001000 του δυαδικού συστήματος, που ισοδυναμεί με τον αριθμό 8
του δεκαδικού συστήματος. Άρα η ολίσθηση προς τα αριστερά ισοδυνα-
μεί με πολλαπλασιασμό επί δύο, ενώ η ολίσθηση προς τα δεξιά ισοδυνα-
μεί με την ακέραια διαίρεση διά δύο.
Το παραπάνω κομμάτι είναι εντός ύλης σωστά;
Δεν γίνεται να ζητήσει να εφαρμόσουν το παραπάνω κομμάτι σε αλγόριθμο;
Δεν έχω καμία διάθεση να το παίξω έξυπνος. Ειλικρινή απορία εκφράζω.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #10 στις: 25 Μάι 2012, 04:55:00 μμ »
Νομίζω πως θα πρεπε να εξεταστεί το πολύ σε σωστό ή λάθος από τη στιγμή που δεν γνωρίζουν το δυαδικό σύστημα  :) Άσχετα αν αναφέρεται το δυαδικό, δεν το διδάσκονται! Το δυαδικό το διδάσκεσαι κανονικά στο 1ο εξάμηνο της πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #11 στις: 25 Μάι 2012, 04:57:55 μμ »
Δηλαδή κατά τη γνώμη σου μετά από την ανάγνωση του παρακάτω κειμένου ο μαθητής έχει καταλάβει τι είναι δυαδικός αριθμός???
Καταρχήν δεν μιλάει πουθενά για δυναμείς του 2. Δεν μιλάει πουθενά για μετατροπές. Αν ο μαθητής δεν μετατρέψει ένα δυαδικό προς και από το δεκαδικό πως θα καταλάβει την αναπαράσταση?
ή μήπως προτείνεις να μάθει ο μαθητής παπαγαλία το παρακάτω κείμενο?

Ας πούμε ότι διαβάζεις το παρακάτω και δεν ξέρεις τι είναι οι δυαδικοί αριθμοί
Έτσι ο αριθμός 17 του δεκαδικού συστήματος ι-
σοδυναμεί με τον αριθμό 00010001 του δυαδικού συστήματος, ο οποίος
μπορεί να αποθηκευθεί σε ένα byte. Αν μετακινήσουμε τα ψηφία αυτά
κατά μία θέση προς τα αριστερά, δηλαδή αν προσθέσουμε ένα 0 στο τέ-
λος του αριθμού και αγνοήσουμε το αρχικό 0, τότε προκύπτει ο αριθμός
00100010 του δυαδικού συστήματος, που ισοδυναμεί με το αριθμό 34
του δεκαδικού συστήματος.


δεν θα σου έρθει λογικά η ερώτηση γιατί?
που αναφέρει την εξήγηση στο βιβλίο?

Στο βιβλίο αναφέρει ένα συγκεκριμένο παράδειγμα και τίποτα άλλο. Εσύ ζητάς τον κανόνα, οπότε ζητάς από τον μαθητή να γενικεύσει το παράδειγμα.
Με το ίδιο σκεπτικό θα μπορούσαμε να ζητήσουμε κώδικα assembly ή lisp αφού υπάρχει σε παράδειγμα του βιβλίου

Επίσης ο πολλαπλασιασμός αλά ρωσικά είναι παράδειγμα και όχι θεωρία και δεν μπορεί να ζητηθεί από τους μαθητές, μόνο η ολίσθηση και αυτή το συζητάμε για το πως θα μπορούσε να ζητηθεί
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #12 στις: 25 Μάι 2012, 05:01:04 μμ »
Η εφαρμογή της ολίσθησης γιατί προϋποθέτει γνώση του δυαδικού συστήματος;
Επαναλαμβάνω οτι είναι πραγματική απορία αυτό που ρωτάω και σε καμία περίπτωση δεν έχω ειρωνική διάθεση. 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #13 στις: 25 Μάι 2012, 05:05:27 μμ »
Πως θα εξηγήσεις σε έναν μαθητή ότι η ολίσθηση αριστερά είναι πολλαπλασιασμός επί 2?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #14 στις: 25 Μάι 2012, 05:11:20 μμ »
Πως θα εξηγήσεις σε έναν μαθητή ότι η ολίσθηση αριστερά είναι πολλαπλασιασμός επί 2?
Δεν διαφωνώ καθόλου με αυτό που λες.
Απλά θεωρώ οτι απο την στιγμή που το αναφέρει στο βιβλίο, οτι με αριστερή ολίσθηση διπλασιάζεται ένας αριθμός και με δεξιά υπερδιπλασιάζεται, και αναφέρει  τον τρόπο με τον οποίο κάνουμε ολίσθηση μπορεί να του ζητήσει να εφαρμόσει αυτήν την τεχνική.
Αλλά απο την στιγμή που η πλειοψηφία πιστεύει το αντίθετο με μένα τότε εγώ κάνω λάθος και ζητώ συγνώμη.   
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #15 στις: 25 Μάι 2012, 05:17:03 μμ »
Ένα λεπτάκι, ποια πλειοψηφία πιστεύει το αντίθετο, αφού 2-3 άτομα έχουν γράψει. Δεν είναι το θέμα αυτό.
Το λες και μόνο σου. Ζητείται να εφαρμόσει την τεχνική.
Η τεχνική καθαυτή μαζί με την εξήγηση και την τεκμηρίωσή της δεν αναφέρεται πουθενά. Αυτό είναι το πρόβλημα.

Το βιβλίο αναφέρει σε διάφορα σημεία απίθανα πράγματα. Το ότι τα αναφέρει δεν σημαίνει ότι μπορεί να ζητηθούν. Δυστυχώς στο μάθημά μας δεν είναι τόσο απλά τα πράγματα.

Απλά θεωρώ οτι απο την στιγμή που το αναφέρει στο βιβλίο, οτι με αριστερή ολίσθηση διπλασιάζεται ένας αριθμός και με δεξιά υπερδιπλασιάζεται, και αναφέρει  τον τρόπο με τον οποίο κάνουμε ολίσθηση μπορεί να του ζητήσει να εφαρμόσει αυτήν την τεχνική.
Αλλά απο την στιγμή που η πλειοψηφία πιστεύει το αντίθετο με μένα τότε εγώ κάνω λάθος και ζητώ συγνώμη.   
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #16 στις: 25 Μάι 2012, 05:33:05 μμ »
Θα διαφωνήσω.
Την τεχνική την αναφέρει.
Απλά δεν κάνει την απόδειξη.
Αν κληθούμε να αναπτύξουμε μια ιατρική εφαρμογή θα πρέπει να γνωρίζουμε απο ιατρική; Ή μας αρκεί να έχουμε έναν έγκυρο τύπο, τον οποίο θα εφαρμόσουμε;
« Τελευταία τροποποίηση: 29 Μάι 2012, 04:19:44 μμ από manosteach »
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #17 στις: 25 Μάι 2012, 06:51:23 μμ »
Stefevan αν γίνεται στείλτο λίγο σε άλλη μορφή γιατί δεν μου το ανοίγει και πρέπει να κάνω κάτι εγκατάσταση στο word και πραγματικά δεν έχω καθόλου όρεξη.....αμα συνεχίσουν με αυτόν τον ρυθμό οι πανελλήνιες μας έχουν διαλύσει....το τελειωτικό χτύπημα θα έρθει με τα μαθηματικά και πραγματικά απορώ πως θα βρούμε την θέληση στο τέλος να γράψουμε και αεππ :/ απλά απογοητευτικό.......

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #18 στις: 25 Μάι 2012, 09:35:26 μμ »
οκ τώρα θα το ανοίξεις :P

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #19 στις: 25 Μάι 2012, 09:53:52 μμ »
Αλλά απο την στιγμή που η πλειοψηφία πιστεύει το αντίθετο με μένα τότε εγώ κάνω λάθος και ζητώ συγνώμη.

Γιατί συγνώμη???  :o Αυτό έλειπε να συμφωνούμε όλοι σε όλα

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #20 στις: 26 Μάι 2012, 09:20:28 μμ »
παραδίδω την λύση μου  :) ....για τυχόν λάθη ειδοποιήστε!!

Αλγόριθμος Θεμα_Γ
πλ ← 0
Για ι από 1 μέχρι 300
  Διάβασε ΒΙ[ι], ΔΙ[ι]
  Αν ΔΙ[ι] = "Δ" τότε
    Αρχή_επανάληψης
      Διάβασε ΠΟ[ι]
    Μέχρις_ότου ΠΟ[ι] ≥ 1
    πλ ← πλ + ΠΟ[ι]
  αλλιώς
    ΠΟ[ι] ← 0
  Τέλος_αν
  πωλησεις[ι] ← 0
Τέλος_επανάληψης
Εμφάνισε πλ
Αρχή_επανάληψης
  Αρχή_επανάληψης
    Διάβασε τιτλος
    Αν τιτλος ≠ " " τότε
      ι ← 1
      βρεθηκε ← Ψευδής
      Όσο ι ≤ 300 και όχι βρεθηκε επανάλαβε
        Αν ΒΙ[ι] = τιτλος τότε
          βρεθηκε ← Αληθής
        αλλιώς
          ι ← ι + 1
        Τέλος_αν
      Τέλος_επανάληψης
    Τέλος_αν
  Μέχρις_ότου βρεθηκε ή τιτλος = " "
  Αν βρεθηκε και ΔΙ[ι] = "Δ" τότε !edited
    ΠΟ[ι] ← ΠΟ[ι] - 1
    πωλησεις[ι] ← πωλησεις[ι] + 1
    Αν ΠΟ[ι] = 0 και ΔΙ[ι] = "ΜΔ" τότε
    Τέλος_αν
  Τέλος_αν
Μέχρις_ότου τιτλος = " "
max ← πωλησεις[1]
ονομα ← ΒΙ[1]
Για ι από 2 μέχρι 300
  Αν πωλησεις[ι] > max τότε
    max ← πωλησεις[ι]
    ονομα ← ΒΙ[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ονομα
Τέλος Θεμα_Γ
« Τελευταία τροποποίηση: 26 Μάι 2012, 10:04:36 μμ από Πανάγος94 »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #21 στις: 26 Μάι 2012, 09:40:35 μμ »
τι εννοείς εδώ?

  Αν Σ και ΔΙ[ι] = "Δ" τότε
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #22 στις: 26 Μάι 2012, 10:05:46 μμ »
πφφφ...απλώς στο τετράδιο την συνθήκη την έβαλα Σ (από Συνθήκη) και μετά που την έγραφα στον διερμηνευτή το έβαλα βρέθηκε για να γίνει πιο κατανοητό...αλλά από ότι φαίνεται κάτι ξέχασα  ;D

metestaki

  • Θαμώνας
  • ***
  • Μηνύματα: 45
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #23 στις: 27 Μάι 2012, 12:12:24 πμ »
Μπορεί μήπως κανείς από σας να δημοσιεύσει σε αυτό το ΘΕΜΑ καμιά άσκηση προτεινόμενη για 2ο,3ο,4ο θέμα (θέλω να είναι δύσκολες αλλά πάντα στα πλαίσια του μαθήματος) .....σας ευχαριστώ!!! αν και υπάρχει χρόνος μέχρι την αεππ δεν πειράζει βάλτε καμιά άσκηση  ;)

Συμφωνώ... Λύσαμε πολλά και διάφορα θέματα πάλι φέτος. Και βέβαια το διαγώνισμα από το Στέκι! Άλλες ασκήσεις "ψαγμένες";  :)

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #24 στις: 27 Μάι 2012, 10:27:51 μμ »
μερικές τελευταίες προτάσεις..
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

metestaki

  • Θαμώνας
  • ***
  • Μηνύματα: 45
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #25 στις: 28 Μάι 2012, 10:44:15 πμ »
μερικές τελευταίες προτάσεις..

Μήπως λείπει καμμιά σελίδα;  :)

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #26 στις: 28 Μάι 2012, 10:52:48 πμ »
παραδίδω την λύση μου  :) ....για τυχόν λάθη ειδοποιήστε!!

  Αν βρεθηκε και ΔΙ[ι] = "Δ" τότε !edited
    ΠΟ[ι] ← ΠΟ[ι] - 1
    πωλησεις[ι] ← πωλησεις[ι] + 1
    Αν ΠΟ[ι] = 0 και ΔΙ[ι] = "ΜΔ" τότε
    Τέλος_αν

  Τέλος_αν
Μέχρις_ότου τιτλος = " "

Γιατί έχεις βάλει αυτήν την δομή επιλογής χωρίς κάποια εντολή;
 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #27 στις: 28 Μάι 2012, 03:05:48 μμ »
Παράθεση
Μήπως λείπει καμμιά σελίδα;

γιατί το λες????? ::)
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #28 στις: 28 Μάι 2012, 07:37:45 μμ »


manosteach αν σου πω ότι θυμάμαι θα είναι ψέμα.....το τετράδιο που την είχα κάνει τελείωσε και το πέταξα  :D .....αν και τώρα που το βλέπω μάλλον ήθελα να βάλω
Αν ΠΟ[ι] = 0 τότε ΔΙ[ι] = "ΜΔ"


manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #29 στις: 28 Μάι 2012, 08:12:07 μμ »

manosteach αν σου πω ότι θυμάμαι θα είναι ψέμα.....το τετράδιο που την είχα κάνει τελείωσε και το πέταξα  :D .....αν και τώρα που το βλέπω μάλλον ήθελα να βάλω
Αν ΠΟ[ι] = 0 τότε ΔΙ[ι] = "ΜΔ"
Μα κατάλαβα οτι κάτι θα έχεις ξεχάσει ή κάτι θα ήθελες να γράψεις διαφορετικό.

Μου επιτρέπεις να κάνω μια παρατήρηση;
Απο την στιγμή που απ' οτι μπορώ να καταλάβω έχεις πολύ καλές γνώσεις πάνω στο μάθημα.
1ο Δεν υπάρχει λόγος να αγχώνεσαι.
2ο Προσωπικά θα προτιμούσα να μην τα βάζεις όλα σε μία επανάληψη. Όχι οτι είναι λάθος απλά με ξεχωριστές επαναλήψεις δεν επιτρέπεις στον βαθμολογητή να μπερδευτεί.   Με απλά λόγια γίνεται πιο ευανάγνωστο το γραπτό σου.
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #30 στις: 28 Μάι 2012, 08:28:39 μμ »
Για να μην παρεξηγηθώ.
Δεν λέω οτι ο τρόπος σου είναι λάθος.
Απλά θεωρώ οτι θα ήταν καλύτερο να τα βάλεις σε ξεχωριστές επαναλήψεις: 1ο για να μπορείς και εσύ ο ίδιος να το ελέγξεις μετά πιο εύκολα και 2ο αυτός που θα πάει να το διορθώσει, να μην μπει στην διαδικασία να προσπαθήσει  να καταλάβει τι κάνεις.
 
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #31 στις: 28 Μάι 2012, 10:08:10 μμ »
μπαααα δεν σε παρεξηγώ.....δεν ξέρω την μέρα των εξετάσεων πως θα μου έρθει να λύσω ένα θέμα πάντως συνήθως χωρίς να ξέρω τον λόγο δεν βλέπω τον εύκολο και πιο κατανοητό τρόπο αλλά πολλές φορές τα σκέφτομαι λίγο πολύπλοκα και έτσι τα προβάλλω....το πολύ πολύ (έτσι κι αλλιώς θα έχω ώρα) θα βάλω και κανένα σχόλιο να μην μπερδευτεί ο βαθμολογητής  ;)

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #32 στις: 28 Μάι 2012, 10:18:21 μμ »
θα βάλω και κανένα σχόλιο να μην μπερδευτεί ο βαθμολογητής  ;)

ε αν βάλεις και σχόλια θα είσαι αρχηγός  ;) κανονικά έτσι πρέπει, όταν δίνεις ένα πρόγραμμα σε κάποιον πρέπει να βάζεις και σχόλια, να εξηγήσεις αυτό που κάνεις τέλος πάντων!  :D

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #33 στις: 28 Μάι 2012, 11:39:36 μμ »
Άσκηση με διαγωνισμό φωτογραφίας. Για απορίες, παρατηρήσεις, λάθη κτλ περιμένω σχόλια :)

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #34 στις: 29 Μάι 2012, 12:21:36 πμ »
γιατί το λες????? ::)

Δεν φαίνεται ο πίνακας για τους μαθητές.

tdrivas

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 656
  • κάποτε έκαιγαν βιβλία,τώρα καίνε μυαλά...
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #35 στις: 29 Μάι 2012, 12:44:22 πμ »
Παράθεση
Δεν φαίνεται ο πίνακας για τους μαθητές.
...
Έχεις απόλυτο δίκιο!!!!
Ο πίνακας είναι
ΜΟ    ΤΜΗΜΑ
<10       Α
10-15    Β
>15       Γ

Ευχαριστώ για την παρατήρηση!!
Thanassis Drivas
BSc in Computer Science
MSc in Space Science Applications and Technologies

alfabit

  • Θαμώνας
  • ***
  • Μηνύματα: 32
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #36 στις: 29 Μάι 2012, 09:41:29 μμ »
Άσκηση με διαγωνισμό φωτογραφίας. Για απορίες, παρατηρήσεις, λάθη κτλ περιμένω σχόλια :)

Συγχαρητήρια, πολύ καλή άσκηση!
Έχω ένα θέμα με τον πίνακα των τάξεων. Μήπως θα έπρεπε να γίνεται πιο ξεκάθαρο τι τιμές περιέχει ο πίνακας αυτός;Υπάρχει βέβαια μια αναφορά στο 4. για την εμφάνιση του γράμματος της τάξης, οπότε υποθέτω ότι μιλάμε για Α,Β,Γ?

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #37 στις: 29 Μάι 2012, 09:58:30 μμ »
Σ'ευχαριστώ!  :)

Ναι, έχεις απόλυτο δίκιο, σε κάποια φάση είχα μια παρένθεση στο ερώτημα δίπλα στη λέξη τάξη... (Α,Β,Γ) αλλά την έβγαλα. Θα έπρεπε  να είναι ξεκάθαρο!

alfabit

  • Θαμώνας
  • ***
  • Μηνύματα: 32
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #38 στις: 29 Μάι 2012, 10:17:42 μμ »
μερικές τελευταίες προτάσεις..

Συνάδελφε έχω να κάνω μια παρατήρηση. Ζητείται από τη διαδικασία ΔΙΑΧ να δημιουργήσει πίνακες μέσω του διαχωρισμού του αρχικού πίνακα ΜΟ. Πώς όμως θα δημιουργηθούν πίνακες όταν δεν γνωρίζουμε εκ των προτέρων τα μεγέθη τους; Δεν ξέρω αν κάνω λάθος σε κάτι αλλά αν έχω καταλάβει καλά την άσκηση,  μου φαίνεται για δυναμική παραχώρηση μνήμης.

metestaki

  • Θαμώνας
  • ***
  • Μηνύματα: 45
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #39 στις: 29 Μάι 2012, 11:48:57 μμ »
Δεν φαίνεται ο πίνακας για τους μαθητές.
Με πρόλαβαν άλλοι!  :D

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #40 στις: 30 Μάι 2012, 01:27:35 πμ »
Νέα άσκηση με τον δείκτη UV εμπνευσμένη από γνωστό site καιρού! Το τελευταίο ερώτημα το έβαλα σαν κομμάτι εφαρμογής κινητού που θα ενημερώνει τον άνθρωπο - χρήστη και θα τον προειδοποιεί  μιας και την ακτινοβολία δεν την καταλαβαίνουμε την άτιμη  :P ! Επίσης με την άσκηση αυτή θέλω να δείξω πόσο σχετίζεται η πληροφορική με τη ζωή μας και τις άλλες επιστήμες και πόσο μπορεί να μας βοηθήσει να αποφύγουμε καταστάσεις και προβλήματα, άσχετα αν και η ίδια μας δημιουργεί άλλα προβλήματα  :(

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #41 στις: 30 Μάι 2012, 03:07:53 πμ »
Και μερικές ασκήσεις  :D

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #42 στις: 30 Μάι 2012, 08:04:46 πμ »
Συνάδελφε έχω να κάνω μια παρατήρηση. Ζητείται από τη διαδικασία ΔΙΑΧ να δημιουργήσει πίνακες μέσω του διαχωρισμού του αρχικού πίνακα ΜΟ. Πώς όμως θα δημιουργηθούν πίνακες όταν δεν γνωρίζουμε εκ των προτέρων τα μεγέθη τους; Δεν ξέρω αν κάνω λάθος σε κάτι αλλά αν έχω καταλάβει καλά την άσκηση,  μου φαίνεται για δυναμική παραχώρηση μνήμης.

Οι πίνακες θα δηλωθούν κανονικά 50 θέσεων όμως επειδή η διαδικασία λέει θα μας επιστρέφει και τον αριθμό των μαθητών του κάθε τμήματος όταν πάμε να εμφανίσουμε ανάλογα ποιο τμήμα θέλουμε θα φτάνουμε μέχρι εκείνη τη θέση που είναι γεμάτος ο πίνακας.

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #43 στις: 30 Μάι 2012, 07:19:31 μμ »
η απάντησή μου για την άσκηση με τα UV....για τυχόν λάθη ή διευκρινίσεις ενημερώστε  ;D

Αλγόριθμος Θεμα_UV
!1
Για ι από 1 μέχρι 22
  Διάβασε ον[ι]
  Για κ από 1 μέχρι 11
    Διάβασε UV[ι, κ]
  Τέλος_επανάληψης
Τέλος_επανάληψης
!2
πλ ← 0
Για ι από 1 μέχρι 22
  Αν UV[ι, 6] < 2.9 τότε
    Εμφάνισε ον[ι], " Χαμηλός"
  αλλιώς_αν UV[ι, 6] ≤ 5.9 τότε
    Εμφάνισε ον[ι], " Μέτριος"
  αλλιώς_αν UV[ι, 6] ≤ 7.9 τότε
    Εμφάνισε ον[ι], " Υψηλός"
    πλ ← πλ + 1
  αλλιώς_αν UV[ι, 6] ≤ 10.9 τότε
    Εμφάνισε ον[ι], " Πολύ υψηλός"
  αλλιώς
    Εμφάνισε "Λαθος δεδομενα"
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε πλ
!3
Για ι από 1 μέχρι 22
  αθ[ι] ← 0
  Για κ από 3 μέχρι 6
    αθ[ι] ← αθ[ι] + UV[ι, κ]
  Τέλος_επανάληψης
  αθ[ι] ← αθ[ι]/4
Τέλος_επανάληψης
max ← αθ[1]
ονmax ← ον[1]
Για ι από 2 μέχρι 22
  Αν αθ[ι] > max τότε
    max ← αθ[ι]
    ονmax ← ον[ι]
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε ονmax
!4
πλ2 ← 0
Για ι από 1 μέχρι 22
  Σ ← Ψευδής
  κ ← 2
  Αρχή_επανάληψης
    κ ← κ + 1
    Σ ← UV[ι, κ] ≥ 6 και UV[ι, κ] ≤ 7.9
  Μέχρις_ότου κ = 6 ή Σ
  Αν Σ τότε
    πλ2 ← πλ2 + 1
    ΟΝ2[πλ2] ← ον[ι]
  Τέλος_αν
Τέλος_επανάληψης
!5
Διάβασε περ, δερ, μαλ
Αν δερ = "Α" ή μαλ = "Ξ" ή μαλ = "Κ" τότε
  ι ← 1
  βρεθηκε ← Ψευδής
  Όσο ι ≤ 22 και όχι βρεθηκε επανάλαβε
    Αν περ = ον[ι] τότε
      βρεθηκε ← Αληθής
    αλλιώς
      ι ← ι + 1
    Τέλος_αν
  Τέλος_επανάληψης
  Για κ από 1 μέχρι 11
    Αν UV[ι, κ] > 5.9 τότε
      Αν κ ≤ 3 τότε
        Εμφάνισε 9 + κ, "πμ"
      αλλιώς
        Εμφάνισε κ - 3, "μμ"
      Τέλος_αν
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_αν
Τέλος Θεμα_UV

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #44 στις: 31 Μάι 2012, 10:48:59 πμ »
Stefevan να φανταστώ στην άσκηση με τον κανόνα του Μοντέ δεν ζητούσες αυτό ε??

Αλγόριθμος Μοντε
Εμφάνισε 0.4
Για ι από 0 μέχρι 8
  Εμφάνισε ((2^ι)*3 + 4)/10
Τέλος_επανάληψης
Τέλος Μοντε

επίσης θα ήθελα ένα tip για την Τ3.....  :)

τέλος θα ήθελα να ρωτήσω κάτι για το θεμα Α2 των επαναληπτικών 2011...έλεγε να ξαναγράψουμε το παρακάτω τμήμα αλγορίθμου μόνο με την χρήση μιας Για...απο...μεχρι...δεν μπήκα στον κόπο να δω όλες τις λύσεις που προτείνουν στο διαδίκτυο αλλά αυτή που βρήκα ήταν διαφορετική από αυτή που έκανα....

αυτό που δινόταν:
i ← 1
j ← 1
Αρχή_επανάληψης
Εμφάνισε Α[i,j]
i ← i + 1
j ← j + 1
Μέχρις_ότου j > 100


θέλω να μου πείτε κατά την γνώμη σας αν θεωρούσατε την παρακάτω απάντηση σωστή....

η λύση μου:
Για ι απο 1 μεχρι 100
Εμφανισε Α[ι,ι]
τελος_επαναληψης

το ξέρω οτι γίνεται χρήση μόνο μιας ακέραιας μεταβλητής αλλά το αποτέλεσμα είναι το ίδιο..
« Τελευταία τροποποίηση: 31 Μάι 2012, 02:46:19 μμ από Πανάγος94 »

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #45 στις: 31 Μάι 2012, 08:04:41 μμ »
Πανάγο.. αφού βγαίνει... γιατί όχι??? :P

Στο Τ3 κάνει κάτι απλό αλλά στο 1 δεν θέλω να χρησιμοποιήσεις τη ν σε αυτά που ίσως προσθέσεις. Θέλω να πας σύμφωνα με το τι κάνει το τμήματα αυτό.

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #46 στις: 31 Μάι 2012, 08:18:42 μμ »
για το θέμα Α2 των επαναληπτικών 2011 επαναληπτικών τι άποψη έχεις?? προσωπικά θα το θεωρούσες σωστό??

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #47 στις: 31 Μάι 2012, 08:28:08 μμ »
ναι σωστό είναι! έχει μία ΓΙΑ και δεν έχει δομή επιλογής... θα μπορούσες επίσης να γράψεις:

Για Ι από 1 μέχρι 100
j ← Ι
Εμφάνισε Α[i,j]
Τέλος_επανάληψης


για να μην πουν ότι δεν χρησιμοποίησες το j

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3517
  • to Iterate is human to Recurse divine
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #48 στις: 31 Μάι 2012, 08:28:32 μμ »
Δεν είναι σωστό, είναι ολόσωστο
για το θέμα Α2 των επαναληπτικών 2011 επαναληπτικών τι άποψη έχεις?? προσωπικά θα το θεωρούσες σωστό??
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2811
  • Πύργος Ηλείας
Απ: Ζητείται 2ο,3ο,4ο θέμα για προθέρμανση....
« Απάντηση #49 στις: 31 Μάι 2012, 09:48:15 μμ »
για να μην πουν ότι δεν χρησιμοποίησες το j

Ποιος να το πει αυτό; Από τη στιγμή που στη λύση δεν είναι αναγκαίο, ούτε η άσκηση επιβάλει τη χρήση του, θα βγει κανείς και θα πει πως έπρεπε να χρησιμοποιηθεί υποχρεωτικά;;;!!!