Αποστολέας Θέμα: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...  (Αναγνώστηκε 7472 φορές)

eleni_p

  • Οπαδός
  • **
  • Μηνύματα: 19
Καλησπέρα,

κάποιοι μαθητές μου έφεραν μια άσκηση που τους έβαλαν στο σχολείο, κάτι σχετικό με το να βρουν αν μια μεταβλητή είναι άρτια ή περιττή, και να βρουν αν μια μεταβλητή είναι ακέραια ή πραγματική και το δεκαδικό μέρος, χωρίς να χρησιμοποιήσουν την εντολή αν. Εγώ δεν βρίσκω λύση (αν οι μαθητές μου μετέφεραν σωστά την άσκηση γιατί και τα παιδιά δεν ήταν σίγουρα - ούτε λύθηκε στην τάξη). Γνωρίζει κάποιος αν λύνεται και πως;

Ευχαριστώ,
Ελένη

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5165
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #1 στις: 10 Οκτ 2011, 04:04:27 μμ »
άρτια <- αριθμός mod 2 = 0

Αντίστοιχα και οι άλλες...

eleni_p

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #2 στις: 10 Οκτ 2011, 04:08:47 μμ »
Ευχαριστώ, δεν το είχα σκεφτεί καθόλου έτσι. Το αν είναι δεκαδικός μπορεί να λυθεί χωρίς τη συνάρτηση Α_Μ(Χ)?

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #3 στις: 10 Οκτ 2011, 10:52:43 μμ »
Πως θα βρεις ΑΝ ειναι κατι χωρις τη χρηση της ΑΝ??
Η ασκηση μαλλον ειναι αυτη : Να γράψετε αλγόριθμο σε ΓΛΩΣΣΑ για τα παρακάτω προβλήματα:
a.   Εισαγωγή αριθμού ακέραιου και έλεγχος αν είναι άρτιος ή περιττός
b.   Εισαγωγή πραγματικού αριθμού και έλεγχος αν  ανήκει στους ακεραίους ( πρέπει το ακέραιο μέρος του να είναι ίδιο με την τιμή του αριθμού)

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #4 στις: 10 Οκτ 2011, 11:37:36 μμ »
Εισαγωγή πραγματικού αριθμού και έλεγχος αν  ανήκει στους ακεραίους ( πρέπει το ακέραιο μέρος του να είναι ίδιο με την τιμή του αριθμού)

Αυτό που έχεις γράψει είναι το κριτήριο, το οποίο μπορείς να το εκχωρήσεις σε λογική μεταβλητή όπως ήδη ειπώθηκε

άρτια <- αριθμός mod 2 = 0

eleni_p

  • Οπαδός
  • **
  • Μηνύματα: 19
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #5 στις: 12 Οκτ 2011, 10:52:44 πμ »
Πως θα βρεις ΑΝ ειναι κατι χωρις τη χρηση της ΑΝ??
Η ασκηση μαλλον ειναι αυτη : Να γράψετε αλγόριθμο σε ΓΛΩΣΣΑ για τα παρακάτω προβλήματα:
a.   Εισαγωγή αριθμού ακέραιου και έλεγχος αν είναι άρτιος ή περιττός
b.   Εισαγωγή πραγματικού αριθμού και έλεγχος αν  ανήκει στους ακεραίους ( πρέπει το ακέραιο μέρος του να είναι ίδιο με την τιμή του αριθμού)

Η εκφώνηση είναι όπως την έγραψα και γίνεται χωρίς αν  - είναι η απάντηση που έδωσε ήδη ο alkis

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #6 στις: 12 Οκτ 2011, 10:56:40 πμ »
πάντως θα χρειαστεί δομή επιλογής στη συνέχεια
Κώδικας: [Επιλογή]
Αν άρτια = αληθής τότε
   Εμφάνισε "είναι άρτιος"
Αλλιώς
   Εμφάνισε "δεν είναι άρτιος"
Τέλος_αν

γιατί το
Κώδικας: [Επιλογή]
Εμφάνισε άρτιαπου θα εμφανίσει την τιμή αληθής ή την τιμή ψευδής, δε νομίζω ότι κάνει

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #7 στις: 12 Οκτ 2011, 03:41:32 μμ »
αυτο εννοουσα με το
Πως θα βρεις ΑΝ ειναι κατι χωρις τη χρηση της ΑΝ??
δεν μπορει να γινει αυτο χωρις την χρηση της αν.

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #8 στις: 12 Οκτ 2011, 11:51:21 μμ »
Νομίζω ότι μπορεί να μας κάνει το εξής:

Κώδικας: [Επιλογή]
Διάβασε αριθμός
άρτια ← αριθμός mod 2 = 0
Γράψε 'Είναι', άρτια, '(ές) ότι είναι άρτια η τιμή της μεταβλητής'

Έχω την εντύπωση ότι το θέμα το εξετάσεων φαίνεται να ρυμουλκεί για ακόμα μία φορά την διδακτική μας...

Να γράψετε αλγόριθμο σε ΓΛΩΣΣΑ για τα παρακάτω προβλήματα:
a. Εισαγωγή αριθμού ακέραιου και έλεγχος αν είναι άρτιος ή περιττός
b. Εισαγωγή πραγματικού αριθμού και έλεγχος αν ανήκει στους ακεραίους

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3219
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #9 στις: 13 Οκτ 2011, 09:44:41 πμ »
Σπύρο το είχα σκεφτεί λίγο διαφορετικά, αλλά ήθελα να δω ποιος διεστραμμένος θα το γράψει  :D  ;D

Κώδικας: [Επιλογή]
Εμφάνισε "Είναι άρτιος;;;;", άρτια

εγώ δεν το βρίσκω κακό, αλλά ως Σ/Λ ή τέλος πάντων στο θέμα 1
όχι σε άσκηση να το τραβάς από τα μαλλιά για να το αναδείξεις...

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #10 στις: 13 Οκτ 2011, 02:14:13 μμ »
Μου επιτρέπεις;

Κώδικας: [Επιλογή]
Εμφάνισε "Είναι άρτιος;;;;", άρτια, "(ές)"
 :D

Σπύρο το είχα σκεφτεί λίγο διαφορετικά, αλλά ήθελα να δω ποιος διεστραμμένος θα το γράψει  :D  ;D
Κώδικας: [Επιλογή]
Εμφάνισε "Είναι άρτιος;;;;", άρτια

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 201
Απ: ΕΙΝΑΙ ΑΡΤΙΟΣ? Η ΕΙΝΑΙ ΑΚΈΡΑΙΟΣ? ΧΩΡΙΣ ΤΗ ΧΡΗΣΗ ΤΗΣ ΑΝ...
« Απάντηση #11 στις: 28 Μάι 2018, 04:31:10 πμ »
Ευχαριστώ, δεν το είχα σκεφτεί καθόλου έτσι. Το αν είναι δεκαδικός μπορεί να λυθεί χωρίς τη συνάρτηση Α_Μ(Χ)?

 ΠΡΟΓΡΑΜΜΑ ακεραιοςΗδεκαδικος
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι
  ΠΡΑΓΜΑΤΙΚΕΣ: χ, υ
  ΛΟΓΙΚΕΣ: φλαγκ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ χ
  υ <- χ
  ΑΝ χ < 0 ΤΟΤΕ
    χ <- -χ
  ΤΕΛΟΣ_ΑΝ
  φλαγκ <- ΨΕΥΔΗΣ

    ι <- 0
    ΟΣΟ ι <= χ ΕΠΑΝΑΛΑΒΕ  !εχω ακεραιο βημα οποτε αν πεσω πανω στο χ σιγουρα αυτος ειναι ακεραιος
      ΑΝ ι = χ ΤΟΤΕ
        φλαγκ <- ΑΛΗΘΗΣ

      ΤΕΛΟΣ_ΑΝ
      ι <- ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ






  ΑΝ φλαγκ = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ "πραγματικος το ", υ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ "ακεραιος το ", υ
  ΤΕΛΟΣ_ΑΝ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ