Αποστολέας Θέμα: Παράμετρος??  (Αναγνώστηκε 2433 φορές)

solaris

  • Θαμώνας
  • ***
  • Μηνύματα: 28
Παράμετρος??
« στις: 16 Μάρ 2006, 04:56:44 μμ »
Μπορώ να έχω το παρακάτω τμήμα προγράμματος:

ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
 ΓΙΑ ξ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
  ΑΝ Π[ξ-1] > Π[ξ] ΤΟΤΕ
     ΚΑΛΕΣΕ Αντιμεταθεση (Π[ξ-1], Π[ξ], ξ)
  ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

....

ΔΙΑΔΙΚΑΣΙΑ Αντιμετάθεση (Χ[ξ-1], Χ[ξ], ξ)
ΜΕΤΑΒΛΗΤΕΣ
 ...: Χ[100], Κ

ΑΡΧΗ
   Κ <-- Χ[ξ-1]
   Χ[ξ-1] <-- Χ[ξ]
   Χ[ξ] <-- Κ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Ευχαριστώ

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 5433
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Παράμετρος??
« Απάντηση #1 στις: 16 Μάρ 2006, 05:11:47 μμ »
Όχι. Διάβασε τη συζήτηση για την Αντιμετάθεσε για να δεις πώς μπορείς να δηλώσεις τη ΔΙΑΔΙΚΑΣΙΑ Αντιμετάθεση.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3295
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Παράμετρος??
« Απάντηση #2 στις: 17 Μάρ 2006, 10:18:45 πμ »