Αποστολέας Θέμα: Θέμα 3ο Ημερησίων  (Αναγνώστηκε 19689 φορές)

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Θέμα 3ο Ημερησίων
« στις: 30 Μάι 2008, 11:55:29 μμ »
Συζητήσεις, απόψεις και προβληματισμοί για το θέμα 3 των ημερησίων.
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

Σιδηρόπουλος Δ.

  • Οπαδός
  • **
  • Μηνύματα: 11
  • Η ζωή είναι ωραία
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #1 στις: 31 Μάι 2008, 12:06:02 μμ »
ΘΕΜΑ 3Ο
Πρόγραμμα Θέμα3
   ΜΕΤΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:Ι, Ο, Σ, Η, Χ
ΧΑΡΑΚΤΗΡΑΣ: Κ

ΑΡΧΗ
Ο<-0
Σ<-0
ΓΙΑ Ι ΑΠΌ 1 ΜΕΧΡΙ 30
ΔΙΑΒΑΣΕ Κ, Η
Χ<- ΧΡΕΩΣΗ (Κ,Η)
ΓΡΑΨΕ “ΧΡΕΩΣΗ”, Χ
ΑΝ Κ= “ΟΙΚΟΛΟΓΙΚA” ΤΟΤΕ
      Ο<-Ο+1
ΑΛΛΙΩΣ
      Σ<-Σ+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Ο,Σ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΧΡΕΩΣΗ (Κ,Η): ΑΚΕΡΑΙΑ
ΑΚΕΡΑΙΕΣ: Η
ΧΑΡΑΚΤΗΡΑΣ: Κ

ΑΡΧΗ
ΑΝ Κ= “ΟΙΚΟΛΟΓΙΚΑ” TOTE
    ΑΝ Η<=7 ΤΟΤΕ
         ΧΡΕΩΣΗ<- 30*Η
    ΑΛΛΙΩΣ_ΑΝ Η<=16
          ΧΡΕΩΣΗ<-20*Η
     ΑΛΛΙΩΣ
          ΧΡΕΩΣΗ <- 10*Η
      ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
       ΑΝ Η<=7 ΤΟΤΕ
         ΧΡΕΩΣΗ<- 40*Η
    ΑΛΛΙΩΣ_ΑΝ Η<=16
          ΧΡΕΩΣΗ<-30*Η
     ΑΛΛΙΩΣ
          ΧΡΕΩΣΗ <- 20*Η
      ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Σιδηρόπουλος Δημήτρης (ΠΕ 19)
Διδάκτορας Πανεπιστημίου Μακεδονίας

clevercitizen

  • Βετεράνος
  • ****
  • Μηνύματα: 75
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #2 στις: 31 Μάι 2008, 12:14:41 μμ »
Εγώ έκανα ΔΙΑΔΙΚΑΣΙΑ! ;D
ΘΕΛΩ
                ΑΛΛΑΓΗ
                ΕΚΠΑΙΔΕΥΤΙΚΟΥ
                ΣΥΣΤΗΜΑΤΟΣ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #3 στις: 31 Μάι 2008, 12:17:23 μμ »
δεν περίμενα κάτι άλλο!!

Σιδηρόπουλος Δ.

  • Οπαδός
  • **
  • Μηνύματα: 11
  • Η ζωή είναι ωραία
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #4 στις: 31 Μάι 2008, 12:33:57 μμ »
Και όμως δεδομένου ότι πρέπει να επιστρέψουμε μια τιμή είναι ξεκάθαρο ότι πρέπει να γίνει συνάρτηση
Σιδηρόπουλος Δημήτρης (ΠΕ 19)
Διδάκτορας Πανεπιστημίου Μακεδονίας

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 84
  • !!!!...!!!
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #5 στις: 31 Μάι 2008, 12:52:43 μμ »
Φυσικά και δεν είναι υποχρεωτικό να γίνει συνάρτηση.
Κάποιοι μαθητές το έλυσαν χρησιμοποιώντας πίνακα όπου αποθήκευσαν όλες τις τιμές και μετά βρήκαν τις χρεώσεις.

Σιδηρόπουλος Δ.

  • Οπαδός
  • **
  • Μηνύματα: 11
  • Η ζωή είναι ωραία
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #6 στις: 31 Μάι 2008, 12:57:26 μμ »
Θεωρώ ότι η σωστότερη απάντηση είναι η συνάρτηση και η χρήση πίνακα είναι περιτή. Εξάλου όπως αναφέρεται και στο βιβλίο οι πίνακες δεσμεύουν περισσότερη μνήμη και θα πρέπει να αποφεύγονται όταν η χρήση τους δεν είναι απαραίτητη. Φυσικά υπάρχουν και εναλλακτικές προσσεγίσεις που ίσως να δινουν το σωστό αποτέλεσμα, αλλά το πως θα βαθμολογηθούν είναι θέμα αυτών που έχουν οριστεί για αυτή τη δουλειά και φυσικά τι οδηγίες θα πάρουν.
Σιδηρόπουλος Δημήτρης (ΠΕ 19)
Διδάκτορας Πανεπιστημίου Μακεδονίας

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 84
  • !!!!...!!!
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #7 στις: 31 Μάι 2008, 01:01:44 μμ »
Σύμφωνα με το σχ. βιβλίο δεν υπάρχει "σωστότερη" απάντηση.
Ως προς το θέμα του υποπρογράμματος η άποψη μου είναι ότι και οι δύο προσεγγίσεις είναι σωστές.

miekb

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #8 στις: 31 Μάι 2008, 01:35:18 μμ »
Κάποια μαθήτρια έλυσε το 3ο θέμα με πίνακες. Η λύση είναι σωστή υπάρχει περίπτωση να κοπούνε μονάδες;
Ευχαριστώ!

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #9 στις: 31 Μάι 2008, 01:39:06 μμ »
στο υποπρόγραμμα τι περνάει; ολόκληρο τον πίνακα ή μόνο κάποια τιμή;
Γράψε υλοποίηση.. Κάνει αυτό που πρέπει η κωδικοποίηση της;

Σιδηρόπουλος Δ.

  • Οπαδός
  • **
  • Μηνύματα: 11
  • Η ζωή είναι ωραία
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #10 στις: 31 Μάι 2008, 01:45:42 μμ »
Σύμφωνα με το σχ. βιβλίο δεν υπάρχει "σωστότερη" απάντηση.
Ως προς το θέμα του υποπρογράμματος η άποψη μου είναι ότι και οι δύο προσεγγίσεις είναι σωστές.

Στο νεο βιβλίο λοιπόν να καταργήσουμε τελείως τις συναρτήσεις, αφού καθε διαδικασία κάνει ότι και κάθε συνάρτηση και πολλά παραπάνω. Επίσης να αλλάξουμε και την δομή και τον τρόπο προγραμματισμού σε όλες τις γλώσσες προγραμματισμού. Το "σωστότερη" αναφέρεται στην πιο ενδεδειγμένη λύση από πλευράς θεωρίας προγραμματισμού. Μήπως η ερώτηση ήθελε να εξετάσει αν οι μαθητές έχουν καταλάβει την διαφορά των συναρτήσεων και των διαδικασιών και να ελένξει επίσης αν γνωρίζουν πότε πρέπει να επιλέξουν το κατάλληλο υποπρόγραμμα ?
Σιδηρόπουλος Δημήτρης (ΠΕ 19)
Διδάκτορας Πανεπιστημίου Μακεδονίας

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 84
  • !!!!...!!!
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #11 στις: 31 Μάι 2008, 01:53:22 μμ »
Αν η ερώτηση λοιπόν ήθελε να εξετάσει ποιος τύπος υποπρογράμματος πρέπει να επιλεχθεί τότε μάλλον έχεις δίκιο.
Θεωρώ όμως οτι αυτή η άποψη βρίσκεται πολύ μακριά από το σχολικό βιβλίο και δεν πρέπει να ξεχνάμε ότι οι μαθητές καλώς ή κακώς εξετάζονται σε αυτό.
Φυσικά δεν προσδοκώ ούτε και θέλω να αλλάξω τον τρόπο του προγραμματισμού απλά λέω την άποψη μου ως προς τον τρόπο βαθμολόγησης σύμφωνα πάντα με το σχολικό βιβλίο.
Διάλογο προσπαθώ να κάνω και δεν ειρωνεύομαι!


Σιδηρόπουλος Δ.

  • Οπαδός
  • **
  • Μηνύματα: 11
  • Η ζωή είναι ωραία
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #12 στις: 31 Μάι 2008, 02:00:19 μμ »
Φυσικά και δεν ειρωνεύομαι, αλλά συζητώ. Η γνώμη μου είναι ότι πρέπει να δοθούν σαφείς οδηγίες προς όλα τα βαθμολογικά κέντρα, ώστε να αντιμετωπιστούν όλοι οι υποψήφιοι με τον ίδιο τρόπο. Αν αποδεχτούμε ότι και οι δύο προσεγγίσεις είναι απόλυτα ορθές, αυτό πρέπει να γωνστοποιηθεί σε όλους, διότι διαφορετικά πιστεύω γι' αυτό και επιμένω ότι ορισμένοι συνάδελφοι θα κόψουν μόρια από τους μαθητές που έκαναν διαδικασία ενώ άλλοι όχι. Φυσικά επιμένω στην "Συνάρτηση" αν θέλουμε να είμαστε ακριβείς. Όμως σίγουρα σε τέτοιο επίπεδο (Γ' Λυκείου) και δεδομένου ότι οι μαθητές έρχονται για πρώτη φορά σε επαφή με το αντικείμενο θα πρέπει να υπάρχει κατανόηση. Από την άλλη πλευρά πιστεύω ότι ο μαθητής θα έπρεπε να επιλέξει το κατάλληλο υποπρόγραμμα ή καλύτερα τον κατάλληλο τύπο υποπρογράμματος (θα έπρεπε να αναφέρει το θέμα). Αυτοί που τα βάλανε μόνο αυτοί ξέρουν τι ακριβώς θέλουν. Εγώ απλά εκφράζω την άποψη μου.
Σιδηρόπουλος Δημήτρης (ΠΕ 19)
Διδάκτορας Πανεπιστημίου Μακεδονίας

Vaggelis100

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #13 στις: 31 Μάι 2008, 02:44:57 μμ »
Καλησπέρα! Εγώ στο 3ο θέμα αντί να πάρω 2 μετρητές για τα οικολογικά και τα συμβατικά αυτοκίνητα, πήρα μόνο 1 για τα οικολογικά και στο τέλος για τα συμβατικά αφαίρεσα αυτό που βρήκα από το 30. Ακόμα στη συνάρτηση ο *** επειδή ήθελα να αλλάξω τα ονόματα των μεταβλητών (τι το ήθελα!!!) χρησιμοποίησα μεταβλητή Η . Θεωρείται δεσμευμένη λέξη; Πόσο θα μου κόψουν; Εγώ φυσικά εννοούσα το αγγλικό :P αλλά και ο λογικός τελεστής είναι Ή και όχι Η
Ευχαριστώ για τις απαντήσεις!!!

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3305
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Θέμα 3ο Ημερησίων
« Απάντηση #14 στις: 31 Μάι 2008, 03:02:15 μμ »
το Η είναι ένα πρόβλημα... Ελπίζω να μη σου κόψει