Τελευταία μηνύματα

Σελίδες: [1] 2 3 4 ... 10
1
Γ΄ Λυκείου / Απ: Προτάσεις για εξορθολογισμό της ύλης από την επόμενη χρονιά
« Τελευταίο μήνυμα από ApoAntonis στις Σήμερα στις 12:41:20 πμ »
Όταν το 20% των υποψηφίων αριστεύουν στο μάθημα (με βαθμό πάνω από 18)
μάλλον θα πρέπει να θεωρηθεί με χαμηλό βαθμό δυσκολίας και
επομένως μπορεί να απορροφήσει αρκετές προσθήκες που θα τον ανεβάσουν.

Για να πω ότι έγραψα κάτι on topic:
να φύγει/καεί/μπεί σε τροχιά γύρω από τον ήλιο και να κυρηχθεί παράνομος
ο ορισμός της ταξινόμησης
που κάθε φορά που τον διαβάζω με πιάνει πονοκέφαλος
(σήμερα τον έδειξα σε δύο φιλολόγους, τον ορισμό, για να παίρνουν ιδέες για ασκήσεις συντακτικού)

2
Δομή επανάληψης / Απ: Δύσκολη μετατροπή
« Τελευταίο μήνυμα από ApoAntonis στις Χθες στις 11:12:43 μμ »
Η δομή ΓΙΑ, δεν κάνει για κάθε ζεύγος Χ,Υ επαναλήψεις.

 με αυτό που έγραψα...ούτε εγώ δεν καταλαβαίνω τι εννοώ  :D

ο thanos_xg έχει δίκιο



3
Διερμηνευτής της ΓΛΩΣΣΑΣ / Απ: Διερμηνευτής σε Mac
« Τελευταίο μήνυμα από akalest0s στις Χθες στις 10:31:50 μμ »
Πάντως, με crossover, το έχω δοκιμάσει και δουλεύει μια χαρά. Τρώει κάτι φρίκες, μερικές φορές, όταν αλλάζεις γλώσσα (ελληνικά/αγγλικά) ή όταν κάνεις copy/paste, αλλά κατά τα άλλα, δεν υπάρχει πρόβλημα.
Το crossover, αν δεν το έχεις αγοράσει, σου επιτρέπει να τρέχεις το κάθε bottle μόνο για 3 μέρες. Ωστόσο, μόνο το συγκεκριμένο bottle σταματάει να τρέχει, που θα πει ότι μπορείς ανεμπόδιστα να φτιάξεις ένα νέο, μέσα σε 4-5 κλικ, το οποίο θα κρατήσει ακόμη 3 μέρες. Τώρα, βέβαια, μόνη της η μαθήτρια μάλλον δεν θα μπορεί να το κάνει, εκτός αν της δώσεις σαφείς οδηγίες, για να συμβουλεύεται κάθε φορά.
Εγώ φροντίζω να μην κλείνω τον διερμηνευτή/bottle, οπότε σε αυτή τη περίπτωση δεν εντοπίζει καν την πάροδο των ημερών. Ο συγκεκριμένος υπολογιστής μου συνήθως μένει για μέεεερες ανοιχτός.
4
Αυτό που κολλάει με το τόπικ;
5
δεν καταλαβαίνω, τί βλέπουμε στο διάγραμμα αυτό;
6
Δομή επανάληψης / Απ: Δύσκολη μετατροπή
« Τελευταίο μήνυμα από akalest0s στις Χθες στις 05:28:48 μμ »
Αδύνατη λόγω του ότι δεν ορίζονται οι τύποι των μεταβλητών Χ, Υ;
γιατί κατά τα άλλα, η λύση του Θανάση προβλέπει κάθε συνδυασμό Χ, Υ.
7
Δομή επανάληψης / Απ: Δύσκολη μετατροπή
« Τελευταίο μήνυμα από ApoAntonis στις Χθες στις 05:20:39 μμ »

edit:
[ignore]
Δεν είναι δύσκολη, είναι αδύνατη με αυτήν την εκφώνηση και μόνο.

Η δομή ΓΙΑ, δεν κάνει για κάθε ζεύγος Χ,Υ επαναλήψεις. [/ignore :) ]
8
υπήρχε μέτρο και χάθηκε ή δεν υπήρξε εξ'αρχής;

από τα στατιστικά του υπουργείου για το 2019

οι σχετικές συχνότητες επί τοις εκατό, οπτικοποιημένες για μεγαλύτερη απόλαυση.

9
Δομή επανάληψης / Απ: Δύσκολη μετατροπή
« Τελευταίο μήνυμα από akalest0s στις Χθες στις 04:39:34 μμ »
ΔΙΑΒΑΣΕ Χ, Υ
Α <- Χ
    ΑΝ Α > 5 ΤΟΤΕ
      β <- Α + 2
      ΓΡΑΨΕ β, Α
    ΤΕΛΟΣ_ΑΝ
  ΓΙΑ Α ΑΠΟ Χ + 2 ΜΕΧΡΙ Υ + 1 ΜΕ_ΒΗΜΑ 2
    ΑΝ Α > 5 ΤΟΤΕ
      β <- Α + 2
      ΓΡΑΨΕ β, Α
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 είπε ο Θανάσης, "Με την προϋπόθεση ότι οι μεταβλητές είναι ακέραιες".
edit -> διόρθωσα τη σκέψη μου, βάσει του κώδικα του Θανάση, για να συμπεριλάβω την περίπτωση όπου το Α ξεκινάει ήδη μεγαλύτερο του 5.
Θανάση γιατί στην λύση σου περνάς τα +2 παντού;


Οκ, μετά από μπόλικες δοκιμές,... ας μείνουμε στην παραπάνω λύση  ;D ::)
(ίσως η πιο εξεζητημένη περίπτωση μετατροπής που έχω συναντήσει)
10
Δομή επανάληψης / Απ: Δύσκολη μετατροπή
« Τελευταίο μήνυμα από thanos_xg στις Χθες στις 04:25:12 μμ »
Με την προϋπόθεση ότι οι μεταβλητές είναι ακέραιες τότε μια πρόταση μετατροπής είναι:

    Διάβασε Χ, Υ
    Α <-- Χ
    Α <-- Α + 2
    Αν Α>5 τότε
        Β <-- Α + 2
        Γράψε  Β, Α
    Τέλος_αν
    Για Α απο Χ+2 μέχρι Υ-1 με βήμα 2
            Αν Α+2>5 τότε
                 Β <-- (Α + 2)+2
                 Γράψε  Β, Α+2
            Τέλος_αν
    Τέλος επανάληψης

Αν οι μεταβλητές δεν είναι ακέραιες χρειάζεται να γνωρίζουμε την ακρίβεια δεκαδικών ψηφίων των πραγματικών μεταβλητών. Αυτό χρειάζεται για να εκτιμήσουμε την τελική τιμή της Για.

Αν Μεταβλητές ακέραιες η τελική τιμή θα είναι Υ-1
Αν έχω μέγιστη ακρίβεια 2 δεκαδικών τότε τελική τιμή Υ-0.01 κλπ
Σελίδες: [1] 2 3 4 ... 10