Γενικό Λύκειο > Συναρτήσεις

Εκχώρηση τιμής στο όνομα της συνάρτησης

(1/2) > >>

thanasisgr:
Καλησπέρα σε όλους,
Θα ήθελα να ρωτήσω αν η ΤΕΛΙΚΉ τιμή που παίρνει μια συνάρτηση εκχωρείται στο όνομά της ΜΙΑ ΜΌΝΟ φορά πριν το τέλος της ΣΥΝΑΡΤΗΣΗΣ  ή Όχι.
Π.χ.

Συνάρτηση min(a, b) :ΑΚΈΡΑΙΑ
ΜΕΤΑΒΛΗΤΈΣ
ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
ΑΝ a<b ΤΟΤΕ
 min<-a
ΑΛΛΙΩΣ
min<-b
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Η

Συνάρτηση min(a, b) :ΑΚΈΡΑΙΑ
ΜΕΤΑΒΛΗΤΈΣ
ΑΚΕΡΑΙΕΣ: a, b, ελαχ
ΑΡΧΗ
ΑΝ a<b ΤΟΤΕ
 ελαχ<-a
ΑΛΛΙΩΣ
ελαχ<-b
ΤΕΛΟΣ_ΑΝ
min<-ελαχ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ




Λαμπράκης Μανώλης:
Καλησπέρα

νομίζω και οι δύο περιπτώσεις είναι σωστές, εξάλλου στο πρώτο παράδειγμα υπάρχει ΑΝ και ΑΛΛΙΩΣ οπότε μία φορά θα γίνει η εκχώρηση ... λίγο πιο γενικός νομίζω είναι ο δεύτερος τρόπος

petrosp13:
Δεν έχει σημασία αν εκχωρείται μια φορά τιμή στην συνάρτηση ή περισσότερες
Δεν θα πρέπει να γίνεται όμως το εξής γιατί είναι αναδρομή:

Συνάρτηση Πλήθος(...):ΑΚΕΡΑΙΑ


Πλήθος <-- Πλήθος + 1

Καρκαμάνης Γεώργιος:

--- Παράθεση από: Λαμπράκης Μανώλης στις 11 Δεκ 2019, 04:17:23 μμ ---Καλησπέρα

νομίζω και οι δύο περιπτώσεις είναι σωστές, εξάλλου στο πρώτο παράδειγμα υπάρχει ΑΝ και ΑΛΛΙΩΣ οπότε μία φορά θα γίνει η εκχώρηση ... λίγο πιο γενικός νομίζω είναι ο δεύτερος τρόπος

--- Τέλος παράθεσης ---

Ετσι είναι όπως τα λέει ο Μανώλης. Και οι δύο περιπτώσεις είναι σωστές αρκεί να μη συμμετέχει το όνομα της συνάρτηση σε έκφραση με πράξεις γιατί όπως πολυ σωστά ανέφερε και ο Πέτρος πιο πάνω, είναι ένα είδος αναδρομής που δεν είναι του παρόντος

evry:
Το παραπάνω παράδειγμα δεν είναι αναδρομή. Είναι λάθος.
Αναδρομή θα ήταν αν δινόταν έτσι:

--- Κώδικας: ---ΣΥΝΑΡΤΗΣΗ ΠΛΗΘΟΣ(Ν): ΑΚΕΡΑΙΑ
     ......

     ΠΛΗΘΟΣ <- ΠΛΗΘΟΣ(Ν-1)+1
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
--- Τέλος κώδικα ---

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση