Αποστολέας Θέμα: Εκχώρηση τιμής στο όνομα της συνάρτησης  (Αναγνώστηκε 378 φορές)

thanasisgr

  • Οπαδός
  • **
  • Μηνύματα: 11
Καλησπέρα σε όλους,
Θα ήθελα να ρωτήσω αν η ΤΕΛΙΚΉ τιμή που παίρνει μια συνάρτηση εκχωρείται στο όνομά της ΜΙΑ ΜΌΝΟ φορά πριν το τέλος της ΣΥΝΑΡΤΗΣΗΣ  ή Όχι.
Π.χ.

Συνάρτηση min(a, b) :ΑΚΈΡΑΙΑ
ΜΕΤΑΒΛΗΤΈΣ
ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
ΑΝ a<b ΤΟΤΕ
 min<-a
ΑΛΛΙΩΣ
min<-b
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Η

Συνάρτηση min(a, b) :ΑΚΈΡΑΙΑ
ΜΕΤΑΒΛΗΤΈΣ
ΑΚΕΡΑΙΕΣ: a, b, ελαχ
ΑΡΧΗ
ΑΝ a<b ΤΟΤΕ
 ελαχ<-a
ΑΛΛΙΩΣ
ελαχ<-b
ΤΕΛΟΣ_ΑΝ
min<-ελαχ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ





Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 710
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #1 στις: 11 Δεκ 2019, 04:17:23 μμ »
Καλησπέρα

νομίζω και οι δύο περιπτώσεις είναι σωστές, εξάλλου στο πρώτο παράδειγμα υπάρχει ΑΝ και ΑΛΛΙΩΣ οπότε μία φορά θα γίνει η εκχώρηση ... λίγο πιο γενικός νομίζω είναι ο δεύτερος τρόπος

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2245
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #2 στις: 12 Δεκ 2019, 12:51:14 πμ »
Δεν έχει σημασία αν εκχωρείται μια φορά τιμή στην συνάρτηση ή περισσότερες
Δεν θα πρέπει να γίνεται όμως το εξής γιατί είναι αναδρομή:

Συνάρτηση Πλήθος(...):ΑΚΕΡΑΙΑ


Πλήθος <-- Πλήθος + 1
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1103
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #3 στις: 20 Ιαν 2020, 07:46:14 πμ »
Καλησπέρα

νομίζω και οι δύο περιπτώσεις είναι σωστές, εξάλλου στο πρώτο παράδειγμα υπάρχει ΑΝ και ΑΛΛΙΩΣ οπότε μία φορά θα γίνει η εκχώρηση ... λίγο πιο γενικός νομίζω είναι ο δεύτερος τρόπος

Ετσι είναι όπως τα λέει ο Μανώλης. Και οι δύο περιπτώσεις είναι σωστές αρκεί να μη συμμετέχει το όνομα της συνάρτηση σε έκφραση με πράξεις γιατί όπως πολυ σωστά ανέφερε και ο Πέτρος πιο πάνω, είναι ένα είδος αναδρομής που δεν είναι του παρόντος

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3181
  • to Iterate is human to Recurse divine
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #4 στις: 20 Ιαν 2020, 12:27:22 μμ »
Το παραπάνω παράδειγμα δεν είναι αναδρομή. Είναι λάθος.
Αναδρομή θα ήταν αν δινόταν έτσι:
Κώδικας: [Επιλογή]
ΣΥΝΑΡΤΗΣΗ ΠΛΗΘΟΣ(Ν): ΑΚΕΡΑΙΑ
     ......

     ΠΛΗΘΟΣ <- ΠΛΗΘΟΣ(Ν-1)+1
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2245
Απ: Εκχώρηση τιμής στο όνομα της συνάρτησης
« Απάντηση #5 στις: 21 Ιαν 2020, 06:43:28 μμ »
Ναι, είναι λάθος γιατί μόνο σαν αναδρομή μπορεί να εκληφθεί και δεν γίνεται έτσι
Το ίδιο λέμε
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής