Αποστολέας Θέμα: Ασάφειες της ΑΕΠΠ  (Αναγνώστηκε 36100 φορές)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4296
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #30 στις: 14 Οκτ 2008, 12:08:34 πμ »
Εγώ πάντως αν με έβαζαν να γράψω πανελλήνιες και μου έδιναν θέμα σχετικό με προτεραιότητα ΚΑΙ και Η, θα απαντούσα:
"Δεν έχει οριστεί η προτεραιότητά τους στο σχολικό βιβλίο. Άλλες γλώσσες ορίζουν μεγαλύτερη προτεραιότητα στο ΚΑΙ, άλλες την ίδια με το Η. Οποιοσδήποτε ορισμός θα ήταν αποδεκτός, αλλά από τη στιγμή που δεν υπάρχει, δεν θα έπρεπε να είχατε βάλει αυτό το ερώτημα.
Αυθαίρετα λοιπόν ορίζω ότι το ΚΑΙ έχει (εδώ θα έγραφα είτε μεγαλύτερη είτε ίση) προτεραιότητα με το Η και απαντώ:
..."

Και δεν πιστεύω ότι θα υπήρχε βαθμολογητής που θα μου το έπιανε λάθος! :P ;)
Μήπως να το προτείναμε στους μαθητές; :D :D :D

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3079
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #31 στις: 14 Οκτ 2008, 02:54:08 μμ »
Όταν ήμουν μαθητής πριν απο λίγα χρόνια, έγραψα σχεδόν άριστα στη φυσική λύνοντας ασκήσεις που περιέγραφαν έναν κόσμο χωρίς τριβές και απώλειες ενέργειας.

Όταν ήμουν μαθητής πριν από λίγα χρόνια, μου έλεγαν οτι τα ηλεκτρόνια περιστρέφονται σε κυκλική τροχιά γύρω από τον πυρήνα. Μετά μου είπαν πρωτοετείς φοιτητές που ακολούθησαν το θετικό κλάδο, πως τα ηλεκτρόνια περιστρέφονται σε ελλειπτικές τροχιές γύρω από τον πυρήνα. Κάποια στιγμή αργότερα πληροφορήθηκα οτι δεν είναι καν συγκεκριμένες τροχιές αλλά είναι κίνηση σε μορφή νέφους, ή κάτι τέτοιο.

Σας πληροφορώ οτι δεν έχω πάθει τίποτα από αυτά τα μικρά "ψέματα" που μου είπαν στο σχολείο (χωρίς να σημαίνει οτι είμαι τελείως καλά σήμερα  :D ) καθώς κατανοώ τους λόγους. τα υπόλοιπα είναι απλά για να συζητάμε τα ίδια και τα ίδια συνεχώς...

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2083
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #32 στις: 14 Οκτ 2008, 03:06:26 μμ »
Δηλαδή. αφού εκτελεστούν οι αρνήσεις, συνεχίζουμε από αριστερά προς τα δεξιά;
Έλεος  >:(
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Wizard

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • Εγκύκλιοι Πληροφορικής
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #33 στις: 08 Φεβ 2009, 11:57:08 πμ »
ΓΙΑ ι ΑΠΟ 10 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ 0 ( ι<-10 ΟΣΟ ι<=1 ... -- δίνει καμία επανάληψη)

Γιατί βρε παιδιά να ισχύει αυτό; Επειδή το βιβλίο λέει "Η τιμή της μεταβλητής συγκρίνεται με την τελική τιμή και εφόσον είναι μικρότερη από αυτή, τότε εκτελούνται οι εντολές που βρίσκονται στο βρόχο"; Δηλαδή, αν δεν είναι, δεν θα γίνει επανάληψη; Η εντολή ΓΙΑ ι ΑΠΟ 10 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -1 στην ΓΛΩΣΣΑ δεν δίνει καμία επανάληψη;

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3079
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #34 στις: 08 Φεβ 2009, 12:04:00 μμ »
Εννοεί για θετικό βήμα φίλε, αβλεψία στη συγγραφή, έχει συμβεί σε όλους μας  8)

Wizard

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • Εγκύκλιοι Πληροφορικής
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #35 στις: 08 Φεβ 2009, 08:11:07 μμ »
Κατανοητό για την αβλεψία, αλλά πού προκύπτει ότι στη ΓΛΩΣΣΑ η εντολή ΓΙΑ ι ΑΠΟ 10 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ 0 δεν δίνει καμία επανάληψη, όταν θέλουμε η λειτουργικότητα ψευδογλώσσας και ΓΛΩΣΣΑΣ να είναι ίδια;

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3079
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #36 στις: 08 Φεβ 2009, 08:15:46 μμ »
Εγώ απο το σχολικό βιβλίο το έχω καταλάβει έτσι:

Αν βήμα = 0 τότε  ! πρώτα αυτός ο έλεγχος
  Άπειρες επαναλήψεις
Αλλιώς_αν β >0 τότε
  Αν τελική >= αρχική τότε
     κάποιες επαναλήψεις
  Αλλιώς
     ΚΑΜΙΑ επανάληψη
  Τέλος_αν
Αλλιώς
  Αν τελική <= αρχική τότε
     κάποιες επαναλήψεις
  Αλλιώς
     ΚΑΜΙΑ επανάληψη
  Τέλος_αν
Τέλος_αν

Wizard

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • Εγκύκλιοι Πληροφορικής
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #37 στις: 09 Φεβ 2009, 07:12:04 πμ »
Συμφωνώ απολύτως!  :)  Δεν καταλαβαίνω γιατί πρέπει να τα μπλέκουμε σε ένα ξεκάθαρο (για μένα) θέμα.

Terius

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #38 στις: 22 Ιαν 2010, 03:40:18 μμ »
καλησπερα. ενα ερωτημα σχετικά με την προτεραιότητα των πράξεων. Αν έχουμε την παρακάτω παράσταση, A+BKAIG>B-AH' G τι εκτελείτε πρώτο?
Ευχαριστώ εκ των προταίρων

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1459
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #39 στις: 22 Ιαν 2010, 04:07:15 μμ »
Κενά δεν έβαλες επίτηδες για να μας δυσκολέψεις στην πράξη ή βαριόσουν να γράψεις ....

A+BKAIG>B-AH' G

Αποκωδικοποιώ σε A+B KAI G>B-A H' G κι απαντώ σύμφωνα με το βιβλίο :

Πρώτα αριθμητικές πράξεις με σειρά απο αριστερά, μετά η συγκριτική και τέλος οι λογικές με με σειρά απο αριστερά. (σελ.166)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

toufeki

  • Επισκέπτης
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #40 στις: 22 Ιαν 2010, 04:19:03 μμ »
...πάντως για όσους ψάχνονται με προτεραιότητες ... ας δουν και το παρακάτω link

http://www.mie.uth.gr/ekp_yliko/07.%CE%94%CE%B7%CE%BB%CF%8E%CF%83%CE%B5%CE%B9%CF%82%CE%BA%CE%B1%CE%B9%CE%95%CE%BA%CF%86%CF%81%CE%AC%CF%83%CE%B5%CE%B9%CF%82_1.ppt
« Τελευταία τροποποίηση: 22 Ιαν 2010, 04:33:42 μμ από toufeki »

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 782
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #41 στις: 23 Ιαν 2010, 08:53:42 μμ »
Εγώ απο το σχολικό βιβλίο το έχω καταλάβει έτσι:

Αν βήμα = 0 τότε  ! πρώτα αυτός ο έλεγχος
  Άπειρες επαναλήψεις
Αλλιώς_αν β >0 τότε
  Αν τελική >= αρχική τότε
     κάποιες επαναλήψεις
  Αλλιώς
     ΚΑΜΙΑ επανάληψη
  Τέλος_αν
Αλλιώς
  Αν τελική <= αρχική τότε
     κάποιες επαναλήψεις
  Αλλιώς
     ΚΑΜΙΑ επανάληψη
  Τέλος_αν
Τέλος_αν

Σωστός !!

Σχετικά με τις προτεραιότητες των λογικών πράξεων θα μπορούσε κάποιος να μου εξηγήσει  τι προσθέτει στην αλγοριθμική σκέψη του μαθητή αν το ΚΑΙ έχει ίση μικρότερη ή μεγαλύτερη προτεραιότητα από την Ή.  Μήπως θα ήταν καλύτερα να μάθει να χρησιμοποιεί παρενθέσεις;
Για μένα ερωτήματα του τύπου A+B KAI G>B-A H' G  είναι απαράδεκτα αφού δεν προσφέρουν τίποτα στο μαθητή.


Σε κάθε περίπτωση ο Alkis έχει δίκιο αφού προσπαθεί να υλοποιήσει μια γλώσσα προγραμματισμού που θα είναι εγγεκριμμένη απο το παιδαγωγικό.   Βέβαια εκεί θα προκύψουν άλλα ερωτήματα όπως για παράδειγμα τι διδάσουμε το βιβλίο ή το πακέτο προγραμματισμού. Φανταζόσαστε τη συζήτηση που θα γίνει αν πέσει κάποιο θέμα που λύνεται  στο προγραμματιστικό περιβάλλον αλλά δεν αναφέρεται  στη θεωρία;.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2404
  • I 'm not young enough to know everything
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #42 στις: 25 Ιαν 2010, 10:10:26 πμ »
Σωστός !!

Σχετικά με τις προτεραιότητες των λογικών πράξεων θα μπορούσε κάποιος να μου εξηγήσει  τι προσθέτει στην αλγοριθμική σκέψη του μαθητή αν το ΚΑΙ έχει ίση μικρότερη ή μεγαλύτερη προτεραιότητα από την Ή.  Μήπως θα ήταν καλύτερα να μάθει να χρησιμοποιεί παρενθέσεις;
Για μένα ερωτήματα του τύπου A+B KAI G>B-A H' G  είναι απαράδεκτα αφού δεν προσφέρουν τίποτα στο μαθητή.

Αυτό είναι σα να ρωτάμε αν πρέπει να οριστεί στις πράξεις πραγματικών η προτεραιότητα των αριθμητικών τελεστών. Αφού στους πραγματικούς δεν αρκεί ο ορισμός των πράξεων + και * αλλά πρέπει να οριστεί και η προτεραιότητα για να μπορούν να υπολογιστούν αριθμητικές παραστάσεις έτσι και στους λογικούς τελεστές πρέπει να οριστεί η προτεραιότητα.

Το θέμα είναι καθαρά μαθηματικό. Και οι αλγόριθμοι δεν μπορεί να είναι ξεκομμένοι από τα μαθηματικά σε νοοτροπία.
Γιώργος Παπαργύρης (gpapargi@hotmail.com)

Terius

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #43 στις: 25 Ιαν 2010, 02:05:45 μμ »
Κενά δεν έβαλα γιατί έτσι μου το έφερε ένας μαθητής μου από το σχολείο του. Την ίδια απάντηση βασιζόμενος στο βιβλίο έδωσα και εγώ στο μαθητή μου αν και μου φαίνεται εντελώς κουλό να γίνεται η συγκριτική πριν από τις λογικές. Προφανώς οι παρενθέσεις σε μια τέτοια πρόταση είναι απαραίτητες γιατί διαφορετικά χάνεται κάθε νόημα. Συμφωνώ πως είναι απαράδεκτες τέτοιες προτάσεις και ελπίζω πως στην επιτροπή θεμάτων δεν θα επιχειρήσουν ποτέ να βάλουν κάτι τέτοιο. Δεν μπορώ όμως να ελπίζω πως και οι συνάδελφοι στα μαθήματά τους θα σκεφτούν ανάλογα.

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 783
Απ: Ασάφειες της ΑΕΠΠ
« Απάντηση #44 στις: 05 Ιούν 2015, 09:31:52 μμ »
Εγώ απο το σχολικό βιβλίο το έχω καταλάβει έτσι:

Αν βήμα = 0 τότε  ! πρώτα αυτός ο έλεγχος
  Άπειρες επαναλήψεις
Αλλιώς_αν β >0 τότε
  Αν τελική >= αρχική τότε
     κάποιες επαναλήψεις
  Αλλιώς
     ΚΑΜΙΑ επανάληψη
  Τέλος_αν
Αλλιώς
  Αν τελική <= αρχική τότε
     κάποιες επαναλήψεις
  Αλλιώς
     ΚΑΜΙΑ επανάληψη
  Τέλος_αν
Τέλος_αν

Επαναφέρω λίγο αυτό το θέμα

Στο σχολικό βιβλίο της Β' Λυκείου αναφερεται το εξής

Για μεταβλητή από τ1 μέχρι τ2 [με_βήμα β]
Εντολές
Τέλος_επανάληψης
...
Αν τ1 > τ2 και β = 0 δεν θα
εκτελεστούν οι εμπεριεχόμενες εντολές της Για, ενώ
αν τ1 <= τ2 και β = 0 η εντολή επανάληψης θα εκτελείται άπειρες φορές (ατέρμονας βρόχος).

Υποθέτω ότι πλεόν το θέμα έληξε με αυτή τη παραδοχή;
« Τελευταία τροποποίηση: 05 Ιούν 2015, 09:42:53 μμ από janag79 »