Αποστολέας Θέμα: Απορία στην Ουρά  (Αναγνώστηκε 1462 φορές)

ElenaP

  • Νέος
  • *
  • Μηνύματα: 2
Απορία στην Ουρά
« στις: 12 Μαΐ 2021, 04:00:50 μμ »
Καλησπέρα.
Σε ασκήσεις με ουρά κάνουμε παράδειγματα και με ολίσθηση?
Εγώ την έχω διδάξει, αλλά το βιβλίο δεν την έχει.
Σας ευχαριστώ.

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1155
Απ: Απορία στην Ουρά
« Απάντηση #1 στις: 20 Μαΐ 2021, 09:38:28 πμ »
Η ολίσθηση εμφανίστηκε ξαφνικά στην ενδεικτική λυση μιας άσκησης του συνοδευτικου υλικού πληροφορικης και μάλιστα χωρίς να χρειάζεται.

Καλό είναι να λύνονται τέτοιες ασκήσεις αλλά στην εκφώνηση του, να υπάρχει περιγραφή της διαδικασίας της ολισθησης ώστε οι μαθητές να καταλαβαίνουν πως να την υλοποιούν

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 480
Απ: Απορία στην Ουρά
« Απάντηση #2 στις: 20 Μαΐ 2021, 10:46:36 πμ »
Καλημέρα κι από εμένα.
ΝΟΜΙΖΩ η εγκύκλιος προτείνει τη διδασκαλία της και μάλιστα, αν θυμάμαι καλά με υλοποίηση και με μία μεταβλητή και με ολίσθιση. Ο Θεός βοηθός να μη μπερδέψεις τα παιδιά αν το κάνεις έτσι όμως. Ο εν λόγω αλγόριθμος εξάγει πάντα το 1ο στοιχείο για παράδειγμα (δε χρειάζεται front) και κάνει ολισθιση, ώστε να ανακτατατάσσει τα στοιχεία. Έτσι ακόμα και το τελευταίο στοιχείο θα είναι στη θέση 1. Οπότε το rear είναι που αλλάζει μόνο κι έτσι εξαλείφεται η ανάγκη της υλοποίησης της ουράς, χρησιμοποιώντας τη μεταβλητή front που έχει το βιβλίο.
Εγώ θα το έδινα - έλυνα ως άσκηση, δε θα το δίδασκα με τη συμβατική έννοια. Αν ζητηθεί κάτι τέτοιο, με λύση κι επεξήγηση της λύσης της άσκησης, είναι καλυμμένα τα παιδιά, δε προσφέρει κάτι παραπάνω νομίζω.

taxata

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Απορία στην Ουρά
« Απάντηση #3 στις: 20 Μαΐ 2021, 11:50:17 μμ »
<<Σημειώνεται ότι για την υλοποίηση της ουράς υπάρχουν στη βιβλιογραφία και άλλες προσεγγίσεις, όπως π.χ. η
αξιοποίηση ενός δείκτη αντί για δύο, με την εξαγωγή πάντα να συνοδεύεται από ολίσθηση. Σε αυτό το σενάριο
υλοποίησης της ουράς τα στοιχεία της παρατίθενται πάντοτε στις πρώτες θέσεις του πίνακα και αρκεί η χρήση ενός
δείκτη για την επισήμανση του τέλους της ουράς.
>> (σελ 24).

Η χρήση ενός μόνο δείκτη αναφέρεται ότι υπάρχει ως προσέγγιση δεν προτείνεται ως γενική αντιμετώπιση εκτός εάν για κάποιο λόγο όπως αναφέρθηκε παραπάνω από τον συνάδελφο Γιώργο περιγράφεται και ζητείται από την εκφώνηση, όσον αφορά την ολίσθηση βέβαια:

<<Να παρουσιαστεί η διαδικασία της «ολίσθησης» των στοιχείων μιας ουράς για την αξιοποίηση όλων των θέσεών
της, στην περίπτωση που ζητείται από την περιγραφή του προβλήματος. Για να μην υπάρξουν κενές, μη
αξιοποιήσιμες, θέσεις στην αρχή της ουράς, υλοποιείται «ολίσθηση». Ως «ολίσθηση» (shift) περιγράφουμε τη
μετακίνηση των περιεχομένων της ουράς, ώστε οι κενές θέσεις προς εισαγωγή νέων στοιχείων να βρίσκονται στο
πίσω μέρος της ουράς. Αν δεν πραγματοποιηθεί ολίσθηση, τότε θεωρούμε ότι η ουρά είναι γεμάτη όταν περιέχει
στοιχείο στην τελευταία της θέση
.>> (σελ  21)

Η διδασκαλία του μαθήματος ειδικά για νέους συναδέλφους είναι ένα παζλ που προκαλεί πονοκέφαλο από 5-6  βιβλία: μαθητή, ασκήσεων, μελέτης, καθηγητή, συμπληρωματικών, λύσεων, οδηγιών διδασκαλίας, διορθώσεων κλπ. από τα οποία πρέπει να βγάλει άκρη
Δεν τυχαίο που πολλοί μαθητές προτιμούν να διαβάζουν από σημειώσεις ή εξωσχολικά βιβλία .
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1155
Απ: Απορία στην Ουρά
« Απάντηση #4 στις: 23 Μαΐ 2021, 11:55:25 μμ »
Καλημέρα κι από εμένα.
ΝΟΜΙΖΩ η εγκύκλιος προτείνει τη διδασκαλία της και μάλιστα, αν θυμάμαι καλά με υλοποίηση και με μία μεταβλητή και με ολίσθιση.

Μπορείς να παραθέσεις την εγκύκλιο που αναφέρει ότι η υλοποιηση γίνεται με ολίσθηση;

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: Απορία στην Ουρά
« Απάντηση #5 στις: 24 Μαΐ 2021, 08:19:53 πμ »
Καλημέρα σε όλους

οι οδηγίες διδασκαλίας που αναφέρονται οι συνάδελφοι είναι εδώ, https://www.esos.gr/arthra/69659/odigies-didaskalias-gia-mathima-pliroforiki-tis-g-taxis-gel , σε περίπτωση που θέλει κάποιος να ρίξει μια ματιά

καλή συνέχεια

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 480
Απ: Απορία στην Ουρά
« Απάντηση #6 στις: 26 Μαΐ 2021, 01:02:12 μμ »
Ευχαριστώ Μανώλη.

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 139
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Απορία στην Ουρά
« Απάντηση #7 στις: 26 Μαΐ 2021, 02:13:41 μμ »
Μπορεί κάποιος συνάδελφος να παραθέσει λυμένο παράδειγμα με ολίσθηση στην ουρά;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Απορία στην Ουρά
« Απάντηση #8 στις: 26 Μαΐ 2021, 04:59:05 μμ »
Αν f > 1 και r  = Ν τότε
   Για ι από 1 μέχρι r - f + 1
      Α[ι] <- Α[f-1+ι]
   Τέλος_επανάληψης
    r <- r - f +1
    f <- 1
Τέλος_αν

Ο παραπάνω είναι ένας τρόπος.

taxata

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Απορία στην Ουρά
« Απάντηση #9 στις: 26 Μαΐ 2021, 06:56:46 μμ »
Και ένας άλλος, εισαγωγή με ολίσθηση σε μορφή διαδικασίας
Κώδικας: ΓΛΩΣΣΑ
  1. ΔΙΑΔΙΚΑΣΙΑ SHIFT_PUSH(Α, Χ, F, R, FLAG)
  2. ΜΕΤΑΒΛΗΤΕΣ
  3.   ΑΚΕΡΑΙΕΣ: Α[10], Χ, F, R, Κ, Ι
  4.   ΛΟΓΙΚΕΣ: FLAG
  5. ΑΡΧΗ
  6.   ΑΝ R = 10 ΤΟΤΕ
  7.     ΑΝ F > 1 ΤΟΤΕ
  8.       Κ <- 1
  9.       ΓΙΑ Ι ΑΠΟ F ΜΕΧΡΙ R
  10.         Α[Κ] <- Α[Ι]
  11.         Κ <- Κ + 1
  12.       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  13.       Α[Κ] <- Χ
  14.       FLAG <- ΑΛΗΘΗΣ
  15.       F <- 1
  16.       R <- Κ
  17.     ΑΛΛΙΩΣ
  18.       FLAG <- ΨΕΥΔΗΣ
  19.     ΤΕΛΟΣ_ΑΝ
  20.   ΑΛΛΙΩΣ
  21.     FLAG <- ΑΛΗΘΗΣ
  22.     R <- R + 1
  23.     Α[R] <- Χ
  24.     ΑΝ F = 0 ΤΟΤΕ
  25.       F <- 1
  26.     ΤΕΛΟΣ_ΑΝ
  27.   ΤΕΛΟΣ_ΑΝ
  28. ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
« Τελευταία τροποποίηση: 26 Μαΐ 2021, 07:14:54 μμ από taxata »
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/

ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 139
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Απορία στην Ουρά
« Απάντηση #10 στις: 26 Μαΐ 2021, 08:21:49 μμ »
ευχαριστώ πολύ

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: Απορία στην Ουρά
« Απάντηση #11 στις: 26 Μαΐ 2021, 08:31:21 μμ »
Άκυρο, μια χαρά είναι  :angel: >:D :laugh:

taxata

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Απορία στην Ουρά
« Απάντηση #12 στις: 26 Μαΐ 2021, 08:37:40 μμ »
Μανώλη εάν κατάλαβα καλά την παρατηρησή σου εκτός από την ολίσθηση μπαίνει και το Χ στην ουρά γι' αυτό.   :)
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 882
Απ: Απορία στην Ουρά
« Απάντηση #13 στις: 26 Μαΐ 2021, 08:38:38 μμ »
ναι ναι έμεινα μόνο στην αντιγραφή σόρυυυυ....το άλλαξα αμέσως   >:D :laugh:

taxata

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 114
  • Live long and prosper \\//
    • Πληροφορική στο ΕΠΑΛ
Απ: Απορία στην Ουρά
« Απάντηση #14 στις: 26 Μαΐ 2021, 08:51:49 μμ »
Ναι Μανώλη την είδα εκ των υστέρων. Πάντως ελπίζω αυτές οι κουβέντες περι ολισθήσεων κλπ να μείνουν  στο πλαίσιο απλά συζητήσεων και να μην τα συναντήσουν οι μαθητές στις εξετάσεις, δεν είναι ούτε η χρονιά κατάλληλη φέτος ούτε στο κανονικό βιβλίο περιέχονται (όσο για το βιβλίο των λύσεων μάλλον μπερδεύει παρά βοηθάει).
Τάσος_Χατζηπαπαδόπουλος
http://users.sch.gr/chatzipap/