Αποστολέας Θέμα: Θέματα επαναληπτικών 2020  (Αναγνώστηκε 506 φορές)

peteglamgr

  • Οπαδός
  • **
  • Μηνύματα: 19
Θέματα επαναληπτικών 2020
« στις: 12 Σεπ 2020, 09:59:31 πμ »
Καλημέρα. Είδατε τα θέματα των επαναληπτικών;
https://www.minedu.gov.gr/publications/docs2020/EXETASEIS-2020-SEPTEMBRIOS/them_plhr_epan_NEO_200911.pdf
Το 4ο ήταν παρόμοιο (απλά με συνάρτηση) με αυτό των επαναληπτικών του 2018.
Το 3ο δεν ήταν άσχημο.

Λύσεις που έγραψα μόλις τώρα, αν δείτε λάθη πείτε, δεν τις έχω τσεκάρει από την αρχή.
Παράθεση
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ Θ3_2020_ΕΠΑΝΑΛΗΠΤΙΚΕΣ
ΜΕΤΑΒΛΗΤΕΣ
   
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΤΙΜΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΤΙΜΗ>=0
  Ι<--0
  ΟΣΟ ΤΙΜΗ<>0 ΚΑΙ Ι<200 ΕΠΑΝΑΛΑΒΕ
    Ι<--Ι+1
    Τ[Ι]<--ΤΙΜΗ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΤΙΜΗ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΤΙΜΗ>=0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  Κ<--Ι
  ΑΙΧΜΕΣ<--0
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Κ-1
    ΑΝ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι-1] ΚΑΙ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι+1] ΤΟΤΕ
      ΑΙΜΕΣ<--ΑΙΧΜΕΣ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΑΙΧΜΕΣ>0 ΤΟΤΕ
    ΓΡΑΨΕ ΑΙΧΜΕΣ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΑΝ ΑΙΧΜΕΣ'
  ΤΕΛΟΣ_ΑΝ

  ΑΝ ΑΙΧΜΕΣ>=2 ΤΟΤΕ
    Π<--0
    ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Κ-1
      ΑΝ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι-1] ΚΑΙ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι+1] ΤΟΤΕ
        Π<--Π+1
        ΑΝ Π=1 Η Π=ΑΙΧΜΕΣ ΤΟΤΕ
          ΓΡΑΨΕ Ι
        ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_4_2020_ΕΠΑΝΑΛΗΠΤΙΚΕΣ
ΜΕΤΑΒΛΗΤΕΣ


ΑΡΧΗ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ ΟΝ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΙΑ Ξ ΑΠΟ Ι+1 ΜΕΧΡΙ 20
      ΔΙΑΒΑΣΕ ΑΠ[Ι,Ξ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΔΙΑΒΑΣΕ ΠΟΛΗ1
  Σ<--0
  Π<--0
  ΟΣΟ ΠΟΛΗ1<>'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ ΠΟΛΗ2
    ΑΠ<--ΑΠΟΣΤΑΣΗ(ΠΟΛΗ1,ΠΟΛΗ2,ΑΠ,ΟΝ)   
    ΑΝ ΑΠ<>0 ΤΟΤΕ
      ΑΝ ΑΠ<=100 ΤΟΤΕ
        ΧΡΕΩΣΗ<--ΑΠ*0.5
      ΑΛΛΙΩΣ
        ΧΡΕΩΣΗ<--100*0.5+(ΑΠ-100)*0.3
      ΤΕΛΟΣ_ΑΝ
      Σ<--Σ+ΧΡΕΩΣΗ
      Π<--Π+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ ΚΑΠΟΙΑ ΠΟΛΗ'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΠΟΛΗ1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Σ,Π

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ             

ΣΥΝΑΡΤΗΣΗ ΑΠΟΣΤΑΣΗ(ΟΝ1,ΟΝ2,ΑΠ,ΟΝ):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:ΟΝ1,ΟΝ2,ΟΝ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΑΠ[20,20]
  ΑΚΕΡΑΙΕΣ:Θ1,Θ2,Ι
ΑΡΧΗ
  Θ1<--0
  Θ2<--0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ ΟΝ[Ι]=ΟΝ1 ΤΟΤΕ
      Θ1<--Ι
    ΑΛΛΙΩΣ_ΑΝ ΟΝ[Ι]=ΟΝ2 ΤΟΤΕ
      Θ2<--Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Θ1=0 Η Θ2=0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΑΠΟΙΑ ΠΟΛΗ ΔΕ ΒΡΕΘΗΚΕ'
    ΑΠΟΣΤΑΣΗ<--0
  ΑΛΛΙΩΣ
    ΑΝ Θ1>Θ2 ΤΟΤΕ
      ΑΠΟΣΤΑΣΗ<--ΑΠ[Θ1,Θ2]
    ΑΛΛΙΩΣ
      ΑΠΟΣΤΑΣΗ<--ΑΠ[Θ2,Θ1]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #1 στις: 12 Σεπ 2020, 10:13:46 πμ »
Έχει ενδιαφέρον και το 2ρο ΣΛ, το είχαμε συζητήσει και εδώ, αλλά δεν ξέρω αν είχαμε καταλήξει κάπου..

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3531
  • to Iterate is human to Recurse divine
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #2 στις: 12 Σεπ 2020, 06:41:47 μμ »
Συνήθως τα θέματα των επαναληπτικών έχουν κάποια πρωτοτυπία, κάποιες νέες ιδέες. Αυτά δεν έχουν τίποτα.
Μάλιστα το απίστευτο που δεν νομίζω να έχει ξαναγίνει είναι ότι πήγαν και πήραν copy/paste το θέμα Β του 2010 και το έβαλαν αυτούσιο!
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #3 στις: 12 Σεπ 2020, 06:47:10 μμ »
ΑΚΡΙΒΩΣ το ίδιο είναι Ευριπίδη ? έλεος...το είδα πως ήταν copy paste η εκφώνηση, αλλά θεώρησα πως άλλαξαν τα νούμερα ... μάλιστα ...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3531
  • to Iterate is human to Recurse divine
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #4 στις: 12 Σεπ 2020, 07:03:52 μμ »
Οκ το παίρνω πίσω δεν είναι αυτούσιο.
Στο φετινό θέμα έχουν ανάποδα τις πρώτες δυο εκχωρήσεις (για ξεκάρφωμα?) :D
και προσπάθησαν να κάνουν με bold τις δεσμευμένες λέξεις αλλά επειδή κάτι δεν πήγε καλά έγιναν όλα με bold. :D
Α και το σημαντικότερο απ'όλα που δείχνει και την εξέλιξη του μαθήματος τα τελευταία χρόνια. Αντί για Εμφάνισε έβαλαν Γράψε.

Τα νούμερα δεν μπορεί να είναι οποιαδήποτε γιατί ο κώδικας αυτός παράγει τους αριθμούς Fibonacci.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2313
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #5 στις: 12 Σεπ 2020, 08:17:31 μμ »
Κι εκείνο και αυτό είναι από τα χειρότερα θέματα που έχουν τεθεί
Το λύνει άνετα και μαθητής της θεωρητικής που έχει διδαχθεί μερικές ώρες πληροφορική στην Β
Από εκεί και πέρα, δεν διάβασα τα προγράμματα, αλλά τα υπόλοιπα μου φαίνονται πολύ εύκολα για επαναληπτικές εξετάσεις
Γιατί;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

ApoAntonis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 134
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #6 στις: 12 Σεπ 2020, 09:42:09 μμ »
Είναι σοβαρά πράγματα αυτά; Μία μονάδα για αντικατάσταση, 7 μονάδες συνολικά ερώτημα που υπάρχει στο βιβλίο 3 στις πρώτες σελίδες;
Ειδικά το υποερώτημα γ, δεν ζητάει να γίνουν οι συγκρίσεις αλλά δίνει και τις δυνατές απαντήσεις!
Δεν καταλαβαίνω εγώ κάτι; Τι εξετάζει το ερώτημα αφού και η ιεραρχία ακόμα δίνεται. Το μόνο που δεν έδωσαν είναι η ιεραρχία των λογικών τελεστών ανάμεσα στο ΟΧΙ και το 'Η.

Στο Β2 η συνθήκη στο ΑΛΛΙΩΣ_ΑΝ εξαιρετικά ΚΑΚΩΣ και ΑΠΑΡΑΔΕΚΤΑ έχει γραφτεί κατά αυτό τον τρόπο.

Στο θέμα Γ ή εγώ δεν ξέρω μπίτι ελληνικά ή τέλος πάντων πρέπει να ξαναπάω σχολείο.
"έως 200 διαδοχικές τιμές"
Σημαίνει διαδοχικές μεταξύ τους ως προς την τιμή τους,
ενώ εννοεί διαδοχικά (fun fact: έχουμε όρο να το πούμε! ακολουθιακά) ως προς την σειρά τους.

Με αφορμή το πέμπτο ερώτημα από το Α1 κοίταξα το βιβλίο σελ. 128:
"Λογικός:Αυτός ο τύπος δέχεται μόνο δύο τιμές: ΑΛΗΘΗΣ και ΨΕΥΔΗΣ. Οι τιμές αντιπροσωπεύουν αληθείς ή ψευδείς συνθήκες"

Εκφράσεις δεν θα έπρεπε να λέει;

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1059
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #7 στις: 12 Σεπ 2020, 10:59:18 μμ »
1.  ΓΙΑ Ξ ΑΠΟ 1  ΜΕΧΡΙ  Ι - 1

2.  ΑΝ (ΠΟΛΗ1 = ΟΝ[1] ΚΑΙ ΠΟΛΗ2 = ΟΝ[20] ) Η  (ΠΟΛΗ1 = ΟΝ[20] ΚΑΙ ΠΟΛΗ2 = ΟΝ[1]) ΤΟΤΕ
           Π <- Π +1
      ΤΕΛΟΣ_ΑΝ

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 152
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #8 στις: 13 Σεπ 2020, 06:25:19 μμ »
3ο θέμα, 25 γραμμές κώδικα
Κώδικας: MySQL
  1. πλ <-- 0
  2. αρχή_επανάληψης
  3.         διάβασε χ
  4.         αν χ > 0 τότε
  5.                 πλ <-- πλ + 1
  6.                 Τ[πλ] <-- χ
  7.         τέλος_αν
  8. μέχρις_ότου πλ = 200 ή χ = 0
  9.  
  10. για χ από 2 μέχρι πλ-1
  11.         αν Τ[χ] > Τ[χ-1] και Τ[χ] > Τ[χ+1] τότε
  12.                 α <-- α + 1
  13.                 θ2 <-- χ
  14.                 αν α = 1 τότε
  15.                         θ1 <-- χ
  16.                 τέλος_αν
  17.         τέλος_αν
  18. τέλος_επανάληψης
  19.  
  20. αν α = 0 τότε
  21.         γράψε 'δε βρέθηκαν αιχμές'
  22. αλλιώς
  23.         γράψε 'βρέθηκαν', α, 'αιχμές'
  24.         αν α >= 2 τότε
  25.                 γράψε 'η 1η στη θέση', θ1, 'και η τελευταία στη θέση', θ2
  26.         τέλος_αν
  27. τέλος_αν
  28.  

Αντώνης Τζιλιβάκης

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέματα επαναληπτικών 2020
« Απάντηση #9 στις: 13 Σεπ 2020, 10:01:24 μμ »
Καλησπέρα κι από εμένα που παρακολουθώ χρόνια το φόρουμ και τις εποικοδομητικές συζητήσεις μεταξύ συναδέλφων.
Ηθελα κι εγώ να θίξω το πόσο πρόχειρα ήταν τα φετινά θέματα των επαναληπτικών. Καμμία φαντασία, σαν να έψαξαν όλα τα παλιότερα θέματα που έχουν μπει, έκαναν μια επιλογή παρόμοιων θεμάτων, τα οποία τα τροποποίησαν..Γιατί τόση προχειρότητα;
Δεν ξέρω ειλικρινά πως γίνεται η επιλογή των ανθρώπων που είναι θεματοδότες (αλήθεια ξέρει κάποιος τα κριτήρια;).

Αισθάνομαι ότι τόσο στις κανονικές ημερήσιες του 2019 και όσο και του 2020, τα θέματα δεν είχαν σε πολλά σημεία ανάπτυξη κριτικής σκέψης και κυρίως δεν γινόταν μια σωστή κλιμάκωση των θεμάτων, ώστε να ξεχωρίσουν οι πιο δυνατοί μαθητές. Ακόμα και στα ερωτήματα ανάπτυξης θεωρίας, έβαλαν κυρίως θέματα απομνημόνευσης. Παρόλο που κλαδικά μάλλον αυτή η επιλογή(εκούσια ή ακούσια) έχει φέρει κόσμο στην κατεύθυνση, θα ήθελα πραγματικά να βλέπω τη διαδικασία της θεματοδοσίας να εξελίσσεται και να βελτιώνεται...