Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 2274 φορές)

giannakos

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Β
« Απάντηση #30 στις: 24 Ιούν 2020, 06:41:45 μμ »
Μπερδεύει ειδικά το "μόνο μία εντολή ΑΝ..ΤΟΤΕ..ΑΛΛΙΩΣ_ΑΝ " (& συμπληρώνουν, "χωρίς επιπλέον εμφωλευμένες εντολές επιλογής" )
νομίζαν πολλοί ότι έπρεπε να έχουν μόνο μία ΑΛΛΙΩΣ_ΑΝ και δεν ήξεραν πώς να αποδώσουν τις υπόλοιπες περιπτώσεις.

Προσπαθώντας να το δω με τα μάτια ενός μαθητή μου όπως μου εξηγούσε τι κατάλαβε από την εκφώνηση, μπορώ να πω ότι τον καταλαβαίνω. Καταλαβαίνω γιατί μπερδεύτηκε (κι ας έχουμε κάνει τόσα παραδείγματα από ΕΠΙΛΕΞΕ σε ΑΛΛΙΩΣ_ΑΝ). Απλά χρειαζόταν να λύσει χωρίς να το πολυσκεφτεί. Αλλά μπερδεύτηκε γιατί είναι στις πανελλήνιες εξετάσεις και προσέχει πολύ τη διατύπωση.
Αυτός λοιπόν έκανε το εξής:
ΑΝ Χ=7 ΤΟΤΕ
  ΓΡΑΨΕ 'Α'
ΑΛΛΙΩΣ_ΑΝ Χ=11 ή Χ=13 ΤΟΤΕ
  ΓΡΑΨΕ 'Β'
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ<20 ΚΑΙ Χ<>11 ΚΑΙ Χ<>13 ΚΑΙ Χ<>7 ΤΟΤΕ
  ΓΡΑΨΕ 'Γ'
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ>=50 και Χ<=100 ΤΟΤΕ
  ΓΡΑΨΕ 'Δ'
ΤΕΛΟΣ_ΑΝ
ΑΝ Χ>=20 ΚΑΙ (Χ<50 ή Χ>100) ΤΟΤΕ
  ΓΡΑΨΕ 'Ε'
ΤΕΛΟΣ_ΑΝ

και ισχυρίζεται ότι είναι εντάξει με την εκφώνηση διότι χρησιμοποίησε μόνο μία ΑΝ..ΤΟΤΕ..ΑΛΛΙΩΣ_ΑΝ, δεν χρησιμοποίησε εμφώλευση και η άσκηση δεν του απαγόρευε να χρησιμοποιήσει απλές ΑΝ
Τι να πω, δίκιο έχεις αλλά δε νομίζω να σου το πάρουν σωστό γιατί περιέργως όλοι εμείς οι καθηγητές καταλαβαίνουμε αμέσως τι θέλει να πει η άσκηση, ασχέτως που καταλαβαίνω ότι έτσι που το λέει μπορεί και να παρανοηθεί. Αναρωτιέμαι βέβαια πόσο δίκαιο είναι αυτό, ότι δηλαδή για όλου εμάς η εκφώνηση είναι αυτονόητη ενώ για κάποιον που θα την ερμηνεύσει με λεπτομέρεια, μπορεί ορθώς να μην είναι.

Το ίδιο μου είπαν κι εμένα 2 καλοί μαθητές μου. Εγώ τους απάντησα ότι θα το πάρουν σωστό.
Μπορείτε λίγο να μας βοηθήσετε?

tall

  • Θαμώνας
  • ***
  • Μηνύματα: 20
Απ: Θέμα Β
« Απάντηση #31 στις: 24 Ιούν 2020, 06:49:46 μμ »
Θα έπρεπε να αναφέρει στην εισαγωγή ότι οι αριθμοί 2,3,5 κλπ. είναι πρώτοι και ο αλγόριθμος να ξεκινήσει από το 3.
Πιστεύω επίσης ότι η κουβέντα αυτή πρέπει να γίνει μετά την Παρασκευή, τα παιδιά έχουν ένα μάθημα ακόμα να δώσουν.

pfan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
  • ...
Απ: Θέμα Β
« Απάντηση #32 στις: 24 Ιούν 2020, 11:01:01 μμ »
Β1. Πολύ σωστά έδωσε η ΚΕΕ την σημείωση ότι το 50..100 έχει όλες τις τιμές από το 50 μέχρι το 100 γιατί οι δύο τελείες τις συναντά κανείς μόνο στις λύσεις που είχαν εκδοθεί για το συμπληρωματικό βιβλίο και θα υπήρχαν πάρα πολλές ερωτήσεις

Β2. Αν και έχει συζητηθεί σε άλλο νήμα εγώ θα πω ότι το θέμα δεν ήταν λάθος οι λύσεις που δόθηκαν στην αρχή ήταν λάθος και είναι φανερό ότι ούτε η ίδια η επιτροπή ήθελε να βάλει στο Β ένα δύσκολο κομμάτι. Επειδή κάπως έπρεπε να σωθεί η κατάσταση απλά πρόσθεσαν στο 4ο κενό το Ή n=2 βέβαια θα μπορούσαν να δώσουν μια λύση λίγο πιο "κομψή"

 1. ΑΛΗΘΗΣ
2.      2
3. n mod i
4. ΨΕΥΔΗΣ Ή n=2
5. ΠΡΩΤΟΣ = ΨΕΥΔΗΣ (ή ΟΧΙ ΠΡΩΤΟΣ)

δεν χρειάζεται να βάλεις το ΨΕΥΔΗΣ το ΠΡΩΤΟΣ <- n=2 αρκεί

Πύρζα Φανή
Καθηγήτρια Πληροφορικής

thanasisgr

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Θέμα Β
« Απάντηση #33 στις: 25 Ιούν 2020, 04:36:24 μμ »
Μια παρατήρηση, ο δοσμένος αλγόριθμος συμπληρωμένος με τις απαντήσεις που αναφέρθηκαν και παραπάνω δεν λειτουργεί σωστά στην περίπτωση που ο αριθμός n πάρει την τιμή 2. Ο αλγόριθμος θα εμφανίσει το μήνυμα οτι δεν είναι πρώτος ενώ το 2 είναι πρώτος αριθμός.
Σωστά για αυτό έδωσαν και τη λύση για το κενό (4) ΨΕΥΔΗΣ 'Η Ν=2

thanasisgr

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: Θέμα Β
« Απάντηση #34 στις: 25 Ιούν 2020, 04:41:21 μμ »
Β1. Πολύ σωστά έδωσε η ΚΕΕ την σημείωση ότι το 50..100 έχει όλες τις τιμές από το 50 μέχρι το 100 γιατί οι δύο τελείες τις συναντά κανείς μόνο στις λύσεις που είχαν εκδοθεί για το συμπληρωματικό βιβλίο και θα υπήρχαν πάρα πολλές ερωτήσεις

Β2. Αν και έχει συζητηθεί σε άλλο νήμα εγώ θα πω ότι το θέμα δεν ήταν λάθος οι λύσεις που δόθηκαν στην αρχή ήταν λάθος και είναι φανερό ότι ούτε η ίδια η επιτροπή ήθελε να βάλει στο Β ένα δύσκολο κομμάτι. Επειδή κάπως έπρεπε να σωθεί η κατάσταση απλά πρόσθεσαν στο 4ο κενό το Ή n=2 βέβαια θα μπορούσαν να δώσουν μια λύση λίγο πιο "κομψή"

 1. ΑΛΗΘΗΣ
2.      2
3. n mod i
4. ΨΕΥΔΗΣ Ή n=2
5. ΠΡΩΤΟΣ = ΨΕΥΔΗΣ (ή ΟΧΙ ΠΡΩΤΟΣ)

δεν χρειάζεται να βάλεις το ΨΕΥΔΗΣ το ΠΡΩΤΟΣ <- n=2 αρκεί
ΧΡΕΙΆΖΕΤΑΙ ΚΑΙ ΤΟ ΨΕΥΔΗΣ

pfan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
  • ...
Απ: Θέμα Β
« Απάντηση #35 στις: 25 Ιούν 2020, 05:39:13 μμ »
ΧΡΕΙΆΖΕΤΑΙ ΚΑΙ ΤΟ ΨΕΥΔΗΣ

Αν βάλεις τον παρακάτω κώδικα θα διαπιστώσεις ότι βγαίνουν σωστά οι 100 πρώτοι αριθμοί!
Δες και στο https://el.wikipedia.org/wiki/%CE%A0%CF%81%CF%8E%CF%84%CE%BF%CF%82_%CE%B1%CF%81%CE%B9%CE%B8%CE%BC%CF%8C%CF%82
Κώδικας: Pascal
  1. ΠΡΟΓΡΑΜΜΑ θεμαΒ
  2. ΜΕΤΑΒΛΗΤΕΣ
  3.   ΑΚΕΡΑΙΕΣ: ν, ι
  4.   ΛΟΓΙΚΕΣ: ΠΡΩΤΟΣ
  5. ΑΡΧΗ
  6.   ΓΙΑ ν ΑΠΟ 1 ΜΕΧΡΙ 100
  7.     ΠΡΩΤΟΣ <- ΑΛΗΘΗΣ
  8.     ι <- 2
  9.     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  10.       ΑΝ ν mod ι = 0 ΤΟΤΕ
  11.         ΠΡΩΤΟΣ <- ν = 2
  12.       ΤΕΛΟΣ_ΑΝ
  13.       ι <- ι + 1
  14.     ΜΕΧΡΙΣ_ΟΤΟΥ ι > ν - 1 Η ΠΡΩΤΟΣ = ΨΕΥΔΗΣ
  15.     ΑΝ ΠΡΩΤΟΣ ΤΟΤΕ
  16.       ΓΡΑΨΕ ν
  17.     ΤΕΛΟΣ_ΑΝ
  18.   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  19. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
  20.  

Αλλά και να μην βάλεις τον κώδικα κάνε ένα πίνακα αλήθειας ή σκέψου με άλγεβρα BOOLE

Σ= Σ1 Η Σ2
όταν το Σ1 είναι πάντα ψευδής σου αρκεί το Σ2  ;)
Πύρζα Φανή
Καθηγήτρια Πληροφορικής

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 565
Απ: Θέμα Β
« Απάντηση #36 στις: 25 Ιούν 2020, 07:21:55 μμ »
ΧΡΕΙΆΖΕΤΑΙ ΚΑΙ ΤΟ ΨΕΥΔΗΣ
Ψευδής Η Χ = Χ

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 795
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Θέμα Β
« Απάντηση #37 στις: 25 Ιούν 2020, 07:38:44 μμ »
Για κοιτάξτε και αυτό
Είναι απο παλιό τετράδιο μαθητή ΑΕΠΠ 
μήπως σας θυμίζει τιποτα?


pfan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
  • ...
Απ: Θέμα Β
« Απάντηση #38 στις: 25 Ιούν 2020, 09:42:02 μμ »
Για κοιτάξτε και αυτό
Είναι απο παλιό τετράδιο μαθητή ΑΕΠΠ 
μήπως σας θυμίζει τιποτα?

Βαγγέλη έχω σχεδόν όλες τις εκδόσεις αλλά στην πρώτη που κοίταξα δεν είναι ....  αλλά  να θυμίσω και εγώ όλες τις προσπάθειες που έχουν γίνει από πάρα πολλούς συναδέλφους να διορθωθούν τα λάθη που υπήρχαν στις εκδόσεις τις παλιές λες να υπάρχει πιθανότητα να έχει διορθωθεί σε επόμενη έκδοση ;;;

Τέλος να θυμίσω ένα παλιό Σ/Λ του 2007 αν μέσα σε συνάρτηση μπορώ να έχω ΔΙΑΒΑΣΕ και ΓΡΑΨΕ μια παλιά έκδοση του βιβλίου του καθηγητή έλεγε ότι ήταν Σωστό σε επόμενη το αφαίρεσαν αυτό και όταν έπεσε το θέμα είχε γίνει πάλι χαμός.

Με λίγα λόγια αν αυτό υπάρχει σε παλιά έκδοση τετραδίου δεν δικαιολογεί το πρόβλημα που προέκυψε ...
Πύρζα Φανή
Καθηγήτρια Πληροφορικής

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Β
« Απάντηση #39 στις: 26 Ιούν 2020, 10:57:18 πμ »
Πάντως το Β1 ήθελε σίγουρα καλύτερη εκφώνηση εκεί στο "να χρησιμοποιεί μόνο μία εντολή ΑΝ..ΤΟΤΕ..ΑΛΛΙΩΣ_ΑΝ". Εφόσον μετά λέει "χωρίς εμφώλευση", το μόνο μία ήταν τελείως περιττό και δημιουργούσε σύγχυση. Όλοι οι μαθητές μου μπερδεύτηκαν, και ευτυχώς στο τέλος το αγνόησαν.
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Θέμα Β
« Απάντηση #40 στις: 26 Ιούν 2020, 04:31:15 μμ »
Κι επειδή ακόμα δε γκρίνιαξα για το θέμα της ΕΠΙΛΕΞΕ ,
ας επαναλάβω εκείνο το προφητικό ποστ του Ιανουαρίου:
https://alkisg.mysch.gr/steki/index.php?topic=7860.msg88732#msg88732
Φιλικά,
Γιώργος Θαλασσινός

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Β
« Απάντηση #41 στις: 26 Ιούν 2020, 04:59:15 μμ »
2-3 απαντήσεις παρακάτω, συμπληρώνεται το καρέ  :angel:
Τι να πεις και τι να κάνεις!
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 946
Απ: Θέμα Β
« Απάντηση #42 στις: 26 Ιούν 2020, 05:47:31 μμ »
2-3 απαντήσεις παρακάτω, συμπληρώνεται το καρέ  :angel:
Τι να πεις και τι να κάνεις!
::)
Φιλικά,
Γιώργος Θαλασσινός

pvs

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 125
Απ: Θέμα Β
« Απάντηση #43 στις: 27 Ιούν 2020, 11:17:05 πμ »
Το ίδιο μου είπαν κι εμένα 2 καλοί μαθητές μου. Εγώ τους απάντησα ότι θα το πάρουν σωστό.
Μπορείτε λίγο να μας βοηθήσετε?
Και σε μένα έτυχε, εντελώς προσωπική άποψη οι μαθητές μας έχουν κάνει λάθος και θα το χάσουν όλο το ερώτημα (δεν φταίει η εκφώνηση). Ξεκάθαρα είναι μία μετατροπή σε πολλαπλή που υπάρχει και στο συμπληρωματικό υλικό. 

ApoAntonis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 133
Απ: Θέμα Β
« Απάντηση #44 στις: 27 Ιούν 2020, 12:46:25 μμ »
έχουν κάνει λάθος

Έχουν κάνει λάθος επειδή δεν θυμήθηκαν τις εκφωνήσεις των ασκήσεων που σίγουρα έχετε κάνει ή επειδή ερμήνευσαν την εκφώνηση με τρόπο διαφορετικό από τον αναμενόμενο;

Το συμπληρωματικό υλικό αναφέρεται σε μετατροπή. Τα θέματα των Πανελλαδικών επιμένουν στην διατύπωση του ισοδύναμου.
Για το ισοδύναμο, και πως τεκμηριώνεται, έχουμε αναφερφεί και στο παρελθόν.

Τραβηγμένο αλλά, τα προγράμμα στα οποία παρατίθεται μια μόνο εντολή πολλαπλής επιλογής ΑΝ,ΑΛΛΙΩΣ_ΑΝ τμηματοποιώντας ένα μέρος της ΕΠΙΛΕΞΕ, και το υπόλοιπο κομμάτι είναι σε ΕΠΙΛΕΞΕ, είναι και πάλι σωστά. Είναι διαφορετικό ζήτημα ότι -σχεδόν σίγουρα- θα διορθωθούν ως λανθασμένα.
Δύο λέξεις λείπουν: μόνο μία εντολή επιλογής, την ΑΝ ... ΤΟΤΕ ... ΑΛΛΙΩΣ_ΑΝ

Θα είχε ενδιαφέρον να γνωρίζαμε από τους βαθμολογητές, αν υπήρξαν "καλά" γραπτά στα οποία η εκφώνηση δημιούργησε σύγχιση.