Αποστολέας Θέμα: Θέμα Γ  (Αναγνώστηκε 1115 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3518
  • to Iterate is human to Recurse divine
Θέμα Γ
« στις: 23 Ιούν 2020, 09:23:50 μμ »
Εδώ συζητάμε για το θέμα Γ των εξετάσεων 2019-2020
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3518
  • to Iterate is human to Recurse divine
Απ: Θέμα Γ
« Απάντηση #1 στις: 24 Ιούν 2020, 10:28:12 πμ »
Από τα πιο εύκολα θέματα Γ που έχουν βάλει τα τελευταία 12 χρόνια.
Ωστόσο θέλει προσοχή η εκφώνηση.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

mikezante

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Γ
« Απάντηση #2 στις: 24 Ιούν 2020, 11:42:34 πμ »
Κώδικας: [Επιλογή]
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πλ, πλβ
  ΠΡΑΓΜΑΤΙΚΕΣ: οριο, βαρος, ωφελιμο, δεμα, χρ, Σ
  ΧΑΡΑΚΤΗΡΕΣ: απαντηση
ΑΡΧΗ
  πλ <- 0
  Σ <- 0
  πλβ <- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Γ2
    ΔΙΑΒΑΣΕ οριο, βαρος
    ΟΣΟ βαρος > οριο ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Δώσε πάλι το βάρος εντός ορίων:'
      ΔΙΑΒΑΣΕ βαρος
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                           !Γ3.α
    ωφελιμο <- οριο - βαρος
    ΓΡΑΨΕ 'Επιτρεπτό βάρος:', ωφελιμο
    ΓΡΑΨΕ 'Να φορτωθεί δέμα;(ΝΑΙ/ΟΧΙ)'
    ΔΙΑΒΑΣΕ απαντηση
                                                                           !Γ3.β
    ΑΝ απαντηση = 'ΝΑΙ' ΤΟΤΕ
      ΔΙΑΒΑΣΕ δεμα
      ΑΝ δεμα > ωφελιμο ΤΟΤΕ
        ΓΡΑΨΕ ' Το δέμα δεν χωράει'
        πλ <- πλ + 1
      ΑΛΛΙΩΣ
        ωφελιμο <- ωφελιμο - δεμα
        ΑΝ δεμα <= 500 ΤΟΤΕ
          χρ <- δεμα*0.5
        ΑΛΛΙΩΣ_ΑΝ δεμα <= 1500 ΤΟΤΕ
          χρ <- 500*0.5 + (δεμα - 500)*0.3
        ΑΛΛΙΩΣ
          χρ <- 500*0.5 + 1000*0.3 + (δεμα - 1500)*0.1
        ΤΕΛΟΣ_ΑΝ
        ΓΡΑΨΕ 'Χρέωση δέματος:', χρ
        ΑΝ δεμα > 1000 ΤΟΤΕ
          πλβ <- πλβ + 1
        ΤΕΛΟΣ_ΑΝ
        Σ <- Σ + χρ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ απαντηση = 'ΟΧΙ'
!Γ4
  ΓΡΑΨΕ 'Πληθος δεμάτων που δεν φορτώθηκαν:', πλ
  ΓΡΑΨΕ 'Συνλικο ποσό:', Σ
  ΓΡΑΨΕ 'Πληθος δεμάτων ανω 1000kg:', πλβ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Γ. Β.

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 836
Απ: Θέμα Γ
« Απάντηση #3 στις: 24 Ιούν 2020, 12:44:26 μμ »
το ΟΣΟ δεν πρέπει να βγει εγω απο το Μέχρις_ότου ?? μία φορά δεν διαβάζουμε το αρχικό βάρος ??

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1057
Απ: Θέμα Γ
« Απάντηση #4 στις: 24 Ιούν 2020, 01:11:21 μμ »
Γ2
Μια φορά ...
  Και το αρχικό βάρος ( ΑΒ )
  Και το όριο   (όριο)

Οπότε μέσα στη Μέχρις_ότου
    βάρος  που μπορεί ακόμα να φορτωθεί στο πλοίο ... ( Β)

     Β <-  όριο - ΑΒ

mikezante

  • Θαμώνας
  • ***
  • Μηνύματα: 43
Απ: Θέμα Γ
« Απάντηση #5 στις: 24 Ιούν 2020, 02:11:40 μμ »
Γ2
Μια φορά ...
  Και το αρχικό βάρος ( ΑΒ )
  Και το όριο   (όριο)

Οπότε μέσα στη Μέχρις_ότου
    βάρος  που μπορεί ακόμα να φορτωθεί στο πλοίο ... ( Β)

     Β <-  όριο - ΑΒ

Σωστά, ευχαριστώ!
Γ. Β.

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 316
Απ: Θέμα Γ
« Απάντηση #6 στις: 24 Ιούν 2020, 06:16:21 μμ »
Εύκολο και μύριζε φέτος η δουλειά πως θα έμπαινε και κλιμακωτή χρέωση.
Καλό θέμα.

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: Θέμα Γ
« Απάντηση #7 στις: 26 Ιούν 2020, 08:43:18 πμ »
Πως το είχες μυριστεί;
Εγώ κάποια στιγμή τελευταίες μέρες, τους έλεγα πως αν μπει κλιμακωτή, θα μπει σε συνδυασμό με κάτι άλλο, όχι μόνη της, και τους είχε φανεί πάρα πολύ περίεργο. Και για να είμαι ειλικρινής, δεν περίμενα να πέσει όντως κλιμακωτή.
Το ίδιο με εισαγωγή σε 2Δ πίνακα. Τους έλεγα, αν μπει κάτι, θα μπει κάτι περίεργο. Η κλασική εισαγωγή σε πίνακα είναι ό,τι πιο τετριμμένο.

Εύκολο θέμα γενικά αυτό, στρωτό και απλό. Κάτι σαν την εύκολη εκδοχή του θέματος Δ 2019 στα ΕΠΑΛ, με βαγόνια και τρένα.
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

ApoAntonis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Γ
« Απάντηση #8 στις: 26 Ιούν 2020, 09:51:11 πμ »
Πως το είχες μυριστεί;

Δεν ρωτάς εμένα αλλά θα απαντήσω τι σκεφτόμουν. Στο θέμα Α, κλιμακωτή και να περιέχει λογικά λάθη.

Για στοίβες ουρές τους έλεγα ότι αν είναι υλοποίηση με πίνακα θα το γράφει ρητά ενώ σε άλλη περίπτωση θα δείχνει μόνο
το ενεργό τμήμα της δομής.

Μιλάμε για την απόλυτη επιτυχία.  :laugh:

Κατά τύχη το τελεύταιο ασκησάκι που έκανα ήταν αριθμητικός πίνακας που ταξινομείται από ΔΙΑΔΙΚΑΣΙΑ και επέκταση για αλφαβητική ταξινόμηση του παράλληλου σε περίπτωση ισοβαθμίας.
3 μονάδες, τους έσωσα λέμε!  :D

Σάκης Δημόπουλος

  • Βετεράνος
  • ****
  • Μηνύματα: 94
  • Dimopoulos Informatics Tutorials
    • Dimopoulos Informatics Tutorials
Απ: Θέμα Γ
« Απάντηση #9 στις: 09 Ιούλ 2020, 08:39:53 μμ »
ΠΛΗΡΟΦΟΡΙΚΗ Πανελήνιες 2020: Λύση θέματος Γ https://www.youtube.com/watch?v=jLm-8HdqZPs&feature=youtu.be

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 316
Απ: Θέμα Γ
« Απάντηση #10 στις: 11 Ιούλ 2020, 05:13:01 μμ »
Πως το είχες μυριστεί;

Έχω φωτογραφία με πίνακα πριν τις Πανελλήνιες.
Σ/Λ (standard)
Συμπλήρωση κώδικα (standard)
Μία ερώτηση ανάπτυξης (standard)
Ουρά (αναμενόμενο ως νέα ύλη)
Στοίβα (αναμενόμενο ως νέα ύλη)
Εκσφαλμάτωση [με διέψευσαν]
Θέμα Δ θα είναι παράλληλοι πίνακες με υποπρογράμματα και sort (σύνηθες θέμα Δ)
ΕΠΙΛΕΞΕ μετατροπή σε ΑΛΛΙΩΣ_ΑΝ και vice versa. (αναμενόμενο ως νέα ύλη)

και πάμε στο δικό σου ερώτημα:

ΘΕΜΑ Γ έχει μπει στο παρελθόν κλιμακωτή. Η κλιμακωτή μπορεί να γίνει εύκολα με ΑΛΛΙΩΣ_ΑΝ η οποία όμως έχει άμεση σχέση με την ΕΠΙΛΕΞΕ που είναι μέσα στη νέα ύλη. Διαχωρίζει και παρομοιάζει ταυτόχρονα τη μία δομή με την άλλη ένα τέτοιο θέμα. Κι αυτό με έκανε να το μυριστώ.

Δε κάνω τον έξυπνο. Το μυρίστηκα σημαίνει... το μυρίσητηκα. Δεν ήταν όλα όσα μυρίστηκα μέσα. Αλλά τα παιδιά προετοιμάστηκαν εφ όλης της ύλης κι ως δια μαγείας τα θέματα έπεσαν 100% όπως φαντάστηκα, διότι ψυχολόγησα καλά την Επιτροπή και τη δικαιολόγηση του νέου βιβλίου, με ύλη που έχουν πετσοκόψει λόγω COVID-19.

Εγώ βέβαια έτρεμα μην έλεγαν κλιμακωτή με ΕΠΙΛΕΞΕ. Μη βαράτε που το αναφέρω ως ενδεχόμενο, έχουν βάλει αδόμητο διάγραμμα το 2018 και στη Πληροφορική Γ ΕΠΑΛ φέτος έβαλαν θεωρητικό θέμα από ασκήσεις... τους έχω ικανούς για όλα και γι' αυτό προετοιμάζω τα παιδιά για τα πάντα.
Βέβαια είπα μπα, δε θα τα τσακίσουν τα παιδιά, ήταν δύσκολη χρονιά. Κι όντως φέτος τα θέματα θεωρούνται εύκολα σα τα περσινά.