Αποστολέας Θέμα: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση  (Αναγνώστηκε 921 φορές)

xyresh96

  • Νέος
  • *
  • Μηνύματα: 1
]υπαρχει καποιου ειδους εντολη για να κανεις break σε μια λουπα η επαναληψη με βαση λογικου τελεστη αν

πχ δοκιμασα να φτιαξω την εξης λουπα

οσο αληθης επανελαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    //εντολη που σταματαει την λουπα?????αν υπαρχει?????????
τελος επαναληψης

αν υπαρχει κατι αναλογο πειτε μου καθως κοιτωντας την πασκαλ που ειναι ιδια η ψευδογλωσσα αυτο υπαρχει......

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 945
Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
« Απάντηση #1 στις: 22 Δεκ 2019, 02:43:07 πμ »
Δεν υπάρχει κάτι ανάλογο.
Αυτό που θέλεις, θα γίνει μάλλον με μια μεχρις_ότου :

Αρχή_επανάληψης
  //καποιες εντολες
μέχρις_ότου (//κατι ειναι αληθες λογω προηγουμενων)
Φιλικά,
Γιώργος Θαλασσινός

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2805
  • Πύργος Ηλείας
Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
« Απάντηση #2 στις: 22 Δεκ 2019, 04:06:01 μμ »
καθως κοιτωντας την πασκαλ που ειναι ιδια η ψευδογλωσσα αυτο υπαρχει......


Δεν την λες και ίδια!

akalest0s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 247
Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
« Απάντηση #3 στις: 28 Δεκ 2019, 12:09:26 πμ »
Κάτι που επιτρέπεται μεν, αλλά θεωρείται κακή τακτική αλγοριθμικά, και είναι βέβαια, είναι το να μεταβάλεις ρητά (explicitly) την μεταβλητή που ελέγχει την αρχική συνθήκη. Αντιπροτείνεται σε κάθε ευκαιρία από το διδακτικό πακέτο.

Δηλαδή, κάτι του τύπου:

Κώδικας: [Επιλογή]
ι <- 1
Όσο ι < 10 επανάλαβε
    εντολές
    ι <- ι+1
    Αν συνθήκη τότε
        ι <- 10
    Τέλος_Αν
Τέλος_επανάληψης
"Abstraction is not the first stage, but the last stage, in a mathematical development." MK
"I don't want to write about a high level thing, unless I fully understand about a low level thing" DK

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2457
  • I 'm not young enough to know everything
Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
« Απάντηση #4 στις: 29 Δεκ 2019, 01:42:15 μμ »
Νομίζω πως το πιο κοντινό σε αυτό που γράφεις είναι το παρακάτω: (χρησιμοποίησα το δικό σου κείμενο κάνοντας μόνο προσθήκες)

λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
 Τέλος_αν
τελος επαναληψης


Δημήτρης Γκίνης

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 505
Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
« Απάντηση #5 στις: 30 Δεκ 2019, 12:21:17 μμ »
Νομίζω πως το πιο κοντινό σε αυτό που γράφεις είναι το παρακάτω: (χρησιμοποίησα το δικό σου κείμενο κάνοντας μόνο προσθήκες)

λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
 Τέλος_αν
τελος επαναληψης


Τροποποιώντας  λιγακι το προηγούμενο :
λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
αλλιώς
//κάποιες άλλες εντολές που θα εκτελεστούν αφού βεβαιωθουμε ότι το λ είναι αληθές
 Τέλος_αν
τελος επαναληψης