Αποστολέας Θέμα: ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ ΜΕ ΕΠΑΝΑΛΗΨΕΙΣ ΣΤΟΙΧΕΙΩΝ  (Αναγνώστηκε 403 φορές)

droopy

  • Θαμώνας
  • ***
  • Μηνύματα: 38
  • you know what... i'm happy
Καλησπέρα,

στην περίπτωση που έχουμε ταξινομημένο πίνακα σε αύξουσα διάταξη και με επαναλήψεις στοιχείων και θέλουμε να εμφανίζει τις θέσεις στις οποίες βρίσκεται το στοιχείο που ψάχνουμε ή το μήνυμα ότι δεν υπάρχει το στοιχείο αυτό, η παρακάτω λύση είναι σωστή;

done ← ψευδής
pos ← 0
i ← 1
 Όσο (done=ψευδής) και (i<=N) επανάλαβε
         Αν A|i|=key τότε
              pos<--i
              ΓΡΑΨΕ ‘ΒΡΕΘΗΚΕ ΣΤΗ ΘΕΣΗ’,pos
               i<--i+1
        αλλιώς_αν Α|i|>key τότε   
               done <-- αληθής
        αλλιώς
               i <-- i+1
       Τέλος_αν
Τέλος_επανάληψης
Αν pos = 0 TOTE
   ΓΡΑΨΕ ‘Δεν βρέθηκε’
Τέλος_αν

Ευχαριστώ.


ikariofil

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 127
  • Γράψτε το προσωπικό σας σλόγκαν!
μια χαρά φαίνεται ...